Ubuntu

WOL doesn't work - Ubuntu 12.04 Daily Build 64-bit

Reported by Andrej84 on 2012-01-10
78
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Linux
In Progress
Medium
linux (Ubuntu)
Medium
Unassigned

Bug Description

Wake On LAN doesn't work after using Ubuntu 12.04 Daily Build 64-bit.

Reproduce the problem:

First case:
1. Start the computer using an older Ubuntu destop disk (I used Ubuntu 10.04 Desktop 64-bit)
2. Choose "Try Ubuntu", any language setting can be used
3. Shut down properly using the menu after the desktop is loaded
4. Try to wake up the computer via LAN from an other computer using etherwake

Second case:
1. Start the computer using Ubuntu 12.04 Daily Build Desktop 64-bit disk
2. Choose "Try Ubuntu", any language setting can be used
3. Shut down properly using the menu after the desktop is loaded
4. Try to wake up the computer via LAN from an other computer using etherwake

After the fisrst case the computer can be waked up via LAN, but after the second case not.

The problem also exists if Ubuntu 12.04 is installed on hard drive.

Andrej84 (balazs-andrejka) wrote :
Andrej84 (balazs-andrejka) wrote :
Andrej84 (balazs-andrejka) wrote :
Andrej84 (balazs-andrejka) wrote :
Andrej84 (balazs-andrejka) wrote :
Andrej84 (balazs-andrejka) wrote :

UPDATE: The problem exists in r8169 module. After removing it then downloading from Realtek homepage and installing r8168 driver (version r8168-8.027.00) the problem disappears.

NOTE: r8168-8.027.00 is not correct, it can be installed after you patched it. Please check the following page for that: http://code.google.com/p/r8168/issues/detail?id=8

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/914439/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Phil. V (philip.v) on 2012-01-12
tags: added: testcase
yurikoles (yurikoles) on 2012-02-25
affects: ubuntu → linux-meta (Ubuntu)
affects: linux-meta (Ubuntu) → linux (Ubuntu)
tags: added: kernel-da-key precise

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 914439

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
status: Incomplete → New
status: New → Incomplete

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get upgrade

If the bug still exists, change the bug status from Incomplete to Incomplete. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

tags: added: kernel-request-3.2.0-17.27
Changed in linux (Ubuntu):
importance: Undecided → Medium
Andrej84 (balazs-andrejka) wrote :

Checked with kernel 3.2.0.17, but WOL is still not working.

balazs@balazs:~$ uname -a
Linux balazs 3.2.0-17-generic #27-Ubuntu SMP Fri Feb 24 15:37:36 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
balazs@balazs:~$

balazs@balazs:~$ sudo lshw -c network
  *-network
       description: Ethernet interface
       product: RTL8111/8168B PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: 02
       serial: 00:1f:d0:5d:5a:60
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=N/A ip=192.168.1.10 latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
       resources: irq:44 ioport:c000(size=256) memory:e8010000-e8010fff memory:e8000000-e800ffff memory:e8020000-e802ffff
balazs@balazs:~$

Andrej84 (balazs-andrejka) wrote :

I cannot run "apport-collect 914439", it crashes.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.3 kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed by the mainline kernel, please add the following tag 'kernel-fixed-upstream-KERNEL-VERSION'. For example, if kernel version 3.3-rc5 fixed the issue, the tag would be: 'kernel-fixed-upstream-v3.3-rc5'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[1] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-rc5-precise/

tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Andrej84 (balazs-andrejka) wrote :

I tried it with kernel 3.3-rc5, but WOL is still not working.

balazs@balazs:~$ uname -a
Linux balazs 3.3.0-030300rc5-generic #201202251535 SMP Sat Feb 25 20:36:29 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
balazs@balazs:~$ sudo lshw -c network
  *-network
       description: Ethernet interface
       product: RTL8111/8168B PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: 02
       serial: 00:1f:d0:5d:5a:60
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip=192.168.1.10 latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
       resources: irq:44 ioport:c000(size=256) memory:e8010000-e8010fff memory:e8000000-e800ffff memory:e8020000-e802ffff
balazs@balazs:~$

As it can seen the r8169 driver version is the same for this kernel.
Please note that the WOL is working correctly in case of installing the r8168 driver downloaded directly from Realtek's web page.

tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Andrej84 (balazs-andrejka) wrote :

I opened an upstream bug report.
Here is the link for that: https://bugzilla.kernel.org/show_bug.cgi?id=42849

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-18.28
tags: added: bot-stop-nagging
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Triaged
Maarten Bezemer (veger) wrote :

Thanks for taking the time to report this bug in the upstream bug tracking system this is a tremendous help. Launchpad has the ability to watch lots of upstream bug trackers and this can be done by following the procedure documented at https://wiki.ubuntu.com/Bugs/Watches. I've added the bug watch for this bug report.

Changed in linux:
importance: Unknown → Medium
status: Unknown → In Progress
e-frog (e-frog) wrote :

I'm facing the same problem after upgrading from oneiric to precise.
The following workaround works for me till this is fixed upstream:

There is a debian package in sid which provides the latest Realtek driver (8.029.00) including dkms configuration

http://packages.debian.org/de/sid/all/r8168-dkms

The nice thing about this is that it automatically re-compiles the r8168 module on kernel updates.

Michael Dudek (papricasix) wrote :

Thank you e-frog, your solutions works great (tested on mainline kernel 3.3.3).

mogliii (mogliii) wrote :

Thanks e-frog. Solution works on Ubuntu 12.04 with "Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)"

Felix Moreno (felix-justdust) wrote :

It was working but last week it stopped to work again, perhaps same bug as this one? It stopped working on the second week of October 2012... Bests

Andrej84, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc1

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: needs-kernel-logs
removed: kernel-request-3.2.0-17.27 kernel-request-3.2.0-18.28
Changed in linux (Ubuntu):
status: Triaged → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.