Wrong Beagle XM detection

Bug #912199 reported by Paolo Pisati on 2012-01-05
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Oneiric
Undecided
Paolo Pisati
Precise
Medium
Unassigned

Bug Description

Per email discussion, we shouldn't carry any of SAUCE patch to properly detect Beagle XM revision since 3.0, so these should go:

3d45106 UBUNTU: SAUCE: omap3: beagle: if rev unknown, assume xM revision C
72bc65c UBUNTU: SAUCE: omap3: beagle: detect new xM revision B
46153cc UBUNTU: SAUCE: omap3: beaglexm: fix DVI initialization

-----

some details about the problem:

[snip]
>> there is an issue with commit 750dfba493ae205b21de78b60d85f42fd5992894 in
>> ubuntu-precise.git:
>>
>> arch/arm/mach-omap2/board-omap3beagle.c
>> @@ -60,7 +60,8 @@
>> * AXBX = GPIO173, GPIO172, GPIO171: 1 1 1
>> * C1_3 = GPIO173, GPIO172, GPIO171: 1 1 0
>> * C4 = GPIO173, GPIO172, GPIO171: 1 0 1
>> - * XMA/XMB = GPIO173, GPIO172, GPIO171: 0 0 0
>> + * XMA = GPIO173, GPIO172, GPIO171: 0 0 0
>> + * XMB = GPIO173, GPIO172, GPIO171: 0 0 1
>> * XMC = GPIO173, GPIO172, GPIO171: 0 1 0
>> @@ -142,10 +143,14 @@ static void __init omap3_beagle_init_rev(void)
>> beagle_config.usr_button_gpio = 7;
>> break;
>> case 0:
>> - printk(KERN_INFO "OMAP3 Beagle Rev: xM Ax/Bx\n");
>> + printk(KERN_INFO "OMAP3 Beagle Rev: xM A\n");
>> omap3_beagle_version = OMAP3BEAGLE_BOARD_XM;
>> beagle_config.usb_pwr_level = GPIOF_OUT_INIT_HIGH;
>> break;
>> + case 1:
>> + printk(KERN_INFO "OMAP3 Beagle Rev: xM B\n");
>> + omap3_beagle_version = OMAP3BEAGLE_BOARD_XM;
>> + break;
>> case 2:
>> printk(KERN_INFO "OMAP3 Beagle Rev: xM C\n");
>> omap3_beagle_version = OMAP3BEAGLE_BOARD_XMC;
>>
>>
>> I do own a beagle-xm rev B and the GPIOs are all zero, so beagle-xm rev A
>> and rev B is indistinguishible (the beaglebord reference does not give
>> GPIOs for rev B, AFAIK)
>>
>> in case there would a rev B would be detected as such, the line
>> beagle_config.usb_pwr_level = GPIOF_OUT_INIT_HIGH;
>> is missing for the case 1 (for rev B) -- only rev C changed the USB power
>> initialization, not rev. B
> Yeah, patches for xM B's can be dropped. When Gerald/CircuitCo first
> announced the "rev B" all the docs/spreadsheets showed a gpio hi/low
> change for detection.. During "production" this change was
> forgotten.. All xm B's are xM A's. (Personally confirmed many times
> with Gerald/CircuitCo). (the only real difference was a revision bump
> on the dm3730..)
>
> As of mainline kernel 3.0, ubuntu shouldn't have to carry any "xM"
> detection related patches...
>
Actually looking at:

http://git.linaro.org/gitweb?p=ubuntu/linux-linaro-precise.git;a=history;f=arch/arm/mach-omap2/board-omap3beagle.c;h=541c8262c6fd005d92d471922050c91fa1de2bc2;hb=HEAD

2011-11-16 Robert Nelson UBUNTU: SAUCE: omap3: beagle: if rev unknown, assume
2011-11-16 Robert Nelson UBUNTU: SAUCE: omap3: beagle: detect new xM revision B
2011-11-16 Ricardo Salveti... UBUNTU: SAUCE: omap3: beaglexm: fix DVI
initialization

should be dropped as:
Joel's commit:
http://git.linaro.org/gitweb?p=ubuntu/linux-linaro-precise.git;a=commit;h=5fe8b4c19dc24e3bb873daf9e96a2439a83bbd79

fixed all those..

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 912199

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Paolo Pisati (p-pisati) on 2012-01-05
description: updated
Paolo Pisati (p-pisati) on 2012-01-05
description: updated
Paolo Pisati (p-pisati) wrote :

here is a P kernel with these patches reverted:

http://people.canonical.com/~ppisati/beaglexm_detection_fix/linux-image-3.2.0-7-omap_3.2.0-7.13~xmdetectfix_armel.deb

tested on XM rev A and C, please try it out on rev B.

Paolo Pisati (p-pisati) wrote :

for O it was slightly different, i reverted these:

4a43e77 UBUNTU: SAUCE: omap3: beagle: if rev unknown, assume xM revision C
facc760 UBUNTU: SAUCE: omap3: beagle: detect new xM revision C
c067beb UBUNTU: SAUCE: omap3: beagle: detect new xM revision B
d01aeaf UBUNTU: SAUCE: omap3: beaglexm: fix DVI initialization

and added:

e23694c OMAP3: beagle: add support for beagleboard xM revision C

a kernel is available here:

http://people.canonical.com/~ppisati/beaglexm_detection_fix/linux-image-3.0.0-15-omap_3.0.0-15.25~xmdetectfix_armel.deb

tested on XM rev C and A, please test it on rev B.

Robert Nelson (robertcnelson) wrote :

Looks good on my xM B:

First with Oneiric:

ubuntu@omap:~$ dmesg | grep Beagle
[ 0.000000] Machine: OMAP3 Beagle Board
[ 0.083557] OMAP3 Beagle Rev: xM Ax/Bx
[ 4.303009] OMAP3 Beagle/Devkit8000 SoC init
ubuntu@omap:~$ uname -a
Linux omap 3.0.0-15-omap #25~xmdetectfix Thu Jan 5 12:10:40 UTC 2012 armv7l armv7l armv7l GNU/Linux

ehci/dvi works

Bootloader notes:
SPL Bootloader: MLO-beagleboard-2011.12-r1
UBOOT Bootloader: u-boot-beagleboard-2011.12-r1.img

Robert Nelson (robertcnelson) wrote :

Likewise with Precise, on my xM B:

ubuntu@omap:~$ dmesg | grep Beagle
[ 0.000000] Machine: OMAP3 Beagle Board
[ 0.048156] OMAP3 Beagle Rev: xM Ax/Bx
[ 4.425476] OMAP3 Beagle/Devkit8000 SoC init
ubuntu@omap:~$ uname -a
Linux omap 3.2.0-7-omap #13~xmdetectfix Thu Jan 5 11:12:24 UTC 2012 armv7l armv7l armv7l GNU/Linux

ehci/dvi works

Bootloader notes:
SPL Bootloader: MLO-beagleboard-2011.12-r1
UBOOT Bootloader: u-boot-beagleboard-2011.12-r1.img

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
importance: Undecided → Medium
Tim Gardner (timg-tpi) on 2012-01-09
Changed in linux (Ubuntu Oneiric):
status: New → Fix Committed
assignee: nobody → Paolo Pisati (p-pisati)
Changed in linux (Ubuntu Precise):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.2.0-8.15

---------------
linux (3.2.0-8.15) precise; urgency=low

  [ Leann Ogasawara ]

  * [Config] Disable CONFIG_ACPI_PROCFS
  * Remove server from getabis
  * Temporarily disable module check
  * [Config] Disable CONFIG_MTD_TESTS
  * [Config] Disable CONFIG_X86_E_POWERSAVER
  * [Config] Set CONFIG_ARCNET=m
  * [Config] Enable CONFIG_ATM_DUMMY=m
  * [Config] Enable CONFIG_BLK_DEV_MD=y
  * ubuntu: fsam7400 select CHECK_SIGNATURE and depend on X86
  * [Config] Enable CONFIG_BLK_DEV_SD=y
  * [Config] Enable CONFIG_BLK_DEV_SR=y
  * [Config] Enable CONFIG_BLK_DEV_UB=m
  * [Config] Enable CONFIG_COPS=m
  * [Config] Enable CONFIG_DVB_USB_EC168=m
  * [Config] Enable CONFIG_ENC28J60=m
  * [Config] Enable CONFIG_FB_UVESA=m
  * [Config] Enable CONFIG_FB_ATY=m
  * [Config] Enable CONFIG_BROADCOM_PHY=y
  * [Config] Enable CONFIG_CICADA_PHY=y
  * [Config] Enable CONFIG_DAVICOM_PHY=y
  * [Config] Enable CONFIG_ICPLUS_PHY=y
  * [Config] Enable CONFIG_LSI_ET1011C_PHY=y
  * [Config] Enable CONFIG_LXT_PHY=y
  * [Config] Enable CONFIG_MARVELL_PHY=y
  * [Config] Enable CONFIG_NATIONAL_PHY=y
  * [Config] Enable CONFIG_QSEMI_PHY=y
  * [Config] Enable CONFIG_SMSC_PHY=y
  * [Config] Enable CONFIG_VITESSE_PHY=y
  * Add 3w-sas to scsi-modules
    - LP: #776542

  [ Mathieu Trudel-Lapierre ]

  * SAUCE: ipv6: make the net.ipv6.conf.all.use_tempaddr sysctl propagate
    to interface settings

  [ Paolo Pisati ]

  * Revert "SAUCE: omap3: beagle: if rev unknown, assume xM revision C"
    - LP: #912199
  * Revert "SAUCE: omap3: beagle: detect new xM revision B"
    - LP: #912199
  * Revert "SAUCE: omap3: beaglexm: fix DVI initialization"
    - LP: #912199

  [ Upstream Kernel Changes ]

  * Bluetooth: Add support for BCM20702A0 [0a5c:21e3]
    - LP: #906832
 -- Leann Ogasawara <email address hidden> Fri, 06 Jan 2012 10:02:03 -0800

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released
Herton R. Krzesinski (herton) wrote :

This bug is awaiting verification that the kernel for Oneiric in -proposed solves the problem (3.0.0-16.28). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-oneiric' to 'verification-done-oneiric'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-oneiric
Paolo Pisati (p-pisati) on 2012-02-02
tags: added: verification-done-oneiric
removed: verification-needed-oneiric
Launchpad Janitor (janitor) wrote :
Download full text (14.0 KiB)

This bug was fixed in the package linux - 3.0.0-16.28

---------------
linux (3.0.0-16.28) oneiric-proposed; urgency=low

  [Herton R. Krzesinski]

  * Release Tracking Bug
    - LP: #922692

  [ Upstream Kernel Changes ]

  * Revert "drm/i915/dp: Fix the math in intel_dp_link_required"
    - LP: #919350

linux (3.0.0-16.27) oneiric-proposed; urgency=low

  [Brad Figg]

  * Release Tracking Bug
    - LP: #920735

  [ Paolo Pisati ]

  * Revert "SAUCE: omap3: beagle: if rev unknown, assume xM revision C"
    - LP: #912199
  * Revert "SAUCE: omap3: beagle: detect new xM revision C"
    - LP: #912199
  * Revert "SAUCE: omap3: beagle: detect new xM revision B"
    - LP: #912199
  * Revert "SAUCE: omap3: beaglexm: fix DVI initialization"
    - LP: #912199
  * [Config] DEFAULT_MMAP_MIN_ADDR=32k on arm
    - LP: #903346

  [ Upstream Kernel Changes ]

  * Revert "rtc: Disable the alarm in the hardware"
    - LP: #913373
  * Support for Terratec G1
    - LP: #821061
  * drm/radeon/kms: fix DP detect and EDID fetch for DP bridges
    - LP: #825777
  * drm/radeon/kms/DCE4.1: fix Select_CrtcSource EncodeMode setting for DP
    bridges (v2)
    - LP: #825777
  * drm/radeon/kms: cleanup atombios_adjust_pll()
    - LP: #825777
  * drm/radeon/kms/atom: rework encoder dpms
    - LP: #825777
  * drm/radeon/kms: check for DP MST mode in a few more places (v2)
    - LP: #825777
  * drm/radeon/kms: rework DP bridge checks
    - LP: #825777
  * drm/radeon/kms: fix DP setup on TRAVIS bridges
    - LP: #825777
  * ALSA: sis7019 - give slow codecs more time to reset
    - LP: #907778
  * ALSA: hda/realtek - Fix Oops in alc_mux_select()
    - LP: #907778
  * alarmtimers: Fix time comparison
    - LP: #907778
  * ARM: davinci: da850 evm: change audio edma event queue to EVENTQ_0
    - LP: #907778
  * arm: mx23: recognise stmp378x as mx23
    - LP: #907778
  * ARM: at91: fix clock conid for atmel_tcb.1 on 9260/9g20
    - LP: #907778
  * ARM: davinci: dm646x evm: wrong register used in
    setup_vpif_input_channel_mode
    - LP: #907778
  * ASoC: Provide a more complete DMA driver stub
    - LP: #907778
  * fs/proc/meminfo.c: fix compilation error
    - LP: #907778
  * thp: add compound tail page _mapcount when mapped
    - LP: #907778
  * thp: set compound tail page _count to zero
    - LP: #907778
  * ptp: Fix clock_getres() implementation
    - LP: #907778
  * mm: Ensure that pfn_valid() is called once per pageblock when reserving
    pageblocks
    - LP: #907778
  * mm: vmalloc: check for page allocation failure before vmlist insertion
    - LP: #907778
  * fix apparmor dereferencing potentially freed dentry, sanitize
    __d_path() API
    - LP: #907778
  * target: Handle 0 correctly in transport_get_sectors_6()
    - LP: #907778
  * intel-iommu: fix return value of iommu_unmap() API
    - LP: #907778
  * intel-iommu: set iommu_superpage on VM domains to lowest common
    denominator
    - LP: #907778
  * intel-iommu: fix superpage support in pfn_to_dma_pte()
    - LP: #907778
  * percpu: fix chunk range calculation
    - LP: #907778
  * iwlwifi: do not re-configure HT40 after associated
    - LP: #907778
  * mac80211: fix race condition caused by late addBA respon...

Changed in linux (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers