Ubuntu

Newly created users cannot access ext4 partitions.

Reported by vipin ms on 2012-01-04
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Hello,

Let me explain my issue in detail, so that you all get a clear picture.

I have a laptop and it's running on ubuntu 11.10. Also i had partitioned my hdd to different partitions, please note that all of my partitions are ext4(one is ntfs). When I installed ubuntu I created a default user named ms. After the install I created another user named abc. The problem is this newly created user(abc) cannot access my internal partitions except ntfs. Here are the various logs.

---
$lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric

$ uname -a
Linux ms-Lenovo-G550 3.0.0-14-generic #23-Ubuntu SMP Mon Nov 21 20:34:47 UTC 2011 i686 i686 i386 GNU/Linux

$ egrep "abc|ms" /etc/passwd
ms:x:1000:1000:MS,,,:/home/ms:/bin/bash
abc:x:1002:1002:abc,,,:/home/abc:/bin/bash

$ id ms
uid=1000(ms) gid=1000(ms) groups=1000(ms),1002(abc),1003(hdd)
abc@ms-Lenovo-G550:~$ id abc
uid=1002(abc) gid=1002(abc) groups=1002(abc),1000(ms),1003(hdd)

abc@ms-Lenovo-G550:~$ mount |tail -5
/dev/sda5 on /media/Songs type ext4 (rw,noexec,nosuid,nodev,commit=0)
/dev/sda8 on /media/Misc_ type ext4 (rw,nosuid,nodev,commit=0,uhelper=udisks)
/dev/sda7 on /media/Softs type ext4 (rw,nosuid,nodev,commit=0,uhelper=udisks)
/dev/sda6 on /media/Films type ext4 (rw,nosuid,nodev,uhelper=udisks)
/dev/sda2 on /media/TEST type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096,default_permissions)

abc@ms-Lenovo-G550:~$ ll /media/
total 32
drwxr-xr-x 8 root root 4096 2012-01-04 16:49 ./
drwxr-xr-x 24 root root 4096 2011-12-11 22:30 ../
drwxrw---- 6 ms ms 4096 2011-11-19 15:45 Films/
drwxr-xr-x 2 root root 4096 2011-12-29 22:40 Misc/
drwx------ 18 ms ms 4096 2011-12-30 17:28 Misc_/
drwx------ 18 ms ms 4096 2012-01-01 08:55 Softs/
drwxrwx---+ 6 ms abc 4096 2011-11-17 03:06 Songs/
drwx------ 1 abc abc 4096 2012-01-04 16:49 TEST/

abc@ms-Lenovo-G550:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sda1 during installation
UUID=9fa65e41-5c75-4636-a3b5-961739b245c2 / ext4 errors=remount-ro 0 1

/dev/sda5 /media/Songs ext4 rw,users,acl 0 0

I mounted all those partitions under the user account abc, but see the permissions except NTFS one(also leave the Songs partition)

Anyway to mount ext4 as same as ntfs? is it a bug or something?

Thanks
Vipin MS
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu4
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ms 1854 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf4700000 irq 46'
   Mixer name : 'Conexant CX20561 (Hermosa)'
   Components : 'HDA:80862802,80860101,00100000 HDA:14f15051,17aac001,00100000'
   Controls : 20
   Simple ctrls : 9
CurrentDmesg: Error: command ['sh', '-c', 'dmesg | comm -13 --nocheck-order /var/log/dmesg -'] failed with exit code 1: comm: /var/log/dmesg: Permission denied
DistroRelease: Ubuntu 11.10
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
MachineType: LENOVO 2958
NonfreeKernelModules: wl
Package: linux (not installed)
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-14-generic root=UUID=9fa65e41-5c75-4636-a3b5-961739b245c2 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.0.0-14.23-generic 3.0.9
Tags: oneiric running-unity
Uname: Linux 3.0.0-14-generic i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 01/18/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 18CN42WW(V2.51)
dmi.board.name: NITU1
dmi.board.vendor: LENOVO
dmi.board.version: REFERENCE
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: No Enclosure
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnLENOVO:bvr18CN42WW(V2.51):bd01/18/2010:svnLENOVO:pn2958:pvrLenovoG550:rvnLENOVO:rnNITU1:rvrREFERENCE:cvnNoEnclosure:ct10:cvrN/A:
dmi.product.name: 2958
dmi.product.version: Lenovo G550
dmi.sys.vendor: LENOVO

vipin ms (vipinmsx) on 2012-01-04
description: updated

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 911709

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: oneiric

apport information

tags: added: apport-collected running-unity
description: updated

apport information

apport information

apport information

apport information

vipin ms (vipinmsx) wrote : Lspci.txt

apport information

vipin ms (vipinmsx) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
vipin ms (vipinmsx) wrote :

After digging and digging I found the answer. It is due to "take ownership of filesystem" option in palimset(Disk utility). If you set that option while formatting any of the partition(ext4/ext3) you cannot write/read it under different user. I found the answer, so I'm closing this bug as solved.

Changed in linux (Ubuntu):
status: Confirmed → Opinion
status: Opinion → Fix Released
status: Fix Released → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers