Oneiric update to 3.0.14 stable release

Bug #907778 reported by Tim Gardner on 2011-12-22
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

SRU Justification

    Impact:
       The upstream process for stable tree updates is quite similar
       in scope to the Ubuntu SRU process, e.g., each patch has to
       demonstrably fix a bug, and each patch is vetted by upstream
       by originating either directly from Linus' tree or in a minimally
       backported form of that patch. The 3.0.14 upstream stable
       patch set is now available. It should be included in the Ubuntu
       kernel as well.

       git://git.kernel.org/

    TEST CASE: TBD

       The following patches are in the 3.0.14 stable release:
ALSA: sis7019 - give slow codecs more time to reset
ALSA: hda/realtek - Fix Oops in alc_mux_select()
alarmtimers: Fix time comparison
ARM: davinci: da850 evm: change audio edma event queue to EVENTQ_0
arm: mx23: recognise stmp378x as mx23
ARM: at91: fix clock conid for atmel_tcb.1 on 9260/9g20
ARM: davinci: dm646x evm: wrong register used in setup_vpif_input_channel_mode
ASoC: Provide a more complete DMA driver stub
fs/proc/meminfo.c: fix compilation error
thp: add compound tail page _mapcount when mapped
thp: set compound tail page _count to zero
ptp: Fix clock_getres() implementation
mm: Ensure that pfn_valid() is called once per pageblock when reserving pageblocks
mm: vmalloc: check for page allocation failure before vmlist insertion
fix apparmor dereferencing potentially freed dentry, sanitize __d_path() API
target: Handle 0 correctly in transport_get_sectors_6()
intel-iommu: fix return value of iommu_unmap() API
intel-iommu: set iommu_superpage on VM domains to lowest common denominator
intel-iommu: fix superpage support in pfn_to_dma_pte()
percpu: fix chunk range calculation
iwlwifi: do not re-configure HT40 after associated
mac80211: fix race condition caused by late addBA response
linux/log2.h: Fix rounddown_pow_of_two(1)
hwmon: (jz4740) fix signedness bug
mmc: mxcmmc: fix falling back to PIO
x86, hpet: Immediately disable HPET timer 1 if rtc irq is masked
jbd/jbd2: validate sb->s_first in journal_get_superblock()
hfs: fix hfs_find_init() sb->ext_tree NULL ptr oops
hwmon: (coretemp) Fix oops on CPU offlining
xfs: fix nfs export of 64-bit inodes numbers on 32-bit kernels
xfs: avoid synchronous transactions when deleting attr blocks
md/raid5: fix bug that could result in reads from a failed device.
xen: only limit memory map to maximum reservation for domain 0.
ext4: display the correct mount option in /proc/mounts for [no]init_itable
ext4: avoid hangs in ext4_da_should_update_i_disksize()
ext4: avoid potential hang in mpage_submit_io() when blocksize < pagesize
ext4: handle EOF correctly in ext4_bio_write_page()
fuse: fix fuse_retrieve
staging: r8712u: Add new USB ID
drm/radeon/kms: add some new pci ids
ibft: Fix finding IBFT ACPI table on UEFI
USB: cdc-acm: add IDs for Motorola H24 HSPA USB module.
usb: option: Add Huawei E398 controlling interfaces
USB: option: Removing one bogus and adding some new Huawei combinations
ASoC: core: Don't schedule deferred_resume_work twice
Linux 3.0.14

Tim Gardner (timg-tpi) on 2011-12-22
tags: added: kernel-stable-tracking-bug
Tim Gardner (timg-tpi) on 2011-12-22
description: updated
Launchpad Janitor (janitor) wrote :
Download full text (14.0 KiB)

This bug was fixed in the package linux - 3.0.0-16.28

---------------
linux (3.0.0-16.28) oneiric-proposed; urgency=low

  [Herton R. Krzesinski]

  * Release Tracking Bug
    - LP: #922692

  [ Upstream Kernel Changes ]

  * Revert "drm/i915/dp: Fix the math in intel_dp_link_required"
    - LP: #919350

linux (3.0.0-16.27) oneiric-proposed; urgency=low

  [Brad Figg]

  * Release Tracking Bug
    - LP: #920735

  [ Paolo Pisati ]

  * Revert "SAUCE: omap3: beagle: if rev unknown, assume xM revision C"
    - LP: #912199
  * Revert "SAUCE: omap3: beagle: detect new xM revision C"
    - LP: #912199
  * Revert "SAUCE: omap3: beagle: detect new xM revision B"
    - LP: #912199
  * Revert "SAUCE: omap3: beaglexm: fix DVI initialization"
    - LP: #912199
  * [Config] DEFAULT_MMAP_MIN_ADDR=32k on arm
    - LP: #903346

  [ Upstream Kernel Changes ]

  * Revert "rtc: Disable the alarm in the hardware"
    - LP: #913373
  * Support for Terratec G1
    - LP: #821061
  * drm/radeon/kms: fix DP detect and EDID fetch for DP bridges
    - LP: #825777
  * drm/radeon/kms/DCE4.1: fix Select_CrtcSource EncodeMode setting for DP
    bridges (v2)
    - LP: #825777
  * drm/radeon/kms: cleanup atombios_adjust_pll()
    - LP: #825777
  * drm/radeon/kms/atom: rework encoder dpms
    - LP: #825777
  * drm/radeon/kms: check for DP MST mode in a few more places (v2)
    - LP: #825777
  * drm/radeon/kms: rework DP bridge checks
    - LP: #825777
  * drm/radeon/kms: fix DP setup on TRAVIS bridges
    - LP: #825777
  * ALSA: sis7019 - give slow codecs more time to reset
    - LP: #907778
  * ALSA: hda/realtek - Fix Oops in alc_mux_select()
    - LP: #907778
  * alarmtimers: Fix time comparison
    - LP: #907778
  * ARM: davinci: da850 evm: change audio edma event queue to EVENTQ_0
    - LP: #907778
  * arm: mx23: recognise stmp378x as mx23
    - LP: #907778
  * ARM: at91: fix clock conid for atmel_tcb.1 on 9260/9g20
    - LP: #907778
  * ARM: davinci: dm646x evm: wrong register used in
    setup_vpif_input_channel_mode
    - LP: #907778
  * ASoC: Provide a more complete DMA driver stub
    - LP: #907778
  * fs/proc/meminfo.c: fix compilation error
    - LP: #907778
  * thp: add compound tail page _mapcount when mapped
    - LP: #907778
  * thp: set compound tail page _count to zero
    - LP: #907778
  * ptp: Fix clock_getres() implementation
    - LP: #907778
  * mm: Ensure that pfn_valid() is called once per pageblock when reserving
    pageblocks
    - LP: #907778
  * mm: vmalloc: check for page allocation failure before vmlist insertion
    - LP: #907778
  * fix apparmor dereferencing potentially freed dentry, sanitize
    __d_path() API
    - LP: #907778
  * target: Handle 0 correctly in transport_get_sectors_6()
    - LP: #907778
  * intel-iommu: fix return value of iommu_unmap() API
    - LP: #907778
  * intel-iommu: set iommu_superpage on VM domains to lowest common
    denominator
    - LP: #907778
  * intel-iommu: fix superpage support in pfn_to_dma_pte()
    - LP: #907778
  * percpu: fix chunk range calculation
    - LP: #907778
  * iwlwifi: do not re-configure HT40 after associated
    - LP: #907778
  * mac80211: fix race condition caused by late addBA respon...

Changed in linux (Ubuntu Oneiric):
status: New → Fix Released
Changed in linux (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers