Clientron E830 Thin Client Needs LDVS removed

Bug #907055 reported by jsass on 2011-12-20
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linux
Undecided
auto-dri-devel
linux (Ubuntu)
Medium
jsass
Precise
Medium
jsass

Bug Description

This thin client is based on an Atom chipset associated with a few netbooks. By default, the LVDS output is left running, and must be disabled in some fashion. Without disabling LVDS, the client appears to be running in dual monitor mode, with only on monitor present.

I have submitted a patch to drivers/gpu/drm/i915/intel_lvds.c for your approval. This addition will permanently disable the non-working LVDS output.
---
AlsaDevices:
 total 0
 crw-rw---T 1 root audio 116, 1 Dec 20 14:44 seq
 crw-rw---T 1 root audio 116, 33 Dec 20 14:44 timer
AplayDevices: aplay: device_list:242: no soundcards found...
ApportVersion: 1.90-0ubuntu1
Architecture: amd64
ArecordDevices: arecord: device_list:242: no soundcards found...
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
CRDA: Error: [Errno 2] No such file or directory
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=416b93f7-becb-4cb1-8f46-98ec74da850b
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111208)
IwConfig:
 lo no wireless extensions.

 eth1 no wireless extensions.

 eth0 no wireless extensions.
Lsusb: Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: Bochs Bochs
Package: linux (not installed)
PciMultimedia:

ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-6-generic root=UUID=68855c0c-4323-4c50-9894-4276925c50a1 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-6.12-generic 3.2.0-rc6
PulseSinks:
 Error: command ['pacmd', 'list-sinks'] failed with exit code 1: Home directory /home/jsass not ours.
 No PulseAudio daemon running, or not running as session daemon.
PulseSources:
 Error: command ['pacmd', 'list-sources'] failed with exit code 1: Home directory /home/jsass not ours.
 No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-6-generic N/A
 linux-backports-modules-3.2.0-6-generic N/A
 linux-firmware 1.66
RfKill:

Tags: precise
Uname: Linux 3.2.0-6-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 01/01/2007
dmi.bios.vendor: Bochs
dmi.bios.version: Bochs
dmi.chassis.type: 1
dmi.chassis.vendor: Bochs
dmi.modalias: dmi:bvnBochs:bvrBochs:bd01/01/2007:svnBochs:pnBochs:pvr:cvnBochs:ct1:cvr:
dmi.product.name: Bochs
dmi.sys.vendor: Bochs

jsass (sass-joel) wrote :

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 907055

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
status: Incomplete → New
status: New → Incomplete

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get upgrade

If the bug still exists, change the bug status from Incomplete to Incomplete. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

tags: added: kernel-request-3.2.0-6.12

apport information

tags: added: apport-collected
description: updated

apport information

apport information

jsass (sass-joel) wrote : Lspci.txt

apport information

apport information

apport information

apport information

jsass (sass-joel) wrote : UdevDb.txt

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Thank you for providing a patch, and making Ubuntu better.

Can you provide some information on the status of the patch with regards to getting it merged upstream? Has it been sent upstream, what sort of feedback has it received, is it getting applied to a subsystem maintainer's tree, etc?

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: kernel-da-key
jsass (sass-joel) wrote :

@jsalisbury

Is there any further information I could provide you? This is my first kernel patch, and am unsure if you are asking me about merging upstream.

Joseph Salisbury (jsalisbury) wrote :

I was asking if you submitted the patch upstream as of yet. This is usually done by contacting the maintainer of a subsystem or sending email to LKML. The reason is that the kernel team is reluctant (not opposed) to apply any patch to a stable kernel that is not from upstream. Applying patches that don't come from upstream add greatly to the support of the kernel as other upstream patches may touch the same area as the non-upstream patch and may prevent them from applying cleanly.

There is some good information available here:
http://kernelnewbies.org/UpstreamMerge

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-7.13
Stéphane Graber (stgraber) wrote :

Disabled the bot as the bug affects any given kernel, so we don't need the extra flood.
This is an almost identical fix to what I did for the Clientron U800 back in Lucid.

Can someone in the kernel team have a quick look to see if it looks and if so, forward the patch upstream?
In my experience this kind of blacklisting are easy fixes that tend to be accepted quite quickly upstream (as the only other way of solving these is by recalling all the affected hardware and flash a new video BIOS).

Changed in linux (Ubuntu):
status: Incomplete → Triaged
tags: added: bot-stop-nagging
Stéphane Graber (stgraber) wrote :

Discussed with jsass on IRC, suggested he forwards the patch by e-mail to <email address hidden> and posts the result of the discussion in the bug report so the fix can be cherry-picked when accepted.

jsass (sass-joel) wrote :

Submitted upstream to dri-devel

Joseph Salisbury (jsalisbury) wrote :

Can you provide some information on the status of the patch once you get a response from upstream? What sort of feedback has it received, is it getting applied to a subsystem maintainer's tree, etc?

jsass (sass-joel) wrote :

I just received my first response to the patch I filed this morning at 11:44AM (EST).

The full response is as follows:

 > --- ./intel_lvds.old 2011-12-20 13:25:49.368291249 -0500
 > +++ ./intel_lvds.c 2011-12-20 13:26:05.160291248 -0500
 > @@ -709,6 +709,14 @@
 > },
 > {
 > .callback = intel_no_lvds_dmi_callback,
 > + .ident = "Clientron E830",
 > + .matches = {
 > + DMI_MATCH(DMI_SYS_VENDOR, "Clientron"),
 > + DMI_MATCH(DMI_PRODUCT_NAME, "E830"),
 > + },
 > + },
 > + {
 > + .callback = intel_no_lvds_dmi_callback,
 > .ident = "Asus EeeBox PC EB1007",
 > .matches = {
 > DMI_MATCH(DMI_SYS_VENDOR, "ASUSTeK Computer INC."),
Reviewed-by: Adam Jackson <email address hidden>

- ajax

Unsure what reviewed consists of, but there does appear to be action on it.

jsass (sass-joel) wrote :

Reviewed-by Adam Jackson on dri-devel mailing list.

Changed in linux (Ubuntu):
assignee: nobody → jsass (sass-joel)
jsass (sass-joel) wrote :

From: Joel Sass <email address hidden>

Signed-off-by: Joel Sass <email address hidden>
Reviewed-by: Adam Jackson <email address hidden>
---
 drivers/gpu/drm/i915/intel_lvds.c | 8 ++++++++
 1 files changed, 8 insertions(+), 0 deletions(-)

diff --git a/drivers/gpu/drm/i915/intel_lvds.c b/drivers/gpu/drm/i915/intel_lvds.c
index 77578b4..e44988e 100644
--- a/drivers/gpu/drm/i915/intel_lvds.c
+++ b/drivers/gpu/drm/i915/intel_lvds.c
@@ -708,6 +708,14 @@ static const struct dmi_system_id intel_no_lvds[] = {
   },
  },
  {
+ .callback = intel_no_lvds_dmi_callback,
+ .ident = "Clientron E830",
+ .matches = {
+ DMI_MATCH(DMI_SYS_VENDOR, "Clientron"),
+ DMI_MATCH(DMI_PRODUCT_NAME, "E830"),
+ },
+ },
+ {
   .callback = intel_no_lvds_dmi_callback,
   .ident = "Asus EeeBox PC EB1007",
   .matches = {
-- 1.7.0.4

Changed in linux (Ubuntu):
status: Triaged → Fix Committed
jsass (sass-joel) wrote :

Merged to drm-intel-next-fixes.
   8ca4013..44306ab drm-intel-next-fixes -> drm-intel-next-fixes

jsass (sass-joel) wrote :
Changed in linux:
status: New → Fix Committed
tags: removed: kernel-da-key
Tim Gardner (timg-tpi) wrote :

committed to precise: "drm/i915: Add Clientron E830 to the ignore LVDS list"

The attachment "patch for drivers/gpu/drm/i915/intel_lvds.c" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

Launchpad Janitor (janitor) wrote :
Download full text (4.4 KiB)

This bug was fixed in the package linux - 3.2.0-21.34

---------------
linux (3.2.0-21.34) precise; urgency=low

  [ AceLan Kao ]

  * SAUCE: (drop after 3.4) asus-wmi: add scalar board brightness adj.
    support
    - LP: #961879
  * SAUCE: (drop after 3.4) asus-wmi: store backlight power status for AIO
    machine
    - LP: #961880

  [ Andy Whitcroft ]

  * [Config]: enable CONFIG_DRM_LOAD_EDID_FIRMWARE

  [ John Johansen ]

  * SAUCE: AppArmor: Add the ability to mediate mount
  * SAUCE: AppArmor: Add profile introspection file to interface
  * SAUCE: AppArmor: basic networking rules
  * SAUCE: Update aufs for build failure caused by apparmor backport
  * SAUCE: AppArmor: Fix change_onexec when called from a confined task
    - LP: #963756

  [ Leann Ogasawara ]

  * Revert "SAUCE: (drop after 3.3) platform/x86: Add driver for Apple gmux
    device"
  * Rebase to v3.2.13
  * d-i: Fix iwl3945 driver name typo in nic-modules
  * d-i: Add missing iwl* drivers to nic-modules
    - LP: #965116
  * d-i: Remove obsolete bcm43xx* drivers from nic-modules
  * d-i: Add brcm*mac drivers to nic-modules

  [ Seth Forshee ]

  * SAUCE: (drop after 3.3) apple_bl: Add register/unregister functions
  * SAUCE: (drop after 3.3) platform/x86: Add driver for Apple gmux device

  [ Tim Gardner ]

  * Add isci to debian scsi-modules udeb
    - LP: #963306
  * SAUCE: fsam7400: use UMH_WAIT_PROC consistently
    - LP: #963685
  * SAUCE: disable_nx should not be in __cpuinitdata section for X86_32
    - LP: #968233

  [ Upstream Kernel Changes ]

  * Bluetooth: Adding USB device 13d3:3375 as an Atheros AR3012.
    - LP: #916319
  * x86: Report cpb and eff_freq_ro flags correctly
    - LP: #960461
  * x86/amd: Add missing feature flag for fam15h models 10h-1fh processors
    - LP: #960461
  * KVM: Move cpuid code to new file
    - LP: #960466
  * KVM: expose latest Intel cpu new features (BMI1/BMI2/FMA/AVX2) to guest
    - LP: #960466
  * apparmor: add missing rcu_dereference()
  * apparmor: fix module parameter handling
  * btrfs, nfs, apparmor: don't pull mnt_namespace.h for no reason...
  * switch security_path_chmod() to umode_t
  * switch securityfs_create_file() to umode_t
  * switch ->path_mkdir() to umode_t
  * switch ->path_mknod() to umode_t
  * capabilities: remove the task from capable LSM hook entirely
  * switch security_path_chmod() to struct path *
  * AppArmor: refactor securityfs to use structures
  * AppArmor: add initial "features" directory to securityfs
  * AppArmor: add "file" details to securityfs
  * AppArmor: export known rlimit names/value mappings in securityfs
  * AppArmor: Add mising end of structure test to caps unpacking
  * AppArmor: Fix dropping of allowed operations that are force audited
  * AppArmor: Fix underflow in xindex calculation
  * AppArmor: fix mapping of META_READ to audit and quiet flags
  * AppArmor: Fix the error case for chroot relative path name lookup
  * AppArmor: Fix error returned when a path lookup is disconnected
  * AppArmor: Fix oops in policy unpack auditing
  * AppArmor: Add const qualifiers to generated string tables
  * AppArmor: Retrieve the dentry_path for error reporting when path lookup
    fails
...

Read more...

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

  • auto-dri-devel Edit

Bug watches keep track of this bug in other bug trackers.