Broadcom bluetooth device BCM20702A0 [0a5c:21e3] not supported

Bug #906832 reported by Glaf on 2011-12-20
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Jesse Sung
Oneiric
High
James M. Leddy
Precise
Medium
Jesse Sung

Bug Description

Same as
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/854399

# usb-devices
T: Bus=06 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 4 Spd=12 MxCh= 0
D: Ver= 2.00 Cls=ff(vend.) Sub=01 Prot=01 MxPS=64 #Cfgs= 1
P: Vendor=0a5c ProdID=21e3 Rev=01.12
S: Manufacturer=Broadcom Corp
S: Product=BCM20702A0
S: SerialNumber=9439E5CBF66C
C: #Ifs= 4 Cfg#= 1 Atr=e0 MxPwr=0mA
I: If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=01 Prot=01 Driver=(none)
I: If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=01 Prot=01 Driver=(none)
I: If#= 2 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
I: If#= 3 Alt= 0 #EPs= 0 Cls=fe(app. ) Sub=01 Prot=01 Driver=(none)

# uname -r
3.0.0-14-generic

Notebook HP Pavilion dm1-4000
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 1: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: av 2374 F.... pulseaudio
CRDA: Error: [Errno 2] Нет такого файла или каталога
Card0.Amixer.info:
 Card hw:0 'Generic'/'HD-Audio Generic at 0xf0344000 irq 42'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 4
   Simple ctrls : 1
Card0.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Card1.Amixer.info:
 Card hw:1 'SB'/'HDA ATI SB at 0xf0340000 irq 16'
   Mixer name : 'IDT 92HD87B2/4'
   Components : 'HDA:111d76d9,103c3387,00100107'
   Controls : 14
   Simple ctrls : 9
DistroRelease: Ubuntu 11.10
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: Hewlett-Packard HP Pavilion dm1 Notebook PC
NonfreeKernelModules: wl fglrx
Package: linux (not installed)
ProcEnviron:
 PATH=(custom, no user)
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-14-generic root=UUID=4bb088d9-a3af-4164-a444-08e5e0c95689 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.0.0-14.23-generic 3.0.9
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-14-generic N/A
 linux-backports-modules-3.0.0-14-generic N/A
 linux-firmware 1.60
StagingDrivers: brcmsmac brcmutil
Tags: oneiric running-unity staging
Uname: Linux 3.0.0-14-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout libvirtd lpadmin plugdev sambashare
dmi.bios.date: 08/04/2011
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.01
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 3387
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 36.0A
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.01:bd08/04/2011:svnHewlett-Packard:pnHPPaviliondm1NotebookPC:pvr0697100000204600000320100:rvnHewlett-Packard:rn3387:rvr36.0A:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.name: HP Pavilion dm1 Notebook PC
dmi.product.version: 0697100000204600000320100
dmi.sys.vendor: Hewlett-Packard

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 906832

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Glaf (lxndr) wrote : AcpiTables.txt

apport information

tags: added: apport-collected oneiric running-unity staging
description: updated
Glaf (lxndr) wrote : AlsaDevices.txt

apport information

Glaf (lxndr) wrote : AplayDevices.txt

apport information

Glaf (lxndr) wrote : BootDmesg.txt

apport information

apport information

apport information

apport information

Glaf (lxndr) wrote : CurrentDmesg.txt

apport information

Glaf (lxndr) wrote : IwConfig.txt

apport information

Glaf (lxndr) wrote : Lspci.txt

apport information

Glaf (lxndr) wrote : Lsusb.txt

apport information

apport information

Glaf (lxndr) wrote : ProcCpuinfo.txt

apport information

apport information

Glaf (lxndr) wrote : ProcModules.txt

apport information

Glaf (lxndr) wrote : PulseSinks.txt

apport information

apport information

Glaf (lxndr) wrote : RfKill.txt

apport information

Glaf (lxndr) wrote : UdevDb.txt

apport information

Glaf (lxndr) wrote : UdevLog.txt

apport information

Glaf (lxndr) wrote : WifiSyslog.txt

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Glaf (lxndr) on 2011-12-20
description: updated
Jesse Sung (wenchien) wrote :

Glaf,

Could you try the following and see if bluetooth works?

sudo -i
modprobe btusb
echo "0a5c 21e3" >> /sys/bus/usb/drivers/btusb/new_id

Glaf (lxndr) wrote :

Thanks, Josse!

It's works!

Previously, this did not work. I have read in the Bug #854399 about patches and decided to try to compile linux kernel.

Glaf (lxndr) wrote :

How to close this ticket?

Jesse Sung (wenchien) wrote :

Glaf,

If you turn power off, and turn it on again, then go through the commands as above, does bluetooth work?
If it works, then we can generate a patch for supporting it. :)

Thanks.

Glaf (lxndr) wrote :

No, after reboot bluetooth is not work.
Really, it is bug.

But i use sleep mode in my notebook. This bug is not critical for me.

Glaf (lxndr) wrote :

This wonderfull script helps me again after reboot :)

sudo -i
modprobe btusb
echo "0a5c 21e3" >> /sys/bus/usb/drivers/btusb/new_id

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Jesse Sung (wenchien) on 2011-12-22
Changed in linux (Ubuntu):
assignee: nobody → Jesse Sung (wenchien)
status: Triaged → In Progress
Jesse Sung (wenchien) wrote :

patch sent to upstream for review.

tags: added: patch
Tim Gardner (timg-tpi) on 2012-01-09
Changed in linux (Ubuntu Precise):
status: In Progress → Fix Committed

The attachment "0001-Bluetooth-Add-support-for-BCM20702A0-0a5c-21e3.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.2.0-8.15

---------------
linux (3.2.0-8.15) precise; urgency=low

  [ Leann Ogasawara ]

  * [Config] Disable CONFIG_ACPI_PROCFS
  * Remove server from getabis
  * Temporarily disable module check
  * [Config] Disable CONFIG_MTD_TESTS
  * [Config] Disable CONFIG_X86_E_POWERSAVER
  * [Config] Set CONFIG_ARCNET=m
  * [Config] Enable CONFIG_ATM_DUMMY=m
  * [Config] Enable CONFIG_BLK_DEV_MD=y
  * ubuntu: fsam7400 select CHECK_SIGNATURE and depend on X86
  * [Config] Enable CONFIG_BLK_DEV_SD=y
  * [Config] Enable CONFIG_BLK_DEV_SR=y
  * [Config] Enable CONFIG_BLK_DEV_UB=m
  * [Config] Enable CONFIG_COPS=m
  * [Config] Enable CONFIG_DVB_USB_EC168=m
  * [Config] Enable CONFIG_ENC28J60=m
  * [Config] Enable CONFIG_FB_UVESA=m
  * [Config] Enable CONFIG_FB_ATY=m
  * [Config] Enable CONFIG_BROADCOM_PHY=y
  * [Config] Enable CONFIG_CICADA_PHY=y
  * [Config] Enable CONFIG_DAVICOM_PHY=y
  * [Config] Enable CONFIG_ICPLUS_PHY=y
  * [Config] Enable CONFIG_LSI_ET1011C_PHY=y
  * [Config] Enable CONFIG_LXT_PHY=y
  * [Config] Enable CONFIG_MARVELL_PHY=y
  * [Config] Enable CONFIG_NATIONAL_PHY=y
  * [Config] Enable CONFIG_QSEMI_PHY=y
  * [Config] Enable CONFIG_SMSC_PHY=y
  * [Config] Enable CONFIG_VITESSE_PHY=y
  * Add 3w-sas to scsi-modules
    - LP: #776542

  [ Mathieu Trudel-Lapierre ]

  * SAUCE: ipv6: make the net.ipv6.conf.all.use_tempaddr sysctl propagate
    to interface settings

  [ Paolo Pisati ]

  * Revert "SAUCE: omap3: beagle: if rev unknown, assume xM revision C"
    - LP: #912199
  * Revert "SAUCE: omap3: beagle: detect new xM revision B"
    - LP: #912199
  * Revert "SAUCE: omap3: beaglexm: fix DVI initialization"
    - LP: #912199

  [ Upstream Kernel Changes ]

  * Bluetooth: Add support for BCM20702A0 [0a5c:21e3]
    - LP: #906832
 -- Leann Ogasawara <email address hidden> Fri, 06 Jan 2012 10:02:03 -0800

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released
Tim Gardner (timg-tpi) on 2012-01-30
Changed in linux (Ubuntu Oneiric):
status: New → Fix Committed
Changed in linux (Ubuntu Oneiric):
assignee: nobody → James M. Leddy (jm-leddy)
importance: Undecided → High
tags: added: blocks-hwcert-enablement
Herton R. Krzesinski (herton) wrote :

This bug is awaiting verification that the kernel for Oneiric in -proposed (3.0.0-16.29) solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-oneiric' to 'verification-done-oneiric'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-oneiric
Anthony Wong (anthonywong) wrote :

@Glaf
Could you give the -proposed kernel a try by following the instructions in comment #32?
If it's not verified before Friday this week, the fix will be dropped. :(

Thanks.

Gab (contini-mailing) wrote :

Hi, i have an hp pavillion with this bluetooth device that started working [0a5c:21e3] as soon as i enabled the "proposed".

hpg6:~$ uname -a
Linux hpg6 3.0.0-16-generic #29-Ubuntu SMP Tue Feb 14 12:48:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

the latest kernel works for me.

Anthony Wong (anthonywong) wrote :

Gab, thanks for your confirmation.

tags: added: verification-done-oneiric
removed: verification-needed-oneiric
geekboy (jkohalmi) wrote :

Same problem here, "-proposed" kernel fixed it.

Launchpad Janitor (janitor) wrote :
Download full text (12.3 KiB)

This bug was fixed in the package linux - 3.0.0-16.29

---------------
linux (3.0.0-16.29) oneiric-proposed; urgency=low

  [Herton R. Krzesinski]

  * Release Tracking Bug
    - LP: #931661

  [ James M. Leddy ]

  * SAUCE: Bluetooth: Add support for BCM20702A0 [0a5c:21e6]
    - LP: #906832

  [ Manoj Iyer ]

  * SAUCE: Bluetooth: Add support for BCM20702A0 [0a5c:21e1]
    - LP: #906832

  [ Merlin Schumacher ]

  * SAUCE: acer-wmi: support for P key on TM8372
    - LP: #865807

  [ Tim Gardner ]

  * SAUCE: Add vendor specific ID (0a5c 21f3) for BCM20702A0
    - LP: #925552

  [ Upstream Kernel Changes ]

  * Revert "(pre-stable) HID: bump maximum global item tag report size to
    96 bytes"
    - LP: #922799
  * Revert "Revert "proc: enable writing to /proc/pid/mem""
    - LP: #922799
  * mtdoops: fix the oops_page_used array size
    - LP: #922799
  * mtd: mtdoops: skip reading initially bad blocks
    - LP: #922799
  * mtd: mtd_blkdevs: don't increase 'open' count on error path
    - LP: #922799
  * mtd: tests: stresstest: bail out if device has not enough eraseblocks
    - LP: #922799
  * drivers/rtc/interface.c: fix alarm rollover when day or month is
    out-of-range
    - LP: #922799
  * ext4: fix undefined behavior in ext4_fill_flex_info()
    - LP: #922799
  * ALSA: snd-usb-us122l: Delete calls to preempt_disable
    - LP: #922799
  * ALSA: ice1724 - Check for ac97 to avoid kernel oops
    - LP: #922799
  * ALSA: hda - Return the error from get_wcaps_type() for invalid NIDs
    - LP: #922799
  * drm/radeon/kms: workaround invalid AVI infoframe checksum issue
    - LP: #922799
  * drm/radeon/kms: disable writeback on pre-R300 asics
    - LP: #922799
  * radeon: Fix disabling PCI bus mastering on big endian hosts.
    - LP: #922799
  * NFS: Retry mounting NFSROOT
    - LP: #922799
  * NFSv4.1: fix backchannel slotid off-by-one bug
    - LP: #922799
  * nfs: fix regression in handling of context= option in NFSv4
    - LP: #922799
  * HID: bump maximum global item tag report size to 96 bytes
    - LP: #724831, #922799
  * UBI: fix missing scrub when there is a bit-flip
    - LP: #922799
  * UBI: fix use-after-free on error path
    - LP: #922799
  * PCI: Fix PCI_EXP_TYPE_RC_EC value
    - LP: #922799
  * PCI: msi: Disable msi interrupts when we initialize a pci device
    - LP: #922799
  * x86/PCI: Ignore CPU non-addressable _CRS reserved memory resources
    - LP: #922799
  * x86/PCI: build amd_bus.o only when CONFIG_AMD_NB=y
    - LP: #922799
  * SCSI: mpt2sas: Release spinlock for the raid device list before
    blocking it
    - LP: #922799
  * SCSI: mpt2sas : Fix for memory allocation error for large host credits
    - LP: #922799
  * xen/xenbus: Reject replies with payload > XENSTORE_PAYLOAD_MAX.
    - LP: #922799
  * ima: free duplicate measurement memory
    - LP: #922799
  * ima: fix invalid memory reference
    - LP: #922799
  * rtl8192se: Fix BUG caused by failure to check skb allocation
    - LP: #922799
  * mac80211: fix rx->key NULL pointer dereference in promiscuous mode
    - LP: #922799
  * memcg: add mem_cgroup_replace_page_cache() to fix LRU issue
    - LP: #922799
  * x86: Fix mmap random address range
    - LP: #92...

Changed in linux (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Stuart Trusty (stuart-trusty) wrote :

ASUS USB-BT400 USB Adapter w/ Bluetooth 4.0 - Ubuntu Linux 13.04 - Fix

sudo su -
modprobe -v btusb
echo "0b05 17cb" >> /sys/bus/usb/drivers/btusb/new_id

halfsoul (joelishness) wrote :

New Asus USB-BT400 not working.

Everything seems to indicate that this has been merged into the kernel and it should be supported, yet Ubuntu indicates "No Bluetooth adapters found".

Is this actually fixed or not?

Ubuntu 13.10

$ uname -r
3.11.0-12-generic

$ lsusb
Bus 003 Device 002: ID 0b05:17cb ASUSTek Computer, Inc.

halfsoul (joelishness) wrote :

Fixed after upgrading kernel.

$ uname -r
3.11.0-13-generic

Paulo Molina (polochamps2004) wrote :

Same issue with my bluetooth adapter - BCM20702A0 0b05:17cf.
Should I file another bug report?

Ubuntu 14.04

$ uname -r
3.13.0-35-generic

$ lsusb
Bus 003 Device 004: ID 0b05:17cf ASUSTek Computer, Inc.

Dominic Warzok (domi1wa) wrote :

I have the same problem with my bluetooth adapter.

$ lsusb
Bus 001 Device 005: ID 0b05:17cb ASUSTek Computer, Inc.

$ uname -r
3.13.0-39-generic

Syslog if you put in the Adapter:

Nov 18 19:22:16 domi-desktop kernel: [ 1068.984359] usb 1-4.1.1: new full-speed USB device number 9 using ehci-pci
Nov 18 19:22:16 domi-desktop kernel: [ 1069.080101] usb 1-4.1.1: New USB device found, idVendor=0b05, idProduct=17cb
Nov 18 19:22:16 domi-desktop kernel: [ 1069.080111] usb 1-4.1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Nov 18 19:22:16 domi-desktop kernel: [ 1069.080118] usb 1-4.1.1: Product: BCM20702A0
Nov 18 19:22:16 domi-desktop kernel: [ 1069.080123] usb 1-4.1.1: Manufacturer: Broadcom Corp
Nov 18 19:22:16 domi-desktop kernel: [ 1069.080127] usb 1-4.1.1: SerialNumber: 000272CDB488
Nov 18 19:22:16 domi-desktop mtp-probe: checking bus 1, device 9: "/sys/devices/pci0000:00/0000:00:12.2/usb1/1-4/1-4.1/1-4.1.1"
Nov 18 19:22:16 domi-desktop mtp-probe: bus: 1, device: 9 was not an MTP device

To post a comment you must log in.