External monitor loses the signal on video switch at times on Asus K54C

Bug #906756 reported by Keng-Yu Lin
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Keng-Yu Lin
Oneiric
High
Keng-Yu Lin
Precise
High
Keng-Yu Lin

Bug Description

This happens at times but with high possibility to reproduce.

On the extended monitor or mirror mode, sometimes the external monitor becomes blank and loses the signal.
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1534 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xdfc00000 irq 49'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:10ec0269,104313c7,00100100 HDA:80862805,80860101,00100000'
   Controls : 18
   Simple ctrls : 10
CurrentDmesg:
 [ 22.237101] init: plymouth-stop pre-start process (1367) terminated with status 1
 [ 22.793424] [drm] Changing LVDS panel from (-hsync, -vsync) to (-hsync, +vsync)
 [ 23.231518] EXT4-fs (sda3): re-mounted. Opts: errors=remount-ro,commit=0
 [ 27.055103] wlan0: no IPv6 routers present
 [ 119.540120] atl1c 0000:04:00.0: vpd r/w failed. This is likely a firmware bug on this device. Contact the card vendor for a firmware update.
DistributionChannelDescriptor:
 # This is a distribution channel descriptor
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-beitou-20111219-0
DistroRelease: Ubuntu 11.10
HibernationDevice: RESUME=UUID=a6d39502-b1da-4fee-b39b-e4f1bd78b0ff
InstallationMedia: Ubuntu 11.10 "Oneiric" - Build amd64 LIVE Binary 20111219-01:11
MachineType: ASUSTeK Computer Inc. K54C
Package: linux 3.0.0.14.16
PackageArchitecture: amd64
ProcEnviron:
 LANGUAGE=en_US:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-14-generic root=UUID=581e665d-03bf-4b35-bc6d-873040f2e20b ro quiet splash acpi_sleep=nonvs acpi_backlight=vendor acpi.brightness_switch_enabled=0 vt.handoff=7
ProcVersionSignature: Ubuntu 3.0.0-14.23beitou1-generic 3.0.9
PulseSinks:
 Error: command ['pacmd', 'list-sinks'] failed with exit code 1: Home directory /home/ubuntu not ours.
 No PulseAudio daemon running, or not running as session daemon.
PulseSources:
 Error: command ['pacmd', 'list-sources'] failed with exit code 1: Home directory /home/ubuntu not ours.
 No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-14-generic N/A
 linux-backports-modules-3.0.0-14-generic N/A
 linux-firmware 1.60
StagingDrivers: mei
Tags: oneiric staging
Uname: Linux 3.0.0-14-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 11/17/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: K54C.T11
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: K54C
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: ATN12345678901234567
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrK54C.T11:bd11/17/2011:svnASUSTeKComputerInc.:pnK54C:pvr1.0:rvnASUSTeKComputerInc.:rnK54C:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0:
dmi.product.name: K54C
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.

Keng-Yu Lin (lexical)
Changed in linux (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Keng-Yü Lin (lexical)
tags: added: blocks-hwcert-enablement
Revision history for this message
Keng-Yu Lin (lexical) wrote : AcpiTables.txt

apport information

tags: added: apport-collected oneiric staging
description: updated
Revision history for this message
Keng-Yu Lin (lexical) wrote : AlsaDevices.txt

apport information

Revision history for this message
Keng-Yu Lin (lexical) wrote : AplayDevices.txt

apport information

Revision history for this message
Keng-Yu Lin (lexical) wrote : BootDmesg.txt

apport information

Revision history for this message
Keng-Yu Lin (lexical) wrote : Card0.Amixer.values.txt

apport information

Revision history for this message
Keng-Yu Lin (lexical) wrote : Card0.Codecs.codec.0.txt

apport information

Revision history for this message
Keng-Yu Lin (lexical) wrote : Card0.Codecs.codec.3.txt

apport information

Revision history for this message
Keng-Yu Lin (lexical) wrote : Dependencies.txt

apport information

Revision history for this message
Keng-Yu Lin (lexical) wrote : IwConfig.txt

apport information

Revision history for this message
Keng-Yu Lin (lexical) wrote : Lspci.txt

apport information

Revision history for this message
Keng-Yu Lin (lexical) wrote : Lsusb.txt

apport information

Revision history for this message
Keng-Yu Lin (lexical) wrote : PciMultimedia.txt

apport information

Revision history for this message
Keng-Yu Lin (lexical) wrote : ProcCpuinfo.txt

apport information

Revision history for this message
Keng-Yu Lin (lexical) wrote : ProcInterrupts.txt

apport information

Revision history for this message
Keng-Yu Lin (lexical) wrote : ProcModules.txt

apport information

Revision history for this message
Keng-Yu Lin (lexical) wrote : RfKill.txt

apport information

Revision history for this message
Keng-Yu Lin (lexical) wrote : UdevDb.txt

apport information

Revision history for this message
Keng-Yu Lin (lexical) wrote : UdevLog.txt

apport information

Revision history for this message
Keng-Yu Lin (lexical) wrote : WifiSyslog.txt

apport information

Revision history for this message
Keng-Yu Lin (lexical) wrote :

SRU patch sent to u-k-t mailing list for review:

SRU Justification:

Impact:
  The external monitor becomes blank at times on extended or mirror mode.

Fix:
  Upstream commit 1519b9956eb4b4180fa3f47c73341463cdcfaa37
  with some conflicts resolved.

Testcase:
  Tested on Asus K54C, both analog VGA and HDMI ports work good.

Changed in linux (Ubuntu):
status: Confirmed → In Progress
Changed in linux (Ubuntu):
importance: Medium → High
Tim Gardner (timg-tpi)
Changed in linux (Ubuntu Precise):
status: In Progress → Fix Released
Changed in linux (Ubuntu Oneiric):
status: New → Fix Committed
assignee: nobody → Keng-Yü Lin (lexical)
Chris Van Hoof (vanhoof)
Changed in linux (Ubuntu Oneiric):
importance: Undecided → High
Revision history for this message
Herton R. Krzesinski (herton) wrote :

This bug is awaiting verification that the kernel for Oneiric in -proposed solves the problem (3.0.0-16.28). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-oneiric' to 'verification-done-oneiric'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-oneiric
Revision history for this message
AceLan Kao (acelankao) wrote :

Confirmed, after switching over 20 times, the extend and mirror mode are all working as expected.

tags: added: verification-done-oneiric
removed: verification-needed-oneiric
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (14.0 KiB)

This bug was fixed in the package linux - 3.0.0-16.28

---------------
linux (3.0.0-16.28) oneiric-proposed; urgency=low

  [Herton R. Krzesinski]

  * Release Tracking Bug
    - LP: #922692

  [ Upstream Kernel Changes ]

  * Revert "drm/i915/dp: Fix the math in intel_dp_link_required"
    - LP: #919350

linux (3.0.0-16.27) oneiric-proposed; urgency=low

  [Brad Figg]

  * Release Tracking Bug
    - LP: #920735

  [ Paolo Pisati ]

  * Revert "SAUCE: omap3: beagle: if rev unknown, assume xM revision C"
    - LP: #912199
  * Revert "SAUCE: omap3: beagle: detect new xM revision C"
    - LP: #912199
  * Revert "SAUCE: omap3: beagle: detect new xM revision B"
    - LP: #912199
  * Revert "SAUCE: omap3: beaglexm: fix DVI initialization"
    - LP: #912199
  * [Config] DEFAULT_MMAP_MIN_ADDR=32k on arm
    - LP: #903346

  [ Upstream Kernel Changes ]

  * Revert "rtc: Disable the alarm in the hardware"
    - LP: #913373
  * Support for Terratec G1
    - LP: #821061
  * drm/radeon/kms: fix DP detect and EDID fetch for DP bridges
    - LP: #825777
  * drm/radeon/kms/DCE4.1: fix Select_CrtcSource EncodeMode setting for DP
    bridges (v2)
    - LP: #825777
  * drm/radeon/kms: cleanup atombios_adjust_pll()
    - LP: #825777
  * drm/radeon/kms/atom: rework encoder dpms
    - LP: #825777
  * drm/radeon/kms: check for DP MST mode in a few more places (v2)
    - LP: #825777
  * drm/radeon/kms: rework DP bridge checks
    - LP: #825777
  * drm/radeon/kms: fix DP setup on TRAVIS bridges
    - LP: #825777
  * ALSA: sis7019 - give slow codecs more time to reset
    - LP: #907778
  * ALSA: hda/realtek - Fix Oops in alc_mux_select()
    - LP: #907778
  * alarmtimers: Fix time comparison
    - LP: #907778
  * ARM: davinci: da850 evm: change audio edma event queue to EVENTQ_0
    - LP: #907778
  * arm: mx23: recognise stmp378x as mx23
    - LP: #907778
  * ARM: at91: fix clock conid for atmel_tcb.1 on 9260/9g20
    - LP: #907778
  * ARM: davinci: dm646x evm: wrong register used in
    setup_vpif_input_channel_mode
    - LP: #907778
  * ASoC: Provide a more complete DMA driver stub
    - LP: #907778
  * fs/proc/meminfo.c: fix compilation error
    - LP: #907778
  * thp: add compound tail page _mapcount when mapped
    - LP: #907778
  * thp: set compound tail page _count to zero
    - LP: #907778
  * ptp: Fix clock_getres() implementation
    - LP: #907778
  * mm: Ensure that pfn_valid() is called once per pageblock when reserving
    pageblocks
    - LP: #907778
  * mm: vmalloc: check for page allocation failure before vmlist insertion
    - LP: #907778
  * fix apparmor dereferencing potentially freed dentry, sanitize
    __d_path() API
    - LP: #907778
  * target: Handle 0 correctly in transport_get_sectors_6()
    - LP: #907778
  * intel-iommu: fix return value of iommu_unmap() API
    - LP: #907778
  * intel-iommu: set iommu_superpage on VM domains to lowest common
    denominator
    - LP: #907778
  * intel-iommu: fix superpage support in pfn_to_dma_pte()
    - LP: #907778
  * percpu: fix chunk range calculation
    - LP: #907778
  * iwlwifi: do not re-configure HT40 after associated
    - LP: #907778
  * mac80211: fix race condition caused by late addBA respon...

Changed in linux (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers