Ubuntu

[Dell XPS L502X] Applying soft block to bluetooth hard blocks wlan

Reported by Jean-Louis Dupond on 2011-12-07
48
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Linux
Invalid
Medium
linux (Ubuntu)
Medium
Kamal Mostafa
Precise
Medium
Kamal Mostafa
Quantal
Medium
Kamal Mostafa

Bug Description

SRU Justification [precise]:

Impact: Prevents using WiFi without Bluetooth, or vice-versa.
Fix: Patch adds two Dell laptop models to rfkill blacklist table; affects only those models.
Testcase: Disable Bluetooth via the indicator icon; verify that WiFi continues to operate.

This patch is being carried in quantal as UBUNTU SAUCE (commit 318d5bb).

-----

In oneiric (and daily kernel) there seems to be a bug in dell-laptop.

When you kill dell-bluetooth, it also hard blocks 'Wireless LAN'.
This should NOT be the case and only block your bluetooth.

jean-louis@laptop-jl:~$ sudo rfkill list
0: dell-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: dell-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: dell-wwan: Wireless WAN
    Soft blocked: no
    Hard blocked: no
5: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
6: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
jean-louis@laptop-jl:~$ sudo rfkill block 1
jean-louis@laptop-jl:~$ sudo rfkill list
0: dell-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: dell-bluetooth: Bluetooth
    Soft blocked: yes
    Hard blocked: no
2: dell-wwan: Wireless WAN
    Soft blocked: no
    Hard blocked: no
6: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

FYI:
root@laptop-jl:/sys/kernel/debug/dell_laptop# cat rfkill
status: 0x1071D
Bit 0 : Hardware switch supported: 1
Bit 1 : Wifi locator supported: 0
Bit 2 : Wifi is supported: 1
Bit 3 : Bluetooth is supported: 1
Bit 4 : WWAN is supported: 1
Bit 5 : Wireless keyboard supported: 0
Bit 8 : Wifi is installed: 1
Bit 9 : Bluetooth is installed: 1
Bit 10: WWAN is installed: 1
Bit 16: Hardware switch is on: 1
Bit 17: Wifi is blocked: 0
Bit 18: Bluetooth is blocked: 0
Bit 19: WWAN is blocked: 0

hwswitch_state: 0x7
Bit 0 : Wifi controlled by switch: 1
Bit 1 : Bluetooth controlled by switch: 1
Bit 2 : WWAN controlled by switch: 1
Bit 7 : Wireless switch config locked: 0
Bit 8 : Wifi locator enabled: 0
Bit 15: Wifi locator setting locked: 0

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: linux-image-3.0.0-14-generic 3.0.0-14.23
ProcVersionSignature: Ubuntu 3.0.0-14.23-generic 3.0.9
Uname: Linux 3.0.0-14-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC665 Analog [ALC665 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: jean-louis 1941 F.... pulseaudio
CRDA: Error: [Errno 2] Bestand of map bestaat niet
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf1c00000 irq 53'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:10ec0665,1028050e,00100003 HDA:80862805,80860101,00100000'
   Controls : 27
   Simple ctrls : 13
Date: Wed Dec 7 21:55:07 2011
HibernationDevice: RESUME=UUID=633b79c4-1f68-4dd5-be23-b297eed028cd
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110705.1)
MachineType: Dell Inc. Dell System XPS L502X
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-14-generic root=UUID=af3a67b1-5cbf-48f1-b0b7-0848ae3017b4 ro quiet splash modeset=1 pcie_aspm=force i915.i915_enable_rc6=1 i915.i915_enable_fbc=1 i915.lvds_downclock=1 vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-14-generic N/A
 linux-backports-modules-3.0.0-14-generic N/A
 linux-firmware 1.60
SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/20/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A06
dmi.board.name: 0NJT03
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrA06:bd07/20/2011:svnDellInc.:pnDellSystemXPSL502X:pvr:rvnDellInc.:rn0NJT03:rvrA00:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: Dell System XPS L502X
dmi.sys.vendor: Dell Inc.

Jean-Louis Dupond (dupondje) wrote :
Brad Figg (brad-figg) on 2011-12-07
Changed in linux (Ubuntu):
status: New → Confirmed
Seth Forshee (sforshee) wrote :

It looks like this issue is kind of nasty. The interface used by dell-laptop involves using an SMI to tell the BIOS to disable the radio, and what the BIOS does in response is completely opaque to us. The functionality for this in dell-laptop seems to be based upon similar functionality in the Dell-provided libsmbios software, and it looks to match what's provided there.

So my expectation at this point is that we're unlikely to get this fixed unless we can get information from Dell about what's happening. There are a couple of things you can try though.

First, check for a BIOS update for your machine. It's possible that this is a bug in the BIOS that's been fixed.

Second, install the smbios-utils package and try playing with smbios-wireless-ctl, using --bt=0 to disable bluetooth and --bt=1 to enable it. See if you observe similar changes in the status of the phy0 switch. If you don't then there may be something that the tool is doing that dell-laptop is not.

Jean-Louis Dupond (dupondje) wrote :

Seems to be broken with smbios-wireless-ctl also :(

Seth Forshee (sforshee) wrote :

That's what I suspected, unfortunately.

There's no bug tracker for libsmbios, but there is a mailing list. It doesn't appear to have had much activity recently, but you could try reporting the bug there. If the list proves unresponsive there are some email addresses in the libsmbios source we could try. If we can get a fix for libsmbios then we can apply the same fix to dell-laptop. I don't see how we'll be able to fix this without some help from Dell.

https://lists.us.dell.com/mailman/listinfo/libsmbios-devel

summary: - dell-laptop: rfkill bug
+ [Dell XPS L502X] Applying soft block to bluetooth hard blocks wlan
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged

I am seeing this issue on an XPS 13 as well. It also uses the Centrino Advanced-N 6230.

Changed in linux:
importance: Unknown → Medium
status: Unknown → Invalid
Kamal Mostafa (kamalmostafa) wrote :

The problem can be cured on the Dell XPS 13z (and maybe the XPS 15z also?) by removing the dell_laptop driver with "sudo rmmod dell_laptop", or by adding the model to the driver's rfkill blacklist table.

Mario Limonciello from Dell has supplied the attached patch, which adds the XPS 13z to the rfkill blacklist table.

Does removing the dell_laptop driver also fix it for the XPS 15z? (If so, that model could also be added to the blacklist table). Would someone with a 15z kindly try "sudo rmmod dell_laptop" and report back?

tags: added: patch
Jean-Louis Dupond (dupondje) wrote :

Removed the dell_laptop module on my XPS L502X, and this works as expected.
So it seems like blacklisting this model will also fix the issue!

Changed in linux (Ubuntu):
assignee: nobody → Kamal Mostafa (kamalmostafa)
Kamal Mostafa (kamalmostafa) wrote :

Thanks Jean-Louis.

I have extended the dell_laptop rfkill blacklist patch to include the Dell XPS 15z as well as the XPS 13z (revised patch attached for reference), and produced a test PPA kernel with the patch applied. Jean-Louis or other 15z owners, please apply this PPA then reboot, and confirm that it fixes the problem: https://launchpad.net/~kamalmostafa/+archive/dellxps

Jean-Louis Dupond (dupondje) wrote :

I will test this later tonigh.
But some small thing:

.ident = "Dell XPS 15z",

The Dell XPS 15z is a different model
L502X != 15z

Jean-Louis Dupond (dupondje) wrote :

I can confirm the kernel in your PPA fixes my issue.
rfkill doesn't show the dell devices anymore, and bluetooth and wireless can be disabled now without killing each other :)

Kamal Mostafa (kamalmostafa) wrote :

This version of the patch has been applied to Ubuntu quantal.

description: updated
Tim Gardner (timg-tpi) on 2012-05-24
Changed in linux (Ubuntu Quantal):
status: Triaged → Fix Committed

The attachment "0001-UBUNTU-SAUCE-dell-laptop-rfkill-blacklist-Dell-XPS-1.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

Tim Gardner (timg-tpi) on 2012-05-25
Changed in linux (Ubuntu Precise):
status: New → Fix Committed
assignee: nobody → Kamal Mostafa (kamalmostafa)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.4.0-3.8

---------------
linux (3.4.0-3.8) quantal; urgency=low

  [ Andy Whitcroft ]

  * [Config] include include/generated/compile.h
    - LP: #942569
  * [Config] fix up postinst to ensure we know which error is which
    - LP: #1002388

  [ Herton Ronaldo Krzesinski ]

  * SAUCE: async_populate_rootfs: fix build warnings
    - LP: #1003417

  [ John Johansen ]

  * Revert "SAUCE: AppArmor: Add the ability to mediate mount"
  * SAUCE: apparmor: Add the ability to mediate mount
  * SAUCE: AppArmor: basic networking rules
  * SAUCE: apparmor: fix profile lookup for unconfined
    - LP: #978038, #987371
  * SAUCE: apparmor: fix long path failure due to disconnected path
    - LP: #955892

  [ Mario Limonciello ]

  * SAUCE: dell-laptop: rfkill blacklist Dell XPS 13z, 15
    - LP: #901410

  [ Stefan Bader ]

  * (config) Built-in xen-acpi-processor

  [ Tim Gardner ]

  * [Config] CONFIG_NET_DSA=m
    - LP: #1004148
  * [Config] Ensure CONFIG_XEN_ACPI_PROCESSOR=y for amd64
 -- Leann Ogasawara <email address hidden> Fri, 25 May 2012 11:38:33 -0700

Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released
Fuad Saud (fuadksd) wrote :

How can it be fixed on precise?

Kamal Mostafa (kamalmostafa) wrote :

@Fuad Saud- The fix for this issue will appear in the next official Ubuntu precise kernel (within the next week, probably). In the meantime, a precise kernel with this patch included is available from my PPA: https://launchpad.net/~kamalmostafa/+archive/dellxps

Fuad Saud (fuadksd) wrote :

@Kamal thanks! there's also another bug with this Dell laptop: when you turn it on the wifi is always "disabled by hardware switch" (the wifi led is off). When I boot Windows it does "remember" the state of wifi when it was turned off. Same happens with screen bright (it is always maximum no matter how it was when you turned off). Should I file another bug for it?

Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Precise in -proposed solves the problem (3.2.0-26.41). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-precise' to 'verification-done-precise'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-precise
tags: added: verification-done-precise
removed: verification-needed-precise
Kamal Mostafa (kamalmostafa) wrote :

@Fuad- Yes, you should file a new bug for each separate problem you encounter, after searching to see if it has been reported already. For what its worth, on my Dell XPS13z with the fixed kernel (comment #17), my system does correctly "remember" the wifi switch state after a reboot. But as you noted, the screen backlight brightness does not get preserved -- I believe that issue is very common, not specific to just the Dell XPS models.

Fuad Saud (fuadksd) wrote :

Thanks! I'll update my kernel today and check the bugs status.

Fuad Saud (fuadksd) wrote :

Sorry, but not working here. If you play with it a little you can check this out: when you turn on wifi via hardware the wifi is ok but not bluetooth; then you open bluetooth settings and it turns on, but then if you turn off everything goes down.

Also, if you turn on wifi via "hardware switch", then disable via software, the led goes off, like and you cannot connect bluetooth anymore; you need to enable it via hardware again...

Fuad Saud (fuadksd) wrote :

I'm not sure what is the supposed behavior of it under subsequent calls of hard blocking and soft blocking, but i seems a little inconsistent. When you soft block it, you have to unlock it via hardware, that doesn't seem to be the wanted behavior.

Is there any log or information I can provide for help?

Changed in linux (Ubuntu Precise):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :
Download full text (13.2 KiB)

This bug was fixed in the package linux - 3.2.0-26.41

---------------
linux (3.2.0-26.41) precise-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1012057

  [ Andy Whitcroft ]

  * [Config] fix up postinst to ensure we know which error is which
    - LP: #1002388
  * [Config] highbank -- commonise filesystems
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise subsystems
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise network protocols
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise input drivers
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise CRYPTO options
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise HID options
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise sensors options
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise EXPORTFS/FHANDLE
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise CONFIG_CRYPTO_LZO
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise ENCRYPTED_KEYS
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise CONFIG_ATALK
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise INET/INET6
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise NLS
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise BLK/CHR
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise PHY settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise CRC settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise BINFMT settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise DM settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise RTC_DRV settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise KEYBOARD/MOUSE settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise USB settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise GPIO settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise I2C settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise numerous subsystem selectors
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise A-C modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise D-F modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise G-I modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise J-L modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise M modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise N-P modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise Q-R modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise S modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise T modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise U-Z modules missmatches
    - LP: #1000831, #1010463

  [ Herton Ronaldo Krzesinski ]

  * SAUCE: fix get_gate_vma call in i386 NX emulation code
    - LP: #1009200

  [ Ike Panhc ]

  * [Config] add...

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released
Alin Andrei (nilarimogard) wrote :

This bug also affects Dell XPS 17, but it looks like the fix was implemented for XPS 13 and 15 only.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.