Activity log for bug #900396

Date Who What changed Old value New value Message
2011-12-05 17:45:17 Herton R. Krzesinski bug added bug
2011-12-05 17:45:36 Herton R. Krzesinski nominated for series Ubuntu Lucid
2011-12-05 17:45:36 Herton R. Krzesinski bug task added linux (Ubuntu Lucid)
2011-12-05 17:45:36 Herton R. Krzesinski nominated for series Ubuntu Maverick
2011-12-05 17:45:36 Herton R. Krzesinski bug task added linux (Ubuntu Maverick)
2011-12-05 17:45:36 Herton R. Krzesinski nominated for series Ubuntu Oneiric
2011-12-05 17:45:36 Herton R. Krzesinski bug task added linux (Ubuntu Oneiric)
2011-12-05 17:46:01 Herton R. Krzesinski linux (Ubuntu): status New Invalid
2011-12-05 17:46:57 Herton R. Krzesinski linux (Ubuntu Lucid): importance Undecided Low
2011-12-05 17:47:01 Herton R. Krzesinski linux (Ubuntu Maverick): importance Undecided Low
2011-12-05 17:47:04 Herton R. Krzesinski linux (Ubuntu Oneiric): importance Undecided Low
2011-12-05 17:47:09 Herton R. Krzesinski linux (Ubuntu Lucid): assignee Herton R. Krzesinski (herton)
2011-12-05 17:47:13 Herton R. Krzesinski linux (Ubuntu Maverick): assignee Herton R. Krzesinski (herton)
2011-12-05 17:47:16 Herton R. Krzesinski linux (Ubuntu Oneiric): assignee Herton R. Krzesinski (herton)
2011-12-05 17:47:25 Herton R. Krzesinski linux (Ubuntu Lucid): status New In Progress
2011-12-05 17:47:29 Herton R. Krzesinski linux (Ubuntu Maverick): status New In Progress
2011-12-05 17:47:32 Herton R. Krzesinski linux (Ubuntu Oneiric): status New In Progress
2011-12-05 17:56:21 Herton R. Krzesinski description commit d0733d2e29b65 (Check for mistakenly passed in non-IPv4 address), causes regressions in applications which expects bind(AF_UNSPEC) with INADDR_ANY to work. It was reported at https://bugzilla.kernel.org/show_bug.cgi?id=42012, but since bugzilla.kernel.org is not available for some time, some of the discussion about this issue is can be seen at http://patchwork.ozlabs.org/patch/112362/ for example as an additional source. Testcase: #include <stdio.h> #include <sys/socket.h> #include <string.h> #include <linux/in.h> int main(int argc, char **argv) { struct sockaddr_in addr; int fd, r; fd = socket(PF_INET, SOCK_STREAM, 0); memset(&addr, 0, sizeof(struct sockaddr_in)); r = bind(fd, (struct sockaddr *)&addr, sizeof(addr)); if (!r) printf("Everything looks good\n"); else printf("ERROR: too strict AF_INET check\n"); close(fd); } SRU Justification Impact bind(AF_UNSPEC) to INADDR_ANY doesn't work anymore, breaking some legacy applications Fix upstream commit 29c486df6a208432b370bd4be99ae1369ede28d8 Testcase small C program below ====================================================================================== commit d0733d2e29b65 (Check for mistakenly passed in non-IPv4 address), causes regressions in applications which expects bind(AF_UNSPEC) with INADDR_ANY to work. It was reported at https://bugzilla.kernel.org/show_bug.cgi?id=42012, but since bugzilla.kernel.org is not available for some time, some of the discussion about this issue is can be seen at http://patchwork.ozlabs.org/patch/112362/ for example as an additional source. Testcase: #include <stdio.h> #include <sys/socket.h> #include <string.h> #include <linux/in.h> int main(int argc, char **argv) {  struct sockaddr_in addr;  int fd, r;  fd = socket(PF_INET, SOCK_STREAM, 0);  memset(&addr, 0, sizeof(struct sockaddr_in));  r = bind(fd, (struct sockaddr *)&addr, sizeof(addr));  if (!r)   printf("Everything looks good\n");  else   printf("ERROR: too strict AF_INET check\n");  close(fd); }
2011-12-06 14:05:12 Tim Gardner linux (Ubuntu Lucid): status In Progress Fix Committed
2011-12-06 14:05:21 Tim Gardner linux (Ubuntu Maverick): status In Progress Fix Committed
2011-12-06 14:05:26 Tim Gardner linux (Ubuntu Oneiric): status In Progress Fix Committed
2011-12-06 14:05:39 Tim Gardner bug added subscriber Ubuntu Stable Release Updates Team
2011-12-14 12:12:04 Herton R. Krzesinski tags verification-needed-oneiric
2011-12-14 12:41:16 Herton R. Krzesinski tags verification-needed-oneiric verification-done-oneiric
2011-12-19 15:07:26 Launchpad Janitor branch linked lp:ubuntu/oneiric-proposed/linux-ti-omap4
2012-01-04 08:59:44 Launchpad Janitor branch linked lp:ubuntu/lucid-proposed/linux-lts-backport-maverick
2012-01-04 12:24:00 Herton R. Krzesinski tags verification-done-oneiric verification-done-maverick verification-done-oneiric
2012-01-05 07:58:26 Launchpad Janitor branch linked lp:ubuntu/lucid-proposed/linux-ec2
2012-01-05 08:04:38 Launchpad Janitor branch linked lp:ubuntu/maverick-proposed/linux-mvl-dove
2012-01-05 12:16:12 Herton R. Krzesinski tags verification-done-maverick verification-done-oneiric verification-done-lucid verification-done-maverick verification-done-oneiric
2012-01-20 09:15:47 Launchpad Janitor linux (Ubuntu Oneiric): status Fix Committed Fix Released
2012-01-20 09:15:47 Launchpad Janitor cve linked 2011-2203
2012-01-20 09:15:47 Launchpad Janitor cve linked 2011-4077
2012-01-20 09:15:47 Launchpad Janitor cve linked 2011-4132
2012-01-20 09:19:47 Launchpad Janitor linux (Ubuntu Maverick): status Fix Committed Fix Released
2012-01-20 09:19:47 Launchpad Janitor cve linked 2011-1162
2012-01-20 09:19:47 Launchpad Janitor cve linked 2011-1576
2012-01-20 09:19:47 Launchpad Janitor cve linked 2011-4110
2012-01-24 05:36:45 Launchpad Janitor linux (Ubuntu Lucid): status Fix Committed Fix Released