[gm45] GPU locks up for a few seconds then recovers when using xscreensaver on random

Bug #899303 reported by Beto1917 on 2011-12-02
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
Medium
linux (Ubuntu)
High
Unassigned

Bug Description

crashed after xscreensaver started

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: xserver-xorg-video-intel 2:2.15.901-1ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-2.6-generic 3.2.0-rc3
Uname: Linux 3.2.0-2-generic i686
.tmp.unity.support.test.0:

ApportVersion: 1.90-0ubuntu1
Architecture: i386
Chipset: gm45
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
Date: Fri Dec 2 14:37:51 2011
DistUpgraded: Log time: 2011-07-07 16:41:03.123900
DistroCodename: precise
DistroVariant: ubuntu
DuplicateSignature: [gm45] GPU lockup EIR: 0x00000010 PGTBL_ER: 0x00000001 render.IPEHR: 0x60020100 Ubuntu 12.04
ExecutablePath: /usr/share/apport/apport-gpu-error-intel.py
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] Device [1025:029b]
   Subsystem: Acer Incorporated [ALI] Device [1025:029b]
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Release i386 (20100429.4)
InterpreterPath: /usr/bin/python2.7
MachineType: Acer Aspire 1410
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gpu-error-intel.py
ProcEnviron:

ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.2.0-2-generic root=UUID=34529bb0-121c-4f52-b1b7-6aca0f1c8e88 ro splash vga=789 quiet splash vt.handoff=7
RelatedPackageVersions:
 xserver-xorg 1:7.6+7ubuntu7
 libdrm2 2.4.27-1ubuntu1
 xserver-xorg-video-intel 2:2.15.901-1ubuntu3
SourcePackage: xserver-xorg-video-intel
Title: [gm45] False GPU lockup EIR: 0x00000010 PGTBL_ER: 0x00000001 render.IPEHR: 0x60020100
UpgradeStatus: Upgraded to precise on 2011-12-01 (1 days ago)
UserGroups:

dmi.bios.date: 09/08/2009
dmi.bios.vendor: INSYDE
dmi.bios.version: v0.3117
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Base Board Product Name
dmi.board.vendor: Acer
dmi.board.version: Base Board Version
dmi.chassis.type: 1
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnINSYDE:bvrv0.3117:bd09/08/2009:svnAcer:pnAspire1410:pvrv0.3117:rvnAcer:rnBaseBoardProductName:rvrBaseBoardVersion:cvnChassisManufacturer:ct1:cvrChassisVersion:
dmi.product.name: Aspire 1410
dmi.product.version: v0.3117
dmi.sys.vendor: Acer
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu7
version.libdrm2: libdrm2 2.4.27-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu4
version.xserver-xorg-core: xserver-xorg-core 2:1.10.4-1ubuntu5
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu3
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Beto1917 (beto-mst) wrote :
tags: removed: need-duplicate-check
Bryce Harrington (bryce) wrote :

Hi Beto,

Did it only crash the one time after running xscreensaver, or does it often/always crash when that's run?

Also, did the system actually lock up after xscreensaver ran? Looks like your system mostly recovered and kept going, does that sound right?

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Incomplete
Beto1917 (beto-mst) wrote :

xscreensaver works fine most of the time. Same bug reappears from time to time, but I cannot reproduce the exact situation to force it to crash... I've set the xsceensaver to show a random pick, perhaps is one particular screensaver that crashes, I can't tell which one though.
System freezes for a couple of seconds, shows the window to report the crash and recovers completely. Ubuntu keeps going normally like a mean bug-dozer!

Bryce Harrington (bryce) wrote :

Alright, thanks. It would help a ton if you were able to pin it down to a specific screensaver, but this sounds fairly well defined already, and could probably be forwarded upstream.

summary: - [gm45] False GPU lockup EIR: 0x00000010 PGTBL_ER: 0x00000001
- render.IPEHR: 0x60020100
+ [gm45] GPU locks up for a few seconds then recovers when using
+ xscreensaver on random
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → High
status: Incomplete → Confirmed
Download full text (3.4 KiB)

Forwarding this bug from Ubuntu reporter Beto1917:
http://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/899303

[Problem]
With xscreensaver set to random, once in a while it freezes for a couple seconds, recovers, and then displays the Apport window to report the lockup. The i915_error_state file and dmesg indicate that a GPU lockup occurred, but the system recovered.

[Original Description]
crashed after xscreensaver started

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: xserver-xorg-video-intel 2:2.15.901-1ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-2.6-generic 3.2.0-rc3
Uname: Linux 3.2.0-2-generic i686
.tmp.unity.support.test.0:

ApportVersion: 1.90-0ubuntu1
Architecture: i386
Chipset: gm45
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
Date: Fri Dec 2 14:37:51 2011
DistUpgraded: Log time: 2011-07-07 16:41:03.123900
DistroCodename: precise
DistroVariant: ubuntu
DuplicateSignature: [gm45] GPU lockup EIR: 0x00000010 PGTBL_ER: 0x00000001 render.IPEHR: 0x60020100 Ubuntu 12.04
ExecutablePath: /usr/share/apport/apport-gpu-error-intel.py
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] Device [1025:029b]
   Subsystem: Acer Incorporated [ALI] Device [1025:029b]
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Release i386 (20100429.4)
InterpreterPath: /usr/bin/python2.7
MachineType: Acer Aspire 1410
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gpu-error-intel.py
ProcEnviron:

ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.2.0-2-generic root=UUID=34529bb0-121c-4f52-b1b7-6aca0f1c8e88 ro splash vga=789 quiet splash vt.handoff=7
RelatedPackageVersions:
 xserver-xorg 1:7.6+7ubuntu7
 libdrm2 2.4.27-1ubuntu1
 xserver-xorg-video-intel 2:2.15.901-1ubuntu3
SourcePackage: xserver-xorg-video-intel
Title: [gm45] False GPU lockup EIR: 0x00000010 PGTBL_ER: 0x00000001 render.IPEHR: 0x60020100
UpgradeStatus: Upgraded to precise on 2011-12-01 (1 days ago)
UserGroups:

dmi.bios.date: 09/08/2009
dmi.bios.vendor: INSYDE
dmi.bios.version: v0.3117
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Base Board Product Name
dmi.board.vendor: Acer
dmi.board.version: Base Board Version
dmi.chassis.type: 1
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnINSYDE:bvrv0.3117:bd09/08/2009:svnAcer:pnAspire1410:pvrv0.3117:rvnAcer:rnBaseBoardProductName:rvrBaseBoardVersion:cvnChassisManufacturer:ct1:cvrChassisVersion:
dmi.product.name: Aspire 1410
dmi.product.version: v0.3117
dmi.sys.vendor: Acer
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu7
version.libdrm2: libdrm2 2.4.27-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu4
version.xserver-xorg-core: xserver-xorg-core 2:1.10.4-1ubuntu5
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6...

Read more...

Bryce Harrington (bryce) wrote :

Beto1917 - I've forwarded this bug upstream to https://bugs.freedesktop.org/show_bug.cgi?id=44886 - please subscribe yourself to this bug, in case they need further information or wish you to test something. Thanks ahead of time!

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Triaged

Created attachment 55718
BootDmesg.txt

Created attachment 55719
CurrentDmesg.txt

Created attachment 55720
i915_error_state.txt

Created attachment 55721
XorgLog.txt

Changed in xserver-xorg-video-intel:
importance: Unknown → Medium
status: Unknown → Confirmed
Bryce Harrington (bryce) wrote :

Hi Beto,

I notice there hasn't been activity on the upstream bug. Before I re-ping them, let me ask, are you still experiencing these GPU lockups with xscreensaver?

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Incomplete
Download full text (4.4 KiB)

It didn't happen to me again, but perhaps it was related to a particular screensaver. I'm not 100% sure it's been fixed but I'm pretty sure it has.

> Date: Tue, 13 Mar 2012 22:43:03 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 899303] Re: [gm45] GPU locks up for a few seconds then recovers when using xscreensaver on random
>
> Hi Beto,
>
> I notice there hasn't been activity on the upstream bug. Before I re-
> ping them, let me ask, are you still experiencing these GPU lockups with
> xscreensaver?
>
> ** Changed in: xserver-xorg-video-intel (Ubuntu)
> Status: Triaged => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/899303
>
> Title:
> [gm45] GPU locks up for a few seconds then recovers when using
> xscreensaver on random
>
> Status in X.org xf86-video-intel:
> Confirmed
> Status in “xserver-xorg-video-intel” package in Ubuntu:
> Incomplete
>
> Bug description:
> crashed after xscreensaver started
>
> ProblemType: Crash
> DistroRelease: Ubuntu 12.04
> Package: xserver-xorg-video-intel 2:2.15.901-1ubuntu3
> ProcVersionSignature: Ubuntu 3.2.0-2.6-generic 3.2.0-rc3
> Uname: Linux 3.2.0-2-generic i686
> .tmp.unity.support.test.0:
>
> ApportVersion: 1.90-0ubuntu1
> Architecture: i386
> Chipset: gm45
> CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
> CompositorRunning: compiz
> Date: Fri Dec 2 14:37:51 2011
> DistUpgraded: Log time: 2011-07-07 16:41:03.123900
> DistroCodename: precise
> DistroVariant: ubuntu
> DuplicateSignature: [gm45] GPU lockup EIR: 0x00000010 PGTBL_ER: 0x00000001 render.IPEHR: 0x60020100 Ubuntu 12.04
> ExecutablePath: /usr/share/apport/apport-gpu-error-intel.py
> ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
> GraphicsCard:
> Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
> Subsystem: Acer Incorporated [ALI] Device [1025:029b]
> Subsystem: Acer Incorporated [ALI] Device [1025:029b]
> InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Release i386 (20100429.4)
> InterpreterPath: /usr/bin/python2.7
> MachineType: Acer Aspire 1410
> ProcCmdline: /usr/bin/python /usr/share/apport/apport-gpu-error-intel.py
> ProcEnviron:
>
> ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.2.0-2-generic root=UUID=34529bb0-121c-4f52-b1b7-6aca0f1c8e88 ro splash vga=789 quiet splash vt.handoff=7
> RelatedPackageVersions:
> xserver-xorg 1:7.6+7ubuntu7
> libdrm2 2.4.27-1ubuntu1
> xserver-xorg-video-intel 2:2.15.901-1ubuntu3
> SourcePackage: xserver-xorg-video-intel
> Title: [gm45] False GPU lockup EIR: 0x00000010 PGTBL_ER: 0x00000001 render.IPEHR: 0x60020100
> UpgradeStatus: Upgraded to precise on 2011-12-01 (1 days ago)
> UserGroups:
>
> dmi.bios.date: 09/08/2009
> dmi.bios.vendor: INSYDE
> dmi.bios.version: v0.3117
> dmi.board.asset.tag: Base Board Asset Tag
> dmi.board.name: Base Board Product Name
> dmi.board.vendor: Ace...

Read more...

Bryce Harrington (bryce) wrote :

Beta, ok thanks. Let's mark the bug fixed, and if it recurs again please feel free to reopen.

[If others are experiencing gpu lockups with xscreensaver, please file new bugs (using ubuntu-bug xorg) rather than reopen Beto's.]

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Fix Released

This is likely to be:

commit c501ae7f332cdaf42e31af30b72b4b66cbbb1604
Author: Chris Wilson <email address hidden>
Date: Wed Dec 14 13:57:23 2011 +0100

    drm/i915: Only clear the GPU domains upon a successful finish

    By clearing the GPU read domains before waiting upon the buffer, we run
    the risk of the wait being interrupted and the domains prematurely
    cleared. The next time we attempt to wait upon the buffer (after
    userspace handles the signal), we believe that the buffer is idle and so
    skip the wait.

    There are a number of bugs across all generations which show signs of an
    overly haste reuse of active buffers.

    Such as:

      https://bugs.freedesktop.org/show_bug.cgi?id=29046
      https://bugs.freedesktop.org/show_bug.cgi?id=35863
      https://bugs.freedesktop.org/show_bug.cgi?id=38952
      https://bugs.freedesktop.org/show_bug.cgi?id=40282
      https://bugs.freedesktop.org/show_bug.cgi?id=41098
      https://bugs.freedesktop.org/show_bug.cgi?id=41102
      https://bugs.freedesktop.org/show_bug.cgi?id=41284
      https://bugs.freedesktop.org/show_bug.cgi?id=42141

    A couple of those pre-date i915_gem_object_finish_gpu(), so may be
    unrelated (such as a wild write from a userspace command buffer), but
    this does look like a convincing cause for most of those bugs.

    Signed-off-by: Chris Wilson <email address hidden>
    Cc: <email address hidden>
    Reviewed-by: Daniel Vetter <email address hidden>
    Reviewed-by: Eugeni Dodonov <email address hidden>
    Signed-off-by: Daniel Vetter <email address hidden>

Bryce Harrington (bryce) wrote :

Upstream thinks this was fixed with the following linux kernel commit:

commit c501ae7f332cdaf42e31af30b72b4b66cbbb1604
Author: Chris Wilson <email address hidden>
Date: Wed Dec 14 13:57:23 2011 +0100

    drm/i915: Only clear the GPU domains upon a successful finish

    By clearing the GPU read domains before waiting upon the buffer, we run
    the risk of the wait being interrupted and the domains prematurely
    cleared. The next time we attempt to wait upon the buffer (after
    userspace handles the signal), we believe that the buffer is idle and so
    skip the wait.

    There are a number of bugs across all generations which show signs of an
    overly haste reuse of active buffers.

    Such as:

      https://bugs.freedesktop.org/show_bug.cgi?id=29046
      https://bugs.freedesktop.org/show_bug.cgi?id=35863
      https://bugs.freedesktop.org/show_bug.cgi?id=38952
      https://bugs.freedesktop.org/show_bug.cgi?id=40282
      https://bugs.freedesktop.org/show_bug.cgi?id=41098
      https://bugs.freedesktop.org/show_bug.cgi?id=41102
      https://bugs.freedesktop.org/show_bug.cgi?id=41284
      https://bugs.freedesktop.org/show_bug.cgi?id=42141

    A couple of those pre-date i915_gem_object_finish_gpu(), so may be
    unrelated (such as a wild write from a userspace command buffer), but
    this does look like a convincing cause for most of those bugs.

    Signed-off-by: Chris Wilson <email address hidden>
    Cc: <email address hidden>
    Reviewed-by: Daniel Vetter <email address hidden>
    Reviewed-by: Eugeni Dodonov <email address hidden>
    Signed-off-by: Daniel Vetter <email address hidden>

Bryce Harrington (bryce) wrote :

Reopening and bumping to kernel team.

User reports not seeing the issue, so perhaps it's already fixed. Still may be worth a review; we've had other reports about lags due to temporary gpu lockups, so this might be relevant still.

affects: xserver-xorg-video-intel (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Fix Released → New
tags: added: kernel-handoff-graphics
Brad Figg (brad-figg) on 2012-04-17
Changed in linux (Ubuntu):
status: New → Confirmed
Andy Whitcroft (apw) wrote :

This fix is now in the 3.2.14 stable update and in the latest precise kernel. If you could test with that kernel and confirm the issue is resolved.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-da-key
Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.