Ubuntu

Alps touchpad detected as both "PS/2 Mouse" and "AlpsPS/2 ALPS GlidePoint"....touchpad features don't work, acts like PS/2 mouse

Reported by Clint on 2011-11-23
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I have an alps touchpad on my laptop Acer 7741 laptop. It never got detected as a touhpad in ubuntu <= 11.04. Finally with 11.10, it finds it as a touchpad and in the mouse config I can see a touchpad tab.

Changing the settings in the mouse config do nothing.

xinput -list gives:

 Virtual core pointer id=2 [master pointer (3)
  ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
  ↳ HP Wireless Optical Mobile Mouse id=9 [slave pointer (2)]
  ↳ AlpsPS/2 ALPS GlidePoint id=13 [slave pointer (2)]
  ↳ PS/2 Mouse id=12 [slave pointer (2)]

(HP optical is my external mouse)

I can modify the sensitivity of the touchpad when I change the PS/2 mouse settings with xinput.

Changing any of the settings in the touchpad tab of the mouse GUI util has no effect.

Disabling the PS/2 mouse disables the touchpad.
Disabling the AlpsPS/2 glidepoint does nothing.

When I do
dmesg | grep -i input I get:

[ 17.613230] input: PS/2 Mouse as /devices/platform/i8042/serio1/input/input11
[ 17.638723] input: AlpsPS/2 ALPS GlidePoint as /devices/platform/i8042/serio1/input/input12

blacklisting psmouse disables the touchpad.

I can use the tapping and movement features of the touchpad....but side-scrolling, multi-touch and most importantly, disable touchpad when typing does not work. These all work in windows.
---
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroRelease: Ubuntu 11.10
DistroVariant: ubuntu
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: Acer Aspire 7741
Package: xserver-xorg-input-synaptics 1.4.1-1ubuntu2
PackageArchitecture: amd64
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-13-generic root=UUID=70ef8bd8-003a-4793-a48b-0f426feaa662 ro splash quiet vga=758 quiet pcie_aspm=force splash acpi_osi= vt.handoff=7
ProcVersionSignature: Ubuntu 3.0.0-13.22-generic 3.0.6
Tags: oneiric ubuntu
Uname: Linux 3.0.0-13-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 01/10/2011
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: V1.20
dmi.board.asset.tag: No Asset Tag
dmi.board.name: JE70_CP
dmi.board.vendor: Acer
dmi.board.version: V1.20
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: V1.20
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrV1.20:bd01/10/2011:svnAcer:pnAspire7741:pvrV1.20:rvnAcer:rnJE70_CP:rvrV1.20:cvnAcer:ct10:cvrV1.20:
dmi.product.name: Aspire 7741
dmi.product.version: V1.20
dmi.sys.vendor: Acer
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu6
version.ia32-libs: ia32-libs 20090808ubuntu26
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/893839/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Clint (crouton-cc) on 2011-11-23
affects: ubuntu → hal (Ubuntu)
Vadim Rutkovsky (roignac) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:

  apport-collect 893839

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

affects: hal (Ubuntu) → xserver-xorg-input-synaptics (Ubuntu)
Changed in xserver-xorg-input-synaptics (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected oneiric ubuntu
description: updated

apport information

apport information

apport information

Clint (crouton-cc) wrote : Lspci.txt

apport information

Clint (crouton-cc) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Incomplete → Confirmed
affects: xserver-xorg-input-synaptics (Ubuntu) → linux (Ubuntu)
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . If possible, please test the latest v3.2-rcN kernel (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed by the mainline kernel, please add the following tag 'kernel-fixed-upstream-KERNEL-VERSION'. For example, if kernel version 3.2-rc1 fixed and issue, the tag would be: 'kernel-fixed-upstream-v3.2-rc1'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'. If you believe this bug does not require upstream testing, please add the tag: 'kernel-upstream-testing-not-needed'.

Thanks in advance.

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: needs-upstream-testing
Clint (crouton-cc) wrote :

I tried kernel:

3.2.0-030200rc4-generic_3.2.0-030200rc4.201112012035_amd64

Vertical scrolling works on the touchpad now.
No touchpad tab in "mouse" preference anymore.

Xinput indicates touchpad is now detected as:
ImPS/2 Generic Wheel Mouse

Alps is no longer in list.

tags: removed: needs-upstream-testing
tags: added: kernel-bug-exists-upstream
Clint (crouton-cc) wrote :

No other touchpad specific features work (disable while typing, etc).

Clint, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested and remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the tag: 'kernel-unable-to-test-upstream'.

Please let us know your results. Thanks in advance.

Helpful Bug Reporting Links:
https://help.ubuntu.com/community/ReportingBugs#Bug_Reporting_Etiquette
https://help.ubuntu.com/community/ReportingBugs#A3._Make_sure_the_bug_hasn.27t_already_been_reported
https://help.ubuntu.com/community/ReportingBugs#Adding_Apport_Debug_Information_to_an_Existing_Launchpad_Bug
https://help.ubuntu.com/community/ReportingBugs#Adding_Additional_Attachments_to_an_Existing_Launchpad_Bug

tags: added: needs-upstream-testing
removed: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Eric Freeman (efreem01) wrote :

I tested this with Mainline Kernel 3.5.4-030504-generic. The touchpad is still detected as a PS/2 Mouse.

I have an Acer V3-771G with an ALPS Touchpad.

xinput -list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ PS/2 Generic Mouse id=12 [slave pointer (2)]

[ 26.269258] input: PS/2 Generic Mouse as /devices/platform/i8042/serio1/input/input7

Eric Freeman, could you please file a new report by executing the following in a terminal:
ubuntu-bug linux

For more on this, please see the Ubuntu Bug Control and Ubuntu Bug Squad article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs#Bug_Reporting_Etiquette

When opening up the new report, please feel free to subscribe me to it. Thank you for your understanding.

Helpful Bug Reporting Links:
https://help.ubuntu.com/community/ReportingBugs#A3._Make_sure_the_bug_hasn.27t_already_been_reported
https://help.ubuntu.com/community/ReportingBugs#Adding_Apport_Debug_Information_to_an_Existing_Launchpad_Bug
https://help.ubuntu.com/community/ReportingBugs#Adding_Additional_Attachments_to_an_Existing_Launchpad_Bug

Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers