Ubuntu

Kernel 3.0 (11.10 default kernel) won't boot unless acpi=off, worked fine with the default kernels of the 3 previous releases

Reported by Alexander Winizki on 2011-10-29
106
This bug affects 22 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

Just upgraded from 11.04 to 11.10 and now the computer freezes a few seconds after I hit enter in the Grub start menu (the caps lock indicator LED on the keyboard does not react to the caps lock button). I have found out two solutions for this: either boot the old 2.6.38 kernel left over from the 11.04 installation (with default boot options) or add acpi=off to the boot options of the 3.0 kernel. I think both of these options are unsatisfactory because with acpi=off I cannot shut down automatically and 2.6.38 won't be supported forever (I will receive no security updates for the 2.6.38 under Oneiric, will I?). So should I file a bug about this (found no similar bugs from tha last month)? Note that under 10.04, 10.10 and 11.04 the computer booted with default options and with no problems. The machine is a Pentium 4 with an Intel mainboard.

When I boot the 3.0 kernel without acpi=off, then it seems to me that no messages are written into the syslog at all. If I boot 3.0 with the recovery option, I see some kernel messages on the screen and then it freezes.

Machine: Desktop computer
Mainboard: Intel D865GBF
BIOS Version: latest available (***.P25)

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: linux-generic 3.0.0.12.14
ProcVersionSignature: Ubuntu 2.6.38-11.50-generic 2.6.38.8
Uname: Linux 2.6.38-11-generic i686
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
ApportVersion: 1.23-0ubuntu3
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: alex 1717 F.... pulseaudio
CRDA: Error: [Errno 2] Datei oder Verzeichnis nicht gefunden
Card0.Amixer.info:
 Card hw:0 'ICH5'/'Intel ICH5 with AD1985 at irq 17'
   Mixer name : 'Analog Devices AD1985'
   Components : 'AC97a:41445375'
   Controls : 50
   Simple ctrls : 35
Date: Sat Oct 29 13:27:08 2011
HibernationDevice: RESUME=UUID=9ae9d6ce-ce91-4efc-a8c0-68c3a4271d84
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release Candidate i386 (20100928)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
ProcEnviron:
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-11-generic root=UUID=bbc0e312-ca8b-4da6-84f9-198f6378d375 ro splash vga=788 quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-11-generic N/A
 linux-backports-modules-2.6.38-11-generic N/A
 linux-firmware 1.60
RfKill:

SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
WifiSyslog:

dmi.bios.date: 08/04/2005
dmi.bios.vendor: Intel Corp.
dmi.bios.version: BF86510A.86A.0077.P25.0508040031
dmi.board.name: D865GBF
dmi.board.vendor: Intel Corporation
dmi.board.version: AAC25843-409
dmi.chassis.type: 2
dmi.modalias: dmi:bvnIntelCorp.:bvrBF86510A.86A.0077.P25.0508040031:bd08/04/2005:svn:pn:pvr:rvnIntelCorporation:rnD865GBF:rvrAAC25843-409:cvn:ct2:cvr:

Alexander Winizki (awinizki) wrote :

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: New → Confirmed
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-12.20
Alexander Winizki (awinizki) wrote :

Now I have tested this with kernel 3.0.0.13.15 - same results, machine hangs. Searched the Ubuntu wiki, but found no information abiut where to get 3.0.0.12.20. I have activated the oneiric-proposed repository in Synaptic and then it offered me the kernel 3.0.0.13.15

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Waleed Hamra (w-hamra1987) wrote :

same issue as with OP, system hangs 1 second after boot. turning off acpi solves the problem, but that's not really a good option, hyper threading gets disabled as well with it. all previous kernel versions worked fine.

Intel 102GCC2 motherboard, with ATI chipset

Waleed Hamra (w-hamra1987) wrote :

if it helps, i booted without quiet and splash to see the actual kernel output when it stops loading, then compared it to a normal boot with a 2.6 kernel. the last lines outputted before it stops are:

[ 0.286362] Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
[ 0.288033] fuse init (API version 7.16)
[ 0.288255] msgmni has been set to 1680
[ 0.288796] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)
[ 0.288853] io scheduler noop registered
[ 0.288858] io scheduler deadline registered
[ 0.288894] io scheduler cfq registered (default)
[ 0.289110] pcieport 0000:00:02.0: setting latency timer to 64
[ 0.289276] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
[ 0.289345] pciehp: PCI Express Hot Plug Controller Driver version: 0.4
[ 0.289643] input: Power Button as /devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input0
[ 0.289654] ACPI: Power Button [PWRB]
[ 0.289782] input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input1
[ 0.289790] ACPI: Power Button [PWRF]

and it stops there. on a normal boot, the next lines are:

[ 0.290064] ACPI: acpi_idle registered with cpuidle
[ 0.292162] ERST: Table is not found!
[ 0.292294] Serial: 8250/16550 driver, 32 ports, IRQ sharing enabled
[ 0.292573] isapnp: Scanning for PnP cards...
[ 0.647624] isapnp: No Plug & Play device found
[ 0.828688] Freeing initrd memory: 18280k freed
[ 0.867250] Linux agpgart interface v0.103
[ 0.869420] brd: module loaded
[ 0.870407] loop: module loaded
[ 0.870564] i2c-core: driver [adp5520] using legacy suspend method
[ 0.870568] i2c-core: driver [adp5520] using legacy resume method

hope this helps on giving any ideas who's the culprit. this bug is getting over my head. i downloaded a 3.1 linux kernel source and compiled it after careful selection of options, and ended with same bug. then brought the config file of the working 2.6 kernel, and used it as starting point to compile the 3.1 kernel (didnt actually modify anything myself, just ran the config and closed it to let it automatically remove any deprecated options that can ruin the compile), and compiled the kernel, and again, same bug.
me thinks it isnt any missing module, some acpi change is doing this, but i cant be sure.
thanks in advance for any help

Waleed Hamra (w-hamra1987) wrote :

output of lspci:
00:00.0 Host bridge: ATI Technologies Inc Radeon Xpress 200 Host Bridge (rev 01)
00:02.0 PCI bridge: ATI Technologies Inc RS480 PCI-X Root Port
00:11.0 IDE interface: ATI Technologies Inc IXP SB400 Serial ATA Controller (rev 80)
00:12.0 IDE interface: ATI Technologies Inc IXP SB400 Serial ATA Controller (rev 80)
00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 80)
00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 80)
00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller (rev 80)
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 82)
00:14.1 IDE interface: ATI Technologies Inc IXP SB400 IDE Controller (rev 80)
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge (rev 80)
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge (rev 80)
01:00.0 VGA compatible controller: nVidia Corporation G96 [GeForce 9400 GT] (rev a1)
02:02.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
02:04.0 Multimedia audio controller: Ensoniq 5880B [AudioPCI] (rev 02)

Sam Smith (sam-smith-gmx) wrote :

I have exact the same problem. I upgrade my ubuntu 11.04 to 11.10 yesterday.
Now I can only boot my Acer Extensa 2902LMi with the grub option acpi=off.
_
The same problem I had had as I installed ubuntu 11.04 a few months ago.
See this bug report:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/759103

The problem with ubuntu 11.04 was gone after kernel update 2.6.38.
So perhaps the cause of the boot problem with ubuntu 11.10 is the same as by ubuntu 11.04.
If anybody know what was the change in kernel 2.6.38 for ubuntu 11.04 this change could help to solve the boot problem in ubuntu 11.10 too.

Suman Guha (suman-iitk2003) wrote :

I am facing exactly the same problem. There is a similar bug reported here:

https://answers.launchpad.net/ubuntu/+source/acpi/+question/175746

I have the same motherboard intel D102GCC2. In my case even with acpi=off it does not boot but I found out somewhere that if the USB in the BIOS are disabled then it works and it actually did. However, with USB disabled I can not access any USB devices and in my case I have an USB mouse.

I am still using the old kernel from previous distribution. The problem has not solved yet with the latest kernel (3.0.0.13).

Thanks in advance. Hope that a fix may be available soon.

tags: added: kernel-bug regression-release
Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in linux:
status: Confirmed → Incomplete
Chris (chrisheaththomas) wrote :

Have the same symptom (freeze after selecting kernel). I have:

Kernel 3.0.0.15.17
INTEL Prescott Pentium 4 P4 3.4GHZ SL7E6 478/800MHZ/1M
Intel D865GLC Micro ATX Socket 478 865G Motherboard

Kernel 2.6.38 and below work fine.

Alexander Winizki, thank you for reporting this and helping make Ubuntu better. The next step is to bisect from the Natty kernel 2.6.38-11.50-generic to the Oneiric kernel, in order to find the offending the commit. Could you please perform this following https://wiki.ubuntu.com/Kernel/KernelBisection ?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Waleed Hamra (w-hamra1987) wrote :

that won't be necessary. check the link for the upstream bug report. there's already a patch available, just awaiting further dev instructions/confirmation.
if acceptable, i can post the patch here for others to try it, and confirm it also fixes their bug, just to make sure we're all discussing the same bug here :)

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Tim Gardner (timg-tpi) wrote :

Waleed - please do attach the patch or the URL of the upstream thread.

Tim Gardner (timg-tpi) wrote :

Waleed - oh, never mind. I just noticed the upstream bug link.

Tim Gardner (timg-tpi) wrote :

https://bugzilla.kernel.org/show_bug.cgi?id=42700
https://bugzilla.kernel.org/show_bug.cgi?id=42700#c11
https://bugzilla.kernel.org/attachment.cgi?id=72490 is the patch to watch for.

It is staged for the 3.4 merge window pull request in Len Brown's repo at git://git.kernel.org/pub/scm/linux/kernel/git/lenb/linux in the 'release' branch. It is _not_ marked for stable, so we'll have to let Greg KH know to get it into 3.2, and then we can pull it into 3.0

Alexander Winizki (awinizki) wrote :

I assume that bisecting the kernel os not necessary any more. Please somebody give me more instructions if I can help testing.

Tim Gardner (timg-tpi) wrote :

No bisecting is needed. Just watch for your patch to appear in git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git

Changed in linux:
status: Incomplete → Fix Released
Jappreet (bains-jappi) wrote :

As i understand the required patch has been released for linux kernel.

My query is do we need to use that patch and recompile our kernel or it will be done in Ubuntu 12.04 automatically.

Presently m running 3.2.0.20.

Waleed Hamra (w-hamra1987) wrote :

it depends on when and where will the patch be accepted into the kernel source upstream. the kernel will continue receiving updates in ubuntu after every minor release from upstream, but if the patch doesn't get released till say, version 3.2, and ubuntu is shipping 3.1, the patch won't show up. so we'll see.
in the meantime, let's make sure we're al taking about the same bug here. i'll post the patch in this thread, can people subscribed to this report compile their kernels with this patch and verify it fixes their problem?

tags: added: patch
Colin King (colin-king) wrote :

I've submitted this patch to the mailing list to be applied for Precise and as a SRU for Oneiric. For the Oneiric SRU I'd like it tested and verified so that we can be 100% it does the trick, so can somebody test this for us?

I've put the kernel .debs at: http://zinc.canonical.com/~cking/lp-883441

Colin King (colin-king) wrote :

Oneiric SRU Justification:

Impact:

commit 64b3db22c04586997ab4be46dd5a5b99f8a2d390 (2.6.39),
"Remove use of unreliable FADT revision field" caused a regression
for old P4 systems because now cst_control and other fields are
not reset to 0.

        The effect is that acpi_processor_power_init will notice
cst_control != 0 and a write to CST_CNT register is performed
that should not happen. As result, the system oopses after the
"No _CST, giving up" message, sometimes in acpi_ns_internalize_name,
sometimes in acpi_ns_get_type, usually at random places. May be
during migration to CPU 1 in acpi_processor_get_throttling.

        Every one of these settings help to avoid this problem:
 - acpi=off
 - processor.nocst=1
 - maxcpus=1

Fix:

Apply upstream commit 3e80acd1af40fcd91a200b0416a7616b20c5d647

Testcase:

Without the fix, machines are effectively unbootable unless acpi=off or processor.nocst=1 or maxcpus=1 is used. With the fix the system will boot.

Tim Gardner (timg-tpi) on 2012-04-02
Changed in linux (Ubuntu Oneiric):
status: New → Fix Committed
Changed in linux (Ubuntu Precise):
status: Confirmed → Fix Committed

The attachment "ACPICA Fix Regression in FADT revision checks" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

Alexander Winizki (awinizki) wrote :

To #20
this bug affects me, but I don't know how to test the deb packages. Tried following: downloaded the packages, then right clicked on them in the file manager (first the headers, then the image) and chosen "Open with Ubuntu Software center". When the Ubuntu Software center opened showing the package, clicked on "install". Received no feedback about the progress of the operation and whether it was completed or not. Waited until no processes containing "dpkg" in their names were running any more. Then, during reboot, no new kernel appears in the Grub boot menu. What now?

Launchpad Janitor (janitor) wrote :
Download full text (5.2 KiB)

This bug was fixed in the package linux - 3.2.0-22.35

---------------
linux (3.2.0-22.35) precise; urgency=low

  [ Andy Whitcroft ]

  * Revert "SAUCE: hotkey quirks for various Zeptro Znote and Fujitsu Amilo
    laptops"
  * SAUCE: (no-up) elide some ioctl warnings which are known benign
    - LP: #972355

  [ Brad Figg ]

  * SAUCE (no-up) Provide a param for allowing the BIOS to handle changing
    the brightness on AC/battery status changes.
    - LP: #949311
  * SAUCE (drop after 3.4) Quirk for enabling backlight hotkeys on Samsung
    N150P
    - LP: #875893

  [ Colin Ian King ]

  * SAUCE: PCI: Allow pcie_aspm=force to work even when FADT indicates it
    is unsupported
    - LP: #962038

  [ Daniel Vetter ]

  * SAUCE: (drop after 3.5) drm/i915: reinstate GM45 TV detection fix
    - LP: #638939

  [ Kees Cook ]

  * SAUCE: SECCOMP: audit: always report seccomp violations
  * SAUCE: SECCOMP: adjust prctl constant

  [ Leann Ogasawara ]

  * [Config] Enable CONFIG_USBIP_CORE=m
    - LP: #900384
  * Rebase to v3.2.14
  * [Config] Updateconfigs after rebase to v3.2.14

  [ Stefan Bader ]

  * d-i: Fix module name for dm-raid45
    - LP: #969248

  [ Tim Gardner ]

  * SAUCE: remove __initdata from vesafb_fix
    - LP: #969309

  [ Upstream Kernel Changes ]

  * Revert "sched: tg->se->load should be initialised to tg->shares"
  * toshiba_acpi: make one-bit bitfields unsigned
    - LP: #810015
  * ACPI: EC: Add ec_get_handle()
    - LP: #810015
  * toshiba_acpi: Support alternate hotkey interfaces
    - LP: #810015
  * toshiba_acpi: Support additional hotkey scancodes
    - LP: #810015
  * toshiba_acpi: Refuse to load on machines with buggy INFO
    implementations
    - LP: #810015
  * ata_piix: Add Toshiba Satellite Pro A120 to the quirks list due to
    broken suspend functionality.
    - LP: #886850
  * sweep the floors and convert some .get_drvinfo routines to strlcpy
    - LP: #921793
  * be2net: init (vf)_if_handle/vf_pmac_id to handle failure scenarios
    - LP: #921793
  * be2net: stop checking the UE registers after an EEH error
    - LP: #921793
  * be2net: don't log more than one error on detecting EEH/UE errors
    - LP: #921793
  * be2net: stop issuing FW cmds if any cmd times out
    - LP: #921793
  * be2net: Fix TX queue create for Lancer
    - LP: #921793
  * be2net: add register dump feature for Lancer
    - LP: #921793
  * be2net: Add EEPROM dump feature for Lancer
    - LP: #921793
  * be2net: Fix VLAN promiscous mode for Lancer
    - LP: #921793
  * be2net: Use V1 query link status command for lancer
    - LP: #921793
  * be2net: Move to new SR-IOV implementation in Lancer
    - LP: #921793
  * be2net: Fix error recovery paths
    - LP: #921793
  * be2net: Add error handling for Lancer
    - LP: #921793
  * be2net: Use new hash key
    - LP: #921793
  * be2net: Fix non utilization of RX queues
    - LP: #921793
  * be2net: netpoll support
    - LP: #921793
  * be2net: update some counters to display via ethtool
    - LP: #921793
  * be2net: workaround to fix a bug in BE
    - LP: #921793
  * be2net: fix ethtool ringparam reporting
    - LP: #921793
  * be2net: refactor/cleanup vf configuration code
    - LP: #921793
...

Read more...

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released
Alexander Winizki (awinizki) wrote :

To #20
I now can confirm that installing the packages
linux-headers-3.0.0-18.31-lp883441-generic_3.0.0-18.31-lp883441_i386.deb
and
linux-image-3.0.0-18.31-lp883441-generic_3.0.0-18.31-lp883441_i386.deb
fixes the bug on my machine mentioned in the first post of this bug report.

Brad Figg (brad-figg) on 2012-04-07
tags: added: verification-needed-oneiric
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Oneiric in -proposed solves the problem ( 3.0.0-19.32). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-oneiric' to 'verification-done-oneiric'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

Waleed Hamra (w-hamra1987) wrote :

i can confirm that the kernel 3.0.0-19.32 in proposed fixes the issue, and allows the computer to start without any kernel parameter tweaks.
thank you all

tags: added: verification-done-oneiric
removed: verification-needed-oneiric
Alexander Winizki (awinizki) wrote :

I also confirm that the kernel 3.0.0-19.32 in proposed fixes the issue. After installing it, my machine boots with default kernel parameters.

Diego Ruotolo (ichise82) wrote :

Hello,
this is my first post in this tracking system.

Sadly I have to say that the patch above does NOT fix the problem for me. I tried several kernels, but no one of the 3.x branch works, patched or unpatched, unless acpi=off .

Here's the kernels I tried:
- kernel 2.6.32 (Ubuntu 10.04 LTS default) --> OK
- kernel 3.0.0 (Ubuntu 11.10 default) --> ERROR
- kernel 3.0.0 patched --> ERROR
- kernel 3.0.0-19.32 (the one proposed here) --> ERROR
- kernel vanilla 3.2 --> ERROR
- kernel vanilla 3.2 patched --> ERROR
- kernel 3.2 (Ubuntu 12.04 LTS default) --> ERROR

There is no way to boot with a kernel 3.x unless acpi=off.
Maybe there is something missing in my kernel configuration?

Let me know if you need more infos or some command output.

Thanks in advice!!!

Launchpad Janitor (janitor) wrote :
Download full text (24.1 KiB)

This bug was fixed in the package linux - 3.0.0-19.33

---------------
linux (3.0.0-19.33) oneiric-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #985736

  [ Luis Henriques ]

  * SAUCE: ite-cir: postpone ISR registration
    - LP: #984387

linux (3.0.0-19.32) oneiric-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #974368

  [ Brad Figg ]

  * SAUCE (no-up) Provide a param for allowing the BIOS to handle changing
    the brightness on AC/battery status changes.
    - LP: #949311
  * SAUCE (no-up) Quirk for enabling backlight hotkeys on Samsung N150P
    - LP: #875893

  [ Daniel Vetter ]

  * SAUCE: (drop after 3.5) drm/i915: reinstate GM45 TV detection fix
    - LP: #638939

  [ Herton Ronaldo Krzesinski ]

  * SAUCE: (no-up) Reinstate missing hunk from nx emulation
    - LP: #972821

  [ Tim Gardner ]

  * SAUCE: ubuntu drivers: use UMH_WAIT_PROC consistently
    - LP: #963685
  * SAUCE: disable_nx should not be in __cpuinitdata section for X86_32
    - LP: #968233
  * SAUCE: (no-up) remove __initdata from vesafb_fix
    - LP: #969309

  [ Upstream Kernel Changes ]

  * usermodehelper: use UMH_WAIT_PROC consistently
    - LP: #963685
  * usermodehelper: introduce umh_complete(sub_info)
    - LP: #963685
  * usermodehelper: implement UMH_KILLABLE
    - LP: #963685
  * usermodehelper: kill umh_wait, renumber UMH_* constants
    - LP: #963685
  * usermodehelper: ____call_usermodehelper() doesn't need do_exit()
    - LP: #963685
  * kmod: introduce call_modprobe() helper
    - LP: #963685
  * kmod: make __request_module() killable
    - LP: #963685
  * x86, tsc: Fix SMI induced variation in quick_pit_calibrate()
    - LP: #965586
  * ata_piix: Add Toshiba Satellite Pro A120 to the quirks list due to
    broken suspend functionality.
    - LP: #886850
  * ACPICA: Fix regression in FADT revision checks
    - LP: #883441
  * ASPM: Fix pcie devices with non-pcie children
    - LP: #961482
  * USB: option: Add MediaTek MT6276M modem&app interfaces
    - LP: #971808
  * USB: option driver: adding support for Telit CC864-SINGLE, CC864-DUAL
    and DE910-DUAL modems
    - LP: #971808
  * USB: option: make interface blacklist work again
    - LP: #971808
  * USB: option: add ZTE MF820D
    - LP: #971808
  * USB: ftdi_sio: fix problem when the manufacture is a NULL string
    - LP: #971808
  * USB: ftdi_sio: add support for BeagleBone rev A5+
    - LP: #971808
  * USB: Microchip VID mislabeled as Hornby VID in ftdi_sio.
    - LP: #971808
  * USB: ftdi_sio: new PID: Distortec JTAG-lock-pick
    - LP: #971808
  * USB: ftdi_sio: add support for FT-X series devices
    - LP: #971808
  * USB: ftdi_sio: new PID: LUMEL PD12
    - LP: #971808
  * powerpc/usb: fix bug of kernel hang when initializing usb
    - LP: #971808
  * usb: musb: Reselect index reg in interrupt context
    - LP: #971808
  * usb: gadgetfs: return number of bytes on ep0 read request
    - LP: #971808
  * USB: gadget: Make g_hid device class conform to spec.
    - LP: #971808
  * futex: Cover all PI opcodes with cmpxchg enabled check
    - LP: #971808
  * sysfs: Fix memory leak in sysfs_sd_setsecdata().
    - LP: #971808
  * tty: ...

Changed in linux (Ubuntu Oneiric):
status: Fix Committed → Fix Released

Hi,
this is my first post in launchpad.

I'm using Ubuntu 10.04 LTS and I have same problem.
After upgrading from kernel 2.6.32-28 to 3.0.0-17 system was able to boot only passing acpi=off (or maxcpus=1).
Yesterday I tried kernel 3.0.0-19 from official repository with no success. Problem persists.

On another machine (identical) this problem does not occur.

Today i found a simple workaround to overcome this iusse.
I set [ACPI APIC SCI IRQ] on ENABLED and problem disappear.

Do you need some logs or informations ?

Thanks.

Simone Camporeale, please execute the following via the Terminal and feel free to subscribe me to it:
ubuntu-bug linux

Thanks!

Thanks Christopher.
I attached output on pastebin:

Unaffected machine ubuntu-log linux output
http://paste.ubuntu.com/1003248/

Affected machine ubuntu-log linux output
http://paste.ubuntu.com/1003249/

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.