Touchpad not recognized [Gigabyte T1125N]

Bug #882864 reported by AF on 2011-10-28
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Touchscreen operates just like a touchpad with cursor following touch everywhere.
Touchpad (Elantech) not recognized at all [also, not recognized in 10.04, 10.10 or 11.04]

(the i8042.xxx trick worked previously on both 11.04 and 11.10)

Paste from lsinput

/dev/input/event0
   bustype : BUS_HOST
   vendor : 0x0
   product : 0x3
   version : 0
   name : "Sleep Button"
   phys : "PNP0C0E/button/input0"
   bits ev : EV_SYN EV_KEY

/dev/input/event1
   bustype : BUS_HOST
   vendor : 0x0
   product : 0x5
   version : 0
   name : "Lid Switch"
   phys : "PNP0C0D/button/input0"
   bits ev : EV_SYN EV_SW

/dev/input/event2
   bustype : BUS_HOST
   vendor : 0x0
   product : 0x1
   version : 0
   name : "Power Button"
   phys : "PNP0C0C/button/input0"
   bits ev : EV_SYN EV_KEY

/dev/input/event3
   bustype : BUS_HOST
   vendor : 0x0
   product : 0x1
   version : 0
   name : "Power Button"
   phys : "LNXPWRBN/button/input0"
   bits ev : EV_SYN EV_KEY

/dev/input/event4
   bustype : BUS_I8042
   vendor : 0x1
   product : 0x1
   version : 43841
   name : "AT Translated Set 2 keyboard"
   phys : "isa0060/serio0/input0"
   bits ev : EV_SYN EV_KEY EV_MSC EV_LED EV_REP

/dev/input/event5
   bustype : BUS_USB
   vendor : 0x5e3
   product : 0x510
   version : 2345
   name : "1.3M WebCam"
   phys : "usb-0000:00:1a.0-1.6/button"
   bits ev : EV_SYN EV_KEY

/dev/input/event6
   bustype : BUS_HOST
   vendor : 0x0
   product : 0x6
   version : 0
   name : "Video Bus"
   phys : "LNXVIDEO/video/input0"
   bits ev : EV_SYN EV_KEY

/dev/input/event7
   bustype : BUS_USB
   vendor : 0x2087
   product : 0xb03
   version : 273
   name : "Cando 11.6 "
   phys : "usb-0000:00:1d.0-1.6/input0"
   uniq : ""
   bits ev : EV_SYN EV_KEY EV_ABS

/dev/input/event8
   bustype : (null)
   vendor : 0x0
   product : 0x0
   version : 0
   name : "HDA Intel HDMI/DP,pcm=3"
   phys : "ALSA"
   bits ev : EV_SYN EV_SW

/dev/input/event9
   bustype : (null)
   vendor : 0x0
   product : 0x0
   version : 0
   name : "HDA Intel HDMI/DP,pcm=3"
   phys : "ALSA"
   bits ev : EV_SYN EV_SW

/dev/input/event10
   bustype : (null)
   vendor : 0x0
   product : 0x0
   version : 0
   name : "HDA Intel HDMI/DP,pcm=3"
   phys : "ALSA"
   bits ev : EV_SYN EV_SW

/dev/input/event11
   bustype : (null)
   vendor : 0x0
   product : 0x0
   version : 0
   name : "HDA Intel Headphone"
   phys : "ALSA"
   bits ev : EV_SYN EV_SW
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ananda 3529 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xbc400000 irq 43'
   Mixer name : 'Intel IbexPeak HDMI'
   Components : 'HDA:10ec0269,14581100,00100004 HDA:80862804,80860101,00100000'
   Controls : 20
   Simple ctrls : 12
DistroRelease: Ubuntu 11.10
HibernationDevice: RESUME=UUID=90201017-cf44-452b-9b74-d5475ec5f0fc
InstallationMedia: Ubuntu 10.04.3 LTS "Lucid Lynx" - Release amd64 (20110720.1)
MachineType: GIGABYTE T1125
Package: linux (not installed)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=caaa240a-ee8f-492f-8928-13ff1443639d ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
PulseSinks:
 Error: command ['pacmd', 'list-sinks'] failed with exit code 1: Home directory /home/ananda not ours.
 No PulseAudio daemon running, or not running as session daemon.
PulseSources:
 Error: command ['pacmd', 'list-sources'] failed with exit code 1: Home directory /home/ananda not ours.
 No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-12-generic N/A
 linux-backports-modules-3.0.0-12-generic N/A
 linux-firmware 1.60
StagingDrivers: mei
Tags: oneiric staging
Uname: Linux 3.0.0-12-generic x86_64
UpgradeStatus: Upgraded to oneiric on 2011-10-27 (11 days ago)
UserGroups:

dmi.bios.date: 05/18/2011
dmi.bios.vendor: INSYDE
dmi.bios.version: F12
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: T1125
dmi.board.vendor: GIGABYTE
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnINSYDE:bvrF12:bd05/18/2011:svnGIGABYTE:pnT1125:pvrF12:rvnGIGABYTE:rnT1125:rvrBaseBoardVersion:cvnChassisManufacturer:ct1:cvrChassisVersion:
dmi.product.name: T1125
dmi.product.version: F12
dmi.sys.vendor: GIGABYTE
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ananda 2844 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xdd800000 irq 45'
   Mixer name : 'Intel IbexPeak HDMI'
   Components : 'HDA:10ec0269,14581100,00100004 HDA:80862804,80860101,00100000'
   Controls : 41
   Simple ctrls : 15
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=90201017-cf44-452b-9b74-d5475ec5f0fc
InstallationMedia: Ubuntu 10.04.3 LTS "Lucid Lynx" - Release amd64 (20110720.1)
MachineType: GIGABYTE T1125
Package: linux (not installed)
ProcFB:
 0 nouveaufb
 1 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-24-generic root=UUID=caaa240a-ee8f-492f-8928-13ff1443639d ro i8042.noloop quiet splash i8042.noloop=1 vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-24.39-generic 3.2.16
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-24-generic N/A
 linux-backports-modules-3.2.0-24-generic N/A
 linux-firmware 1.79
SourcePackage: linux
StagingDrivers: mei
Tags: precise staging precise staging
Uname: Linux 3.2.0-24-generic x86_64
UpgradeStatus: Upgraded to precise on 2012-05-28 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare vboxusers
dmi.bios.date: 05/18/2011
dmi.bios.vendor: INSYDE
dmi.bios.version: F12
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: T1125
dmi.board.vendor: GIGABYTE
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnINSYDE:bvrF12:bd05/18/2011:svnGIGABYTE:pnT1125:pvrF12:rvnGIGABYTE:rnT1125:rvrBaseBoardVersion:cvnChassisManufacturer:ct1:cvrChassisVersion:
dmi.product.name: T1125
dmi.product.version: F12
dmi.sys.vendor: GIGABYTE

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 882864

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
AF (shuffle) wrote : AcpiTables.txt

apport information

tags: added: apport-collected oneiric staging
description: updated
AF (shuffle) wrote : AlsaDevices.txt

apport information

AF (shuffle) wrote : AplayDevices.txt

apport information

AF (shuffle) wrote : BootDmesg.txt

apport information

apport information

apport information

apport information

AF (shuffle) wrote : CurrentDmesg.txt

apport information

AF (shuffle) wrote : IwConfig.txt

apport information

AF (shuffle) wrote : Lspci.txt

apport information

AF (shuffle) wrote : Lsusb.txt

apport information

apport information

AF (shuffle) wrote : ProcCpuinfo.txt

apport information

apport information

AF (shuffle) wrote : ProcModules.txt

apport information

AF (shuffle) wrote : RfKill.txt

apport information

AF (shuffle) wrote : UdevDb.txt

apport information

AF (shuffle) wrote : UdevLog.txt

apport information

AF (shuffle) wrote : WifiSyslog.txt

apport information

AF (shuffle) on 2011-11-26
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

AF, thank you for reporting this and helping make Ubuntu better. This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

tags: added: lucid maverick natty needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete

Chris,

I really wish I could. Unfortunately I dropped my computer and the
screen doesn't work now...
I looked for a replacement, but Gigabyte and online vendors don't seem
to carry this screen...
Any chance you know where I can get one? (11.6" capacitive touchscreen
1164x768 or similar)

If I can find a replacement, I'll fix mine and then be happy to test it out.

Thanks,

Ananda

On 04/01/2012 10:10 PM, Christopher M. Penalver wrote:
> AF, thank you for reporting this and helping make Ubuntu better. This
> bug was reported a while ago and there hasn't been any activity in it
> recently. We were wondering if this is still an issue? Can you try with
> the latest development release of Ubuntu? ISO CD images are available
> from http://cdimage.ubuntu.com/releases/ .
>
> If it remains an issue, could you run the following command from a
> Terminal (Applications->Accessories->Terminal). It will automatically
> gather and attach updated debug information to this report.
>
> apport-collect -p linux<replace-with-bug-number>
>
> Also, if you could test the latest upstream kernel available that would
> be great. It will allow additional upstream developers to examine the
> issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once
> you've tested the upstream kernel, please remove the 'needs-upstream-
> testing' tag. This can be done by clicking on the yellow pencil icon
> next to the tag located at the bottom of the bug description and
> deleting the 'needs-upstream-testing' text. Please let us know your
> results.
>
> Thanks in advance.
>
> ** Tags added: lucid maverick natty needs-upstream-testing
>
> ** Changed in: linux (Ubuntu)
> Status: Confirmed => Incomplete
>

AF (shuffle) wrote : AcpiTables.txt

apport information

tags: added: precise
description: updated
AF (shuffle) wrote : AlsaDevices.txt

apport information

apport information

AF (shuffle) wrote : BootDmesg.txt

apport information

AF (shuffle) wrote : CRDA.txt

apport information

apport information

apport information

apport information

apport information

AF (shuffle) wrote : IwConfig.txt

apport information

AF (shuffle) wrote : Lspci.txt

apport information

AF (shuffle) wrote : Lsusb.txt

apport information

apport information

AF (shuffle) wrote : ProcCpuinfo.txt

apport information

AF (shuffle) wrote : ProcEnviron.txt

apport information

apport information

AF (shuffle) wrote : ProcModules.txt

apport information

AF (shuffle) wrote : PulseList.txt

apport information

AF (shuffle) wrote : RfKill.txt

apport information

AF (shuffle) wrote : UdevDb.txt

apport information

AF (shuffle) wrote : UdevLog.txt

apport information

AF (shuffle) wrote : WifiSyslog.txt

apport information

AF (shuffle) wrote : AcpiTables.txt

apport information

description: updated
AF (shuffle) wrote : AlsaDevices.txt

apport information

apport information

AF (shuffle) wrote : BootDmesg.txt

apport information

AF (shuffle) wrote : CRDA.txt

apport information

apport information

apport information

apport information

apport information

AF (shuffle) wrote : IwConfig.txt

apport information

AF (shuffle) wrote : Lspci.txt

apport information

AF (shuffle) wrote : Lsusb.txt

apport information

apport information

AF (shuffle) wrote : ProcCpuinfo.txt

apport information

AF (shuffle) wrote : ProcEnviron.txt

apport information

apport information

AF (shuffle) wrote : ProcModules.txt

apport information

AF (shuffle) wrote : RfKill.txt

apport information

AF (shuffle) wrote : UdevDb.txt

apport information

AF (shuffle) wrote : UdevLog.txt

apport information

AF (shuffle) wrote : WifiSyslog.txt

apport information

Update: The touchpad stopped working on my T1125N when I update Ubuntu to 12.04
No manner of combinations of i8042.xxx remedy the problem either...

(the i8042.xxx trick worked previously on both 11.04 and 11.10)

description: updated
TomaszCiolek (tmciolek) wrote :

I have the same issue with a Gigabyte T1125P

However I have managed to enable the elantech touchpad to hevae like a simple ps2 mouse by adding the "i8042.noloop" option to grub, but thats was the easy part (I have bigger issues with the Cando display, which appears to be badly calibrated and is causing isasues).

description: updated
summary: - Cando Touchscreen recognized, Touchpad Not [Gigabyte T1125N]
+ Touchpad not recognized [Gigabyte T1125N]

TomaszCiolek, please do not make comments on this report. For more on this, please see https://help.ubuntu.com/community/ReportingBugs#A3._Make_sure_the_bug_hasn.27t_already_been_reported . If you are having a problem in Ubuntu, please file a new report by executing the following via the Terminal and feel free to subscribe me to it:
ubuntu-bug linux

Thanks!

Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.