Ubuntu

linux-image-extra missing postinit/postrm

Reported by manik on 2011-10-26
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Tim Gardner
Oneiric
Undecided
Tim Gardner
Precise
Undecided
Tim Gardner

Bug Description

With Oneiric running as a guest in a Qemu/KVM environment, upon installing linux-image-virtual, the reiserfs modules are no longer available.

cat /proc/version_signature
Ubuntu 3.0.0-12.20-virtual 3.0.4

lspci -vnvn
00:00.0 Host bridge [0600]: Intel Corporation 440FX - 82441FX PMC [Natoma] [8086:1237] (rev 02)
 Subsystem: Red Hat, Inc Qemu virtual machine [1af4:1100]
 Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-

00:01.0 ISA bridge [0601]: Intel Corporation 82371SB PIIX3 ISA [Natoma/Triton II] [8086:7000]
 Subsystem: Red Hat, Inc Qemu virtual machine [1af4:1100]
 Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-

00:01.1 IDE interface [0101]: Intel Corporation 82371SB PIIX3 IDE [Natoma/Triton II] [8086:7010] (prog-if 80 [Master])
 Subsystem: Red Hat, Inc Qemu virtual machine [1af4:1100]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Region 0: [virtual] Memory at 000001f0 (32-bit, non-prefetchable) [size=8]
 Region 1: [virtual] Memory at 000003f0 (type 3, non-prefetchable) [size=1]
 Region 2: [virtual] Memory at 00000170 (32-bit, non-prefetchable) [size=8]
 Region 3: [virtual] Memory at 00000370 (type 3, non-prefetchable) [size=1]
 Region 4: I/O ports at c000 [size=16]
 Kernel driver in use: ata_piix

00:01.2 USB Controller [0c03]: Intel Corporation 82371SB PIIX3 USB [Natoma/Triton II] [8086:7020] (rev 01) (prog-if 00 [UHCI])
 Subsystem: Red Hat, Inc Qemu virtual machine [1af4:1100]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin D routed to IRQ 10
 Region 4: I/O ports at c020 [size=32]
 Kernel driver in use: uhci_hcd

00:01.3 Bridge [0680]: Intel Corporation 82371AB/EB/MB PIIX4 ACPI [8086:7113] (rev 03)
 Subsystem: Red Hat, Inc Qemu virtual machine [1af4:1100]
 Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Interrupt: pin A routed to IRQ 9

00:02.0 VGA compatible controller [0300]: Cirrus Logic GD 5446 [1013:00b8] (prog-if 00 [VGA controller])
 Subsystem: Red Hat, Inc Device [1af4:1100]
 Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Region 0: Memory at f0000000 (32-bit, prefetchable) [size=32M]
 Region 1: Memory at f2000000 (32-bit, non-prefetchable) [size=4K]
 Expansion ROM at f2010000 [disabled] [size=64K]
 Kernel modules: cirrusfb

00:03.0 Ethernet controller [0200]: Red Hat, Inc Virtio network device [1af4:1000]
 Subsystem: Red Hat, Inc Device [1af4:0001]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin A routed to IRQ 11
 Region 0: I/O ports at c040 [size=32]
 Region 1: Memory at f2020000 (32-bit, non-prefetchable) [size=4K]
 Capabilities: [40] MSI-X: Enable+ Count=3 Masked-
  Vector table: BAR=1 offset=00000000
  PBA: BAR=1 offset=00000800
 Kernel driver in use: virtio-pci

00:04.0 SCSI storage controller [0100]: Red Hat, Inc Virtio block device [1af4:1001]
 Subsystem: Red Hat, Inc Device [1af4:0002]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin A routed to IRQ 10
 Region 0: I/O ports at c080 [size=64]
 Region 1: Memory at f2021000 (32-bit, non-prefetchable) [size=4K]
 Capabilities: [40] MSI-X: Enable+ Count=2 Masked-
  Vector table: BAR=1 offset=00000000
  PBA: BAR=1 offset=00000800
 Kernel driver in use: virtio-pci

00:05.0 RAM memory [0500]: Red Hat, Inc Virtio memory balloon [1af4:1002]
 Subsystem: Red Hat, Inc Device [1af4:0005]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin A routed to IRQ 10
 Region 0: I/O ports at c0c0 [size=32]
 Kernel driver in use: virtio-pci

00:06.0 SCSI storage controller [0100]: Red Hat, Inc Virtio block device [1af4:1001]
 Subsystem: Red Hat, Inc Device [1af4:0002]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin A routed to IRQ 11
 Region 0: I/O ports at c100 [size=64]
 Region 1: Memory at f2022000 (32-bit, non-prefetchable) [size=4K]
 Capabilities: [40] MSI-X: Enable+ Count=2 Masked-
  Vector table: BAR=1 offset=00000000
  PBA: BAR=1 offset=00000800
 Kernel driver in use: virtio-pci

00:07.0 SCSI storage controller [0100]: Red Hat, Inc Virtio block device [1af4:1001]
 Subsystem: Red Hat, Inc Device [1af4:0002]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin A routed to IRQ 11
 Region 0: I/O ports at c140 [size=64]
 Region 1: Memory at f2023000 (32-bit, non-prefetchable) [size=4K]
 Capabilities: [40] MSI-X: Enable+ Count=2 Masked-
  Vector table: BAR=1 offset=00000000
  PBA: BAR=1 offset=00000800
 Kernel driver in use: virtio-pci

00:08.0 SCSI storage controller [0100]: Red Hat, Inc Virtio block device [1af4:1001]
 Subsystem: Red Hat, Inc Device [1af4:0002]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin A routed to IRQ 10
 Region 0: I/O ports at c180 [size=64]
 Region 1: Memory at f2024000 (32-bit, non-prefetchable) [size=4K]
 Capabilities: [40] MSI-X: Enable+ Count=2 Masked-
  Vector table: BAR=1 offset=00000000
  PBA: BAR=1 offset=00000800
 Kernel driver in use: virtio-pci

00:09.0 SCSI storage controller [0100]: Red Hat, Inc Virtio block device [1af4:1001]
 Subsystem: Red Hat, Inc Device [1af4:0002]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin A routed to IRQ 10
 Region 0: I/O ports at c1c0 [size=64]
 Region 1: Memory at f2025000 (32-bit, non-prefetchable) [size=4K]
 Capabilities: [40] MSI-X: Enable+ Count=2 Masked-
  Vector table: BAR=1 offset=00000000
  PBA: BAR=1 offset=00000800
 Kernel driver in use: virtio-pci

00:0a.0 SCSI storage controller [0100]: Red Hat, Inc Virtio block device [1af4:1001]
 Subsystem: Red Hat, Inc Device [1af4:0002]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin A routed to IRQ 11
 Region 0: I/O ports at c200 [size=64]
 Region 1: Memory at f2026000 (32-bit, non-prefetchable) [size=4K]
 Capabilities: [40] MSI-X: Enable+ Count=2 Masked-
  Vector table: BAR=1 offset=00000000
  PBA: BAR=1 offset=00000800
 Kernel driver in use: virtio-pci

00:0b.0 SCSI storage controller [0100]: Red Hat, Inc Virtio block device [1af4:1001]
 Subsystem: Red Hat, Inc Device [1af4:0002]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin A routed to IRQ 11
 Region 0: I/O ports at c240 [size=64]
 Region 1: Memory at f2027000 (32-bit, non-prefetchable) [size=4K]
 Capabilities: [40] MSI-X: Enable+ Count=2 Masked-
  Vector table: BAR=1 offset=00000000
  PBA: BAR=1 offset=00000800
 Kernel driver in use: virtio-pci

00:0c.0 SCSI storage controller [0100]: Red Hat, Inc Virtio block device [1af4:1001]
 Subsystem: Red Hat, Inc Device [1af4:0002]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin A routed to IRQ 10
 Region 0: I/O ports at c280 [size=64]
 Region 1: Memory at f2028000 (32-bit, non-prefetchable) [size=4K]
 Capabilities: [40] MSI-X: Enable+ Count=2 Masked-
  Vector table: BAR=1 offset=00000000
  PBA: BAR=1 offset=00000800
 Kernel driver in use: virtio-pci

00:0d.0 SCSI storage controller [0100]: Red Hat, Inc Virtio block device [1af4:1001]
 Subsystem: Red Hat, Inc Device [1af4:0002]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin A routed to IRQ 10
 Region 0: I/O ports at c2c0 [size=64]
 Region 1: Memory at f2029000 (32-bit, non-prefetchable) [size=4K]
 Capabilities: [40] MSI-X: Enable+ Count=2 Masked-
  Vector table: BAR=1 offset=00000000
  PBA: BAR=1 offset=00000800
 Kernel driver in use: virtio-pci

Tim Gardner (timg-tpi) wrote :

All other modules are packaged in linux-image-extra-virtual.

sudo apt-get install linux-image-extra-virtual

affects: linux-meta (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Opinion
manik (jeffery-bray) wrote :

I installed linux-image-extra-virtual
When I ls /lib/modules/3.0.0-12-virtual/kernel/fs/reiserfs/
I can see reiserfs.ko is there.
However modprobe reiserfs
produces FATAL: Module reiserfs not found.
and my reiserfs disks are still not mountable.

manik (jeffery-bray) wrote :

after installing linux-image-extra-virtual I had to run depmod -a
This fixed the problem

Tim Gardner (timg-tpi) on 2011-10-28
summary: - reiserfs module missing in linux-image-virtual
+ linux-image-extra missing postinit/postrm
Changed in linux (Ubuntu Oneiric):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Changed in linux (Ubuntu Precise):
assignee: nobody → Tim Gardner (timg-tpi)
status: Opinion → In Progress
Tim Gardner (timg-tpi) wrote :

SRU Justification

Impact: The linux-image-extra-ABI-virtual package is missing postinit and postrm scripts. This prevents the full installation of the new modules into modules.dep.

Tim Gardner (timg-tpi) on 2011-10-28
Changed in linux (Ubuntu Precise):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.1.0-2.3

---------------
linux (3.1.0-2.3) precise; urgency=low

  [ Tim Gardner ]

  * Add postinit and postrm scripts to the extras package
    - LP: #882120
 -- Leann Ogasawara <email address hidden> Fri, 28 Oct 2011 12:48:33 -0700

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released
Herton R. Krzesinski (herton) wrote :

This bug is awaiting verification that the kernel for Oneiric in -proposed solves the problem (3.0.0-14.23). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-oneiric' to 'verification-done-oneiric'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-oneiric
Tim Gardner (timg-tpi) wrote :

linux-image-extra-3.0.0-14-virtual_3.0.0-14.23_amd64.deb:
 new debian package, version 2.0.
 size 25497584 bytes: control archive= 75672 bytes.
     869 bytes, 24 lines control
  271349 bytes, 2649 lines md5sums
     161 bytes, 8 lines * postinst #!/bin/sh
     164 bytes, 8 lines * postrm #!/bin/sh

tags: added: verification-done-oneiric
removed: verification-needed-oneiric
Tim Gardner (timg-tpi) on 2011-12-05
Changed in linux (Ubuntu Oneiric):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (24.8 KiB)

This bug was fixed in the package linux - 3.0.0-14.23

---------------
linux (3.0.0-14.23) oneiric-proposed; urgency=low

  [Herton R. Krzesinski]

  * Release Tracking Bug
    - LP: #893213

  [ Andy Whitcroft ]

  * debian: add locking to protect debian/files from parallel update

  [ Konrad Rzeszutek Wilk ]

  * SAUCE: x86/paravirt: Partially revert "remove lazy mode in interrupts"
    - LP: #854050

  [ Leann Ogasawara ]

  * Revert "ubuntu: fsam7400 disable driver"
    - LP: #876030

  [ Seth Forshee ]

  * [Config] Enable EVENT_POWER_TRACING_DEPRECATED=y for powertop

  [ Tim Gardner ]

  * Add postinit and postrm scripts to the extras package
    - LP: #882120
  * [Config] CONFIG_R6040=m
    - LP: #650899
  * [Config] CONFIG_MEMSTICK_R592=m
    - LP: #238208
  * [Config] CONFIG_HID_ACRUX_FF=y
    - LP: #890952

  [ Upstream Kernel Changes ]

  * Revert "NFS: Ensure that writeback_single_inode() calls write_inode()
    when syncing"
    - LP: #890952
  * sparc64: Force the execute bit in OpenFirmware's translation entries.
    - LP: #881420
  * sched/rt: Migrate equal priority tasks to available CPUs
    - LP: #881420
  * sched: Fix up wchan borkage
    - LP: #881420
  * ide-disk: Fix request requeuing
    - LP: #881420
  * posix-cpu-timers: Cure SMP wobbles
    - LP: #881420
  * lis3: fix regression of HP DriveGuard with 8bit chip
    - LP: #881420
  * ASoC: use a valid device for dev_err() in Zylonite
    - LP: #881420
  * ASoC: Fix setting update bits for WM8753_LADC and WM8753_RADC
    - LP: #881420
  * drm/radeon: Update AVIVO cursor coordinate origin before x/yorigin
    calculation.
    - LP: #881420
  * drm/radeon/kms: fix regression in DP aux defer handling
    - LP: #881420
  * drm/radeon/kms: add retry limits for native DP aux defer
    - LP: #881420
  * drm/radeon/kms: fix channel_remap setup (v2)
    - LP: #881420
  * ptp: fix L2 event message recognition
    - LP: #881420
  * x86/PCI: use host bridge _CRS info on ASUS M2V-MX SE
    - LP: #881420
  * qla2xxx: Fix crash in qla2x00_abort_all_cmds() on unload
    - LP: #881420
  * libsas: fix panic when single phy is disabled on a wide port
    - LP: #881420
  * md: Avoid waking up a thread after it has been freed.
    - LP: #881420
  * dm table: avoid crash if integrity profile changes
    - LP: #881420
  * mmc: mxs-mmc: fix clock rate setting
    - LP: #881420
  * exec: do not call request_module() twice from search_binary_handler()
    - LP: #881420
  * ARM: mach-ux500: enable fix for ARM errata 754322
    - LP: #881420
  * drm/radeon/kms: retry aux transactions if there are status flags
    - LP: #881420
  * drm/radeon/kms: use hardcoded dig encoder to transmitter mapping for
    DCE4.1
    - LP: #881420
  * ipv6: fix NULL dereference in udp6_ufo_fragment()
    - LP: #881420
  * ahci: Enable SB600 64bit DMA on Asus M3A
    - LP: #881420
  * MIPS: PM: Use struct syscore_ops instead of sysdevs for PM (v2)
    - LP: #881420
  * ftrace: Fix regression of :mod:module function enabling
    - LP: #881420
  * ftrace: Fix regression where ftrace breaks when modules are loaded
    - LP: #881420
  * ftrace: Fix warning when CONFIG_FUNCTION_TRACER is not defined
    - LP: #881420
  * ...

Changed in linux (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers