Oneiric update to 3.0.8 stable release

Bug #881420 reported by Tim Gardner on 2011-10-25
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

    SRU Justification

    Impact:
       The upstream process for stable tree updates is quite similar
       in scope to the Ubuntu SRU process, e.g., each patch has to
       demonstrably fix a bug, and each patch is vetted by upstream
       by originating either directly from Linus' tree or in a minimally
       backported form of that patch. The 3.0.8 upstream stable
       patch set is now available. It should be included in the Ubuntu
       kernel as well.

       git://git.kernel.org/

    TEST CASE: TBD

       The following patches are in the 3.0.8 stable release:

sparc64: Force the execute bit in OpenFirmware's translation entries.
sched/rt: Migrate equal priority tasks to available CPUs
sched: Fix up wchan borkage
ide-disk: Fix request requeuing
posix-cpu-timers: Cure SMP wobbles
lis3: fix regression of HP DriveGuard with 8bit chip
ASoC: use a valid device for dev_err() in Zylonite
ASoC: Fix setting update bits for WM8753_LADC and WM8753_RADC
drm/radeon: Update AVIVO cursor coordinate origin before x/yorigin calculation.
drm/radeon/kms: fix regression in DP aux defer handling
drm/radeon/kms: add retry limits for native DP aux defer
drm/radeon/kms: fix channel_remap setup (v2)
ptp: fix L2 event message recognition
x86/PCI: use host bridge _CRS info on ASUS M2V-MX SE
qla2xxx: Fix crash in qla2x00_abort_all_cmds() on unload
libsas: fix panic when single phy is disabled on a wide port
md: Avoid waking up a thread after it has been freed.
dm table: avoid crash if integrity profile changes
mmc: mxs-mmc: fix clock rate setting
exec: do not call request_module() twice from search_binary_handler()
ARM: mach-ux500: enable fix for ARM errata 754322
drm/radeon/kms: retry aux transactions if there are status flags
drm/radeon/kms: use hardcoded dig encoder to transmitter mapping for DCE4.1
ipv6: fix NULL dereference in udp6_ufo_fragment()
ahci: Enable SB600 64bit DMA on Asus M3A
MIPS: PM: Use struct syscore_ops instead of sysdevs for PM (v2)
ftrace: Fix regression of :mod:module function enabling
ftrace: Fix regression where ftrace breaks when modules are loaded
ftrace: Fix warning when CONFIG_FUNCTION_TRACER is not defined
Linux 3.0.7
ARM: 7113/1: mm: Align bank start to MAX_ORDER_NR_PAGES
ARM: 7117/1: perf: fix HW_CACHE_* events on Cortex-A9
HID: usbhid: Add support for SiGma Micro chip
hwmon: (w83627ehf) Properly report thermal diode sensors
Avoid using variable-length arrays in kernel/sys.c
drm/radeon/kms/atom: fix handling of FB scratch indices
cputimer: Cure lock inversion
fuse: fix memory leak
Platform: fix samsung-laptop DMI identification for N150/N210/220/N230
uvcvideo: Fix crash when linking entities
drm/ttm: ensure ttm for new node is bound before calling move_notify()
drm/ttm: unbind ttm before destroying node in accel move cleanup
CIFS: Fix ERR_PTR dereference in cifs_get_root
xfs: start periodic workers later
xfs: use a cursor for bulk AIL insertion
xfs: do not update xa_last_pushed_lsn for locked items
xfs: force the log if we encounter pinned buffers in .iop_pushbuf
xfs: revert to using a kthread for AIL pushing
firewire: sbp2: fix panic after rmmod with slow targets
x86: Fix S4 regression
hwmon: (w83627ehf) Fix negative 8-bit temperature values
mm: fix race between mremap and removing migration entry
x25: Prevent skb overreads when checking call user data
crypto: ghash - Avoid null pointer dereference if no key is set
ALSA: HDA: conexant support for Lenovo T520/W520
ALSA: hda - Add position_fix quirk for Dell Inspiron 1010
Linux 3.0.8

Tim Gardner (timg-tpi) on 2011-10-25
tags: added: kernel-stable-tracking-bug
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux (Ubuntu Oneiric):
status: New → Confirmed
Changed in linux (Ubuntu):
status: New → Confirmed
madbiologist (me-again) wrote :

The list of patches in this bug's description seems to be different to the one in the 3.0.8 stable changelog at http://www.kernel.org/pub/linux/kernel/v3.0/ChangeLog-3.0.8
It has these:

drm/ttm: ensure ttm for new node is bound before calling move_notify()
drm/ttm: unbind ttm before destroying node in accel move cleanup
drm/radeon/kms/atom: fix handling of FB scratch indices

but not these:

drm/radeon: Update AVIVO cursor coordinate origin before x/yorigin
drm/radeon/kms: fix regression in DP aux defer handling
drm/radeon/kms: add retry limits for native DP aux defer
drm/radeon/kms: fix channel_remap setup (v2)

The latter group have been cc'd to stable but don't seem to have made it into 3.0.8.

I'm not sure of the significance of this.

madbiologist (me-again) wrote :

OK, sorry, the 4 commits I mentioned above were mentioned in the 3.0.7 changelog at http://www.kernel.org/pub/linux/kernel/v3.0/ChangeLog-3.0.7

I'm guessing we skipped the update to 3.0.7, in which case we will get these with 3.0.8 instead.

tekstr1der (tekstr1der) wrote :

It appears this was never built, and 3.0.9 stable has been released last week.

Will there now be an SRU for the 3.0.9 kernel in Oneiric?

papukaija (papukaija) wrote :

The next SRU is 3.0.0-14.23 (tracked in bug 893213).

Launchpad Janitor (janitor) wrote :
Download full text (24.8 KiB)

This bug was fixed in the package linux - 3.0.0-14.23

---------------
linux (3.0.0-14.23) oneiric-proposed; urgency=low

  [Herton R. Krzesinski]

  * Release Tracking Bug
    - LP: #893213

  [ Andy Whitcroft ]

  * debian: add locking to protect debian/files from parallel update

  [ Konrad Rzeszutek Wilk ]

  * SAUCE: x86/paravirt: Partially revert "remove lazy mode in interrupts"
    - LP: #854050

  [ Leann Ogasawara ]

  * Revert "ubuntu: fsam7400 disable driver"
    - LP: #876030

  [ Seth Forshee ]

  * [Config] Enable EVENT_POWER_TRACING_DEPRECATED=y for powertop

  [ Tim Gardner ]

  * Add postinit and postrm scripts to the extras package
    - LP: #882120
  * [Config] CONFIG_R6040=m
    - LP: #650899
  * [Config] CONFIG_MEMSTICK_R592=m
    - LP: #238208
  * [Config] CONFIG_HID_ACRUX_FF=y
    - LP: #890952

  [ Upstream Kernel Changes ]

  * Revert "NFS: Ensure that writeback_single_inode() calls write_inode()
    when syncing"
    - LP: #890952
  * sparc64: Force the execute bit in OpenFirmware's translation entries.
    - LP: #881420
  * sched/rt: Migrate equal priority tasks to available CPUs
    - LP: #881420
  * sched: Fix up wchan borkage
    - LP: #881420
  * ide-disk: Fix request requeuing
    - LP: #881420
  * posix-cpu-timers: Cure SMP wobbles
    - LP: #881420
  * lis3: fix regression of HP DriveGuard with 8bit chip
    - LP: #881420
  * ASoC: use a valid device for dev_err() in Zylonite
    - LP: #881420
  * ASoC: Fix setting update bits for WM8753_LADC and WM8753_RADC
    - LP: #881420
  * drm/radeon: Update AVIVO cursor coordinate origin before x/yorigin
    calculation.
    - LP: #881420
  * drm/radeon/kms: fix regression in DP aux defer handling
    - LP: #881420
  * drm/radeon/kms: add retry limits for native DP aux defer
    - LP: #881420
  * drm/radeon/kms: fix channel_remap setup (v2)
    - LP: #881420
  * ptp: fix L2 event message recognition
    - LP: #881420
  * x86/PCI: use host bridge _CRS info on ASUS M2V-MX SE
    - LP: #881420
  * qla2xxx: Fix crash in qla2x00_abort_all_cmds() on unload
    - LP: #881420
  * libsas: fix panic when single phy is disabled on a wide port
    - LP: #881420
  * md: Avoid waking up a thread after it has been freed.
    - LP: #881420
  * dm table: avoid crash if integrity profile changes
    - LP: #881420
  * mmc: mxs-mmc: fix clock rate setting
    - LP: #881420
  * exec: do not call request_module() twice from search_binary_handler()
    - LP: #881420
  * ARM: mach-ux500: enable fix for ARM errata 754322
    - LP: #881420
  * drm/radeon/kms: retry aux transactions if there are status flags
    - LP: #881420
  * drm/radeon/kms: use hardcoded dig encoder to transmitter mapping for
    DCE4.1
    - LP: #881420
  * ipv6: fix NULL dereference in udp6_ufo_fragment()
    - LP: #881420
  * ahci: Enable SB600 64bit DMA on Asus M3A
    - LP: #881420
  * MIPS: PM: Use struct syscore_ops instead of sysdevs for PM (v2)
    - LP: #881420
  * ftrace: Fix regression of :mod:module function enabling
    - LP: #881420
  * ftrace: Fix regression where ftrace breaks when modules are loaded
    - LP: #881420
  * ftrace: Fix warning when CONFIG_FUNCTION_TRACER is not defined
    - LP: #881420
  * ...

Changed in linux (Ubuntu Oneiric):
status: Confirmed → Fix Released
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers