Sleep/hibernate not working after upgrade to 11.10 Oneiric

Bug #879071 reported by Marius B. Kotsbak on 2011-10-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
pm-utils (Ubuntu)
Undecided
Unassigned

Bug Description

Seems to be a regression, as this worked fine in Natty. The laptop is a Gigabyte T1005.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: linux-image-3.0.0-12-generic 3.0.0-12.20
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 1: Intel [HDA Intel], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 1.23-0ubuntu3
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 1: Intel [HDA Intel], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: marius 7666 F.... pulseaudio
CRDA: Error: [Errno 2] Ingen slik fil eller filkatalog
Card1.Amixer.info:
 Card hw:1 'Intel'/'HDA Intel at 0x98200000 irq 52'
   Mixer name : 'Realtek ALC269VB'
   Components : 'HDA:10ec0269,1458b100,00100100'
   Controls : 11
   Simple ctrls : 7
Date: Thu Oct 20 22:08:58 2011
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=49e028f9-7435-4850-8244-8523020782de
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
MachineType: GIGABYTE T1005
ProcEnviron:
 LANGUAGE=nb_NO:nb:no_NO:no:nn_NO:nn:en
 PATH=(custom, user)
 LANG=nb_NO.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=f1d0446d-3ea3-46a7-9842-8773acca78e6 ro crashkernel=384M-2G:64M,2G-:128M quiet splash i8042.noloop=1 vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-12-generic N/A
 linux-backports-modules-3.0.0-12-generic N/A
 linux-firmware 1.60
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: Upgraded to oneiric on 2011-10-17 (3 days ago)
dmi.bios.date: 08/30/2010
dmi.bios.vendor: GIGABYTE
dmi.bios.version: GSBF05
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: T1005
dmi.board.vendor: GIGABYTE
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnGIGABYTE:bvrGSBF05:bd08/30/2010:svnGIGABYTE:pnT1005:pvrGSBF05:rvnGIGABYTE:rnT1005:rvrBaseBoardVersion:cvnChassisManufacturer:ct1:cvrChassisVersion:
dmi.product.name: T1005
dmi.product.version: GSBF05
dmi.sys.vendor: GIGABYTE

Marius B. Kotsbak (mariusko) wrote :
Brad Figg (brad-figg) on 2011-10-20
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the release candidate kernel versus the daily build. Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the others). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed by the mainline kernel, please add the following tag 'kernel-fixed-upstream-KERNEL-VERSION'. For example, if kernel version 3.1-rc9 fixed and issue, the tag would be: 'kernel-fixed-upstream-v3.1-rc9'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Thanks in advance.

tags: added: needs-upstream-testing
Marius B. Kotsbak (mariusko) wrote :

I tested the live version from USB stick and could not reproduce the problem there, and the kernel version is the same. So I guess this is maybe caused by some other component. Seems like I also can't shutdown without a hang.

tags: removed: needs-upstream-testing
Steve Langasek (vorlon) wrote :

neither the acpi nor the acpi-support package is involved with hibernate.

Changed in acpi (Ubuntu):
status: New → Invalid
Changed in acpi-support (Ubuntu):
status: New → Invalid
Steve Langasek (vorlon) wrote :

How would you test hibernation with a live USB stick anyway? The live environment doesn't support hibernation.

Marius B. Kotsbak (mariusko) wrote :

Well, I mean sleep/suspend or what it is called, using the Z-button, in a low power state and then I wake it up by touching a key. Which component might be involved in this? I could not see any errors in the log files.

Joseph Salisbury (jsalisbury) wrote :

Were you able to test the upstream kernel mentioned in comment #2?

Also, if you boot back into the Natty kernel, does the problem go away?

Steve Langasek (vorlon) wrote :

ok; if this behaves differently in the live environment then on an install, then it's probably not the kernel. Possibly pm-utils; assigning there.

affects: acpi-support (Ubuntu) → pm-utils (Ubuntu)
Changed in pm-utils (Ubuntu):
status: Invalid → New
Marius B. Kotsbak (mariusko) wrote :

Same with 2.6.38-11-generic, sleep command just locks screen.

Marius Kotsbak, thank you for reporting this and helping make Ubuntu better. This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please provide the information following https://wiki.ubuntu.com/DebuggingKernelSuspendHibernateResume ? As well, can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ . However, note you can only test Suspend, not Hibernate, when using a LiveCD. If the issue remains, run the following command in the development release from a Terminal (Applications->Accessories->Terminal) as it will automatically gather and attach updated debug information to this report.

apport-collect -p linux <BUGNUMBER>

Additionally, if you could try to reproduce this with the upstream mainline kernel that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.

Please let us know your results. Thanks in advance.

tags: added: needs-bisect needs-upstream-testing regression-release
no longer affects: acpi (Ubuntu)
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Marius B. Kotsbak (mariusko) wrote :

I don't see this in Precise, so I close it as fixed.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Changed in pm-utils (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers