re-enabeling wirelss network on network manager does not work properly

Bug #876822 reported by Carla Sella on 2011-10-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
NetworkManager
Fix Released
Medium
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I found out testing wirless network on my laptop (http://testcases.qa.ubuntu.com/Hardware/Network/Wireless) that if you disable wireless networking and the re-enable it wireless networks are not displayed.
To get them displayed you have to check enable wireless, uncheck enable networking and re-check enable networking, and then you will see the wireless networks again.
---
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
CRDA: Error: [Errno 2] File o directory non esistente
DistroRelease: Ubuntu 11.10
Gconf:

IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
IpRoute:
 default via 10.0.0.138 dev wlan0 proto static
 10.0.0.0/24 dev wlan0 proto kernel scope link src 10.0.0.9 metric 2
 169.254.0.0/16 dev wlan0 scope link metric 1000
Keyfiles: Error: [Errno 2] File o directory non esistente
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
Package: network-manager 0.9.1.90-0ubuntu3
PackageArchitecture: amd64
ProcEnviron:
 PATH=(custom, no user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Tags: oneiric running-unity
Uname: Linux 3.0.0-12-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

apport information

tags: added: apport-collected oneiric running-unity
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Mark Nighswonger (marknigh) wrote :

Don't disable it. The test assumes that you have not established a wireless network as of yet. It might not be the best way to have to reestablish wireless connectivity, I'm not sure that that alone makes it a bug though. IMHO

Mark,

Actually, it's a likely scenario that after the killswitch was enabled and disabled again, the driver might end up in the wrong state, blocking scanning results.

Carla,

Once wireless is re-enabled, does it list something like "Device not ready"? Or just nothing listed under it at all? I looked at the logs quickly and I could only find instances of your tests where wireless was re-enabled only for a few seconds before using your workaround. It would be more helpful if you could confirm you've waited at least a minute before killing off networking completely, just in case it takes a little bit of time before the driver triggers a scan.

Changed in network-manager (Ubuntu):
status: New → Incomplete
Carla Sella (carla-sella) wrote :

Once wireless is re-enabled, you can see the tick near "Enable wireless" but nothing is listed, it is as if I did not re-enable it.
This time I waited for at least two minutes, but nothing happended.
I hand to deselect "Enable networkin" and reselect it to have the wireless networks displayed again and be re-connected to the network I was connected before diasbling it.

Changed in network-manager (Ubuntu):
status: Incomplete → Confirmed

Reassigning to 'linux', since this is most likely an issue with rescans at the driver level.

affects: network-manager (Ubuntu) → linux (Ubuntu)
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the release candidate kernel versus the daily build. Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the others). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed by the mainline kernel, please add the following tag 'kernel-fixed-upstream-KERNEL-VERSION'. For example, if kernel version 3.1-rc9 fixed and issue, the tag would be: 'kernel-fixed-upstream-v3.1-rc9'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Thanks in advance.

tags: added: needs-upstream-testing
Carla Sella (carla-sella) wrote :

I tried kernel 3.1.0-030100-generic_3.1.0-030100.201110241006_amd64.deb but the problem is not solved.
Nothing changes.

Joe Areeda (areeda) wrote :

I just started the laptop testing and cannot duplicate this.
I disabled wireless from the applet and upon reenabling I get the list of networks.
ifconfig wlan down turns it off and then it reconnects automatically in a minute or so.

I'm not sure how to link to my whole configuration but I'm running on a Thinkpad 510 (3.0.0-12-generic #20-Ubuntu SMP x86_64).

Joe

Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

The bugzilla.kernel.org may still be unavailable due to the recent break-in. One alternative would be to report this directly to the subsystem maintainer or to the Linux Kernel Mailing List - <email address hidden>

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Carla Sella (carla-sella) wrote :

I reported the bug upstream in LKML: http://marc.info/?l=linux-kernel&m=132050334429405&w=2

Carla Sella (carla-sella) wrote :

I got this answer: http://marc.info/?l=linux-kernel&m=132071438022879&w=2 I will try to report this bug to the network
manager developers.

Carla Sella (carla-sella) wrote :

I reported the bug on gnome bugzilla: https://bugzilla.gnome.org/show_bug.cgi?id=663650

Carla Sella (carla-sella) wrote :

https://bugzilla.gnome.org/show_bug.cgi?id=663650
  NetworkManager | nm-applet | 0.9.x

Akhil Laddha <lakhil> changed:

           What |Removed |Added
----------------------------------------------------------------------------
             Status|NEEDINFO |RESOLVED
         Resolution| |FIXED

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/876822

tags: added: laptop-testing
Carla Sella (carla-sella) wrote :

I tried to disable wireless networking on network manager and then re-enable
it on Precise Pangolin Beta 2 and it works so I can say the bug is solved.
https://bugzilla.gnome.org/show_bug.cgi?id=663650.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
status: Fix Released → Fix Committed

Carla Sella, this bug report is being closed due to your last comment regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in linux (Ubuntu):
status: Fix Committed → Invalid
Changed in network-manager:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.