Lack of fsam7400 kernel module in oneiric?

Bug #876030 reported by Michał Małecki on 2011-10-16
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Oneiric
Medium
Leann Ogasawara

Bug Description

== SRU Justification ==
Per the Oneiric Ubuntu Kernel Delta review, we purposely decided to disable the fsam7400 kernel module because it was an out of tree module which produces an extra maintenance burden and overhead every release. Should anyone object, it would be re-enabled. If there were no objections, it would be dropped in the subsequent 12.04 Precise LTS release. A bug reporter has requested we re-enable this module to support the rfkill switch on their Fujitsu laptop

== Impact ==
Confirmed to affect Fujitsu Siemens Amilo Pro V3505, likely other Fujitsu models are affected as well.

== Fix ==
Re-enable the fsam7400 module

== Test Case ==
With the driver, confirm the ability to toggle the rfkill switch. Without the driver, this is not possible.

----------

After upgrade (Linux 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:50:42 UTC 2011 i686 i686 i386 GNU/Linux) there are no fsam7400 kernel module.

I've found that Kernel Team "yank the code"?
https://wiki.ubuntu.com/KernelTeam/ReleaseStatus/Oneiric

We are using it to turn on our wi-fi cards:
http://ubuntuforums.org/showpost.php?p=8717830&postcount=5

tags: added: oneiric
affects: ubuntu → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 876030

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

Hi Michał,

Wow, that bot is fast. Anyways, please disregard comment #1 from the bot. Due to the fact that the fsam7400 is an out of tree driver (which produces extra maintenance burden and overhead), we purposely disabled it in Oneiric with the hopes of completely dropping it from the upcoming Precise 12.04 release. However, you've confirmed there are still some users which are dependent on the driver. Thus, I've built and Oneiric test kernel which re-enables the driver. Please test and let me know yours results. I can then submit this for Oneiric SRU (stable release update) and also propose to keep it enabled for the Precise 12.04 release. Thanks.

http://people.canonical.com/~ogasawara/lp876030/

Changed in linux (Ubuntu Oneiric):
assignee: nobody → Leann Ogasawara (leannogasawara)
importance: Undecided → Medium
status: New → In Progress
Michał Małecki (michalus) wrote :

Hi Leann,

Thanks for quick answer. Your build (Linux 3.0.0-13-generic #21~lp876030v1 SMP Mon Oct 17 15:04:11 UTC 2011 i686 i686 i386 GNU/Linux) is working properly for me. Now I can disable "rf switch" and start wi-fi card. All the old way.

I think that, this kernel module is necessary for many users of Fujitsu Siemens. My computer is for example "Fujitsu Siemens Amilo Pro V3505" however fsam7400 name is corresponding to the "Fujitsu Siemens Amilo M 7400" model. Some of Fujitsu Siemens laptops were sold, brand new, with Linux operating system (no MS Windows). I think that the most of them have no hardware switch for wi-fi, only software "rf switch".

If this story could repeat during Precise 12.04 "kernel delta review"?

Again thanks for help.

Thanks for the quick testing turnaround and feedback. I'll submit this for Oneiric SRU and also use this to support keeping the module enabled for the upcoming Precise 12.04 release. Thanks.

Changed in linux (Ubuntu):
status: Incomplete → In Progress
description: updated
Changed in linux (Ubuntu Oneiric):
status: In Progress → Fix Committed
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (10.3 KiB)

This bug was fixed in the package linux - 3.1.0-1.1

---------------
linux (3.1.0-1.1) precise; urgency=low

  [ Andiry Xu ]

  * SAUCE: (drop during 3.2 merge) xHCI: AMD isoc link TRB chain bit quirk
    - LP: #872811

  [ Andy Whitcroft ]

  * Revert "ubuntu: compcache -- follow changes to bd_claim/bd_release"
    - LP: #832694
  * Revert "ubuntu: compcache -- version 0.5.3"
    - LP: #832694
  * [Config] standardise CONFIG_NETFILTER_XT_TARGET_TCPOPTSTRIP=m
  * [Config] Enable CONFIG_MACVTAP=m
    - LP: #822601
  * record the compiler in the ABI and check for inconsistant builds
  * [Config] move ECRYPT_FS back to =y for all architectures
    - LP: #827197
  * [Config] enable CONFIG_DRM_VMWGFX=m
    - LP: #698009
  * [Config] re-fix ECRYPT_FS=y
    - LP: #827197
  * enforcer -- ensure we have CONFIG_ECRYPT_FS=y
    - LP: #827197
  * [Config] dropping compcache configuration options
  * [Config] standardise on HZ=250
  * SAUCE: headers_install: fix #include "..." usage for userspace
    - LP: #824377
  * make module-inclusion selection retain the left overs
  * add a new linux-image-extras package for virtual

  [ Colin Watson ]

  * Deliver more Atheros, Ralink, and iwlagn NIC drivers to d-i

  [ edwin_rong ]

  * SAUCE: Staging: add driver for Realtek RTS5139 cardreader
    - LP: #824273

  [ Greg Kroah-Hartman ]

  * SAUCE: staging: rts5139: add vmalloc.h to some files to fix the build.
    - LP: #824273

  [ Jesse Sung ]

  * SAUCE: Unregister input device only if it is registered
    - LP: #839238

  [ Jiri Kosina ]

  * SAUCE: HID: add MacBookAir4, 2 to hid_have_special_driver[]

  [ Joshua V. Dillon ]

  * SAUCE: HID: add support for MacBookAir4,2 keyboard.

  [ Kees Cook ]

  * [Config] enable and enforce SECCOMP_FILTER on x86

  [ Keng-Yu Lin ]

  * [Config] Enable CONFIG_RTS5139=m on i386/amd64
    - LP: #824273

  [ Leann Ogasawara ]

  * Revert "ubuntu: overlayfs -- ovl: make lower mount read-only"
  * Revert "ubuntu: overlayfs -- fs: limit filesystem stacking depth"
  * Revert "ubuntu: overlayfs -- ovl: improve stack use of lookup and
    readdir"
  * Revert "ubuntu: overlayfs -- ovl: fix overlayfs over overlayfs"
  * Revert "ubuntu: overlayfs -- overlayfs: implement show_options"
  * Revert "ubuntu: overlayfs -- overlayfs: add statfs support"
  * Revert "ubuntu: overlayfs -- overlay filesystem"
  * Revert "ubuntu: overlayfs -- overlay: overlay filesystem documentation"
  * Revert "SAUCE: ARM: OMAP: Add macros for comparing silicon revision"
  * Revert "SAUCE: OMAP: DSS2: check for both cpu type and revision, rather
    than just revision"
  * Revert "SAUCE: OMAP: DSS2: enable hsclk in dsi_pll_init for OMAP36XX"
  * Revert "ubuntu: fsam7400 disable driver"
    - LP: #876030
  * rebase to v3.1-rc1
  * [Config] updateconfigs after rebase to v3.1-rc1
  * rebase to v3.1-rc2
  * [Config] Updateconfigs after rebase to v3.1-rc2
  * ubuntu: Yama - update calls to generic_permission() and
    inode->i_op->permission()
  * ubuntu: ndiswrapper -- remove netdev_priv macro
  * ubuntu: aufs -- Temporarily disable due to build failure
  * [Config] Diable INTEL_MID_PTI on armel
  * [Config] Temporarily disable CONFIG_FTMAC100 on armel
  * [Conf...

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Herton R. Krzesinski (herton) wrote :

This bug is awaiting verification that the kernel for Oneiric in -proposed solves the problem (3.0.0-14.23). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-oneiric' to 'verification-done-oneiric'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-oneiric
Michał Małecki (michalus) wrote :

I confirm, it's working on Linux 3.0.0-14-generic #23-Ubuntu SMP Mon Nov 21 20:34:47 UTC 2011 i686 i686 i386 GNU/Linux.

tags: added: verification-done-oneiric
Launchpad Janitor (janitor) wrote :
Download full text (24.8 KiB)

This bug was fixed in the package linux - 3.0.0-14.23

---------------
linux (3.0.0-14.23) oneiric-proposed; urgency=low

  [Herton R. Krzesinski]

  * Release Tracking Bug
    - LP: #893213

  [ Andy Whitcroft ]

  * debian: add locking to protect debian/files from parallel update

  [ Konrad Rzeszutek Wilk ]

  * SAUCE: x86/paravirt: Partially revert "remove lazy mode in interrupts"
    - LP: #854050

  [ Leann Ogasawara ]

  * Revert "ubuntu: fsam7400 disable driver"
    - LP: #876030

  [ Seth Forshee ]

  * [Config] Enable EVENT_POWER_TRACING_DEPRECATED=y for powertop

  [ Tim Gardner ]

  * Add postinit and postrm scripts to the extras package
    - LP: #882120
  * [Config] CONFIG_R6040=m
    - LP: #650899
  * [Config] CONFIG_MEMSTICK_R592=m
    - LP: #238208
  * [Config] CONFIG_HID_ACRUX_FF=y
    - LP: #890952

  [ Upstream Kernel Changes ]

  * Revert "NFS: Ensure that writeback_single_inode() calls write_inode()
    when syncing"
    - LP: #890952
  * sparc64: Force the execute bit in OpenFirmware's translation entries.
    - LP: #881420
  * sched/rt: Migrate equal priority tasks to available CPUs
    - LP: #881420
  * sched: Fix up wchan borkage
    - LP: #881420
  * ide-disk: Fix request requeuing
    - LP: #881420
  * posix-cpu-timers: Cure SMP wobbles
    - LP: #881420
  * lis3: fix regression of HP DriveGuard with 8bit chip
    - LP: #881420
  * ASoC: use a valid device for dev_err() in Zylonite
    - LP: #881420
  * ASoC: Fix setting update bits for WM8753_LADC and WM8753_RADC
    - LP: #881420
  * drm/radeon: Update AVIVO cursor coordinate origin before x/yorigin
    calculation.
    - LP: #881420
  * drm/radeon/kms: fix regression in DP aux defer handling
    - LP: #881420
  * drm/radeon/kms: add retry limits for native DP aux defer
    - LP: #881420
  * drm/radeon/kms: fix channel_remap setup (v2)
    - LP: #881420
  * ptp: fix L2 event message recognition
    - LP: #881420
  * x86/PCI: use host bridge _CRS info on ASUS M2V-MX SE
    - LP: #881420
  * qla2xxx: Fix crash in qla2x00_abort_all_cmds() on unload
    - LP: #881420
  * libsas: fix panic when single phy is disabled on a wide port
    - LP: #881420
  * md: Avoid waking up a thread after it has been freed.
    - LP: #881420
  * dm table: avoid crash if integrity profile changes
    - LP: #881420
  * mmc: mxs-mmc: fix clock rate setting
    - LP: #881420
  * exec: do not call request_module() twice from search_binary_handler()
    - LP: #881420
  * ARM: mach-ux500: enable fix for ARM errata 754322
    - LP: #881420
  * drm/radeon/kms: retry aux transactions if there are status flags
    - LP: #881420
  * drm/radeon/kms: use hardcoded dig encoder to transmitter mapping for
    DCE4.1
    - LP: #881420
  * ipv6: fix NULL dereference in udp6_ufo_fragment()
    - LP: #881420
  * ahci: Enable SB600 64bit DMA on Asus M3A
    - LP: #881420
  * MIPS: PM: Use struct syscore_ops instead of sysdevs for PM (v2)
    - LP: #881420
  * ftrace: Fix regression of :mod:module function enabling
    - LP: #881420
  * ftrace: Fix regression where ftrace breaks when modules are loaded
    - LP: #881420
  * ftrace: Fix warning when CONFIG_FUNCTION_TRACER is not defined
    - LP: #881420
  * ...

Changed in linux (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers