Comment 10 for bug 875892

peter b (b1pete) wrote :

@jsalisbury

well, a little story first -

- I disabled/removed the STA driver then
- over the weekend a belkin N300 usb wifi dongle plugged in and tried;
- I fiddled with dkms and tried to get the realtek module loaded; net results same as with the internal broadcom (the realtek module was created and installed with no errors); brief conn'n established , the dongle light was coming on - as with broadcom then out of the blue disconnected and dongle light disappeared.
- then in additional drivers the belkin/realtek driver removed too.
- used ndiswrapper and xp drivers; net result even worse than the first two - as soon as the command connect issued the desktop disappeared , dumped to a console with enable trace last line and a hard pc lock.

so I decided for a new oneiric install with the N300 usb wifi present. alernate CD install went ok. after first boot

sudo ifconfig
[sudo] password for peter:
eth0 Link encap:Ethernet HWaddr 1c:75:08:de:da:a0
          inet6 addr: fe80::1e75:8ff:fede:daa0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:2309 errors:0 dropped:0 overruns:0 frame:0
          TX packets:30 errors:0 dropped:0 overruns:0 carrier:1
          collisions:0 txqueuelen:1000
          RX bytes:142092 (142.0 KB) TX bytes:5470 (5.4 KB)
          Interrupt:41

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wlan0 Link encap:Ethernet HWaddr ec:55:f9:24:47:97
          inet addr:192.168.2.16 Bcast:192.168.2.255 Mask:255.255.255.0
          inet6 addr: fe80::ee55:f9ff:fe24:4797/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:124694 errors:0 dropped:0 overruns:0 frame:0
          TX packets:66189 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:183797851 (183.7 MB) TX bytes:5757259 (5.7 MB)

sudo iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:"BELL864"
          Mode:Managed Frequency:2.427 GHz Access Point: 00:26:50:B3:59:69
          Bit Rate=11 Mb/s Tx-Power=19 dBm
          Retry long limit:7 RTS thr:off Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=70/70 Signal level=-148 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:132 Missed beacon:0

/etc/udev/rules.d/70-persistent-net.rules

# This file was automatically generated by the /lib/udev/write_net_rules
# program, run by the persistent-net-generator.rules rules file.
#
# You can modify it, as long as you keep each rule on a single
# line, and change only the value of the NAME= key.

# PCI device 0x1969:0x2062 (atl1c)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="1c:75:08:de:da:a0", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

# PCI device 0x14e4:0x4727 (brcmsmac)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="ec:55:f9:24:47:97", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"

big diff from first post #4. no eth1 - now wlan0; no wl but (from lsmod)

brcmsmac 631693 0
....
brcmutil 17837 1 brcmsmac
......
mac80211 310872 1 brcmsmac
......
cfg80211 199587 2 brcmsmac,mac80211
.......
crc_ccitt 12667 1 brcmsmac

conclusion : broadcom internal wifi works flawless; solid good steady conn'n. why this time and not on first install ? v hard for me to tell. I used the same install media, reformatted the same size part sda7 same swap - totally puzzled.

thanks to all. I will not try any other kernels - if it ain't broken don't fix it. thank you Joseph.