Ath9k driver causes kernel panic and system freeze on Ubuntu 11.10

Bug #875503 reported by Ashwin on 2011-10-16
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

After I installed Ubuntu 11.10. I tried bridging eth0 and wlan0 with this script:

#####################################
#!/bin/bash

service network-manager stop
ifconfig eth0 0.0.0.0
ifconfig eth0 up

ifconfig wlan0 0.0.0.0
ifconfig wlan0 up

brctl addbr br0
hostapd -dd /etc/hostapd/hostapd.conf > /var/log/hostapd.log &
sleep 5
brctl addif br0 eth0
brctl addif br0 wlan0

ifconfig br0 192.168.1.15 netmask 255.255.255.0
ifconfig br0 up
route add default gw 192.168.1.1

#########################

And it showed up this error:

l2_packet_receive - recvfrom: Network is down
device wlan0 is already a member of a bridge; can't enslave it to bridge br0.

I have used same scripts on earlier Ubuntu versions; but there was no such error.

Apart from that error, after enabling the bridge, the moment another device tried to connect to it, the system freezes. I ran same script by logging to CLI (alt + f5), then when the freeze happens, error message kept on scrolling on screen (so fast that I could not read anything).

I tried loading 2.6.38 kernel, then also the first mentioned errors showed up, but system did not freeze and the bridge (access point mode) worked fine.

---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 1.23-0ubuntu3
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ashwin 1563 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf7cf8000 irq 45'
   Mixer name : 'Realtek ALC269'
   Components : 'HDA:10ec0269,10438442,00100004'
   Controls : 9
   Simple ctrls : 5
DistroRelease: Ubuntu 11.10
HibernationDevice: RESUME=UUID=d3930f52-5879-4184-ae59-7d0712e31d29
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
MachineType: ASUSTeK Computer INC. 1005PX
Package: linux (not installed)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-11-generic root=UUID=2ddb9538-ee18-40ec-ae85-2f28759a7486 ro quiet splash pcie_aspm=force vt.handoff=7
ProcVersionSignature: Ubuntu 2.6.38-11.50-generic 2.6.38.8
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-11-generic N/A
 linux-backports-modules-2.6.38-11-generic N/A
 linux-firmware 1.60
StagingDrivers: zram
Tags: oneiric running-unity staging
Uname: Linux 2.6.38-11-generic i686
UpgradeStatus: Upgraded to oneiric on 2011-10-15 (4 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 04/30/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0601
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 1001PX
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0601:bd04/30/2010:svnASUSTeKComputerINC.:pn1005PX:pvrx.x:rvnASUSTeKComputerINC.:rn1001PX:rvrx.xx:cvnASUSTeKComputerINC.:ct10:cvrx.x:
dmi.product.name: 1005PX
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.

Ashwin (ashwinloyal) on 2011-10-16
tags: added: brctl compat-wireless hostapd
IKT (ikt) on 2011-10-17
affects: ubuntu → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 875503

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected oneiric running-unity staging
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-12.20
Ashwin (ashwinloyal) on 2011-11-22
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: kernel-3.0.0-13
Ashwin (ashwinloyal) on 2011-12-12
tags: added: kernel-3.0.0-14
Ashwin (ashwinloyal) on 2011-12-15
tags: added: kernel-request-3.0.0-13 kernel-request-3.0.0-14
removed: kernel-3.0.0-13 kernel-3.0.0-14

Ashwin, thank you for reporting this and helping make Ubuntu better. This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please capture the oops via https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Capturing_OOPs ? As well, can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Ashwin (ashwinloyal) on 2012-04-06
Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions