[Realtek ALC268] ALSA test tone not correctly played back (regression in lucid from 2.6.32-33.72)

Bug #875300 reported by Dominic Hargreaves on 2011-10-15
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Lucid
Medium
Herton R. Krzesinski

Bug Description

No sound at all is audible on this Dell Mini 9 running linux-image-2.6.32-34-generic. Reverting to linux-image-2.6.32-33-generic fixes the problem.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: alsa-base 1.0.22.1+dfsg-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-34.77-generic 2.6.32.44+drm33.19
Uname: Linux 2.6.32-34-generic i686
NonfreeKernelModules: wl
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: dom 1565 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf0540000 irq 22'
   Mixer name : 'Realtek ALC268'
   Components : 'HDA:10ec0268,102802b0,00100101'
   Controls : 13
   Simple ctrls : 8
Date: Sat Oct 15 21:36:13 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Release i386 (20100429.4)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
SelectedCard: 0 Intel HDA-Intel - HDA Intel
SourcePackage: alsa-driver
Symptom: audio
Title: [Realtek ALC268] ALSA test tone not correctly played back
dmi.bios.date: 08/05/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A00
dmi.board.name: CN0J14
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A00
dmi.modalias: dmi:bvnDellInc.:bvrA00:bd08/05/2008:svnDellInc.:pnInspiron910:pvrA00:rvnDellInc.:rnCN0J14:rvrA00:cvnDellInc.:ct8:cvrA00:
dmi.product.name: Inspiron 910
dmi.product.version: A00
dmi.sys.vendor: Dell Inc.
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: dom 1565 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf0540000 irq 22'
   Mixer name : 'Realtek ALC268'
   Components : 'HDA:10ec0268,102802b0,00100101'
   Controls : 13
   Simple ctrls : 8
DistroRelease: Ubuntu 10.04
EcryptfsInUse: Yes
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Release i386 (20100429.4)
MachineType: Dell Inc. Inspiron 910
NonfreeKernelModules: wl
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-34-generic root=UUID=22cd9775-b2b5-426d-9873-b7fd791ad33e ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-34.77-generic 2.6.32.44+drm33.19
Regression: Yes
RelatedPackageVersions: linux-firmware 1.34.7
Reproducible: Yes
Tags: lucid ubuntu-une audio regression-update needs-upstream-testing
Uname: Linux 2.6.32-34-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 08/05/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A00
dmi.board.name: CN0J14
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A00
dmi.modalias: dmi:bvnDellInc.:bvrA00:bd08/05/2008:svnDellInc.:pnInspiron910:pvrA00:rvnDellInc.:rnCN0J14:rvrA00:cvnDellInc.:ct8:cvrA00:
dmi.product.name: Inspiron 910
dmi.product.version: A00
dmi.sys.vendor: Dell Inc.

Dominic Hargreaves (dom) wrote :

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 875300

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Julian Wiedmann (jwiedmann) wrote :

Probably caused by http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-lucid.git;a=commit;h=afcbc7ee8b6b20c0480245b829787f12964d669f . Try 'model=dell' and see if that makes it work again? https://help.ubuntu.com/community/HdaIntelSoundHowto has documentation on how to use the model parameter.

tags: added: regression-update
Dominic Hargreaves (dom) wrote :

Workaround confirmed, thanks.

Changed in linux (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Marc Deslauriers (mdeslaur) wrote :

I can confirm this regression on three mini 9's owned by myself and family that are running Lucid.

Tim Gardner (timg-tpi) wrote :

Lucid - Revert "ALSA: hda: Fix quirk for Dell Inspiron 910"

Changed in linux (Ubuntu):
status: Triaged → Invalid
Changed in linux (Ubuntu Lucid):
status: New → Fix Committed
Changed in linux (Ubuntu Lucid):
assignee: nobody → Herton R. Krzesinski (herton)
Changed in linux (Ubuntu Lucid):
importance: Undecided → Medium
Herton R. Krzesinski (herton) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-lucid' to 'verification-done-lucid'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-lucid
Dominic Hargreaves (dom) wrote :

I am no longer able to verify the fix as I've since upgraded the netbook to 11.10 (since the notification that 10.04 was no longer supported on netbooks).

Brad Figg (brad-figg) wrote :

The patch reverts a stable upstream patch that was not intended for 2.6.32 but for 2.6.38 instead. The application of this patch in 2.6.32 has caused a regression. The commit is a one line "fix" which removes a single quirk. I believe that we should accept this patch even though the original bug submitter is no longer able to verify the fix.

tags: added: verification-done-lucid
removed: verification-needed-lucid
Launchpad Janitor (janitor) wrote :
Download full text (9.7 KiB)

This bug was fixed in the package linux - 2.6.32-37.81

---------------
linux (2.6.32-37.81) lucid-proposed; urgency=low

  [Brad Figg]

  * Release Tracking Bug
    - LP: #899339

  [ Upstream Kernel Changes ]

  * (pre-stable) sparc: sigutil: Include <linux/errno.h>
    - LP: #899311

linux (2.6.32-37.80) lucid-proposed; urgency=low

  [Brad Figg]

  * Release Tracking Bug
    - LP: #898283

  [ Upstream Kernel Changes ]

  * Revert "x86, hotplug: Use mwait to offline a processor, fix the legacy
    case"
    - LP: #888042
  * Revert "usb: musb: restore INDEX register in resume path"
    - LP: #888042
  * Revert "MIPS: MTX-1: Make au1000_eth probe all PHY
    - LP: #888042
  * Revert "ALSA: hda: Fix quirk for Dell Inspiron 910"
    - LP: #875300
  * USB: ftdi_sio: add Calao reference board support
    - LP: #888042
  * USB: EHCI: Do not rely on PORT_SUSPEND to stop USB resuming in
    ehci_bus_resume().
    - LP: #888042
  * rt2x00: do not drop usb dev reference counter on suspend
    - LP: #888042
  * atm: br2684: Fix oops due to skb->dev being NULL
    - LP: #888042
  * sparc: Allow handling signals when stack is corrupted.
    - LP: #888042
  * sparc: fix array bounds error setting up PCIC NMI trap
    - LP: #888042
  * net: Fix IPv6 GSO type checks in Intel ethernet drivers
    - LP: #888042
  * ipv6: Add GSO support on forwarding path
    - LP: #888042
  * GRO: fix merging a paged skb after non-paged skbs
    - LP: #888042
  * xen-blkfront: fix data size for xenbus_gather in blkfront_connect
    - LP: #888042
  * md/linear: avoid corrupting structure while waiting for rcu_free to
    complete.
    - LP: #888042
  * powerpc/pci: Check devices status property when scanning OF tree
    - LP: #888042
  * xen: x86_32: do not enable iterrupts when returning from exception in
    interrupt context
    - LP: #888042
  * xen/smp: Warn user why they keel over - nosmp or noapic and what to use
    instead.
    - LP: #888042
  * ARM: davinci: da850 EVM: read mac address from SPI flash
    - LP: #888042
  * md: Fix handling for devices from 2TB to 4TB in 0.90 metadata.
    - LP: #888042
  * net/9p: fix client code to fail more gracefully on protocol error
    - LP: #888042
  * fs/9p: Fid is not valid after a failed clunk.
    - LP: #888042
  * net/9p: Fix the msize calculation.
    - LP: #888042
  * irda: fix smsc-ircc2 section mismatch warning
    - LP: #888042
  * qla2xxx: Correct inadvertent loop state transitions during port-update
    handling.
    - LP: #888042
  * e1000: Fix driver to be used on PA RISC C8000 workstations
    - LP: #888042
  * ASoC: Fix reporting of partial jack updates
    - LP: #888042
  * ALSA: HDA: Cirrus - fix "Surround Speaker" volume control name
    - LP: #888042
  * b43: Fix beacon problem in ad-hoc mode
    - LP: #888042
  * wireless: Reset beacon_found while updating regulatory
    - LP: #888042
  * USB: PL2303: correctly handle baudrates above 115200
    - LP: #888042
  * ASIX: Add AX88772B USB ID
    - LP: #888042
  * hvc_console: Improve tty/console put_chars handling
    - LP: #888042
  * TPM: Call tpm_transmit with correct size
    - LP: #888042
  * TPM: Zero buffer after copying to userspace
    - LP: #88804...

Read more...

Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.