Ubuntu

usb-port don't works (don't see the 3g modem and usbdisk) Lenovo x100e

Reported by Yavorovskiy Vladimir on 2011-10-13
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

 ubuntu10.10-11.04(32bit) usb-port don't works (don't see the 3g modem and usbdisk) I must few time reboot my netbook(lenovo x100e) and than netbook see 3G-modem. Usbdisk is seen but I can not write the information on the usb-disks. For the first time I thought my netboot had technical bug but when I installed windows xp on it Usb- port worked very well I like ubuntu and hope you'll kill the bugs.
  Excuse me for my not very well english.
 Vladimir
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: vladimir 1344 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xd0600000 irq 16'
   Mixer name : 'Conexant CX20582 (Pebble)'
   Components : 'HDA:14f15066,17aa21b2,00100302'
   Controls : 8
   Simple ctrls : 5
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw 6XHT36WW-1.176000'
   Mixer name : 'ThinkPad EC 6XHT36WW-1.176000'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
DistroRelease: Ubuntu 11.04
HibernationDevice: RESUME=UUID=5ba07814-97e0-4055-914b-b76733c12016
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
MachineType: LENOVO 3508W1X
Package: linux (not installed)
ProcEnviron:
 LANGUAGE=uk_UA:en
 LANG=uk_UA.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-11-generic root=UUID=658aac54-80f0-44b2-8a8f-978410ded91a ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 2.6.38-11.50-generic 2.6.38.8
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-11-generic N/A
 linux-backports-modules-2.6.38-11-generic N/A
 linux-firmware 1.52
Tags: natty
Uname: Linux 2.6.38-11-generic i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 03/12/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6XET36WW (1.20a)
dmi.board.name: INVALID
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6XET36WW(1.20a):bd03/12/2010:svnLENOVO:pn3508W1X:pvrThinkPadX100e:rvnLENOVO:rnINVALID:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 3508W1X
dmi.product.version: ThinkPad X100e
dmi.sys.vendor: LENOVO
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: vladimir 1381 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xd0600000 irq 16'
   Mixer name : 'Conexant CX20582 (Pebble)'
   Components : 'HDA:14f15066,17aa21b2,00100302'
   Controls : 8
   Simple ctrls : 5
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw 6XHT36WW-1.176000'
   Mixer name : 'ThinkPad EC 6XHT36WW-1.176000'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
DistroRelease: Ubuntu 11.04
HibernationDevice: RESUME=UUID=5ba07814-97e0-4055-914b-b76733c12016
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
MachineType: LENOVO 3508W1X
Package: linux (not installed)
ProcEnviron:
 LANGUAGE=uk_UA:en
 PATH=(custom, no user)
 LANG=uk_UA.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-12-generic root=UUID=658aac54-80f0-44b2-8a8f-978410ded91a ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 2.6.38-12.51-generic 2.6.38.8
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-12-generic N/A
 linux-backports-modules-2.6.38-12-generic N/A
 linux-firmware 1.52
Tags: natty
Uname: Linux 2.6.38-12-generic i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 03/12/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6XET36WW (1.20a)
dmi.board.name: INVALID
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6XET36WW(1.20a):bd03/12/2010:svnLENOVO:pn3508W1X:pvrThinkPadX100e:rvnLENOVO:rnINVALID:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 3508W1X
dmi.product.version: ThinkPad X100e
dmi.sys.vendor: LENOVO

affects: ubuntu → linux (Ubuntu)
summary: - usb-port don't works (don't see the 3g modem and usbdisk)
+ usb-port don't works (don't see the 3g modem and usbdisk) Lenovo x100e

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 873656

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected natty
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Yavorovskiy Vladimir (yavd111) wrote :

I has changed the status of the bug to 'Confirmed', please help me correct this bug.
  Vladimir

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the release candidate kernel versus the daily build. Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

tags: added: needs-upstream-testing

From 'lsusb', there is not usb 3g modem device at all, could you
make sure there is one usb 3g modem device in your laptop?

Also there is no usb disk device from 'lsusb', and there is only
one usb card reader. And of course, you need to plug one sd/mmc
card into the slot, then you may access the data on the card.

So either the report is incomplete, or it is not a bug.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete

apport information

description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Hi Yavorovskiy Vladimir,

Now I can find the issue from dmesg[1] in your CurrentDmesg.txt.

It is probably caused by power over-consumption of your 3g modem
and usb disk. The two devices are different interfaces inside a same usb
configuration.

If the modem and usb disk have their own power supply, please try to
plug the power supply to see if there is still the issue.

If the power supply still don't help the issue, please first enable usbmon[2] to
start tracing the traffic, then plug your 3g modem plus usb disk. Finally, post
the usbmon result to us.

[1],
[ 48.864560] ehci_hcd 0000:00:12.2: force halt; handshake f805c424
00004000 00000000 -> -110
[ 48.864560] ehci_hcd 0000:00:12.2: HC died; cleaning up
[ 48.865256] usb 1-1: USB disconnect, address 3
[ 48.865623] qcaux ttyUSB0: qcaux converter now disconnected from ttyUSB0
[ 48.865639] qcaux 1-1:1.2: device disconnected

[2], usbmon guide
- Documentation/usb/usbmon.txt inside linux kernel source code
or
- http://www.mjmwired.net/kernel/Documentation/usb/usbmon.txt

thanks,
--
Ming Lei

Ming Lei (tom-leiming) wrote :

Hi Yavorovskiy Vladimir,

Looks like there is a periodic schedule bug inside the ATI ehci controller.

I have built kernel packages inside the link[1] with a work around for the issue, could you
install the 3 packages to see if your issue can be fixed?

[1], http://kernel.ubuntu.com/~ming/bugs/873656/

thanks,
--
Ming Lei

Ming Lei (tom-leiming) wrote :

Looks like same issue is still on upstream kernel, see below
http://marc.info/?t=132009845400002&r=1&w=2

Changed in linux (Ubuntu):
status: Incomplete → Triaged
tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing
Jungle Boy (mowgli80) wrote :

Having same USB issues on precise beta kernel which does not allow me to install (USB read errors). Can easily reproduce the handshake "force halt" error by dd if=/dev/sdb of=/dev/null bs=1M every time as well. I am having AMD E350 based laptop. The last kernel to somewhat work for me was 3.0.0.7 from natty beta, which allows reads and worked for small amount of writes but corrupts the drive for large amount of writes.

Yavorovskiy Vladimir, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.12.1

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: bios-outdated-1.36 needs-upstream-testing regression-potential
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Triaged → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.