internal speakers do not work on MacBook Pro

Bug #87253 reported by Matt Galvin
8
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Colin Ian King
linux-source-2.6.20 (Ubuntu)
Medium
Daniel T Chen

Bug Description

internal speakers do not work on MacBook Pro although the headphone jack does work.

Revision history for this message
Andrew Ash (ash211) wrote :

Thanks for taking the time to report this bug. Unfortunately we can't fix it, because your description didn't include enough information.

Please include the information requested from https://help.ubuntu.com/community/DebuggingSoundProblems as separate attachments.

Changed in alsa-driver:
assignee: nobody → ash211
status: Unconfirmed → Needs Info
Revision history for this message
Matt Galvin (mgalvin) wrote :
Revision history for this message
Matt Galvin (mgalvin) wrote :
Revision history for this message
Matt Galvin (mgalvin) wrote :
Revision history for this message
Matt Galvin (mgalvin) wrote :
Revision history for this message
Matt Galvin (mgalvin) wrote :
Revision history for this message
Matt Galvin (mgalvin) wrote :
Revision history for this message
Matt Galvin (mgalvin) wrote :

I have already un-muted everything and turned the volume all the way up. no sound from internal speakers. headphone jack works fine.

Revision history for this message
AJ Slater (aj-slater) wrote :

Volume Applet->Open Volume Control->Switches: Line in as Output = checked.

Works with Edgy and hda_intel Alsa Drivers 1.0.13 and above on MacBook Pro 15"

Revision history for this message
Matt Galvin (mgalvin) wrote :

thanks for the tip but sadly this did not work for me on this machine.

Revision history for this message
Daniel T Chen (crimsun) wrote :

The requisite patch[0] has been merged already, but it is not available in a default feisty kernel yet.

[0] http://hera.kernel.org/git/?p=linux/kernel/git/bcollins/ubuntu-2.6.git;a=commitdiff;h=2fadead62fc6222b10799bd8cb134cfb6a79171f

Changed in alsa-driver:
assignee: ash211 → crimsun
status: Needs Info → Fix Committed
Revision history for this message
Matthew Garrett (mjg59) wrote :

This code doesn't quite appear to work - there's still no sound from the internal speakers. I've attached a patch from alsa-devel which makes things better, though I'm not sure if it's entirely correct. This provides two useful control channels, headphone and speakers, which are independently controllable.

Changed in alsa-driver:
status: Fix Committed → In Progress
Revision history for this message
Matthew Garrett (mjg59) wrote :

The patch

Revision history for this message
Anthony Mercatante (tonio) wrote :

I just tested that patch and that's way better, since there is no channel to unmute in alsamixer to get sound, and now headphone and speaker level are independantly configurable.

Revision history for this message
Anthony Mercatante (tonio) wrote :

Here is a screenshot showing the improvements with that patch.
1/ no more channel to unmute to get sound working.
2/ speakers level is now seen as "speaker" which makes sense.
3/ headphone and speakers level are independantly configurable.

I'm using this and making tests for 3 days now, and I didn't notice any issue.

Revision history for this message
Anthony Mercatante (tonio) wrote :

As the patch only works for new gen macbooks, here is the content of my /proc/asound/card0/codec#0.

Revision history for this message
Daniel T Chen (crimsun) wrote :

Mangled and pushed to Ben.

Changed in alsa-driver:
importance: Undecided → Low
status: In Progress → Fix Committed
Changed in linux-source-2.6.20:
status: Fix Committed → Fix Released
Revision history for this message
Anthony Mercatante (tonio) wrote :

Reopened as the issue is still present.
The patch was removed during gutsy dev cycle.

Changed in linux-source-2.6.20:
importance: Low → Medium
milestone: none → ubuntu-8.04
status: Fix Released → New
Revision history for this message
Anthony Mercatante (tonio) wrote :

Here is a rewritten patch to work against 2.6.24 branch

Changed in linux:
milestone: ubuntu-8.04 → none
status: New → Fix Released
Changed in linux-source-2.6.24:
importance: Undecided → Medium
milestone: none → ubuntu-8.04
Changed in linux:
assignee: nobody → ubuntu-kernel-team
status: New → Triaged
Changed in linux:
assignee: ubuntu-kernel-team → colin-king
status: Triaged → In Progress
Revision history for this message
Colin Ian King (colin-king) wrote :

Thank you Anthony for the patch - this fix is now committed.

Changed in linux:
status: In Progress → Fix Committed
Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Fix should be available in the latest 2.6.24-12 release. Thanks.

Changed in linux:
status: Fix Committed → Fix Released
Revision history for this message
fejes (anthony-fejes) wrote :

Is this regressed - I currently have this problem with a macbook pro 6,2 running kubuntu 10.10 (Maverick) kernel 2.6.35-24

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers