Ubuntu

"unable to enumerate USB device" with BeagleBoard-xM

Reported by Robert Pollak on 2011-10-10
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned
linux-ti-omap (Ubuntu)
Undecided
Unassigned

Bug Description

When booting my BeagleBoard-xM rev C with the http://cdimage.ubuntu.com/daily-preinstalled/current/oneiric-preinstalled-desktop-armel+omap.img.gz (from 2011-10-06), no USB devices (keyboard, mouse, LAN) work.

Therefore I am stuck at the OEM install's language selection screen.

/var/log/dmesg says: hub 1-0:1.0: unable to enumerate USB device on port 2

The attached dmesg is from a boot without mouse and LAN cable.

Robert Pollak (robert-pollak) wrote :
Robert Pollak (robert-pollak) wrote :

Using a powered hub, as e.g. described here http://groups.google.com/group/beagleboard/browse_thread/thread/b4944d13d93b07f4, also does not help.

Oliver Grawert (ogra) wrote :

i would rather suspect x-loader or u-boot to be at fault ... someon from linaro should look at it.
the linux-ti-omap package doesnt exist anymore, the omap3 kernel comes from the linux packagage.

Changed in linux-ti-omap (Ubuntu):
status: New → Invalid
Changed in linux (Ubuntu):
importance: Undecided → High

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 871650

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: oneiric
Robert Pollak (robert-pollak) wrote :

No way for user input, so setting to 'Confirmed' as requested.

I will provide additional logs, if necessary.

Btw., this is not a power supply problem, since keyboard, mouse and LAN work fine when booting Ångström Linux.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-12.20
Robert Pollak (robert-pollak) wrote :

Here is the dmesg from the first boot of the current daily build (dated 2011-10-09). The bug is still present.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Robert Pollak (robert-pollak) wrote :

Btw, our second BeagleBoard-xM rev C shows the same problem.

Paolo Pisati (p-pisati) wrote :

substitute the x-loader/u-boot files present on mmcblk0p1 with these one:

http://people.canonical.com/~ppisati/natty_bootloaders/

does it help?

Robert Pollak (robert-pollak) wrote :

Paolo: No, with these files it does not boot at all: even the serial console stays empty.

Robert Pollak (robert-pollak) wrote :

Should I try a netboot image installation instead (with http://ports.ubuntu.com/ubuntu-ports/dists/oneiric/main/installer-armel/current/images/omap/netboot/), or will this make no difference?

Ricardo Salveti (rsalveti) wrote :

John, now that you also got a Beagle xM rev C, can you check if you're able to reproduce this issue with either Ubuntu's or Linaro's kernel?

Robert, there's a chance that u-boot might also be the culprit, so can you also check using natty's x-loader and u-boot? Just grab both MLO and u-boot.bin from the x-loader and u-boot-linaro packages for omap4 and try to boot your board with them.

> Robert, there's a chance that u-boot might also be the culprit, so can
> you also check using natty's x-loader and u-boot?

Isn't that what I already did on Paolo's suggestion, see comments 9 and 10?

> Just grab both MLO and u-boot.bin from the x-loader and u-boot-linaro
> packages for omap4 and try to boot your board with them.

Ricardo, you surely meant omap3?
And since I am an ARM newbie, I have to ask: Where can I get those files?

In launchpad I found
https://launchpad.net/ubuntu/+archive/primary/+files/x-loader-omap3-beagle_1.5.0%2Bgit20110325%2Bb6bbfe7-1ubuntu1_armel.deb
via https://launchpad.net/ubuntu/+source/x-loader,
and https://launchpad.net/ubuntu/+archive/primary/+files/u-boot-linaro-omap3-beagle_2011.04.2-0ubuntu1_armel.deb
via https://launchpad.net/ubuntu/+source/u-boot-linaro.
Are these what I need?

Or should I try something from the "Linaro Overlay PPA"
https://launchpad.net/~linaro-maintainers/+archive/overlay ?

Ricardo Salveti (rsalveti) wrote :

On Mon, Oct 17, 2011 at 5:29 AM, Robert Pollak <email address hidden> wrote:
>> Robert, there's a chance that u-boot might also be the culprit, so can
>> you also check using natty's x-loader and u-boot?
>
> Isn't that what I already did on Paolo's suggestion, see comments 9 and
> 10?

Could be, don't know which ones he copied for you, but it should
probably be from natty.

>> Just grab both MLO and u-boot.bin from the x-loader and u-boot-linaro
>> packages for omap4 and try to boot your board with them.
>
> Ricardo, you surely meant omap3?

Yeah, sorry, my brain was confused by the time I commented at this bug :-)

> And since I am an ARM newbie, I have to ask: Where can I get those files?
>
> In launchpad I found
> https://launchpad.net/ubuntu/+archive/primary/+files/x-loader-omap3-beagle_1.5.0%2Bgit20110325%2Bb6bbfe7-1ubuntu1_armel.deb
> via https://launchpad.net/ubuntu/+source/x-loader,
> and https://launchpad.net/ubuntu/+archive/primary/+files/u-boot-linaro-omap3-beagle_2011.04.2-0ubuntu1_armel.deb
> via https://launchpad.net/ubuntu/+source/u-boot-linaro.

Exactly, if you run 'dpkg -X <package> .' you should have the files
you need, like:
./usr/lib/u-boot/omap3_beagle/u-boot.bin
and
./usr/lib/x-loader/omap3530beagle/MLO

In case you're not able to get anything from your serial, as you
reported with paolo's binaries, you may need to recreate your first
partition filesystem.

For that just mount it at your host, copy all the files from the first
partition, create a new vfat fs (mkfs.vfat -F 32 /dev/sdX1), mount it
again and copy all the files back, copying the MLO first.

Please give it a try and let me know if it works for you.

Robert Pollak (robert-pollak) wrote :

> copying the MLO first.

Ah. Maybe Paolo's files did not work because I just replaced MLO? At that time I did not know that MLO has to be on the first sector of the SD card (as mentioned here: http://groups.google.com/group/beagleboard/browse_thread/thread/33e7b0fd61a313f0).

Testing ...

Robert Pollak (robert-pollak) wrote :

Using Oneiric [1] with Natty's MLO and u-boot.bin (as listed in comment 14), I still see the bug.
 (When these two files are added I additionally get a display error: wrong reddish colors and a seemingly low color depth.)
I have attached oneiric+natty.log in case I did something wrong.

[1] http://cdimage.ubuntu.com/releases/11.10/release/ubuntu-11.10-preinstalled-desktop-armel+omap.img.gz

Do I have to replace the two files before the partition gets expanded, i.e. before the first boot? I did it afterwards, because I also wanted to test the unmodified Oneiric release (which unexpectedly still showed the bug).

Since it was suggested that Natty should work, I have now tested it [2], as described in https://wiki.ubuntu.com/ARM/OmapNetbook (with the kernel update that is mentioned there). This also shows the bug! (and the above-mentioned color error)

[2] http://cdimage.ubuntu.com/releases/11.04/release/ubuntu-11.04-preinstalled-netbook-armel+omap.img.gz

Robert Pollak (robert-pollak) wrote :

"unexpectedly" -> "as expected" (re: unmodified Oneiric release showing the bug)

Robert Pollak (robert-pollak) wrote :

I have now successfully installed Oneiric via Robert Nelson's http://elinux.org/BeagleBoardUbuntu#Method_2:_Use_the_NetInstall_method as workaround.

Robert Pollak (robert-pollak) wrote :

For the record:

On 2011-10-24, John Rigby from Linaro told me after testing a Rev C board:
> The latest linaro image works fine for me today:
>
> hwpack_linaro-omap3_20111023-0_armel_supported.tar.gz
> nano-n-tar-20111023-0.tar.gz

I will probably not get around testing those soon.

I don't know what John's result means for Oneiric or Precise.

Paolo Pisati (p-pisati) wrote :

Nice to know, i'm waiting for a rev c board to arrive here, after that i'll be able to test and see what's wrong with our setup.

tags: added: iso-testing
neels (neels) wrote :
Download full text (9.3 KiB)

bump, still no USB nor ethernet on neither 11.04 nor 11.10 on my beagleboard xM Rev C.
I tried the newest MLO and u-boot.img from wget http://www.angstrom-distribution.org/demo/beagleboard/ (20-Jan-2012 13:48) without noticeable change.

There is but one error message that repeats:
[ 3.254364] hub 1-0:1.0: unable to enumerate USB device on port 2

lsusb shows only two USB hubs.
But there are numerous messages about USB that look successful...

[[[

[ 0.092712] libata version 3.00 loaded.
[ 0.093048] usbcore: registered new interface driver usbfs
[ 0.093109] usbcore: registered new interface driver hub
[ 0.093261] usbcore: registered new device driver usb
[ 0.093872] omap_i2c omap_i2c.1: bus 1 rev4.0 at 2600 kHz
[ 0.096374] twl4030: PIH (irq 7) chaining IRQs 368..375
[ 0.096405] twl4030: power (irq 373) chaining IRQs 376..383
[ 0.096832] twl4030: gpio (irq 368) chaining IRQs 384..401
[ 0.099090] print_constraints: VUSB1V5: 1500 mV normal standby
[ 0.099487] print_constraints: VUSB1V8: 1800 mV normal standby
[ 0.099822] print_constraints: VUSB3V1: 3100 mV normal standby
[ 0.101593] twl4030_usb twl4030_usb: Initialized TWL4030 USB module
[ 0.102325] print_constraints: VMMC1: 1850 <--> 3150 mV at 3150 mV normal standby
[ 0.102722] print_constraints: VDAC: 1800 mV normal standby
[ 0.103118] print_constraints: VPLL2: 1800 mV normal standby
[ 0.103546] print_constraints: VSIM: 1800 <--> 3000 mV at 1800 mV normal standby
[ 0.103851] omap_i2c omap_i2c.3: bus 3 rev4.0 at 100 kHz
[ 0.104736] Advanced Linux Sound Architecture Driver Version 1.0.24.
[ 0.105346] NetLabel: Initializing
[ 0.105346] NetLabel: domain hash size = 128
[ 0.105377] NetLabel: protocols = UNLABELED CIPSOv4
[ 0.105438] NetLabel: unlabeled traffic allowed by default
[ 0.105804] Switching to clocksource 32k_counter
[ 0.111999] Switched to NOHz mode on CPU #0
[ 0.115325] AppArmor: AppArmor Filesystem Enabled
[ 0.125396] musb-hdrc: version 6.0, musb-dma, otg (peripheral+host)
[ 0.125518] omap_device: musb-omap2430.-1: new worst case activate latency 0: 30517
[ 0.125579] omap_device: omap_i2c.1: new worst case activate latency 0: 30517
[ 0.126251] omap_device: omap_i2c.1: new worst case deactivate latency 0: 30517
[ 0.128356] musb-hdrc: ConfigData=0xde (UTMI-8, dyn FIFOs, bulk combine, bulk split, HB-ISO Rx, HB-ISO Tx, SoftConn)
[ 0.128387] musb-hdrc: MHDRC RTL version 1.800
[ 0.128387] musb-hdrc: setup fifo_mode 4
[ 0.128417] musb-hdrc: 28/31 max ep, 16384/16384 memory
[ 0.128601] musb-hdrc musb-hdrc: USB OTG mode controller at fa0ab000 using DMA, IRQ 92
[ 0.129119] NET: Registered protocol family 2
[ 0.129455] IP route cache hash table entries: 4096 (order: 2, 16384 bytes)
[ 0.130218] TCP established hash table entries: 16384 (order: 5, 131072 bytes)
[ 0.130584] TCP bind hash table entries: 16384 (order: 4, 65536 bytes)
[ 0.130798] TCP: Hash tables configured (established 16384 bind 16384)
[ 0.130798] TCP reno registered
[ 0.130828] UDP hash table entries: 256 (order: 0, 4096 bytes)
[ 0.130828] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[ 0...

Read more...

neels (neels) wrote :

FYI, this linaro nano image works right away:
http://releases.linaro.org/images/11.12/oneiric/nano/beagle-nano.img.gz

That's apparently also Oneiric, and it works like a charm, right away, and made my day. So if someone looked through the differences between this linaro image and Ubuntu's own 11.10 omap image, that should yield success squashing this bug, I guess.

Paolo Pisati (p-pisati) wrote :

@neels: please try one of the kernels posted here:

http://bugs.launchpad.net/bugs/912199

it fixes the usb problem and will be part of the next update.

Oliver Grawert (ogra) on 2012-06-19
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers