[Inspiron 1545] Bluetooth does not work with 12.04

Bug #870779 reported by Jeff Lane on 2011-10-08
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

This came in via Answers and I've converted it to a bug.

The short of the story is that the user has a Dell Inspiron 1545. He got a replacement motherboard from Dell that has a different bluetooth adapter than what was originally in the machine, and that bluetooth adapter does not work with Ubuntu. I did a little digging, and the adapter he DOES have is shown to be certified in some Lenovo and HP systems, but no Dells that I could find. So I know the component has been marked as working at least, but it's not working for this user.

Here's the full discussion: https://answers.launchpad.net/ubuntu-certification/+question/173582

Jeff Lane (bladernr) wrote :
Download full text (4.1 KiB)

This is the original discussion we had via Answers, I'm putting it in here for context...
#1
Hi, what do you mean by Bluetooth is not working? Can you be more descriptive?

Can you provide the output of the lsusb command?

I did some digging and that bluetooth card has been tested and is known to work in a few different Dell laptops from Ubuntu 9.10 to Ubuntu 11.04.

#2
On 8 October 2011 03:05, Jeff Lane <email address hidden>wrote:

[...]
Hi Jeff,
Bluetooth icon is disabled always. When i tried to switch on, it get grayed.

The following is the result of lsusb.

Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 004: ID 413c:8162 Dell Computer Corp.
Bus 003 Device 003: ID 413c:8161 Dell Computer Corp.
Bus 003 Device 002: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part
of BCM2046 Bluetooth)
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 0c45:63ee Microdia
Bus 001 Device 003: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0
multicard reader
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

#3
Interesting... you have a completely different bluetooth adapter.

The one we have in the certified system is:

Dell Computer Corporation: Wireless 365 Bluetooth with a PCIID of 413c:8160

The one you have is this:

0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)

That one is only known to work in a couple of Lenovo and HP systems, but no Dells.

Is this a newer model 1545? How long have you had it? And is this the original bluetooth device, or have you replaced it with a bluetooth dongle?

#4
Jeff,
Am using this system for the past two years.
I didn't replaced the bluetooth module.
Is there any other way to activate this?

#5
Jeff,
Once i faced some problem with LCD.
By that time, dell replaced my motherboard with new one.

#6
Yeah, that makes a difference. Essentially, you have a different version of the 1545 than what was originally certified.

Often, an OEM will make changes to a system during its lifetime, and sell what is basically a completely different computer with the same model name. I think that's what's happened here. When you had your LCD problem and they replaced the motherboard, you got a new or field replaceable motherboard with probably totally different components.

Here's what we CAN do, as there's not much more to do via this venue, which is for feedback.

1: I'm going to convert this to a bug. This will help us sort this out, because while the 1545 you have is not a certified model, the bluetooth adapter you have IS on other certified machines, so there may be a chance someone can solve this there.

2: go to forums.ubuntu.com and ask this there as well, and provide a link to the bug report I open. There may well be someone in the Ubuntu community that has this same version of the 1545 or at leas...

Read more...

Changed in ubuntu-certification:
status: New → Confirmed
affects: ubuntu-certification → linux
Changed in linux:
status: Confirmed → New
Jeff Lane (bladernr) wrote :

Changed this to the kernel as this is seems to be a driver issue with bluetooth, not a certification issue.

Jeff,
Thanks a lot for considering this problem and trying to bring out a
solution.

On 8 October 2011 23:57, Jeff Lane <email address hidden> wrote:

> ** Also affects: ubuntu-certification
> Importance: Undecided
> Status: New
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/870779
>
> Title:
> [Inspiron 1545] Bluetooth does not work with 11.04
>
> Status in The Linux Kernel:
> New
> Status in Ubuntu Certification Programme:
> New
>
> Bug description:
> This came in via Answers and I've converted it to a bug.
>
> The short of the story is that the user has a Dell Inspiron 1545. He
> got a replacement motherboard from Dell that has a different bluetooth
> adapter than what was originally in the machine, and that bluetooth
> adapter does not work with Ubuntu. I did a little digging, and the
> adapter he DOES have is shown to be certified in some Lenovo and HP
> systems, but no Dells that I could find. So I know the component has
> been marked as working at least, but it's not working for this user.
>
> Here's the full discussion: https://answers.launchpad.net/ubuntu-
> certification/+question/173582
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linux/+bug/870779/+subscriptions
>

--
Thanks & regards.,
DEEPAN CHAKKARAVARTHY
97 86 44 71 11

Hi. I have the same problem. Same Notebook, same Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth). with the brand new Oneiric. I can say I had this problem with Ubuntu 11.04 and now, again, with Ubuntu 11.10. But I don't remember very well if it was also prior to 11.04; probably not. If there is anything I can do. Thanks.

I also have this issue. I recall the bluetooth working just fine with 11.04, but for 11.10 it just stopped working (it was a clean install.)

Bus 003 Device 005: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)

Jeff Lane (bladernr) wrote :

Nothing ever happened with it an no new reports of issues with later releases.

Changed in ubuntu-certification:
status: New → Invalid
no longer affects: linux

This bug is "valid" and its a hardware issue. Dell lattest Bluetooth DFU make the hardware unresponsible over Linux. The fix for this issue is update DFU with USBID 8103 of DFU from old windows xp driver.

1) Download the file from http://www.dell.com/support/drivers/us/en/brdhs1/driverdetails?driverid=XRCFG
2) Extract it from Download folder

leonardo@leonardo-Vostro1310:~$ unzip ~/Downloads/Dell_Wireless-360-Module-wit_A01_R155592.exe

3) update dfu from the file inside the folder

leonardo@leonardo-Vostro1310:~$ sudo dfutool upgrade XP64/DFU/Dell_413c_8103.dfu

4) Reboot. Bluetooth will start with the BT Led on. Attempt to pair/connect are sucessfull.

This happens after Vista driver updates the DFU. Searching in the Net, notebooks not used with windows does not manifest this issue.

Any atempt to reset the BT does not work until i've updated the DFU with this version. This driver have DFU for differents USBIDs but this ID worked for Vostro 1310.

Changing back to confirmed to see what Ubuntu devels will think about this.

Changed in ubuntu-certification:
status: Invalid → Confirmed
summary: - [Inspiron 1545] Bluetooth does not work with 11.04
+ [Inspiron 1545] Bluetooth does not work with 12.04
Daniel Manrique (roadmr) wrote :

I'm moving this to linux, where it stands a better chance of being looked at. If the bluetooth adapter was changed, then its certification status no longer applies, unfortunately.

affects: ubuntu-certification → linux
affects: linux → linux (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions