Ubuntu

Brightness unchangeable via keyboard or brightness applet Acer Aspire 5750-9668

Reported by Christopher M. Penalver on 2011-09-30
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Low
linux (Ubuntu)
Low
Unassigned

Bug Description

1) lsb_release -rd
Description: Ubuntu precise (development branch)
Release: 12.04

lsb_release -rd
Description: Ubuntu oneiric (development branch)
Release: 11.10

2) uname -a
Linux monikerpc 3.4.0-030400rc1-generic #201203312035 SMP Sun Apr 1 00:43:10 UTC 2012 i686 i686 i386 GNU/Linux

apt-cache policy xfce4-power-manager-plugins
xfce4-power-manager-plugins:
  Installed: 1.0.10-4
  Candidate: 1.0.10-4
  Version table:
 *** 1.0.10-4 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/universe i386 Packages
        100 /var/lib/dpkg/status

uname -a
Linux monikerpc 3.0.0-12-generic-pae #20-Ubuntu SMP Fri Oct 7 16:37:17 UTC 2011 i686 i686 i386 GNU/Linux

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2-rc4-oneiric/
uname -r 3.2.0-030200rc4-generic

 apt-cache policy xfce4-power-manager-plugins
xfce4-power-manager-plugins:
  Installed: 1.0.11-0ubuntu1
  Candidate: 1.0.11-0ubuntu1
  Version table:
 *** 1.0.11-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/universe i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen when one presses the Fn key and the Left or Right arrow, the brightness goes up or down respectively.

4) What happens is the brightness does not change and remains at 100% no matter what.

WORKAROUND: Changing /etc/default/grub from:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

save, sudo update-grub then restarting allowed brightness applet or keyboard Fn and Right or Left to change brightness.

Following the debug info at:https://wiki.ubuntu.com/Kernel/Debugging/Backlight

this issue falls into the "Backlight control does not work, but there are entries in /sys/class/backlight" category.

lsmod | grep thinkpad_acpi

does not yield any information.

No such path as: /proc/acpi/video

Following: https://wiki.ubuntu.com/BIOSandUbuntu#Buggy%20DSDT

sudo acpidump -o acpidump.txt && acpixtract acpidump.txt
Acpi table [DSDT] - 36436 bytes written to DSDT.dat
Acpi table [SSDT] - 3010 bytes written to SSDT1.dat
Acpi table [SSDT] - 2316 bytes written to SSDT2.dat
Acpi table [SSDT] - 2454 bytes written to SSDT3.dat

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/863156/+attachment/2490437/+files/acpixtract.zip

iasl -d DSDT.dat

Intel ACPI Component Architecture
AML Disassembler version 20100528 [Oct 15 2010]
Copyright (c) 2000 - 2010 Intel Corporation
Supports ACPI Specification Revision 4.0a

Loading Acpi table from file DSDT.dat
Acpi table [DSDT] successfully installed and loaded
Pass 1 parse of [DSDT]
Pass 2 parse of [DSDT]
Parsing Deferred Opcodes (Methods/Buffers/Packages/Regions)
...............................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
Parsing completed

Found 5 external control methods, reparsing with new information
Pass 1 parse of [DSDT]
Pass 2 parse of [DSDT]
Parsing Deferred Opcodes (Methods/Buffers/Packages/Regions)
...............................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
Parsing completed
Disassembly completed, written to "DSDT.dsl"
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/863156/+attachment/2528912/+files/DSDT.dsl

sudo fwts
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/863156/+attachment/2490447/+files/results.log

sudo fwts method
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/863156/+attachment/2490450/+files/results.log

Changing the "xfce4-brightness-plugin 1.0.10" to half way down goes from:

/sys/class/backlight/intel_backlight$ grep . /sys/class/backlight/acpi_video0/*
/sys/class/backlight/acpi_video0/actual_brightness:9
/sys/class/backlight/acpi_video0/bl_power:0
/sys/class/backlight/acpi_video0/brightness:9
/sys/class/backlight/acpi_video0/max_brightness:9
/sys/class/backlight/acpi_video0/type:firmware

to:

/sys/class/backlight/intel_backlight$ grep . /sys/class/backlight/acpi_video0/*
/sys/class/backlight/acpi_video0/actual_brightness:5
/sys/class/backlight/acpi_video0/bl_power:0
/sys/class/backlight/acpi_video0/brightness:5
/sys/class/backlight/acpi_video0/max_brightness:9
/sys/class/backlight/acpi_video0/type:firmware

Clicking on keyboard Fn and Left arrow together once goes from:

/sys/class/backlight/intel_backlight$ grep . /sys/class/backlight/acpi_video0/*
/sys/class/backlight/acpi_video0/actual_brightness:9
/sys/class/backlight/acpi_video0/bl_power:0
/sys/class/backlight/acpi_video0/brightness:9
/sys/class/backlight/acpi_video0/max_brightness:9
/sys/class/backlight/acpi_video0/type:firmware

to:

grep . /sys/class/backlight/acpi_video0/*
/sys/class/backlight/acpi_video0/actual_brightness:7
/sys/class/backlight/acpi_video0/bl_power:0
/sys/class/backlight/acpi_video0/brightness:7
/sys/class/backlight/acpi_video0/max_brightness:9
/sys/class/backlight/acpi_video0/type:firmware

dmesg|grep 'ACPI: Video'
[ 4.181103] ACPI: Video Device [GFX0] (multi-head: yes rom: no post: no)

lspci |grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: linux-image-3.0.0-12-generic-pae 3.0.0-12.19
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic-pae 3.0.4
Uname: Linux 3.0.0-12-generic-pae i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu2
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: moniker 1750 F.... xfce4-volumed
                      moniker 1798 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xc0700000 irq 50'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:10ec0269,10250504,00100100 HDA:80862805,80860101,00100000'
   Controls : 20
   Simple ctrls : 11
Date: Fri Sep 30 06:05:13 2011
EcryptfsInUse: Yes
InstallationMedia: Xubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110921.3)
MachineType: Acer Aspire 5750
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic-pae root=UUID=af001e50-f2b3-44af-a197-164b20aa8c44 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-12-generic-pae N/A
 linux-backports-modules-3.0.0-12-generic-pae N/A
 linux-firmware 1.60
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/11/2011
dmi.bios.vendor: Acer
dmi.bios.version: V1.05
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: JE50_HR
dmi.board.vendor: Acer
dmi.board.version: Base Board Version
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: V1.05
dmi.modalias: dmi:bvnAcer:bvrV1.05:bd02/11/2011:svnAcer:pnAspire5750:pvrV1.05:rvnAcer:rnJE50_HR:rvrBaseBoardVersion:cvnAcer:ct10:cvrV1.05:
dmi.product.name: Aspire 5750
dmi.product.version: V1.05
dmi.sys.vendor: Acer

Brad Figg (brad-figg) on 2011-09-30
Changed in linux (Ubuntu):
status: New → Confirmed

Marking to Low as this issue has more than enough information to demonstrate a bug but the root cause is to be determined.

description: updated
Changed in linux (Ubuntu):
importance: Undecided → Low
summary: - Brightness unchangable Acer Aspire 5750-9668
+ Brightness unchangeable via keyboard or brightness applet Acer Aspire
+ 5750-9668
description: updated
tags: added: hw-specific kernel-acpi
description: updated

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-12.20
description: updated
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: removed: kernel-request-3.0.0-12.20
Brad Figg (brad-figg) on 2011-10-08
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-12.20
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
description: updated
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

tags: added: needs-upstream-testing

Joseph Salisbury (jsalisbury), the test was inconclusive for kernel 3.1.0-999_3.1.0-999.201110040905 as the moment it booted up the kernel backtraced and I was unable load up Xubuntu.

tags: removed: needs-upstream-testing
Joseph Salisbury (jsalisbury) wrote :

@Christopher,

The 3.1.0-999_3.1.0-999.201110040905 kernel is considered the "Tip of the tree". The tip of the tree is a moving target and harder to determine what has actually been tested.

The release candidates are generally much more stable. Would it be possible for you to try the kernel at:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.1-rc9-oneiric/

Joseph Salisbury (jsalisbury), http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.1-rc9-oneiric/ also backtraced.

Bug reproducible in mainline kernel:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2-rc4-oneiric/
uname -r 3.2.0-030200rc4-generic

linux (Ubuntu) -> Triaged

description: updated
tags: removed: kernel-request-3.0.0-12.20
Changed in linux (Ubuntu):
status: Confirmed → Triaged
Changed in linux:
importance: Unknown → Low
status: Unknown → Incomplete
description: updated
tags: added: bot-stop-nagging precise
description: updated
tags: added: acpi bios
Jason Stephens (ionix-s) wrote :

I'm also affected by this bug on my Acer Aspire 5742G-6426

Jason Stephens, please execute the following via the Terminal and feel free to subscribe me to it:
ubuntu-bug linux

Thanks!

Changed in linux:
status: Incomplete → Fix Released
Changed in linux (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.