Laptop testing tracker-Suspend/Resume smoke test Case ID: snr-001/snr-002

Bug #862751 reported by Mark Nighswonger on 2011-09-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

snr-001 Laptop suspends then has to be powered off and back on. snr-002 Laptop always fails to suspend on first test. Subsequent tests pass but the program does not sense that the laptop has suspended and reports a failure to suspend. Once into the hands off portion of countdown delayed testing, at some point the machine suspends into the same state as snr-001 and has to be rebooted which ends the testing sequence. It also does not initiate an apport case automatically. snr-003 There is no hibernation option in the drop down menu.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: linux-image-3.0.0-12-generic 3.0.0-12.19
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC272X Analog [ALC272X Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 1.23-0ubuntu2
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC272X Analog [ALC272X Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: mark 1471 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0x98200000 irq 45'
   Mixer name : 'Realtek ALC272X'
   Components : 'HDA:10ec0272,10250349,00100001'
   Controls : 17
   Simple ctrls : 10
Date: Thu Sep 29 16:15:32 2011
HibernationDevice: RESUME=UUID=bac5372a-4884-43bc-a221-742a64931aa1
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110831)
MachineType: Acer AO532h
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=5b8e5fce-9408-4392-9391-ab307a751a34 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-12-generic N/A
 linux-backports-modules-3.0.0-12-generic N/A
 linux-firmware 1.60
SourcePackage: linux
UpgradeStatus: Upgraded to oneiric on 2011-09-25 (4 days ago)
dmi.bios.date: 04/28/2011
dmi.bios.vendor: Acer
dmi.bios.version: V1.26
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: AO532h
dmi.board.vendor: Acer
dmi.board.version: V1.26
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: V1.26
dmi.modalias: dmi:bvnAcer:bvrV1.26:bd04/28/2011:svnAcer:pnAO532h:pvrV1.26:rvnAcer:rnAO532h:rvrV1.26:cvnAcer:ct10:cvrV1.26:
dmi.product.name: AO532h
dmi.product.version: V1.26
dmi.sys.vendor: Acer

Mark Nighswonger (marknigh) wrote :
Mark Nighswonger (marknigh) wrote :

version.log attachment

Brad Figg (brad-figg) on 2011-09-29
Changed in linux (Ubuntu):
status: New → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-12.20
Mark Nighswonger (marknigh) wrote :

The problem still exists. I did find some additional information that might help to diagnose this. If I select suspend in the drop down menu, it appears to suspend. When I try to bring it backup I have a black screen that nothing can change and I have to do a manual reboot. If I close my netbook, I have the selected the power setting that it will suspend. This is a recoverable state and it acts as it should, bringing me to the login prompt. It appears perhaps it could be a problem with whatever instruction is carried out when selecting from the drop down menu.
On a side note it would be nice to have a shutdown selection in the drop down menu. It takes some time and 4 steps to log out confirm, shutdown confirm.

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

tags: added: needs-upstream-testing
tags: removed: apport-bug i386 kernel-request-3.0.0-12.20 needs-upstream-testing oneiric
Mark Nighswonger (marknigh) wrote :

Tested the latest upstream kernel
linux-headers-3.1.0-999-generic_3.1.0-999.201110040905_i386.deb 04-Oct-2011 11:19 860K
linux-headers-3.1.0-999_3.1.0-999.201110040905_all.deb 04-Oct-2011 09:10 11M
linux-image-3.1.0-999-generic_3.1.0-999.201110040905_i386.deb 04-Oct-2011 11:19 35M

The problem still exists!

tags: added: apport-bug i386 kernel-request-3.0.0-12.20 oneiric
Changed in linux (Ubuntu):
status: Incomplete → Triaged

Mark Nighswonger, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

If reproducible, could you also please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc5

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: bot-stop-nagging latest-bios-v1.26 needs-upstream-testing
removed: kernel-request-3.0.0-12.20
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Triaged → Incomplete
Download full text (5.6 KiB)

Hi Christopher,

That laptop died a while back. I'm sure that this can be closed out. I
haven't had much time to work with UBUNTU as I am attending an Engineering
program that takes up most of my time.

Merry Christmas,
.
Mark Nighswonger

On Thu, Dec 26, 2013 at 10:31 AM, Christopher M. Penalver <
<email address hidden>> wrote:

> Mark Nighswonger, this bug was reported a while ago and there hasn't
> been any activity in it recently. We were wondering if this is still an
> issue? If so, could you please test for this with the latest development
> release of Ubuntu? ISO images are available from
> http://cdimage.ubuntu.com/daily-live/current/ .
>
> If it remains an issue, could you please run the following command in
> the development release from a Terminal
> (Applications->Accessories->Terminal), as it will automatically gather
> and attach updated debug information to this report:
>
> apport-collect -p linux <replace-with-bug-number>
>
> If reproducible, could you also please test the latest upstream kernel
> available (not the daily folder) following
> https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional
> upstream developers to examine the issue. Once you've tested the upstream
> kernel, please comment on which kernel version specifically you tested. If
> this bug is fixed in the mainline kernel, please add the following tags:
> kernel-fixed-upstream
> kernel-fixed-upstream-VERSION-NUMBER
>
> where VERSION-NUMBER is the version number of the kernel you tested. For
> example:
> kernel-fixed-upstream-v3.13-rc5
>
> This can be done by clicking on the yellow circle with a black pencil icon
> next to the word Tags located at the bottom of the bug description. As
> well, please remove the tag:
> needs-upstream-testing
>
> If the mainline kernel does not fix this bug, please add the following
> tags:
> kernel-bug-exists-upstream
> kernel-bug-exists-upstream-VERSION-NUMBER
>
> As well, please remove the tag:
> needs-upstream-testing
>
> Once testing of the upstream kernel is complete, please mark this bug's
> Status as Confirmed. Please let us know your results. Thank you for your
> understanding.
>
> ** Tags removed: kernel-request-3.0.0-12.20
> ** Tags added: bot-stop-nagging latest-bios-v1.26 needs-upstream-testing
>
> ** Changed in: linux (Ubuntu)
> Importance: Undecided => Medium
>
> ** Changed in: linux (Ubuntu)
> Status: Triaged => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/862751
>
> Title:
> Laptop testing tracker-Suspend/Resume smoke test Case ID:
> snr-001/snr-002
>
> Status in “linux” package in Ubuntu:
> Incomplete
>
> Bug description:
> snr-001 Laptop suspends then has to be powered off and back on.
> snr-002 Laptop always fails to suspend on first test. Subsequent tests
> pass but the program does not sense that the laptop has suspended and
> reports a failure to suspend. Once into the hands off portion of
> countdown delayed testing, at some point the machine suspends into the
> same state as snr-001 and has to be rebooted which ends the testing
> sequence. It also does not init...

Read more...

Mark Nighswonger, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/linux/+bug/862751/comments/8 regarding you no longer have access to the hardware. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers