DMA: Out of SW-IOMMU space on 8GB RAM Intel Mobile 4 Series Chipset Laptop due to wired ethernet (jme)

Bug #856496 reported by Matt C on 2011-09-22
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Installed Ubuntu 11.04 on a brand new laptop with 8GB RAM. Set off Update Manager in an update and upgrade cycle.
Within a minute, experiencing constant kernel errors in dmesg:

  DMA: Out of SW-IOMMU space for 8124 bytes at device 0000:08:00.0

(The number of bytes varies.)

Immediately network traffic ceases and the root filesystem remounts ro. (Note I have also experienced root filesystem corruption.)

Booting with mem=3G, prevents the issue so it appears to be a problem that occurs with 4-8GB RAM and this chipset.

Upgraded kernel to latest 2.6.38-11-generic; the problem persists.
Tried cmdlines intel_iommu=off and iommu=off, no change, laptop won't boot with iommu=off and stops at initramfs prompt. Also tried BIOS OS options 'Other' and 'Windows 7 / Vista' (default), no change.

Laptop has Intel Corportation Mobile 4 Series Chipset.

Attaching lspci etc.

Matt C (proteus400) wrote :

References - similar but not identical bugs and forum posts:

https://bugs.edge.launchpad.net/mactel-support/+bug/267089
https://bugzilla.redhat.com/show_bug.cgi?id=471329
http://ubuntuforums.org/showthread.php?t=1652837

I wish I could get on bugzilla.kernel.org its very relevant here and I can't find a cache or mirror :/

Matt C (proteus400) wrote :
Matt C (proteus400) wrote :
Matt C (proteus400) wrote :
Matt C (proteus400) wrote :
Matt C (proteus400) wrote :

Tried blacklisting r8192se_pci wireless driver, no change.
Its hard to get a dmesg of the actual error because I'm unable to write any form of I/O when it happens.
Basically it's:
DMA: Out of SW-IOMMU space for 8192 bytes at device 0000:08:00.0
DMA: Out of SW-IOMMU space for 72 bytes at device 0000:08:00.0
DMA: Out of SW-IOMMU space for 8192 bytes at device 0000:08:00.0
DMA: Out of SW-IOMMU space for 8192 bytes at device 0000:08:00.0
... many many of these

Plus ext3 disk write failures and remount-ro event

Matt C (proteus400) wrote :

dmesg from 8G mode (before the errors begin only)

Matt C (proteus400) wrote :

UPDATE - Booted back into 8GB RAM mode (without ram=3G kernel option) in order to grab some dmesg, now using a wireless connection instead of the wired network I was using and have found that ***the fault only occurs when traffic is flowing on the wired network adapter***.

08:00.0 Ethernet controller: JMicron Technology Corp. JMC260 PCI Express Fast Ethernet Controller (rev 05)
 Subsystem: CLEVO/KAPOK Computer Device 5101
 Kernel driver in use: jme
 Kernel modules: jme

Matt C (proteus400) wrote :

lshw -C network

summary: DMA: Out of SW-IOMMU space on 8GB RAM Intel Mobile 4 Series Chipset
- Laptop
+ Laptop due to wired ethernet (jme)
affects: linux-meta (Ubuntu) → linux (Ubuntu)
Brad Figg (brad-figg) on 2011-09-23
Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: natty
Matt C (proteus400) wrote :

User experience note: I first tried to install Ubuntu 11.04 from a USB stick, and configured networking as guided by the installer, the install crashed while copying files presumably because of this issue. I tried again to install and this time I burned a CD instead and skipped configuring the network. This time it worked but once I got installed I hit the problem again straight away when I connected to the network, I couldn't even install the updates without I/O unexpectedly just stalling. 2 hours of googling and diagnostics later and I was able to identify the problem and report a bug.. If I was a new user of Ubuntu or novice I would probably give up based on negative experience after this. Thankfully I'm not, I'm a big Ubuntu advocate, and this is just a kernel bug.

I'm sure you get a lot of sterile bug reports but I would like to say thank you guys for what is by far the best distro overall imho and a genuine fit for 21st Century Linux experience.

I might join the Ubuntu beta testing program to assist to try and catch bugs like this before general release.

Matt C, thank you for reporting this and helping make Ubuntu better. This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete

I just installed Kubuntu 13.04 today and I noticed that I can't write to CIFS server anymore. It write about 90 MB after that the whole network in the computer becomes unresponsive and load goes up massively.

Kernel: Linux subi 3.8.0-7-generic #15-Ubuntu SMP Thu Feb 21 20:07:18 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

At shut-down I also noticed those errors:

DMA: Out of SW-IOMMU space for 8192 bytes at device 0000:08:00.0

hyper_ch, if you have a bug in Ubuntu, could you please file a new report by executing the following in a terminal:
ubuntu-bug linux

For more on this, please see the Ubuntu Kernel team article:
https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports

the Ubuntu Bug Control team and Ubuntu Bug Squad team article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report may delay your problem being addressed as quickly as possible.

Thank you for your understanding.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.