very slow internet connection with brcmsmac driver

Bug #856314 reported by jeff E on 2011-09-22
This bug affects 12 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)

Bug Description

Using the daily build of Ubuntu 11.10, using the default brcmsmac driver, I sometimes (randomly) get a very slow internet connection that seems to completely halt. If I disconnect the internet connection and re-connect, it is OK again, but only until it happens again, randomly.
I have a Broadcom 4313 driver.
This bug does not happen on previous distributions or on my windows partition.

I also cannot install propriety drivers instead, because of another bug:

jeff E (thenessus) on 2011-09-22
description: updated
tags: added: 11.10 brcmsmac broadcom driver oneiric
CTenorman (ctenorman) wrote :

I'm having what may be a related problem. I frequently can't connect with my broadcom 4313, and when connected the internet essentially doesn't work. This also did not occur on previous Ubuntu versions or on a Windows install.

I think this qualifies as a high-priority issue, as it's a total show-stopper for anyone with a broadcom 4313 card (see this thread:, and there are a fair number of them.

I hope this gets fixed soon, as I'm forced to use Windows on my netbook in the interim.

Sérgio Faria (sergio91pt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect 856314
When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at

affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: kernel-wifi
Ben (a0-ben-ch) wrote :

I believe I'm experiencing the same issue. When it occurs, if I try pinging a remote machine I get the following message:

ping: sendmsg: No buffer space available

Hardware info:

01:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)
 Subsystem: AzureWave Device 2047
 Flags: bus master, fast devsel, latency 0, IRQ 16
 Memory at fea00000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: brcmsmac
 Kernel modules: bcma, brcmsmac

This issue was not present in the 11.04 kernels, even when used with the compat wireless releases of brcmsmac.

Ben (a0-ben-ch) wrote :

I posted a duplicate of this bug with the apport information from my system at 871580

Alex Yuffa (ayuffa) wrote :

Have the same slow connection issue on Aspire One 522.

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? It will allow additional upstream developers to examine the issue. Refer to . Please test the release candidate kernel versus the daily build. Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the others). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

tags: added: needs-upstream-testing
Alex Yuffa (ayuffa) wrote :

Good news, the kernel 3.0.0-13 released yesterday/today fixed the slow wireless connection problem.

Bad news, on Acer Aspire One 522 the computer freezes just like it did under Natty, the same fix as before
"In BIOS, simply listing network boot before HDD boot DOES solve the networking issue on Acer Aspire One 522. Wireless and LAN are now working" see

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Alex Yuffa (ayuffa) wrote :

Posted #7 little too fast. The good news is only partial.

On SECURED (WPA/WPA2) wireless the 3.0.0-13 kernel works great but on UNSECURED connection wireless is still very slow (56k or so).

Could someone confirm this behavior? Also, could someone check WEP secure connection too?

Alex Yuffa (ayuffa) wrote :

Still very slow download speed on unsecured wireless connection in 3.0.0-14-generic kernel.

UNSECURED Wireless speeds:
Download ~ 0.40 Mbps
Upload ~ 3.5 Mbps (this one is good)

On secured wireless (WPA/WPA2) both download and upload speeds are fine.

Alex Yuffa (ayuffa) wrote :

Until drivers in the kernel are fixed, you can use this workaround to get fast wireless speeds on secured and/or unsecured wifi.

1. Add the following two lines at the end of your /etc/modprobe.d/blacklist.conf file
blacklist bcma
blacklist brcmsmac

2. Install proprietary Broadcom STA wireless driver via
On kubunutu: sudo jockey-kde
On ubuntu: sudo jockey

3. Reboot

Jacques (jacques-eavr) wrote :

Interestingly, even the proprietary "wl" driver seems to have this issue, randomly.

With this driver, what is sure and deterministic, is the fact that activating power management decreases the throughput to ~150KB/s. But sometimes, after a reboot and even without activating pm, the throughput drops to ~30 KB/s. The only way to exit this state is to unload and reload the module. This behavior is shared by wl and brcmsmac drivers.

I currently try this workaround :

cat /etc/pm/config.d/config

I let you know if it really works...around.

Paul F-Y (pbfy0) wrote :

I have this problem, or at least something very similar. I get low signal strength and speeds with brcmsmac. I also have a broadcom 4313. The wl driver works perfectly.

N0M4D (edu2004eu) wrote :

For me none of the other drivers are working, so I'm stuck with brcmsmac. Have been using it for hours now and suddenly I started getting very slow DL speeds (~70KB/s). On Ubuntu 14.04 LTS and 3.13.0-24-generic kernel. So, confirming the issue still persists for newer kernels.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers