[GM965] reproducible: watching video with DRI will freeze X

Bug #853057 reported by Tomas Pospisek on 2011-09-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

How to reproduce:

* start Firefox from Ubuntu Lynx, with flash installed
* then go to: http://www.ardmediathek.de/ard/servlet/content/3517136?documentId=8068044
* watch the footage a bit, switch windows or click on tab or click outside of the browser window

Result:
* nothing will happen
* CTRL-Alt-Del will have no effect
* CTRL-Alt-Backspace will have no effect
* CTRL-Alt-F1 (changing into a tty) will have no effect
* sometimes the footage/film will continue to be shown, sometimes only sound will continue
* system will be completely unusable

I have not tried to ssh in and kill processes etc.

Important note:
* this will *only* happen, when DRI is enabled. When I put "Option 'NoDRI'" into the xorg.conf, then the video will *not* crash X.

Architecture:
* amd64

Machine:
Hewlett-Packard HP Compaq 6710b

Release:
* Ubuntu 10.04 LTS

lspci -v -v:
* 00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
        Subsystem: Hewlett-Packard Company Device 30c0
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Interrupt: pin A routed to IRQ 29
        Region 0: Memory at e4300000 (64-bit, non-prefetchable) [size=1M]
        Region 2: Memory at d0000000 (64-bit, prefetchable) [size=256M]
        Region 4: I/O ports at 4000 [size=8]
        Capabilities: <access denied>
        Kernel driver in use: i915
        Kernel modules: i915

kerel log:
* doesn't show anything special.

Package:
* xserver-xorg-video-intel 2:2.9.1-3ubuntu5

lsmod:
cryptd
aes_x86_64
aes_generic
binfmt_misc
ppdev
vboxnetadp
vboxnetflt
vboxdrv
dm_crypt
tpm_infineon
snd_hda_codec_analog
arc4
snd_hda_intel
snd_hda_codec
snd_hwdep
snd_pcm_oss
snd_mixer_oss
snd_pcm
snd_seq_dummy
snd_seq_oss
snd_seq_midi
snd_rawmidi
snd_seq_midi_event
snd_seq
sbp2
joydev
iwl3945
snd_timer
ieee1394
btusb
bluetooth
snd_seq_device
iwlcore
hp_accel
tpm_tis
lis3lv02d
tpm
tpm_bios
snd
input_polldev
psmouse
serio_raw
mac80211
led_class
soundcore
snd_page_alloc
cfg80211
lp
parport
fbcon
tileblit
font
bitblit
softcursor
vga16fb
vgastate
i915
drm_kms_helper
drm
i2c_algo_bit
video
tg3
output
intel_agp
ahci

Related Packages:
* xserver-xorg 1:7.5+5ubuntu1
  libgl1-mesa-glx 7.7.1-1ubuntu3
  libdrm2 2.4.18-1ubuntu3

xorg.conf:
* none

Xorg.log:
* see attachement

Tomas Pospisek (tpo-deb) wrote :
bugbot (bugbot) on 2011-09-18
tags: added: freeze
Bryce Harrington (bryce) wrote :

Given that it only occurs with DRI enabled, this points to a kernel drm bug. Refiling.

If you can still reproduce this you may want to attach kernel logs, etc. Try running apport-collect 853057

affects: xserver-xorg-video-intel (Ubuntu) → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 853057

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: hardy
Tomas Pospisek (tpo-deb) wrote :

Can't reproduce any more. Thanks Bryce, thanks Brad. I'm thus closing this bug report.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments