Ubuntu

7392:7811 Edimax EW-7811Un USB dongle won't connect to networks (rtl8192cu module)

Reported by mikewhatever on 2011-09-16
314
This bug affects 59 people
Affects Status Importance Assigned to Milestone
Linux
Incomplete
Medium
linux (Ubuntu)
Medium
Unassigned

Bug Description

The networks around are visible, but when trying to connect, the NM repeatedly asks for the password. Connecting to an open network fails as well.

lsusb
Bus 001 Device 002: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]

lsmod | grep 8192
rtl8192cu 103210 0
rtl8192c_common 75767 1 rtl8192cu
rtlwifi 110972 1 rtl8192cu
mac80211 310872 3 rtl8192cu,rtl8192c_common,rtlwifi

WORKAROUND: Use the drivers downloaded from Realtek's website.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: linux-image-3.0.0-11-generic 3.0.0-11.18
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 3937 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfe978000 irq 43'
   Mixer name : 'Realtek ALC662 rev1'
   Components : 'HDA:10ec0662,1b352201,00100101'
   Controls : 20
   Simple ctrls : 12
CasperVersion: 1.284
Date: Fri Sep 16 20:53:04 2011
LiveMediaBuild: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110915.1)
MachineType: czc czc
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/casper/vmlinuz noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash --
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-11-generic N/A
 linux-backports-modules-3.0.0-11-generic N/A
 linux-firmware 1.60
RfKill:
 1: phy1: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/16/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 080016
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: czc
dmi.board.vendor: czc
dmi.board.version: 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: czc
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr080016:bd03/16/2010:svnczc:pnczc:pvr1.0:rvnczc:rnczc:rvr1.0:cvnczc:ct3:cvr1.0:
dmi.product.name: czc
dmi.product.version: 1.0
dmi.sys.vendor: czc

mikewhatever (mikewhatever) wrote :
Brad Figg (brad-figg) on 2011-09-17
Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: oneiric

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-12.19

Unfortunately, it still doesn't work with the 3.0.0-12 kernel from the daily ISO Oct 7.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-12.20

Am wondering if these are all the same bug as they all involve RTL8192CU having trouble maintaining a connection.

   https://bugs.launchpad.net/ubuntu/+source/linux-backports-modules-2.6.38/+bug/869530
   https://bugs.launchpad.net/ubuntu/+source/linux-backports-modules-3.0.0/+bug/862684

I'll be testing the 3.0.0-12.20 kernel once I get back to the "office" this afternoon. I wonder if it includes the latest (2011-10-07) changes from upstream? "The changes include: 1. Adding new chip revisions including new firmware."

  http://article.gmane.org/gmane.linux.kernel.wireless.general/78677/match=rtl8192cu

Alan Pater (alan-pater) wrote :

Ok. No luck with the latest kernel and linux-firmware package.

~$ uname -a
Linux crow 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:50:42 UTC 2011 i686 i686 i386 GNU/Linux

~$ ls -l /lib/firmware/rtlwifi
total 272
-rw-r--r-- 1 root root 13540 2011-08-23 07:22 rtl8192cfw.bin
-rw-r--r-- 1 root root 16014 2011-08-23 07:23 rtl8192cufw.bin
-rw-r--r-- 1 root root 20526 2011-08-23 07:23 rtl8192defw.bin
-rw-r--r-- 1 root root 88856 2011-08-23 07:23 rtl8192sefw.bin
-rw-r--r-- 1 root root 129304 2011-08-23 07:25 rtl8712u.bin

syslog attached to bug #869530.

   https://bugs.launchpad.net/ubuntu/+source/linux-backports-modules-2.6.38/+bug/869530

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

tags: added: needs-upstream-testing
Alan Pater (alan-pater) wrote :

See comment #6 in Bug #869530.

The kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.1-rc9-oneiric/ did not resolve our issue.

tags: removed: needs-upstream-testing
Alan Pater (alan-pater) on 2011-10-13
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

Changed in linux (Ubuntu):
status: Confirmed → Triaged

AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: i386
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/controlC0', '/dev/snd/pcmC0D0c', '/dev/snd/pcmC0D0p', '/dev/snd/pcmC0D1c', '/dev/snd/pcmC0D2c', '/dev/snd/pcmC0D3c', '/dev/snd/pcmC0D4p', '/dev/snd/by-path', '/dev/snd/controlC29', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
Card0.Amixer.info:
 Card hw:0 'ICH6'/'Intel ICH6 with AD1981B at irq 22'
   Mixer name : 'Analog Devices AD1981B'
   Components : 'AC97a:41445374'
   Controls : 26
   Simple ctrls : 18
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw 70HT28WW-1.05'
   Mixer name : 'ThinkPad EC 70HT28WW-1.05'
   Components : ''
   Controls : 2
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
   Playback channels: Mono
   Limits: Playback 0 - 14
   Mono: Playback 7 [50%] [on]
DistroRelease: Ubuntu 11.04
HibernationDevice: RESUME=UUID=1f935c28-d8ff-46ba-b9ff-ae5fc91286be
MachineType: IBM 1875M1U
Package: linux (not installed)
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcEnviron:
 LANGUAGE=es:en
 LANG=es_GT.UTF-8
 LC_MESSAGES=es_ES.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-11-generic root=UUID=64033bba-f5e3-4e07-80a2-2db250a4fe6f ro splash quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 2.6.38-11.50-generic 2.6.38.8
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-11-generic N/A
 linux-backports-modules-2.6.38-11-generic N/A
 linux-firmware 1.60
Tags: natty unity-2d
Uname: Linux 2.6.38-11-generic i686
UpgradeStatus: Upgraded to natty on 2011-09-10 (40 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 05/29/2007
dmi.bios.vendor: IBM
dmi.bios.version: 70ET69WW (1.29 )
dmi.board.name: 1875M1U
dmi.board.vendor: IBM
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: IBM
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnIBM:bvr70ET69WW(1.29):bd05/29/2007:svnIBM:pn1875M1U:pvrThinkPadT43:rvnIBM:rn1875M1U:rvrNotAvailable:cvnIBM:ct10:cvrNotAvailable:
dmi.product.name: 1875M1U
dmi.product.version: ThinkPad T43
dmi.sys.vendor: IBM

tags: added: apport-collected natty unity-2d

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

I've gotten in touch with upstream developers, they suggest running wireshark to isolate the issue. I don't have a lot of experience with wireshark, but I'll give it a try if i can find a bit of time.

http://comments.gmane.org/gmane.linux.kernel.wireless.general/79401

I've messed around with this a bit and I think, at least,
the rtl8192cu driver needs to be rewritten to eliminate the BKL (big Kernel Lock).

Where is the documentation that explains the BKL and how to replace it in drivers?

The BKL calls are defined in smp_lock.h.
Is smp_lock.h included in any of the linux-firmware source code?

smp_lock.h is included twice in the manufacturer (realtek) sources for the driver.

My work around is to stay with 11.04,
and building my own version of rtl8192cu from the manufacturer sources.
It works great in my CQU-906.

mikewhatever (mikewhatever) wrote :

Just tested OpenSuse RC2 with the 3.1 kernel. Same problem, APs visible, won't connect. Looks like the driver needs to go back to the testing branch for another year or two.

Xavier López (xavilope) wrote :

I confirm that the propietary RTL8192CU driver can be compiled successfully changing those linux/smp_lock.h includes to linux/smp.h. The propietary driver works fine.

Thanks a lot, chicoff, you've saved my 11.10 install :-)

David Pérez (sanete) wrote :

Steps I follow:

1) Download the driver
2) Unzip RTL819xCU_USB_linux_v3.3.0_2971.zip in a directory
3) cd directory
4) sudo ./install.sh
5) It compiles ok
6) But I don't know how to install it.

Here are the last lines of output of install.sh:

make[1]: Leaving directory `/usr/src/linux-headers-3.0.0-12-generic'
##################################################
Compile make driver ok!!
##################################################
Authentication requested [root] for remove driver:
ERROR: Module 8192cu does not exist in /proc/modules
Authentication requested [root] for insert driver:
insmod: error inserting '8192cu.ko': -1 Device or resource busy
Authentication requested [root] for install driver:
install -p -m 644 8192cu.ko /lib/modules/3.0.0-12-generic/kernel/drivers/net/wireless/
/sbin/depmod -a 3.0.0-12-generic
##################################################
The Setup Script is completed !
##################################################

I'm using Linux Mint 12, which is based in Ubuntu 11.10.
Any help by a Linux guru will be greatly appreciated.

David Pérez (sanete) wrote :

I think the old module interferes with the new compiled one.

David Pérez (sanete) wrote :

Solved!
Sorrry for the noise. I'm quite novice.

How to compile it:

1) Turn off wifi
2) Reboot computer
3) modprobe -rv rtl8192cu
4) cd directory
5) sudo ./install.sh

Hope it maybe useful to anyone else!.

summary: - Oneric daily - Edimax EW-7811Un USB dongle won't connect to networks
- (rtl8192cu module)
+ Oneric, Precise daily - Edimax EW-7811Un USB dongle won't connect to
+ networks (rtl8192cu module)
tags: added: 3.2.0-17-generic
removed: apport-collected edimax natty oneiric unity-2d
tags: added: 3.2.0.-18-generic
tags: added: 3.2.0-18-generic
removed: 3.2.0.-18-generic
tags: added: rtl8192cu
removed: ew-7811un
tags: added: 3.2.0-20-generic
tags: added: apport-collected precise
description: updated
Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: 3.2.0-21-generic
tags: added: 3.2.0-22-generic
removed: 3.2.0-17-generic
tags: added: 3.5.0-2-generic
summary: - Oneric, Precise daily - Edimax EW-7811Un USB dongle won't connect to
- networks (rtl8192cu module)
+ Edimax EW-7811Un USB dongle won't connect to networks (rtl8192cu module)
tags: added: quantal
summary: - Edimax EW-7811Un USB dongle won't connect to networks (rtl8192cu module)
+ 7392:7811 Edimax EW-7811Un USB dongle won't connect to networks
+ (rtl8192cu module)
tags: added: bot-stop-nagging kernel-wifi needs-upstream-testing
removed: 3.2.0-18-generic 3.2.0-20-generic 3.2.0-21-generic 3.2.0-22-generic 3.5.0-2-generic kernel-request-3.0.0-12.19 kernel-request-3.0.0-12.20 rtl8192cu
affects: linux (Fedora) → linux
Changed in linux:
importance: Undecided → Unknown
status: New → Unknown
tags: added: oneiric
Changed in linux (Ubuntu):
status: Triaged → Incomplete
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
tags: added: kernel-unable-to-test-upstream kernel-unable-to-test-upstream-3.6.0-030600rc1-generic
tags: added: natty
tags: added: running-unity
description: updated
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux:
status: Confirmed → Incomplete
description: updated
tags: added: kernel-bug-exists-upstream kernel-bug-exists-upstream-3.6.0-030600rc1-generic
removed: kernel-unable-to-test-upstream kernel-unable-to-test-upstream-3.6.0-030600rc1-generic
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-bug-exists-upstream-3.6.2-030602-generic
removed: kernel-bug-exists-upstream-3.6.0-030600rc1-generic needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: kernel-bug-exists-upstream-v3.6.2-quantal
removed: kernel-bug-exists-upstream-3.6.2-030602-generic
Changed in linux (Ubuntu):
status: Confirmed → Triaged
Karl Taüfer (daphyre-x) on 2012-11-10
information type: Public → Private
information type: Private → Public
tags: added: needs-upstream-testing
removed: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Triaged → Incomplete
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-bug-exists-upstream-v3.8-rc4
removed: kernel-bug-exists-upstream-v3.6.2-quantal needs-upstream-testing
description: updated
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: needs-upstream-testing raring
description: updated
tags: removed: natty
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
TK (tkrishan) on 2013-01-31
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
108 comments hidden view all 188 comments

apport information

tags: added: staging

apport information

apport information

mIRROR (mirror-ftw) wrote :

I'm a noob to this, I did my best
the first lines in wifisyslog repeat like forever
hope this helps

tags: removed: staging
mikewhatever (mikewhatever) wrote :

I've switched to the development release to test - currently on Raring 32bit, kernel 3.8.0-12-generic.

The device is the same as before:

Bus 001 Device 002: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]

The same module:

rtl8192cu 66659 0
rtlwifi 69015 1 rtl8192cu
rtl8192c_common 47075 1 rtl8192cu
mac80211 526481 3 rtlwifi,rtl8192c_common,rtl8192cu
cfg80211 436177 2 mac80211,rtlwifi

...and as before, wireless doesn't work with the same sympthoms, as 18 months ago.

The only difference, I've added '-dd' to wpa_supplicant for higher verbosity:

~$ ps aux | grep wpa
root 896 0.0 0.1 6276 2288 ? Ss 07:39 0:00 /sbin/wpa_supplicant -B -P -dd /run/sendsigs.omit.d/wpasupplicant.pid -u -s -O /var/run/wpa_supplicant

 Tried connecting with 'rtl8192cu swenc=0' (the defalt), and 'rtl8192cu swenc=1'. Syslog attached.

PS: Not bothering to change the status, as Chistopher will change it back to Incomplete anyway.

Casey Greene (casey-s-greene) wrote :

I observe the exact same issue with the latest amd64 raring kernel.

Olcay Korkmaz (olci) wrote :
mmalmeida (mmalmeida) wrote :

This bug also affects me. I just bought a TP-Link Nano USB Adapter (TL-WN725N), which has the following chipset:

Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN

Same behaviour as described in original poster: after supplying a password, it will never be able to successfully connect.

Strangest thing is: sometimes when I disconnect the dongle from the USB slot and attach it again, it will successfully connect to the wifi network. However, if I then disconnect from that wifi (from the network-manager tray), it won't be able to connect again to any network (until I physically detach and attach the USB dongle again).

mmalmeida (mmalmeida) wrote :

Given Olcay's comment (#155), does this mean we can expect a working kernel in a near future?

What would an ETA be for this? Is 1 week viable?
Please let me know how I can help. I can test a patched kernel to confirm if the fix works. Just let me know how.

Olcay Korkmaz (olci) wrote :

The attached patch fixes the realtek (vendor) driver 3.4.4.4749-20121105 for the kernel v3.7 and v3.8 series but didn't test on 3.9 kernel

mikewhatever (mikewhatever) wrote :

@ocli Thanks for the heads up. I really hope the patch fixes the kernel tree driver, cause I am tired of building one from realtek.com.

@mmalmedia Two months sounds like a more reasonable time frame for a stable Ubuntu release.

mikewhatever (mikewhatever) wrote :

Building the patched 3.4.4.4749-20121105 driver on 13.04 (kernel 3.8) didn't work for me. It failed with error 2.

mmalmeida (mmalmeida) on 2013-03-29
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Seth Forshee (sforshee) wrote :

The patch from the Linux bugzilla is currently working its way to Ubuntu through the stable kernel releases. If that patch really does fix the issues then it should be fixed in the official Ubuntu kernels in 3-6 weeks, and sooner than that in raring.

For now I've done a test build of the raring kernel with that patch. Please give it a try let me know whether or not it fixes the issues.

http://people.canonical.com/~sforshee/lp852190/linux-3.8.0-15.25~lp852190v201303291747/

1 comments hidden view all 188 comments
mmalmeida (mmalmeida) wrote :

Seth - with your kernel I've successfully turned wireless on and off, connected and disconnected to a network successfully, so it seems to be ok.

I do have another problem - I have 2 wifi networks and, even though I can connect to both, in one of them I don't have internet or access to the LAN; I can ping my machine (192.168.1.115) but not the router (192.168.1.1). I don't have problems with any other device connected to it. Could this be related?

I have tried with both automatic DHCP and manual (with router as DNS address).

mmalmeida (mmalmeida) wrote :

Attached is the syslog, ifconfig and a ping test on the troublesome wifi network.

mikewhatever (mikewhatever) wrote :

@Seth Thanks for the patched kernel. It seems to work ok here.

Seth Forshee (sforshee) wrote :

mmalmeida: Being able to ping the machine's own IP address doesn't prove anything. You're obviously able to communicate with the AP, to some degree at least, since you can associate and DHCP works. I'd suggest trying again when an official kernel with the fix is released, and if you see problems there then open a new bug.

Omega (atrauzzi) wrote :

Running Raring at kernel version 3.8.0-19-generic, 64bit. Still not working. When can we expect this to be fixed?

mikewhatever (mikewhatever) wrote :

@Omega Hopefully sooner then later, but keep your expectations reasonable. With only 40 affected users, I can imagine, this bug is not too high on the developers' priority list.

Omega (atrauzzi) wrote :

@Mikewhatever - There are only 40 people who have logged onto Launchpad and complained about it.

I can guarantee you far more than 40 people are actually affected by this. Most of which just throw their hands up and go on to speak ill of Ubuntu and Linux.

Your response - while seemingly rational - abandons all intuition.

mikewhatever (mikewhatever) wrote :

There is a slew of the 8192cu related changes with the 3.2.0-48-generic update for Precise, and that seems to provide a fix, and a happy end for this bug report. I've un-blacklisted the module, rebooted, and was glad to find the wireless connection established.

Here is the info summary, as shown by the update manager:

  * rtlwifi: rtl8192cu: Fix schedule while atomic bug splat
    - LP: #1164646
--
  * rtlwifi: rtl8192cu: Fix problem that prevents reassociation
    - LP: #1164646
--
  * rtlwifi: rtl8192cu: Fix NULL dereference BUG when using new_id
    - LP: #1150557
  * rtlwifi: rtl8192cu: Add new USB ID
    - LP: #1150557
--
  * rtlwifi: rtl8192cu: Add new USB ID
    - LP: #1087865
--
  * rtlwifi: rtl8192cu: Change buffer allocation for synchronous reads
    - LP: #1039087
--
  * rtlwifi: rtl8192cu: New USB IDs
    - LP: #1024020
--
  * rtlwifi: rtl8192ce: rtl8192cu: rtl8192de: Fix low-gain setting when
    scanning

Thanks everyone for participating.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released

On Fri, Jun 14, 2013 at 2:49 PM, mikewhatever <email address hidden> wrote:
> There is a slew of the 8192cu related changes with the 3.2.0-48-generic
> update for Precise, and that seems to provide a fix, and a happy end for
> this bug report. I've un-blacklisted the module, rebooted, and was glad
> to find the wireless connection established.
>
> Here is the info summary, as shown by the update manager:

In fact, from the below upstream discussion, 8192cu driver should have
some bug about transfer buffer:

       http://marc.info/?t=137121757300006&r=1&w=2

Thanks,

Antti Haapala (ztane) wrote :

So when is the fix landing to raring, or is it supposed to be there already? Because I have a fresh Edimax EW-7811Un, 3.8.0-25-generic #37-Ubuntu SMP Thu Jun 6 20:47:07 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux, and I certainly couldn't connect into any kind of pw protected net; open wifi seemed to work for like 3 minutes, after which the connection was severed and reconnection not possible anymore.

I also tried the workaround (compiling the 8192cu driver by realtec), and managed to get them compile with the latest patch provided in the comments modprobed it in, but while it seemed to work for a while, then it dropped connection too and had dmesg full of strange stuff, so I disconnected the adapter and *boom* got a kernel panic...

It seems fixed in raring, kernel 3.8.0-26-generic. I'm writing from a WPA-protected network, using the rtl8192cu driver for this dongle.

Balinares (balinares) wrote :

It doesn't work here in Saucy, kernel 3.11.0-12-generic. The hardware (Belkin N300 USB dongle, id F7D2102, using chipset Realtek RTL8192CU) is recognized properly and the rtl8192cu module loads fine. However, the hardware fails to see any nearby AP. It worked fine in Raring with Timothy Phillips' patched driver (https://code.google.com/p/realtek-8188cus-wireless-drivers-3444749-ubuntu-1304/), which unfortunately isn't compatible with the 3.11 kernel used in Saucy.

Antti Haapala / Balinares, if you have a bug in Ubuntu, the Ubuntu Kernel team, Ubuntu Bug Control team, and Ubuntu Bug Squad would like you to please file a new report by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report would delay your problem being addressed as quickly as possible.

No need exists to comment here at this time. After reading the above documentation in it's entirety, if you have further questions, you are welcome to redirect them to the appropriate mailing list or forum via http://www.ubuntu.com/support/community/mailinglists , or you may contact me directly.

Thank you for your understanding.

Aaron Peromsik (aperomsik) wrote :

With the recent kernel update this started working for me. Looks like it is using the packaged firmware, not the updated one, which might mean the updated one is not needed for this device.

$ uname -a
Linux kermit 3.11.0-13-generic #20-Ubuntu SMP Wed Oct 23 07:38:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
$ lsusb
Bus 001 Device 008: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]

[ 65.908605] rtl8192cu: Loading firmware rtlwifi/rtl8192cufw.bin

-rw-r--r-- 1 root root 16014 Apr 25 2013 rtl8192cufw.bin
-rw-r--r-- 1 root root 16116 Oct 27 15:56 rtl8192cufw_TMSC.bin

senpaji (senthil300794) wrote :

i am not able to use tp link 723 usb wifi adapter driver for linux

1 comments hidden view all 188 comments
mikewhatever (mikewhatever) wrote :

Unfortunately, despite the fixes, it doesn't work very well at all. If you have time to wait a couple of more years, may be the driver will get there, and may be not.
Meanwhile, Realtek has an updated driver for us, good for kernel 3.9:
http://www.realtek.com/downloads/downloadsView.aspx?Langid=1&PNid=48&PFid=48&Level=5&Conn=4&DownTypeID=3&GetDown=false&Downloads=true#RTL8192CU
There is also a pached driver to install on 3.8:
https://code.google.com/p/realtek-8188cus-wireless-drivers-3444749-ubuntu-1304/

Changed in linux (Ubuntu):
status: Fix Released → Incomplete

mikewhatever, thank you for your comment. Could you please confirm this issue exists with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ . If the issue remains, please just make a comment to this.

If reproducible, could you also please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc7

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

mikewhatever (mikewhatever) wrote :

I may (or may not) do more testing at my own leisure, and others affected are welcome to contribute. That said, it's pretty clear by now, that doing more testing doesn't help anyone.

Christopher, while your attention to this bug report has been remarkable, and I'd like to thank you for that, can you please stop copy/pasting those canned test requests. Their only goal is, apparently, to change the status to Incomplete, and hopefully, close it in 60 days.

mmalmeida (mmalmeida) wrote :

I "solved" it by buying another usb wifi dongle. I got tired of the hassle and time taken to test, compile, etc.

mikewhatever, thank you for your comment.

>"...it's pretty clear by now, that doing more testing doesn't help anyone."

This would be anything but clear as a developer has worked on addressing your issue before, as per your now closed bug report https://bugzilla.kernel.org/show_bug.cgi?id=45241 . Unfortunately, it wasn't a fix all.

>"...can you please stop copy/pasting those canned test requests."

Please review carefully https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette .

>"Their only goal is, apparently, to change the status to Incomplete, and hopefully, close it in 60 days."

In order to mark this Triaged, the latest upstream kernel would need to be tested -> http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.13-trusty/ . If the problem is reproducible, then upstream would be re-engaged (as they will immediately ask you have you tested upstream 3.13+ if you do otherwise).

Thank you for your understanding.

Peter Schüller (schueller-p) wrote :

I have the same issue with a WN8200ND adapter (same driver): i cannot connect to access points with the kernel module shipped in the newest 14.4 build

I didn't find any reference to the following repository which I used to fix the issue partially:
https://github.com/pvaret/rtl8192cu-fixes

Status is as follows:
* before using the above modified driver, my 14.4 kernel (3.13.0-19-generic 64 bit) could not connect to any accesspoint i tried
* after using this driver i can connect to my cellphone's access point but not to another accesspoint where i can connect with my laptop nicely.

If I compare both accesspoints - the one i can connect and the one I cannot - the differences start after

"link to Broadcom AP"

the accesspoint that works:
"OnAuthCclient
network.SupportedRates[0] = ......
...
many more such lines

the accesspoints that does not work:
"link_timer_hdl: auth timeout and try again
(4 times)
report_join_res(-1)
"

Peter Schüller (schueller-p) wrote :

Here is another guy having the same problem
http://tinymicros.com/wiki/TP-Link_WN8200ND_On_BeagleBone_Black

and I noticed an additional differing line that could be relevant:

"issue_deauth_ex(wlan0) to <mac address>, ch:13, 5/5 in 496 ms"

i did not find anything useful while googling this line

Peter Schüller, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Luke (lukebenes) on 2014-04-03
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Luke (lukebenes) wrote :

I have the same hardware as described in the first comment, Edimax EW-7811Un.

With 3.11.0-12 kernel in Saucy, I cannot connect to my WRT54G access point.

If I use the drivers from: https://github.com/pvaret/rtl8192cu-fixes
my Wireless card works perfectly

With Linux kernel 3.13 in a Trusty Tahr beta install, I can sometimes connect to my network, but the network frequently disappears. The only way to connect is to remove the USB device or reboot the computer.

kernel.org Bug 45241 was closed, but the kernel 3.13's driver does not work as well as pvaret's fixes with 3.11. Does Ubuntu's 3.13 contain Larry Finger's patch? If so, more work still needs to be done to fix the driver in the kernel. Should I create a new bug report or reopen 45241?

Please let me know if there is anything else I can provide to be of assistance.

Luke, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Displaying first 40 and last 40 comments. View all 188 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.