5.1 built-in surround detected as 4.0 on Acer Aspire 8943G with ALC670

Bug #839800 reported by Lukáš Chmela on 2011-09-02
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ALSA driver
Unknown
Unknown
linux (Ubuntu)
Medium
Unassigned

Bug Description

After fresh installation even stereo configuration is set. From the menu can be selected 4.0 configuration making the rear left and right speakers work, however, front center and LFE (subwoofer) do not emit any sound in any application. They can be only tested (and they are working within this command) by `speaker-test -D default -c6 -twav`.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: linux-image-3.0.0-9-generic 3.0.0-9.15
ProcVersionSignature: Ubuntu 3.0.0-9.15-generic 3.0.3
Uname: Linux 3.0.0-9-generic x86_64
NonfreeKernelModules: fglrx
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC670 Analog [ALC670 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: lukaschmela 1568 F.... pulseaudio
                      lukaschmela 3169 F.... npviewer.bin
 /dev/snd/pcmC0D0p: lukaschmela 3169 f...m npviewer.bin
 /dev/snd/timer: lukaschmela 3169 F.... npviewer.bin
CRDA: Error: [Errno 2] Adresář nebo soubor neexistuje
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf8600000 irq 43'
   Mixer name : 'Realtek ALC670'
   Components : 'HDA:10ec0670,1025038b,00100002'
   Controls : 26
   Simple ctrls : 15
Card1.Amixer.info:
 Card hw:1 'Generic'/'HD-Audio Generic at 0xf8120000 irq 44'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Fri Sep 2 20:13:29 2011
HibernationDevice: RESUME=UUID=943a0f17-f0f5-4dc8-8690-910e4a5157ff
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
MachineType: Acer Aspire 8943G
ProcEnviron:
 PATH=(custom, no user)
 LANG=cs_CZ.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-9-generic root=UUID=5a6c1031-1093-4c45-9e38-abbd07085899 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-9-generic N/A
 linux-backports-modules-3.0.0-9-generic N/A
 linux-firmware 1.60
SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/11/2010
dmi.bios.vendor: Phoenix
dmi.bios.version: V1.06
dmi.board.name: SM83-CP
dmi.board.vendor: Acer
dmi.board.version: Not Applicable
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenix:bvrV1.06:bd08/11/2010:svnAcer:pnAspire8943G:pvrNotApplicable:rvnAcer:rnSM83-CP:rvrNotApplicable:cvnAcer:ct10:cvrN/A:
dmi.product.name: Aspire 8943G
dmi.product.version: Not Applicable
dmi.sys.vendor: Acer
---
ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: lukaschmela 1879 F.... pulseaudio
 /dev/snd/controlC0: lukaschmela 1879 F.... pulseaudio
CRDA:
 country AT:
  (2402 - 2482 @ 40), (N/A, 20)
  (5170 - 5250 @ 40), (N/A, 20)
  (5250 - 5330 @ 40), (N/A, 20), DFS
  (5490 - 5710 @ 40), (N/A, 27), DFS
CurrentDmesg:
 [ 37.445031] sd 4:0:0:0: >[sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
 [ 37.462576] sdb: sdb1
 [ 41.354089] FAT-fs (sdb1): Invalid FSINFO signature: 0x00000000, 0x00000000 (sector = 1)
 [ 124.351347] update-notifier[2306]: segfault at 31 ip 00007f3f83eda5f8 sp 00007fff8fee6390 error 4 in libgvfscommon.so[7f3f83ec5000+35000]
DistroRelease: Ubuntu 12.10
HibernationDevice: RESUME=UUID=943a0f17-f0f5-4dc8-8690-910e4a5157ff
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MachineType: Acer Aspire 8943G
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=cs_CZ.UTF-8
 SHELL=/bin/bash
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-17-generic root=UUID=d76edc48-f639-47b3-93ea-9198b99a0341 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-17-generic N/A
 linux-backports-modules-3.5.0-17-generic N/A
 linux-firmware 1.95
Tags: quantal running-unity
Uname: Linux 3.5.0-17-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 08/11/2010
dmi.bios.vendor: Phoenix
dmi.bios.version: V1.06
dmi.board.name: SM83-CP
dmi.board.vendor: Acer
dmi.board.version: Not Applicable
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenix:bvrV1.06:bd08/11/2010:svnAcer:pnAspire8943G:pvrNotApplicable:rvnAcer:rnSM83-CP:rvrNotApplicable:cvnAcer:ct10:cvrN/A:
dmi.product.name: Aspire 8943G
dmi.product.version: Not Applicable
dmi.sys.vendor: Acer

Lukáš Chmela (lukaschmela) wrote :
Changed in linux (Ubuntu):
status: New → Confirmed
affects: linux → alsa-driver

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel currently in the release pocket than the one you tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-11.18
_artem_ (artemeas) wrote :

no changes even on kernel 3.0.4

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-12.19
Lukáš Chmela (lukaschmela) wrote :

Yes, I can confirm this bug with the latest developement release version 3.0.0-12.19.

Nothing has changed, the configuration is still shown as 4.0 at most.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-12.20
Lukáš Chmela (lukaschmela) wrote :
Download full text (18.7 KiB)

Persists with kernel version 3.0.0-12.20.
In syslog, there are some messages regarding ALSA and PulseAudio:

Oct 10 15:19:27 Oneiric-beta1-Aspire-8943G pulseaudio[1666]: [alsa-sink] alsa-util.c: snd_pcm_avail() navrátil hodnotu, která je nezvykle vysoká: 3528320 bajtů (10000 ms). - snd_pcm_avail() returned a value that is unusually high: 3528320 bytes (10000 ms).
Oct 10 15:19:27 Oneiric-beta1-Aspire-8943G pulseaudio[1666]: [alsa-sink] alsa-util.c: S největší pravděpodobností se jedná o chybu v ovladači ALSA "snd_hda_intel". Nahlaste prosím tento problém vývojářům ALSA. - This is most likely a bug in the ALSA driver "snd_hda_intel". Please report this problem to ALSA developers.
Oct 10 15:19:27 Oneiric-beta1-Aspire-8943G pulseaudio[1666]: [alsa-sink] alsa-util.c: snd_pcm_dump():
Oct 10 15:19:27 Oneiric-beta1-Aspire-8943G pulseaudio[1666]: [alsa-sink] alsa-util.c: Soft volume PCM
Oct 10 15:19:27 Oneiric-beta1-Aspire-8943G pulseaudio[1666]: [alsa-sink] alsa-util.c: Control: PCM Playback Volume
Oct 10 15:19:27 Oneiric-beta1-Aspire-8943G pulseaudio[1666]: [alsa-sink] alsa-util.c: min_dB: -51
Oct 10 15:19:27 Oneiric-beta1-Aspire-8943G pulseaudio[1666]: [alsa-sink] alsa-util.c: max_dB: 0
Oct 10 15:19:27 Oneiric-beta1-Aspire-8943G pulseaudio[1666]: [alsa-sink] alsa-util.c: resolution: 256
Oct 10 15:19:27 Oneiric-beta1-Aspire-8943G pulseaudio[1666]: [alsa-sink] alsa-util.c: Its setup is:
Oct 10 15:19:27 Oneiric-beta1-Aspire-8943G pulseaudio[1666]: [alsa-sink] alsa-util.c: stream : PLAYBACK
Oct 10 15:19:27 Oneiric-beta1-Aspire-8943G pulseaudio[1666]: [alsa-sink] alsa-util.c: access : MMAP_INTERLEAVED
Oct 10 15:19:27 Oneiric-beta1-Aspire-8943G pulseaudio[1666]: [alsa-sink] alsa-util.c: format : S16_LE
Oct 10 15:19:27 Oneiric-beta1-Aspire-8943G pulseaudio[1666]: [alsa-sink] alsa-util.c: subformat : STD
Oct 10 15:19:27 Oneiric-beta1-Aspire-8943G pulseaudio[1666]: [alsa-sink] alsa-util.c: channels : 4
Oct 10 15:19:27 Oneiric-beta1-Aspire-8943G pulseaudio[1666]: [alsa-sink] alsa-util.c: rate : 44100
Oct 10 15:19:27 Oneiric-beta1-Aspire-8943G pulseaudio[1666]: [alsa-sink] alsa-util.c: exact rate : 44100 (44100/1)
Oct 10 15:19:27 Oneiric-beta1-Aspire-8943G pulseaudio[1666]: [alsa-sink] alsa-util.c: msbits : 16
Oct 10 15:19:27 Oneiric-beta1-Aspire-8943G pulseaudio[1666]: [alsa-sink] alsa-util.c: buffer_size : 441040
Oct 10 15:19:27 Oneiric-beta1-Aspire-8943G pulseaudio[1666]: [alsa-sink] alsa-util.c: period_size : 88208
Oct 10 15:19:27 Oneiric-beta1-Aspire-8943G pulseaudio[1666]: [alsa-sink] alsa-util.c: period_time : 2000181
Oct 10 15:19:27 Oneiric-beta1-Aspire-8943G pulseaudio[1666]: [alsa-sink] alsa-util.c: tstamp_mode : ENABLE
Oct 10 15:19:27 Oneiric-beta1-Aspire-8943G pulseaudio[1666]: [alsa-sink] alsa-util.c: period_step : 1
Oct 10 15:19:27 Oneiric-beta1-Aspire-8943G pulseaudio[1666]: [alsa-sink] alsa-util.c: avail_min : 440158
Oct 10 15:19:27 Oneiric-beta1-Aspire-8943G pulseaudio[1666]: [alsa-sink] alsa-util.c: period_event : 0
Oct 10 15:19:27 Oneiric-beta1-Aspire-8943G pulseaudio[1666]: [alsa-sink] alsa-util.c: start_threshold : -1
Oct 10 15:19:27 Oneiric-beta1-Aspire-894...

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: bot-stop-nagging needs-upstream-testing
removed: kernel-request-3.0.0-11.18 kernel-request-3.0.0-12.19 kernel-request-3.0.0-12.20
tags: added: kernel-audio
tags: added: kernel-sound kernel-sound-speaker
removed: kernel-audio

Lukáš Chmela, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please provide the information following https://wiki.ubuntu.com/DebuggingSoundProblems ?

As well, could you please test for this with the latest development release of Ubuntu? ISO CD images are available from http://www.ubuntu.com/download/desktop .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested and remove the tag:
needs-upstream-testing

This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the text:
needs-upstream-testing

If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the following tags:
kernel-unable-to-test-upstream
kernel-unable-to-test-upstream-VERSION-NUMBER

Please let us know your results. Thank you for your understanding.

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
tags: added: apport-collected quantal
description: updated
tags: added: kernel-bug-exists-upstream kernel-bug-exists-upstream-v3.6.2-quantal
removed: needs-upstream-testing
Lukáš Chmela (lukaschmela) wrote :

Thank you for your advice, Christopher M. Penalver.

I have tried kernel version 3.6.2-030602.201210121823 (amd64) from http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6.2-quantal/ running on Ubuntu 12.10. Version 3.7-rc1 from http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.7-rc1-quantal/ is not installable for me because of the missing *_all.deb package.

The bug still persists in the 3.6.2 kernel - I can only choose Analog 4.0 Surround Output from the system sound menu in the top panel (front center and LFE speakers are not recognized).

I will run apport-collect once I uninstall the upstream kernel as it needs the one from quantal repository.

apport information

description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Lukáš Chmela (lukaschmela) wrote :

I'm sorry for my mistake, the upstream kernel version tested was really 3.7.0-030700rc1-generic (there was only a problem installing fglrx but the kernel has installed well).

tags: added: kernel-bug-exists-upstream-3.7.0-030700rc1-generic
removed: kernel-bug-exists-upstream-v3.6.2-quantal
tags: added: kernel-bug-exists-upstream-v3.7-rc1-quantal
removed: kernel-bug-exists-upstream-3.7.0-030700rc1-generic
description: updated
Raymond (superquad-vortex2) wrote :

you need a modified version of

http://git.kernel.org/?p=linux/kernel/git/tiwai/sound.git;a=commitdiff;h=3b315d70b094e8b439358756a9084438fd7a71c2;hp=8871e5b91518a47284b6bc2603b44dbc79c85446

create front , rear, center and lfe playback volume to support 5.1 this mean that you will loss the headphone playback volume since there are only 3 DACs

headphone connected to front DAC, blue line in jack and pink mic jack cabn be retask as output similar to those desktop with three jacks at fear panel

Node 0x02 [Audio Output] wcaps 0x41d: Stereo Amp-Out
  Control: name="Bass Speaker Playback Volume", index=0, device=0
    ControlAmp: chs=3, dir=Out, idx=0, ofs=0
  Amp-Out caps: ofs=0x40, nsteps=0x40, stepsize=0x03, mute=0
  Amp-Out vals: [0x2c 0x2c]
  Converter: stream=8, channel=2
  PCM:
    rates [0x560]: 44100 48000 96000 192000
    bits [0xe]: 16 20 24
    formats [0x1]: PCM
  Power states: D0 D1 D2 D3 EPSS
  Power: setting=D0, actual=D0
Node 0x03 [Audio Output] wcaps 0x41d: Stereo Amp-Out
  Control: name="Headphone Playback Volume", index=0, device=0
    ControlAmp: chs=3, dir=Out, idx=0, ofs=0
  Amp-Out caps: ofs=0x40, nsteps=0x40, stepsize=0x03, mute=0
  Amp-Out vals: [0x2c 0x2c]
  Converter: stream=8, channel=0
  PCM:
    rates [0x560]: 44100 48000 96000 192000
    bits [0xe]: 16 20 24
    formats [0x1]: PCM
  Power states: D0 D1 D2 D3 EPSS
  Power: setting=D0, actual=D0
Node 0x04 [Audio Output] wcaps 0x41d: Stereo Amp-Out
  Control: name="Speaker Playback Volume", index=0, device=0
    ControlAmp: chs=3, dir=Out, idx=0, ofs=0
  Device: name="ALC670 Analog", type="Audio", device=0
  Amp-Out caps: ofs=0x40, nsteps=0x40, stepsize=0x03, mute=0
  Amp-Out vals: [0x2c 0x2c]
  Converter: stream=8, channel=0
  PCM:
    rates [0x560]: 44100 48000 96000 192000
    bits [0xe]: 16 20 24
    formats [0x1]: PCM
  Power states: D0 D1 D2 D3 EPSS
  Power: setting=D0, actual=D0

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Pending results of action items requested in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/839800/comments/8 :
>"Could you please provide the information following https://wiki.ubuntu.com/DebuggingSoundProblems ?"

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Lukáš Chmela (lukaschmela) wrote :
Lukáš Chmela (lukaschmela) wrote :

I guess this is all what was missing from the list. If there's anything else you need to investigate the issue, could you please be more specific?

Raymond (superquad-vortex2) wrote :

http://git.kernel.org/?p=linux/kernel/git/tiwai/sound.git;a=commit;h=2df03514de41f3bbb5623f2e7f2bf594e49cb2ec

the patch add the pin fixup for the subwoofer at node 0x15 with sequence number 2

the driver won't support 5.1 since there are only two speaker mode 0x18 and 0x15

dreKion (drekion) wrote :

Hello I'm in Ubuntu 14.04 and I have this problem. Only have audio 4.0.

How can I apply the path?

To post a comment you must log in.