initramfs blkid /dev/xvda1 did not return, failed boot

Bug #838199 reported by Scott Moser on 2011-08-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

We saw a failure EC2 testing of Beta Candidate for oneiric [1].
In [2], we did collect a 'terminated' log, that shows a the failure.

useful console log at [4], which i'll attach also. The interesting section of log is:
  [11963.827784] udevd[82]: starting version 173
  Begin: Loading essential drivers ... done.
  Begin: Running /scripts/init-premount ... done.
  Begin: Mounting root file system ... Begin: Running /scripts/local-top ... done.
  Gave up waiting for root device. Common problems:
   - Boot args (cat /proc/cmdline)
     - Check rootdelay= (did the system wait long enough?)
     - Check root= (did the system wait for the right device?)
   - Missing modules (cat /proc/modules; ls /dev)
  ALERT! /dev/disk/by-label/cloudimg-rootfs does not exist. Dropping to a shell!
  BusyBox v1.18.4 (Ubuntu 1:1.18.4-2ubuntu1) built-in shell (ash)
  Enter 'help' for a list of built-in commands.
  udevd[91]: timeout: killing '/sbin/blkid -o udev -p /dev/xvda1' [102]
  udevd[91]: timeout: killing '/sbin/blkid -o udev -p /dev/xvda1' [102]
  udevd[91]: timeout: killing '/sbin/blkid -o udev -p /dev/xvda1' [102]
  ...[repeated]...
  udevd[91]: '/sbin/blkid -o udev -p /dev/xvda1' [102] terminated by signal 9 (Killed)

At that point, the test harness rebooted the system and it came back up properly.
This bug was opened on an instance of m1.large in eu-west-1 of the same ami.

[1] https://jenkins.qa.ubuntu.com/job/oneiric-server-ec2/7/
[2] https://jenkins.qa.ubuntu.com/job/oneiric-server-ec2/7/ARCH=amd64,REGION=eu-west-1,STORAGE=ebs,TEST=multi-part-ud,label=ubuntu-server-ec2-testing/artifact/

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: linux-image-3.0.0-9-virtual 3.0.0-9.15
ProcVersionSignature: User Name 3.0.0-9.15-virtual 3.0.3
Uname: Linux 3.0.0-9-virtual x86_64
AlsaDevices:
 total 0
 crw-rw---- 1 root audio 116, 1 2011-08-31 15:34 seq
 crw-rw---- 1 root audio 116, 33 2011-08-31 15:34 timer
AplayDevices: Error: [Errno 2] No such file or directory
Architecture: amd64
ArecordDevices: Error: [Errno 2] No such file or directory
CurrentDmesg: [ 20.210019] eth0: no IPv6 routers present
Date: Wed Aug 31 15:40:06 2011
Ec2AMI: ami-820b38f6
Ec2AMIManifest: (unknown)
Ec2AvailabilityZone: eu-west-1b
Ec2InstanceType: m1.large
Ec2Kernel: aki-62695816
Ec2Ramdisk: unavailable
Lspci:

Lsusb: Error: command ['lsusb'] failed with exit code 1: unable to initialize libusb: -99
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: root=LABEL=cloudimg-rootfs ro console=hvc0
ProcModules: acpiphp 24080 0 - Live 0x0000000000000000
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)

Scott Moser (smoser) wrote :

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 838199

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Scott Moser (smoser) wrote :

Its not possible to collect logs, instance is gone.

Changed in linux (Ubuntu):
status: Incomplete → New
Brad Figg (brad-figg) wrote :

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 838199

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Scott Moser (smoser) on 2011-08-31
description: updated
tags: added: iso-testing
Scott Moser (smoser) wrote :

please stop, bot!

Changed in linux (Ubuntu):
status: Incomplete → New
Brad Figg (brad-figg) wrote :

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 838199

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

"If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'."

Updating status to Confirmed to prevent the bot from touching this bug any further.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Pete Graner (pgraner) on 2011-09-07
Changed in linux (Ubuntu):
importance: Undecided → Low

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel currently in the release pocket than the one you tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-11.17
Tim Gardner (timg-tpi) wrote :

Scott - this likely won't get fixed until its reproducible.

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers