radeon driver power management is very bad: GPU always runs at maximum clock speed

Bug #825989 reported by RISC_CPU on 2011-08-13
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xserver-xorg-driver-ati
Invalid
High
linux (Ubuntu)
Medium
Unassigned

Bug Description

Opensource radeon driver's power management is EXTREMELY bad, at least in default OS setup.

Configuation:
 Virtually any (K,X)Ubuntu (32, 64) so far. Latest tested is Xubuntu 11.10 alpha but problem also exists in 11.04, etc.

Problem
 I own 2 x AMD HD 5770 PCI-E graphic cards. When I use Radeon opensource driver, power management is REALLY, REALLY bad. Both GPUs are always running at maximum - 850MHz core and 1200MHz RAM. Never reducing frequency, ever. Even if load is minimal or one of cards is unused at all (secondary display detached and no other loads on secondary GPU). This leads to unreasonable power dissipation for nothing, CO2 emissions, etc. Cards have leds to indicate load, each supply phase with it's own led. I can see GPU supply runs all 3 phases all the time on both cards. In fact, it's quite unpleasant to get ~100W of heat for nothing when it is already +30C around. Not to mention GPU coolers are making some noise and power consumption is bad.

Expected:
 fglrx is much better at power management. Under exactly same scenario it instantly downclocks both cards to 157MHz core and ~340MHz RAM, drastically reducing power consumption (I can even see how 3rd phase of card's supply is shut off on it's LED after fglrx loads and hear that cooler slows down). I believe opensource Radeon should do the same, in default setups. After all, it can get frequencies from the card so it's probably not that hard to set thses frequencies as well. Actually it looks like if Radeon actually capable of managing power but this does not works for some reason yet.

ProblemType: Bug
[deleted] - erroneously pasted this from wrong (fglrx) package.

RISC_CPU (risc-cpu) wrote :
description: updated
Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Confirmed
bugbot (bugbot) on 2011-08-17
tags: added: xubuntu

[This is not my own bug, but I decided that it would be better to repost it upstream from https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/825989. I have the same problem with my laptop GPU.]

The clock frequency of the GPU is set to maximum by default and it is never throttled back. This leads to a laptop battery that is drained quickly, an unneccesary amount of heat produced, an annoying fan, etc etc.

Users can set the frequency through the command line like with
echo dynpm > /sys/class/drm/card0/device/power_method
but most users don't know about this.

Changed in xserver-xorg-driver-ati:
importance: Unknown → High
status: Unknown → Confirmed
Bryce Harrington (bryce) wrote :

Hey risc-cpu,

Hi, thanks for reporting this issue during the development period of
Ubuntu.

I notice there's not been further comments to the bug report since the
release came out, would you mind updating us on the status of it in the
release?

Are you still able to reproduce the issue? If not, do you think the bug
report can be closed, or do you think we should continue tracking it?

Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Incomplete

Does this change anything?: http://www.botchco.com/agd5f/?p=57
Available in kernel 3.11

RISC_CPU, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

If reproducible, could you also please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc6

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: needs-kernel-logs needs-upstream-testing regression-potential
affects: xserver-xorg-video-ati (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Medium
madbiologist (me-again) wrote :

Radeon dynamic power management was introduced in the 3.11 kernel and further refined in the 3.13 kernel used by Ubuntu 14.04 "Trusty Tahr".

Changed in linux (Ubuntu):
status: Incomplete → Fix Released

Fix released downstream.

Changed in xserver-xorg-driver-ati:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.