gnome-system-monitor fails to launch with latest kernel upgrade

Bug #825207 reported by cement_head on 2011-08-12
70
This bug affects 14 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Canonical Kernel Team

Bug Description

After kernel upgrade this AM (Friday, August 12, 2011) gnome-system-monitor fails to launch.

$ export GNOME_SYSTEM_MONITOR_DEBUG=1
$ gnome-system-monitor
** (gnome-system-monitor:4668): DEBUG: [0.971 procman.cpp:695 main] post gtk_init

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: linux-image-2.6.35-30-generic-pae 2.6.35-30.57
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.35-30.57-generic-pae 2.6.35.13
Uname: Linux 2.6.35-30-generic-pae i686
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/by-path', '/dev/snd/controlC1', '/dev/snd/hwC1D0', '/dev/snd/pcmC1D3p', '/dev/snd/pcmC1D7p', '/dev/snd/controlC0', '/dev/snd/hwC0D0', '/dev/snd/pcmC0D0c', '/dev/snd/pcmC0D0p', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code -9:
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xe6760000 irq 49'
   Mixer name : 'IDT 92HD90BXX'
   Components : 'HDA:111d76e7,10280493,00100102'
   Controls : 15
   Simple ctrls : 10
Card1.Amixer.info:
 Card hw:1 'NVidia'/'HDA NVidia at 0xe5080000 irq 17'
   Mixer name : 'Nvidia GPU 1c HDMI/DP'
   Components : 'HDA:10de001c,10280493,00100100'
   Controls : 8
   Simple ctrls : 2
Date: Fri Aug 12 09:17:11 2011
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=0273fb62-9ecb-4cad-942a-cf585d2afee3
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
MachineType: Dell Inc. Latitude E6420
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-30-generic-pae root=UUID=94b61cf9-6273-418f-93cc-76bbeafa2533 ro vga=791 quiet quiet splash
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.38.8
SourcePackage: linux
dmi.bios.date: 05/24/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A05
dmi.board.name: 032T9K
dmi.board.vendor: Dell Inc.
dmi.board.version: A01
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA05:bd05/24/2011:svnDellInc.:pnLatitudeE6420:pvr01:rvnDellInc.:rn032T9K:rvrA01:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude E6420
dmi.product.version: 01
dmi.sys.vendor: Dell Inc.

cement_head (andorjkiss) wrote :
cement_head (andorjkiss) wrote :

Update:

Running as root makes it work:

$ sudo gnome-system-monitor

** (gnome-system-monitor:12824): WARNING **: SELinux was found but is not enabled.

Question: How do I enable SELinux as non-root?

- CH

cement_head (andorjkiss) wrote :

Update: Running as root does not make it work, rather gives the root system processes.

Userspace still barfs. The SELinus warning is not related to the bug (It shows up on another Lucid system wherein the g-s-m works perfectly).

I think its a icon set????

Here's the strace (attached)

Changed in linux (Ubuntu):
status: New → Confirmed
cartman (nsbm-abbath) wrote :

Same in Ubuntu 10.04. Kernel - 2.6.32-34-generic

Big Booty To Win Image
Tell me som
            Enter to win

emarkay (mrk) wrote :

Someone needs to fix the above spam post...

Also this affects me - workaround is to use prior kernel.

It also prevents WINE from working.

See:http://ubuntuforums.org/showthread.php?s=1f944174ef4af3ead5eb0c64cdd8fc85&t=1826937&page=2

emarkay (mrk) wrote :

Also may be related to bug #827038.

cement_head (andorjkiss) wrote :

Update.

Rolling back from Maverick Proposed to Maverick Updates the following packages:

Downgraded the following packages:
linux-headers-2.6.35-30
linux-headers-2.6.35-30-generic-pae
linux-image-2.6.35-30-generic-pae
linux-source-2.6.35

From the 2.6.35-30.57 series back to 2.6.35-30.56 series works and fixed the gnome-system-monitor issue for me.

Wine never had an issue (but I'm using Maverick)

- CH

emarkay (mrk) wrote :

So it IS a kernel error and yet it's undecided and unassigned?

I would hope that the appropriate person responsible for kernel issue delegation gets this assigned to a high priority as it's not an obvious fault, may affect more than the 2 packages noted.

emarkay (mrk) wrote :

Update:
The most recent (less than an hour ago) latest system update to the (2.6.32-34.74) kernel now allow System Monitor to function.

However a WINE app is still crashing.

I tried to reinstall it (Irfanview 4.25) and got these messages in the Console:

"fixme:system:SystemParametersInfoW Unimplemented action: 88 (SPI_SETICONS)
err:ntdll:RtlpWaitForCriticalSection section 0x165294 "?" wait timed out in thread 0034, blocked by 0010, retrying (60 sec)"

It won't run via Desktop Shortcut, and when I attempt to load it from the Console with "wine irfanview.exe", I get this:

wine: cannot find L"C:\\windows\\system32\\irfanview.exe"

Something is still wrong with this latest kernel.

Changed in linux (Ubuntu):
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
importance: Undecided → High
status: Confirmed → Triaged
Nicola Jelmorini (jelmorini) wrote :

Yesterday I have received a new update for the Kernel packages (2.6.32-34-generic), and now after the reboot, all seems to work correctly again.
gnome system monitor don't crash anymore.

emarkay (mrk) wrote :

Nicola, can you look at:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/828550
and see if you can confirm any of those reports - that bug may be related to this one.

David Clayton (dcstar) wrote :

I had this System Monitor bug and the last update fixed that issue, but my VMware Player was also broken by this kernel and remains broken even with the System Monitor fix:

https://bugs.launchpad.net/bugs/829842

cement_head (andorjkiss) wrote :

Fix is for Lucid only - Maverick Meerkat has not been patched/fixed.

- CH

emarkay (mrk) wrote :

This now appears to be corrected with the bugfix/release noted below. Can other reporters/commentators confirm - then this can be closed.
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/832332

Herton R. Krzesinski (herton) wrote :

These new kernels were/are available in -proposed, which likely fixes the problem reported here:
2.6.32-34.74 or 2.6.32-34.75 (lucid)
2.6.35-30.38 (maverick)

@cement_head: can you confirm maverick 2.6.35-30.38 fix the bug for you?

cartman (nsbm-abbath) wrote :

With the latest kernel update Gnome System Monitor works fine for me.
Ubuntu 10.04

Herton R. Krzesinski (herton) wrote :

sorry, I meant version 2.6.35-30.58 for maverick (typo...)

NoOp (glgxg) wrote :

On 08/24/2011 08:15 AM, Herton R. Krzesinski wrote:
> These new kernels were/are available in -proposed, which likely fixes the problem reported here:
> 2.6.32-34.74 or 2.6.32-34.75 (lucid)
> 2.6.35-30.38 (maverick)

Working again with:
$ uname -a
2.6.35-30-generic #58-Ubuntu SMP Thu Aug 18 17:35:58 UTC 2011 i686 GNU/Linux

Also on 64bit x86_64 - same kernel.

cement_head (andorjkiss) wrote :

@herton

New series (2.6.35-30.58) resolves bug with gnome-system-monitor on Maverick Meerkat 10.10.

Confirmed solution.

Thanks very much,
CH

Herton R. Krzesinski (herton) wrote :

Thanks everyone for testing. This probably is a duplicate of 827198, but I'm marking this anyway as Fix Released (regression in -proposed which is now corrected).

Changed in linux (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers