Live session boot time too hight (end_request: I/O error, dev fd0, sector 0)

Bug #820519 reported by Fabio Marconi on 2011-08-03
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Casper
New
Undecided
Unassigned
Linux
Invalid
Medium
linux (Ubuntu)
Medium
Tim Gardner
Oneiric
Medium
Tim Gardner

Bug Description

Hello
The boot of the live session is delayed because

Aug 3 17:20:56 ubuntu kernel: [ 11.783749] aufs test_add:262:exe[609]: uid/gid/perm //filesystem.squashfs 0/0/0755, 1000/1000/0755
Aug 3 17:20:56 ubuntu kernel: [ 25.038509] end_request: I/O error, dev fd0, sector 0
Aug 3 17:20:56 ubuntu kernel: [ 37.118643] end_request: I/O error, dev fd0, sector 0
Aug 3 17:20:56 ubuntu kernel: [ 37.118652] Buffer I/O error on device fd0, logical block 0
Aug 3 17:20:56 ubuntu kernel: [ 49.199184] end_request: I/O error, dev fd0, sector 0
Aug 3 17:20:56 ubuntu kernel: [ 49.199193] Buffer I/O error on device fd0, logical block 0
Aug 3 17:20:56 ubuntu kernel: [ 62.508980] end_request: I/O error, dev fd0, sector 0
Aug 3 17:20:56 ubuntu kernel: [ 74.589065] end_request: I/O error, dev fd0, sector 0
Aug 3 17:20:56 ubuntu kernel: [ 74.589074] Buffer I/O error on device fd0, logical block 0
Aug 3 17:20:56 ubuntu kernel: [ 86.668627] end_request: I/O error, dev fd0, sector 0
Aug 3 17:20:56 ubuntu kernel: [ 86.668634] Buffer I/O error on device fd0, logical block 0
Aug 3 17:20:56 ubuntu kernel: [ 105.186605] Adding 2029564k swap on /dev/sda5. Priority:-1 extents:1 across:2029564k

in a system with the floppy not connected (only power is attached)

Thanks
Fabio

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: casper 1.275
ProcVersionSignature: Ubuntu 3.0.0-7.9-generic 3.0.0
Uname: Linux 3.0.0-7-generic x86_64
Architecture: amd64
CasperVersion: 1.275
Date: Wed Aug 3 18:33:28 2011
LiveMediaBuild: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110803)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: casper
UpgradeStatus: No upgrade log present (probably fresh install)

Fabio Marconi (fabiomarconi) wrote :
description: updated
Fabio Marconi (fabiomarconi) wrote :
Fabio Marconi (fabiomarconi) wrote :
Fabio Marconi (fabiomarconi) wrote :
Fabio Marconi (fabiomarconi) wrote :
affects: casper (Ubuntu) → linux (Ubuntu)
tags: added: iso-testing
Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
Fabio Marconi (fabiomarconi) wrote :

triaged and confirmed upstream

Changed in linux (Ubuntu):
status: New → Confirmed
Pete Graner (pgraner) on 2011-09-07
Changed in linux (Ubuntu):
importance: Undecided → Medium
Tim Gardner (timg-tpi) wrote :

I don't think this is really a bug. The installer partitioner is probably probing the floppy drive and correctly getting errors back since there is no media inserted. From the logs it appears that this didn't actually prevent your installation from completing.

Changed in linux (Ubuntu):
status: Confirmed → Invalid
Fabio Marconi (fabiomarconi) wrote :

Hello Tim
sorry, but here the problem is that it is waiting for a non existing device ( no data cable connected to the floppy drive)
Thanks
Fabio

Fabio Marconi (fabiomarconi) wrote :

Present in Oneiric Beta 1 too, just tested, but only in live session.
Set again to confirmed

Changed in linux (Ubuntu):
status: Invalid → Confirmed
Fabio Marconi (fabiomarconi) wrote :

kern.log from beta 1

Tim Gardner (timg-tpi) wrote :

Fabio - lets see if we can get some debug out of the floppy driver. Add this parameter to your grub kernel command line: "floppy=debug".

Changed in linux (Ubuntu Oneiric):
assignee: nobody → Tim Gardner (timg-tpi)
status: Confirmed → In Progress
Fabio Marconi (fabiomarconi) wrote :

kern.log with floppy=debug boot option

Fabio Marconi (fabiomarconi) wrote :

Hello Tim
fixed disabling floppy in bios settings.
Sorry, kick me if you want.
Thanks
Fabio

Changed in linux (Ubuntu Oneiric):
status: In Progress → Invalid
Tim Gardner (timg-tpi) wrote :

no problem, I'm glad that fixed your boot delay.

Changed in linux:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.