No driver for the Network controller: Ralink corp. Device 5390

Bug #815064 reported by Dave Morley on 2011-07-23
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Leann Ogasawara

Bug Description

This Ralink device has no driver on ubuntu but seems to on other distro suse and fedora for example. I see that there is a driver that someone has posted to the forums I'll track it down.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: linux-image-3.0.0-6-generic 3.0.0-6.7
ProcVersionSignature: Ubuntu 3.0.0-6.7-generic 3.0.0-rc7
Uname: Linux 3.0.0-6-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC270 Analog [ALC270 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: davmor2 1318 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xd4400000 irq 43'
   Mixer name : 'Intel IbexPeak HDMI'
   Components : 'HDA:10ec0270,103c1425,00100100 HDA:80862804,80860101,00100000'
   Controls : 20
   Simple ctrls : 11
CurrentDmesg:
 [ 18.372740] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
 [ 23.003516] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=0
 [ 23.972917] init: plymouth-stop pre-start process (1183) terminated with status 1
 [ 29.141438] eth0: no IPv6 routers present
Date: Sat Jul 23 14:15:20 2011
HibernationDevice: RESUME=UUID=5d0bfe16-060f-4175-9e73-0a51ba58d6c4
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110720)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
 Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
 Bus 002 Device 003: ID 090c:37b0 Feiya Technology Corp.
MachineType: Hewlett-Packard HP G62 Notebook PC
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-6-generic root=UUID=d45b7a89-667d-4199-bc5f-0b0eaeabeb4b ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-6-generic N/A
 linux-backports-modules-3.0.0-6-generic N/A
 linux-firmware 1.56
RfKill:
 0: hp-wifi: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/23/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.32
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 1425
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 54.56
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.32:bd11/23/2010:svnHewlett-Packard:pnHPG62NotebookPC:pvr0597130000202710010020100:rvnHewlett-Packard:rn1425:rvr54.56:cvnHewlett-Packard:ct10:cvrN/A:
dmi.product.name: HP G62 Notebook PC
dmi.product.version: 0597130000202710010020100
dmi.sys.vendor: Hewlett-Packard

Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :

Pretty sure this is the link I used http://ubuntuforums.org/showthread.php?t=1685430

Brad Figg (brad-figg) on 2011-07-23
Changed in linux (Ubuntu):
status: New → Confirmed
Dave Morley (davmor2) wrote :

https://build.opensuse.org/package/binaries?nextstatus=404&package=rt5390sta&project=driver%3Awireless&repository=11.3-update

grabbing the above applying the patches and then making then provides me with a working driver with the wrong name so then if I manually rename the drivers and copy to the correct folders the driver works fine.

I followed the steps from this post.

http://ubuntuforums.org/showpost.php?p=10452987&postcount=42

Hi Dave,

I've taken a look at this and it appears there is already a driver in the mainline kernel which should support this device. We hadn't enabled the driver as it was and still is marked as EXPERIMENTAL:

drivers/net/wireless/rt2x00/Kconfig:

config RT2800PCI_RT53XX
       bool "rt2800pci - Include support for rt53xx devices (EXPERIMENTAL)"
       depends on EXPERIMENTAL
       default y
       ---help---
         This adds support for rt53xx wireless chipset family to the
         rt2800pci driver.
         Supported chips: RT5390

Our default policy is to disable EXPERIMENTAL options until we have a specific request to enable them. So, I'd consider your bug here a request to enable this experimental driver. Thus, I've built a test kernel with this driver now enabled, eg CONFIG_RT2800PCI_RT53XX=y. Please test and let me know your results. Thanks.

http://people.canonical.com/~ogasawara/lp815064/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → In Progress
Changed in linux (Ubuntu):
assignee: nobody → Leann Ogasawara (leannogasawara)
Dave Morley (davmor2) wrote :

leann that works a treat, signal is booming out driver seems stable but I'll check back in with you when you come online.

Great, good to hear. I've gone ahead and applied this patch to our git repo. I expect it to be in the next kernel upload and in time for the Alpha3 release. Thanks!

Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.0.0-7.9

---------------
linux (3.0.0-7.9) oneiric; urgency=low

  [ Andy Whitcroft ]

  * Revert "[Upstream] add local prefix to oss local change_bits"
  * Revert "SAUCE: add tracing for user initiated readahead requests"
  * Revert "SAUCE: vfs: Add a trace point in the mark_inode_dirty function"
  * Revert "SAUCE: Input: ALPS - Enable Intellimouse mode for Lenovo
    Zhaoyang E47"
  * Revert "SAUCE: fix documentation strings for struct input_keymap_entry"
  * Revert "SAUCE: vt -- fix handoff numbering to 1..n and add range checks
    (grub)"
  * Revert "SAUCE: vt -- fix handoff numbering to 1..n and add range
    checks"
  * Revert "SAUCE: vt -- allow grub to request automatic vt_handoff"
  * Revert "SAUCE: vt -- maintain bootloader screen mode and content until
    vt switch"
  * [Config] enable CONFIG_MTRR_SANITIZER_ENABLE_DEFAULT=1
    - LP: #816035
  * ubuntu: Yama: if an underlying filesystem provides a permissions op use
    it
  * SAUCE: (no-up) add tracing for user initiated readahead requests
  * SAUCE: vt -- maintain bootloader screen mode and content until vt
    switch
  * SAUCE: vt -- allow grub to request automatic vt_handoff

  [ Arjan van de Ven ]

  * SAUCE: (no-up) vfs: Add a trace point in the mark_inode_dirty function

  [ Kees Cook ]

  * Revert "SAUCE: (no-up) Disable building the ACPI debugfs source"
  * [Config] enforce ACPI_CUSTOM_METHOD disabled

  [ Keng-Yu Lin ]

  * SAUCE: (no-up) Input: ALPS - Enable Intellimouse mode for Lenovo
    Zhaoyang E47
    - LP: #632884, #803005

  [ Leann Ogasawara ]

  * [Config] Enable CONFIG_BLK_DEV_CMD64X=m on powerpc
    - LP: #513131
  * [Config] Enable CONFIG_RT2800PCI_RT53XX=y
    - LP: #815064

  [ Rezwanul Kabir ]

  * SAUCE: (no-up) Add support for Intellimouse Mode in ALPS touchpad on
    Dell E2 series Laptops
    - LP: #632884

  [ Upstream Kernel Changes ]

  * Revert "yama: if an underlying filesystem provides a permissions op use
    it"
  * Revert "Add support for Intellimouse Mode in ALPS touchpad on Dell E2
    series Laptops"
  * Revert "tty: include linux/slab.h for kfree"
  * Revert "gpio/ml_ioh_gpio: include linux/slab.h for kfree"
  * Revert "pch_dma: add include/slab.h for kfree"
  * mmc: Added quirks for Ricoh 1180:e823 lower base clock frequency
    - LP: #773524
  * oss: rename local change_bits to avoid powerpc bitsops.h definition
 -- Leann Ogasawara <email address hidden> Mon, 25 Jul 2011 09:08:01 -0700

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Banshee (banshee-sodar) wrote :

Unfortunately, does not work for me, HP Pavilion dm1 (amd fusion e-350) . I have ralink 539f (which should be the same as 5390), unfortunately, 3.0.0-7.9 kernel does not solve it. On natty I use drivers from Ralink with patches, and rt5390sta works for my 539f.

I also cannot follow http://atinfinity.wordpress.com/2011/05/21/ralink-rt5390-wi-fi-driver-on-ubuntu-11-04/ - driver does not compile,

Banshee (banshee-sodar) wrote :

after reinstalling linux-headers 3.0.0-7.9 I managed to compile rt5390sta (see instructions above), and it is working.

unfortunately, kernel drivers yet do not work.

Julian Wiedmann (jwiedmann) wrote :

The ID for 539f was added in 3.1, that's why it's still missing in Oneiric:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux.git;a=commit;h=71e0b38c2914018b01f3f08b43ee9e3328197699

Banshee, could you please try the rt2800pci again. As Julian pointed out your devices ID is missing in kernel 3.0. You can however give it to the driver at runtime [1][2] with:
echo "1814 539f" | sudo tee /sys/bus/pci/drivers/rt2800pci/new_id

The whole process for testing this should probably look something like this:
modprobe -rv rt5390sta
modprobe -v rt2800pci
echo "1814 539f" | sudo tee /sys/bus/pci/drivers/rt2800pci/new_id

Hope this works. I never actually tried it myself.

If the rt2800pci then works for you we should backport the ID-patch via <email address hidden> so that we get out of the box support for this on oneiric.

[1]: This works only since kernel 3.0 for rt2x00 drivers due to a bug fixed with:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux.git;a=commit;h=e01ae27f8ce6bd3ee26ef33c704f62449ce8233b
[2]: General documentation for this:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux.git;a=blob;f=Documentation/PCI/pci.txt;h=6148d4080f888a9967492717b2837bbbb0b56970;hb=HEAD

Dave Morley (davmor2) wrote :

Guys just to confirm I've done a fresh install of the weekend post the new kernel landing and wifi is working out of the box, I would suggest moving the issue with the other WIFI card to another bug for the sake of clarity being as it is a different issue to the one I had. It will save confusion.

Great :-)
- and the other ID issue has found its home on bug 802444. I'm going to send the patch to stable.

Phil Turmel (pturmel-lp) wrote :

I helped my daughter install natty on her brand-new Asus K73E, which has the Ra-Link RT5390. Wolfgang's suggestion in #11 was the jackpot.

For other's reference, I got her wireless working in three steps:

1) Installed kernel 3.0.0 from http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.0-oneiric/
2) Added "bt2800pci" to /etc/modules
3) Added "echo 1814 5390 >/sys/bus/pci/drivers/rt2800pci/new_id" to /etc/rc.local

palimmo (palimmo) wrote :

Hi!
I have a HP g62 with this Ralink 5390.
I've tried following the #14... but nothing! (I've typed both bt2800pci and rt2800pci. Is the last one correct?)

Could you give me other advice in order to fix it?

Thank you!

palimmo (palimmo) wrote :

my
/etc/rc.local
now is:

exit 0
echo 1814 5390 >/sys/bus/pci/drivers/rt2800pci/new_id

and my
/etc/modules
is:

lp
rtc
rt5390sta
rt2800pci

Are they correct?

Both the current 3.0.1 stable mainline kernel[1] and the current oneiric kernel that is based on it already have support for both 1814:5390 and 1814: 539f built in. The workaround in comment 14 (/sys/bus/pci/drivers/rt2800pci/new_id) should therefore not be necessary anymore if you are using one of those kernels.

Whenever the workaround is still necessary:
rt2800pci is the correct module name.

exit 0 ends your script. Your command needs to go before exit 0:
echo 1814 5390 >/sys/bus/pci/drivers/rt2800pci/new_id
exit 0

Don't load both modules. Remove rt5390sta from /etc/modules.

[1] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.0.1-oneiric/

palimmo (palimmo) wrote :

Mh.. thank you Wolfgang Kufner.
Now it works!

But.. the led changes continuously and very fast the colour, from white to orange and so on!

Could it be dangerous???

palimmo (palimmo) wrote :

Mh...
I've also tried to delete both
echo 1814 5390 >/sys/bus/pci/drivers/rt2800pci/new_id
in
/etc/rc.local

and

rt5390sta
rt2800pci
in
/etc/modules

And it works as well!

....but it flashes continuously! So worrying!

Don't worry about the flashes. They are just informational. Whether Wifi is enabled, whether it is transmitting or receiving data,... Maybe your notebook's manual has something to say about what the colors are supposed to mean. Or just ignore it.

If you find the flashes too bright and too distracting you could file a wishlist bug for an option to turn them off. Or just put some tape over it.

palimmo (palimmo) wrote :

Thank you again!

How can I "file a wishlist bug for an option to turn them off"?
Do you mean to open a new bug?

Yes. Just file a new bug by typing in a terminal window:
ubuntu-bug linux
That's all. "Wishlist" is just the importance attribute the bug
probably should have, but you can't set that yourself.

If you decide to file a bug report about this, please subscribe me to it.

palimmo (palimmo) wrote :

I can't with this command
ubuntu-bug linux
because
"It appears you are currently running a mainline kernel. It would be better to report this bug upstream at http://bugzilla.kernel.org/ so that the upstream kernel developers are aware of the issue. If you'd still like to file a bug against the Ubuntu kernel, please boot with an official Ubuntu kernel and re-file"

But.. what do you think about this?
~$ ls /sys/class/leds
rt2800pci-phy0::assoc rt2800pci-phy0::quality rt2800pci-phy0::radio

Sorry, didn't think about that.

/sys/class/leds sounds promising, but let's move the discussion to the
question (question 167837) that you opened about this.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers