Ubuntu

Update to kernel 2.6.38-10 causes hang on startup

Reported by Mannex on 2011-07-15
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

After update to 2.6.38-10, machine hangs on startup. Used a grub boot (held down shift keys) to revert 2.6.38-10to 2.6.38-8, and all was fine. Completely removed -10, redownloaded packages and reinstalled, same thing. On boot, screen goes all purple, then hangs. No Ubuntu logo. I also have a copy of the relevant syslog entries during the hang. I will try to attach.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-10-generic 2.6.38-10.46
ProcVersionSignature: Ubuntu 2.6.38-10.46-generic 2.6.38.7
Uname: Linux 2.6.38-10-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: mannex 1782 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0x90400000 irq 16'
   Mixer name : 'IDT 92HD75B2X5'
   Components : 'HDA:111d7608,103c363f,00100202 HDA:11c11040,103c137e,00100200'
   Controls : 13
   Simple ctrls : 8
Date: Fri Jul 15 12:45:08 2011
HibernationDevice: RESUME=UUID=400110b3-914d-4d77-906d-66c363141081
MachineType: Hewlett-Packard Presario CQ61 Notebook PC
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-10-generic root=UUID=0e3ab9f5-d8bb-44bf-861b-2fff1fd094a4 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-10-generic N/A
 linux-backports-modules-2.6.38-10-generic N/A
 linux-firmware 1.52
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/25/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.13
dmi.board.name: 363F
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 42.15
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.13:bd01/25/2010:svnHewlett-Packard:pnPresarioCQ61NotebookPC:pvr0491110000200D10000020000:rvnHewlett-Packard:rn363F:rvr42.15:cvnHewlett-Packard:ct10:cvrN/A:
dmi.product.name: Presario CQ61 Notebook PC
dmi.product.version: 0491110000200D10000020000
dmi.sys.vendor: Hewlett-Packard

Mannex (russ-mannex) wrote :
juliobahar (yahalla-julio) wrote :

I have the same issue on my Natty 64-bit happened after I upgraded to kernel 2.6.38-10 generic.
I found the only work around is to start ubuntu in recovery mode (from grub) and choose fsck (file system check) on next reboot was the way to start gui, or in recovery mode as well, choose to start ubuntu normally to boot into the a terminal and from there you do "sudo service gdm start"

Changed in linux (Ubuntu):
status: New → Confirmed
Mannex (russ-mannex) wrote :

I used startup-manager to simply select 38-8 as the default, so I'm using the old kernel, but I don't have to use grub to boot.

Steve Conklin (sconklin) on 2011-07-18
Changed in linux (Ubuntu Natty):
status: New → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Invalid
Steve Conklin (sconklin) wrote :

The logs appear to be from 2.6.38-8, which makes sense since that's the only kernel you can boot.

When you are attempting to boot 2.6.38-10, can you hit the Ctl-Alt-F1 combination (all at once) to see what the output of the console says? Ctl-Alt-F7 takes you back to the other session. If you can see what's on the console, then describe it or better yet take a photo and attach it to the bug.

Thanks!

Steve Conklin (sconklin) wrote :

and one more thing to try- we also have this bug reported:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/811498

try waiting at least a minute when it appears to be hung. If it continues, then I'll flag these as duplicates.

Thanks

Mannex (russ-mannex) wrote :

Trying to launch tty1 (ctrl-alt-F1) doesn't seem to work. It hangs before I can do that. So, via grub I launched 38-10 recovery mode so I could see what was happening. It hangs after displaying these lines:

Jul 19 14:24:37 Leviathan kernel: [ 1.329440] ata1: SATA max UDMA/133 abar m1024@0x90408000 port 0x90408100 irq 22
Jul 19 14:24:37 Leviathan kernel: [ 1.329444] ata2: SATA max UDMA/133 abar m1024@0x90408000 port 0x90408180 irq 22

I have waited five minutes, and no boot. Sorry.

Ton (ton-venhuizen) wrote :

Same hangs here. Could start the 2.6.38-10 with many times pressing <ctrl>
(Compaq laptop, AMD Sempron M100, 1.7 GB, Ubuntu 11.04, Gnome, AMD)

Mannex (russ-mannex) wrote :

Based on Ton's comment, I should note here another possibility. I am also using a Compaq, and these laptops are notorious for having strange sound configurations. For example, the speakers will never work during a boot session if a boot the machine with headphones plugged in. If I boot without the headphones plugged in, my speakers will work, but the headphones will not (unless I reboot with the headphones plugged in).

The reason I'm mentioning this, is because there might be a possibility that the machine is hanging in an attempt to do something with the sound system. Just a thought.

juliobahar (yahalla-julio) wrote :

@Mannex Nothing to do with sound. I'm having the same issue with my desktop computer, which is definitely not a compaq

tags: added: regression-update
T Kortehisto (kortehisto) wrote :

I have the same problem with my desktop. Sometimes my system boots up with 2.6.38-10 normally and other times it hangs at purple screen.

Herton R. Krzesinski (herton) wrote :

Hi, can you all install and test the 2.6.38-11.47 kernel in -proposed, and check if the issue still happens with it? See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

description: updated
description: updated
juliobahar (yahalla-julio) wrote :

@herton I've tried the proposed 2.6.38-11 kernel and my system seems stable so far. It boots fine and never suddenly restarts.

juliobahar (yahalla-julio) wrote :

@herton I'm sorry to inform you that the new 2.6.38-11 kernel, failed me just now. I was watching a youtube video on google chrome and it happened just like with the -10 generic stable version. In addition boot stopped at the pink screen. I tried an older kernel version it stopped as well. The only way about was to run a fsck.

I had this problem as well. I found that a very temporary (as in only takes effect while you're doing it) is to interact with the machine. It stalls on bootup, and I press keys (it seems like numlock, cntrl, and alt work the best) and it continues working.

I also have the same problem while running the system, and I press a key or touch the touchpad and it continues working. I stop interacting with it, it either stalls or runs very slowly.

Mannex (russ-mannex) wrote :

Appears fixed in 2.6.38-11:

mannex@Leviathan:~$ uname -a
Linux Leviathan 2.6.38-11-generic #48-Ubuntu SMP Fri Jul 29 19:05:14 UTC 2011 i686 athlon i386 GNU/Linux

Mannex (russ-mannex) wrote :

If no objections, I'll close this as fixed released.

juliobahar (yahalla-julio) wrote :

I'm testing my system for like 8 hours now with the new kernel
Linux xxx 2.6.38-11-generic #48-Ubuntu SMP Fri Jul 29 19:05:14 UTC 2011 i686 i686 i386 GNU/Linux
So far I have no complains

Mannex (russ-mannex) on 2011-08-20
Changed in linux (Ubuntu Natty):
status: Confirmed → Fix Released
juliobahar (yahalla-julio) wrote :

Well I just restarted my desktop and the Pink screen showed up again. Stays there with no output whatsoever so that I can tackle the issue. I had to restart using recovery mode and ROOT gdm start to get the gnome running.
@Mannex are you positive that this is not happening to you?

Mannex (russ-mannex) wrote :

Yes, I am positive that it is not happening. I have now rebooted several times and confirmed my linux kernel version using uname. If it's still a problem, perhaps it should be reopened. Can you confirm your kernel version?

juliobahar (yahalla-julio) wrote :

@Mannex it is mentioned in post #17
Linux xxx 2.6.38-11-generic #48-Ubuntu SMP Fri Jul 29 19:05:14 UTC 2011 i686 i686 i386 GNU/Linux

Mannex (russ-mannex) wrote :

Ah yes, you did mention it. Sorry 'bout that. I'll set the status back.

Changed in linux (Ubuntu Natty):
status: Fix Released → Confirmed
juliobahar (yahalla-julio) wrote :

@Mannex well dear I'm sorry but it seems that I'm one of a few whose been affected by this bug. I think it is unfair to the developers keeping this open as the workaround is working so far. What do you say?!

Mannex (russ-mannex) wrote :

I have no problem with closing it, as long as there are no objections. I thought that if you are still experiencing the problem, others might be as well. Perhaps it should be opened as a new bug, since the title of this one clearly mentions kernel 10, not 11. I'll go ahead and close this then.

Changed in linux (Ubuntu Natty):
status: Confirmed → Fix Released
To post a comment you must log in.