"halt" does not power off the system

Bug #809628 reported by Søren Holm on 2011-07-12
This bug report is a duplicate of:  Bug #859075: Oneiric does not shutdown. Edit Remove
96
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Linux
New
Undecided
Unassigned
upstart
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

When shutting down the kernel ends writing "Power off" and then "System halted".

Normally this should end up powering off the system by in teh curent Oneiric it doesn't.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: linux-image-3.0.0-4-generic 3.0.0-4.5
ProcVersionSignature: Ubuntu 3.0.0-4.5-generic 3.0.0-rc6
Uname: Linux 3.0.0-4-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: NVidia [HDA NVidia], device 0: ALC660-VD Analog [ALC660-VD Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: sgh 1434 F.... kded4
                      sgh 1635 F.... kmix
CRDA: Error: [Errno 2] Ingen sådan fil eller filkatalog
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xfecd8000 irq 22'
   Mixer name : 'Realtek ALC660-VD'
   Components : 'HDA:10ec0660,10430000,00100001'
   Controls : 24
   Simple ctrls : 15
Date: Wed Jul 13 01:14:44 2011
HibernationDevice: RESUME=UUID=6fc16235-9eea-4880-aeef-cdc890b89248
InstallationMedia: Kubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110705)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 003: ID 174f:a821 Syntek Web Cam - Packard Bell BU45, PB Easynote MX66-208W
 Bus 002 Device 002: ID 046d:c03d Logitech, Inc. M-BT96a Pilot Optical Mouse
 Bus 001 Device 006: ID 03f0:110c Hewlett-Packard
MachineType: Packard Bell BV Easy Note_MX51
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-4-generic root=UUID=cc344a8a-d2aa-4acc-a86d-d1ecaa8b5d51 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-4-generic N/A
 linux-backports-modules-3.0.0-4-generic N/A
 linux-firmware 1.56
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/11/2006
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: T12MvNC.204
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: Easy Note_MX51
dmi.board.vendor: Packard Bell BV
dmi.board.version: 1.00
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: Packard Bell BV
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrT12MvNC.204:bd10/11/2006:svnPackardBellBV:pnEasyNote_MX51:pvrPB71HD0091:rvnPackardBellBV:rnEasyNote_MX51:rvr1.00:cvnPackardBellBV:ct10:cvr1.0:
dmi.product.name: Easy Note_MX51
dmi.product.version: PB71HD0091
dmi.sys.vendor: Packard Bell BV

Søren Holm (sgh) wrote :
Brad Figg (brad-figg) on 2011-07-19
Changed in linux (Ubuntu):
status: New → Confirmed
Søren Holm (sgh) wrote :

This is still a problem with latest daily build. I can also add that qemu also not powered off.

Interestingly this only occurs when halting from the commandline, shutting down via graphical controls of the window manager works.

My laptop won't power off no matter what I do. :(

I think it is not a bug, it's a feature. They probably changed the default behaviour of /sbin/halt which does not power off anymore. It works with "halt -p" or simply poweroff.

Søren Holm (sgh) wrote :

Well it does nt work for me according to the screenshot.

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel currently in the release pocket than the one you tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-11.17
Søren Holm (sgh) wrote :

It's still valid.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel currently in the release pocket than the one you tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-11.18
PhobosK (phobosk) wrote :

Since this is a change in the default behaviour of /sbin/halt and the binary is part of the upstart package, it is not the kernel to blame.

Testcase -> Oneiric, Kubuntu (i.e. KDM used and a KDE desktop), Unity purged:

1. Using KDE's "Shutdown" button actually does a halt with no poweroff, no matter if the "Shutdown" sequence is initiated inside a running KDE session or at the KDM login screen
2. Using the Power button of the PC at the KDM login screen does do the job normally (i.e. does poweroff).
3. Using /sbin/halt inside a KDE session or at the KDM login (in another terminal of course) does only halt no poweroff
4. Using /sbin/halt -p anywhere does poweroff the system as it is expected and as it was in Natty
5. The /etc/init.d/halt script is never executed though it should be at runlevel 0

Csimbi (turbotalicska) wrote :

I have nearly the same problem as the original poster.
Ubuntu server, 64bit.
I just upgraded from 11.04 to 11.10 (Zotac ITX board) - and I did not change any settings in the process so it should work as before.
But.
The system will not power off when it's supposed to - which is scheduled to happen at 23:00 every day (via cron).
It will halt the system but it will not cut the power; I have to hold down the power button to cut the power.
The last two messages are:
* Will now halt...
[ 174.941747] System halted.
Thanks for fixing.

Same as Bug #881792 and Bug #880240.

Csimbi (turbotalicska) wrote :

BTW, wake-on-lan won't work after this. I wonder if it's related.
Since physical access to the hardware is limited, I would appreciate a fast-track resolution on this.
Thank you.

daniele (daniele-email) wrote :

I have the same issue,

daniele (daniele-email) wrote :

I have the same issue, I also tried different linux cmdline options without success.

root@camera-mythv:~# uname -a
Linux camera-mythv 3.0.0-16-generic #29-Ubuntu SMP Tue Feb 14 12:48:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers