1002:6779 AMD RADEON HD 6450 random pixels on display

Bug #805211 reported by Arseny Klimovsky on 2011-07-03
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-driver-ati
Fix Released
Medium
linux (Ubuntu)
High
Unassigned

Bug Description

I'm trying to use a AMD RADEON HD 6450 video card, but it fails to show a login screen, see screen photo attached.
I've tried different kernel (2.6.38-8, 2.6.38-10, 2.6.39-3) and driver versions (from main repository and from xorg-edgers ppa), no success.
The fglrx drivers makes a SegFault on my system. I tried to use vesa and removed packages, related to radeon, but it still does not show the login screen correctly, see the same screen photo.

The logs and info attached automatically are from the situation where a vesa driver expected to be used.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xserver-xorg-video-radeon (not installed)
ProcVersionSignature: Ubuntu 2.6.38-10.46-generic 2.6.38.7
Uname: Linux 2.6.38-10-generic x86_64
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
Date: Sun Jul 3 23:01:07 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
GraphicsCard:
 ATI Technologies Inc NI Caicos [AMD RADEON HD 6450] [1002:6779] (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:03dc]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
ProcEnviron:
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-2.6.38-10-generic root=UUID=ca260b9b-380b-4b09-9c78-54901c6bb687 ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xserver-xorg-video-ati
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/15/2011
dmi.bios.vendor: Intel Corp.
dmi.bios.version: BLH6710H.86A.0110.2011.0415.1506
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: DH67BL
dmi.board.vendor: Intel Corporation
dmi.board.version: AAG10189-205
dmi.chassis.type: 3
dmi.modalias: dmi:bvnIntelCorp.:bvrBLH6710H.86A.0110.2011.0415.1506:bd04/15/2011:svn:pn:pvr:rvnIntelCorporation:rnDH67BL:rvrAAG10189-205:cvn:ct3:cvr:
version.compiz: compiz 1:0.9.4+bzr20110606-0ubuntu1~natty1
version.ia32-libs: ia32-libs 20090808ubuntu13
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

description: updated
bugbot (bugbot) on 2011-07-04
tags: added: edgers
Timo Aaltonen (tjaalton) on 2011-09-06
Changed in xserver-xorg-video-ati (Ubuntu):
importance: Undecided → High
status: New → Confirmed
assignee: nobody → Timo Aaltonen (tjaalton)
Changed in xserver-xorg-driver-ati:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in xserver-xorg-driver-ati:
status: Confirmed → Incomplete
Patrik Kullman (nomego) wrote :

Just wanted to add that Dave Airlie sent me a patch{0] in the FreeDesktop Bug Tracker[1] for this same issue which fixed the problem for me.

Would be great to have this patch included for the oneiric kernel if possible, it would make Ubuntu work for people with HD6450 cards out of the box.

[0]: https://bugs.freedesktop.org/attachment.cgi?id=51806
[1]: https://bugs.freedesktop.org/show_bug.cgi?id=40103

Timo Aaltonen (tjaalton) wrote :

I haven't tried it myself, but looks promising. Moving over to the kernel, though it's not going to help oneiric since the kernel freeze is in effect (which means the kernel for the final installation image is already set in stone).

Changed in xserver-xorg-video-ati (Ubuntu):
assignee: Timo Aaltonen (tjaalton) → nobody
Changed in xserver-xorg-driver-ati:
status: Incomplete → Fix Released
madbiologist (me-again) on 2011-11-04
affects: xserver-xorg-video-ati (Ubuntu) → linux (Ubuntu)

Arseny Klimovsky, thank you for reporting this and helping make Ubuntu better. Natty reached EOL on October 2012.
Please see this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

We were wondering if this is still an issue in a supported release? If so, could you please test for this with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested and remove the tag:
needs-upstream-testing

This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the text:
needs-upstream-testing

If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the following tags:
kernel-unable-to-test-upstream
kernel-unable-to-test-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

Please let us know your results. Thank you for your understanding.

Helpful Bug Reporting Tips:
https://help.ubuntu.com/community/ReportingBugs

summary: - AMD RADEON HD 6450 random pixels on display
+ 1002:6779 AMD RADEON HD 6450 random pixels on display
tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.