"Shift with Numeric Keypad works as in MS Windows" implemented partially

Bug #802028 reported by Max Vlasov
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I usually use Control-Insert, Shift-Insert as the keys for clipboard operations, but Insert in my case is on numeric keypad (Num Lock Off). If I use it as by default, Ctrl-Insert works, Shift-Insert enters 0. If I activate "Shift with Numeric Keypad works as in MS Windows" option, both key sequences don't work. (On Windows Insert key on the numeric keypad always works for Ctrl-Ins,Shift-Ins clipboard command)

Note: I suppose it has something to do with standard controls (edit, memo) used in general applications (for example Places-Search for files field, entering name of a new folder, gedit). In application with its own controls (Firefox, LibreOffice Write), Control-(Numeric)Insert, Shift-(Numeric)Insert work correctly. So I supposedly should choose "gtk" package, but there's no with exactly this name.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-8-generic 2.6.38-8.42
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC2: maxim 1368 F.... pulseaudio
 /dev/snd/controlC0: maxim 1368 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'CMI8738'/'C-Media CMI8738 (model 55) at 0xc000, irq 21'
   Mixer name : 'CMedia PCI'
   Components : ''
   Controls : 41
   Simple ctrls : 22
Card1.Amixer.info:
 Card hw:1 'UART'/'MPU-401 UART at 0x330, irq 10'
   Mixer name : ''
   Components : ''
   Controls : 0
   Simple ctrls : 0
Card1.Amixer.values:

Card2.Amixer.info:
 Card hw:2 'I82801DBICH4'/'Intel 82801DB-ICH4 with ALC655 at irq 17'
   Mixer name : 'Realtek ALC655 rev 0'
   Components : 'AC97a:414c4760'
   Controls : 41
   Simple ctrls : 26
CurrentDmesg:
 [ 29.700423] agpgart-intel 0000:00:00.0: AGP 2.0 bridge
 [ 29.700454] agpgart-intel 0000:00:00.0: putting AGP V2 device into 4x mode
 [ 29.700502] nvidia 0000:01:00.0: putting AGP V2 device into 4x mode
 [ 36.128040] eth0: no IPv6 routers present
 [ 36.433069] EXT4-fs (loop0): re-mounted. Opts: errors=remount-ro,commit=0
Date: Sat Jun 25 23:54:44 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
MachineType: ASUSTeK Computer INC. P4GE-MX
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=2478A4F578A4C6C0 loop=/hostname/disks/root.disk ro quiet splash
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-8-generic N/A
 linux-backports-modules-2.6.38-8-generic N/A
 linux-firmware 1.52
RfKill:

SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/29/2005
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: ASUS P4GE-MX ACPI BIOS Revision 1007
dmi.board.name: P4GE-MX
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: 2.xx
dmi.chassis.asset.tag: 123456789000
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrASUSP4GE-MXACPIBIOSRevision1007:bd08/29/2005:svnASUSTeKComputerINC.:pnP4GE-MX:pvr2.xx:rvnASUSTeKComputerINC.:rnP4GE-MX:rvr2.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: P4GE-MX
dmi.product.version: 2.xx
dmi.sys.vendor: ASUSTeK Computer INC.

Revision history for this message
Max Vlasov (max-vlasov) wrote :
Brad Figg (brad-figg)
Changed in linux (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers