Macbook Bluetooth not working

Bug #800697 reported by Jussi Pakkanen on 2011-06-22
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

My Macbook pro has a built-in Bluetooth adapter that works in OSX. In Ubuntu it does not work. Bluetooth applet says that no Bluetooth adapters are plugged in.

When I plug in an external Bluetooth adapter, it works.

This is in natty but I tried oneiric alpha cd and it does not work either.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-8-generic 2.6.38-8.42
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: jpakkane 1675 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xa0900000 irq 47'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:10134206,106b1c00,00100302 HDA:80862805,80860101,00100000'
   Controls : 34
   Simple ctrls : 16
Date: Wed Jun 22 16:41:40 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110413)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.

 vboxnet0 no wireless extensions.
MachineType: Apple Inc. MacBookPro8,1
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/zsh
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=2ee94f0e-11b3-42a2-a009-1a9b94b11fc9 ro quiet splash drm.debug=0xe vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-8-generic N/A
 linux-backports-modules-2.6.38-8-generic N/A
 linux-firmware 1.52
RfKill:

SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/22/11
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBP81.88Z.0047.B0E.1104221557
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-94245B3640C91C81
dmi.board.vendor: Apple Inc.
dmi.board.version: MacBookPro8,1
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-94245B3640C91C81
dmi.modalias: dmi:bvnAppleInc.:bvrMBP81.88Z.0047.B0E.1104221557:bd04/22/11:svnAppleInc.:pnMacBookPro8,1:pvr1.0:rvnAppleInc.:rnMac-94245B3640C91C81:rvrMacBookPro8,1:cvnAppleInc.:ct10:cvrMac-94245B3640C91C81:
dmi.product.name: MacBookPro8,1
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

Jussi Pakkanen (jpakkane) wrote :
Brad Figg (brad-figg) on 2011-06-22
Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: iso-testing
Jussi Pakkanen (jpakkane) wrote :

I installed natty-proposed and now it works.

Jussi Pakkanen (jpakkane) wrote :

When using Oneiric alpha 2 ISO the adapter is detected but it sees no devices and thus can't pair with them.

Hi Jussi,

Do any interesting error messages appear in the logs with the oneiric kernel when you're unable to pair? Thanks.

Jussi Pakkanen (jpakkane) wrote :

I tried again with the same CD and could not reproduce this issue. The adapter sees devices and can pair with them. I tried about 4 times and it always worked.

Ok cool. I'm going to go ahead and close this bug out then since it appears to be resolved (at least unreproducible) for Oneiric.

For Natty, the kernel which was in natty-proposed has since been promoted to -updates (2.6.38-10.46). So this should now be resolved in Natty for you as well based on comment #2. Thanks.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers