Ethernet card in the Acer ICONIA TAB W500 is not recognized

Bug #800457 reported by Pablo Javier on 2011-06-21
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Kernel does not recognize the card. I did the testing under Case ID: hcn-001 and did not work. Furthermore, I tried modprobing asix (which found could be the driver) and still did not appear in ifconfig.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-8-generic 2.6.38-8.42
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
NonfreeKernelModules: fglrx
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 1: SB [HDA ATI SB], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: pablo 1495 F.... pulseaudio
CRDA: Error: [Errno 2] No existe el fichero o el directorio
Card0.Amixer.info:
 Card hw:0 'Generic'/'HD-Audio Generic at 0x90144000 irq 40'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 4
   Simple ctrls : 1
Card0.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Card1.Amixer.info:
 Card hw:1 'SB'/'HDA ATI SB at 0x90140000 irq 16'
   Mixer name : 'Realtek ALC269VB'
   Components : 'HDA:10ec0269,10250577,00100100'
   Controls : 12
   Simple ctrls : 7
Date: Tue Jun 21 18:36:33 2011
HibernationDevice: RESUME=UUID=d926e265-edab-4a5a-acca-4d19412dba53
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
MachineType: acer ICONIA Tab W500P
ProcEnviron:
 LANGUAGE=es_PA:en
 LANG=es_AR.UTF-8
 LC_MESSAGES=es_PA.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=4274b4dd-bdea-45b5-9067-af283d299e96 ro splash quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-8-generic N/A
 linux-backports-modules-2.6.38-8-generic N/A
 linux-firmware 1.52
RfKill:
 1: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/24/2011
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: EAB00V1.05
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: WT1
dmi.board.vendor: acer
dmi.board.version: Base Board Version
dmi.chassis.type: 10
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsydeCorp.:bvrEAB00V1.05:bd02/24/2011:svnacer:pnICONIATabW500P:pvrEAB00V1.05:rvnacer:rnWT1:rvrBaseBoardVersion:cvnChassisManufacturer:ct10:cvrChassisVersion:
dmi.product.name: ICONIA Tab W500P
dmi.product.version: EAB00V1.05
dmi.sys.vendor: acer

Pablo Javier (pablojavier) wrote :
Brad Figg (brad-figg) on 2011-06-21
Changed in linux (Ubuntu):
status: New → Confirmed
Pavel Borecki (pavel-borecki) wrote :

This device is from ASIX, concretely AX88772B chip, see http://www.asix.com.tw/products.php?op=pItemdetail&PItemID=105;71;101&PLine=71
There is also the Linux driver available for download (in source code form) which is licensed by GPL2+. I can confirm its functionality under Natty (i386) in this tablet device dock - it would be great to see it backported into Natty kernel.

Pavel Borecki (pavel-borecki) wrote :

Support for this device was added to upstream:
 https://github.com/torvalds/linux/commit/308859097831831a979f2e82cbeef0a94f438080#drivers/net/usb/asix.c

Please, backport it into Oneric kernel.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/800457

tags: added: laptop-testing

Pablo Javier, thank you for reporting this and helping make Ubuntu better. This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers