bug grp_led:scroll

Bug #796155 reported by Pavlo Bohmat on 2011-06-12
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

After the upgrade, straying backlight display keyboard. grp_led: scroll works with ru, ua, but then begins to burn on the en, ru. As if the default layout is ua instead of en. Retrieved on fluxbox1.3.1 + fbxkb and Unity 3.8.14. After restarting the X server, everything comes back to normal.

/etc/X11/xorg.conf:
Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us,ru,ua"
    Option "XkbVariant" ",winkeys,winkeys"
    Option "XkbOptions" "grp:menu_toggle,grp_led:scroll"
EndSection

После обновления, сбивается подсветка индикации раскладки клавиатуры. grp_led:scroll работает с ru,ua, но потом начинает гореть на en,ru. Как будто раскладкой по умолчанию становится ua вместо en. Проверено на fluxbox1.3.1+fbxkb и Unity 3.8.14. После перезагрузки Х сервера, все приходит в норму.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xorg 1:7.6+4ubuntu3
ProcVersionSignature: Ubuntu 2.6.39-3.10-generic 2.6.39
Uname: Linux 2.6.39-3-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Это каталог: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 270.41.06 Mon Apr 18 14:53:56 PDT 2011
 GCC version: gcc version 4.6.1 (Ubuntu/Linaro 4.6.0-7ubuntu1)
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,imgpng,grid,vpswitch,compiztoolbox,commands,regex,place,mousepoll,snap,unitymtgrabhandles,move,gnomecompat,session,resize,wall,animation,workarounds,expo,ezoom,staticswitcher,fade,scale,unityshell]
CompositorRunning: None
Date: Sun Jun 12 12:37:31 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current, 270.41.06, 2.6.39-3-generic, x86_64: installed
 vboxhost, 4.0.8, 2.6.39-3-generic, x86_64: installed
GraphicsCard:
 nVidia Corporation NV43 [GeForce 6600] [10de:0141] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: LeadTek Research Inc. Device [107d:2001]
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
JockeyStatus:
 xorg:nvidia_173 - Драйвер ускоренной графики NVIDIA (Проприетарные, Выключен, Не используется)
 xorg:nvidia_current - Драйвер ускоренной графики NVIDIA (Проприетарные, Выключен, Не используется)
MachineType: Gigabyte Technology Co., Ltd. GA-MA785GMT-UD2H
ProcEnviron:
 LANGUAGE=ru_UA:ru:en_GB:en
 PATH=(custom, no user)
 LANG=ru_UA.utf8
 LC_MESSAGES=ru_UA.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.39-3-generic root=UUID=04f9caf0-db00-4d7f-8fe0-b819233a856c ro vga=791 quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/30/2009
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F5
dmi.board.name: GA-MA785GMT-UD2H
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF5:bd11/30/2009:svnGigabyteTechnologyCo.,Ltd.:pnGA-MA785GMT-UD2H:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-MA785GMT-UD2H:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-MA785GMT-UD2H
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.compiz: compiz 1:0.9.4+bzr20110606-0ubuntu3
version.ia32-libs: ia32-libs 20090808ubuntu13
version.libdrm2: libdrm2 2.4.25-2ubuntu2
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Pavlo Bohmat (bohm) wrote :
bugbot (bugbot) on 2011-06-12
affects: xorg (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
Bryce Harrington (bryce) wrote :

Hi Pavlo Bohmat,
Hmm... I'm not sure I totally understand your description of the problem. Could you please elaborate and clarify? You may find it helpful to read "How to report bugs effectively" http://www.chiark.greenend.org.uk/~sgtatham/bugs.html or the Ubuntu-X bug reporting guidelines at http://wiki.ubuntu.com/X/Reporting .

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Incomplete
Pavlo Bohmat (bohm) wrote :

On the keyboard light "scroll" to burn in the languages ​​ru, ua. But the setting gets off to en, ru. On the Nvidia driver very often, and with the driver xserver-xorg-video-ati is very rare, but it happens.

Bryce Harrington (bryce) wrote :

Hmm, ok well if it affects -ati as well, it's probably something lower down in the stack. Guessing the kernel.

affects: nvidia-graphics-drivers (Ubuntu) → linux (Ubuntu)
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
Pavlo Bohmat (bohm) wrote :

again dist-upgrade (Mon Sep 19 10:20:26 EEST 2011) the problem persists, but less frequently.

Linux 3.0.0-11-generic #18-Ubuntu SMP Tue Sep 13 23:38:01 UTC 2011 x86_64
xserver-xorg-video-ati_6.14.99~git20110811.g93fc084-0ubuntu1_amd64.deb

Pavlo Bohmat (bohm) wrote :
To post a comment you must log in.