Ubuntu

Adaptec 39320D slows down boot

Reported by karaluh on 2007-01-16
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
Jaunty
Medium
Tim Gardner

Bug Description

Dapper, 2.6.15-27-386. System freezes for 41 seconds on "Mounting root filesystem". I've found, that it's happening because of Adaptec's 39320D SCSI card. If it's pluged out, system boots normaly. Google, forum.ubuntu.pl and ubuntuforums.org weren't helpful. I used dmesg and peace of paper and got this:

 [17179578.776000] P0P4 MC97 USB1 USB2 USB3 USB4 EUSB PS2K PS2M ILAN
 [17179578.776000] ACPI: (supports S0 S1 S3 S4 S5)
 [17179578.776000] Freeing unused kernel memory: 288k freed
 [17179578.824000] Capability LSM initialized
 [17179579.332000] SCSI subsystem initialized
 [17179579.336000] ACPI: PCI Interrupt 0000:02:0a.0[A] -> GSI 22 (level, low) -> IRQ 169

 boot stops here for a while

 [17179594.564000] scsi0 : Adaptec AIC79XX PCI-X SCSI HBA DRIVER, Rev 3.0
 [17179594.564000] <Adaptec 39320D Ultra320 SCSI adapter>
 [17179594.564000] aic7902: Ultra320 Wide Channel A, SCSI Id=7, PCI 33 or 66Mhz, 512 SCBs
 [17179594.564000]
 [17179597.904000] Vendor: FUJITSU Model: MAP3367NP Rev: 0108
 [17179597.908000] Type: Direct-Access ANSI SCSI revision: 03
 [17179597.908000] target0:0:14: asynchronous
 [17179597.908000] scsi0:A:14:0: Tagged Queuing enabled. Depth 32
 [17179597.908000] target0:0:14: Beginning Domain Validation
 [17179597.912000] target0:0:14: wide asynchronous
 [17179597.912000] target0:0:14: FAST-160 WIDE SCSI 320.0 MB/s DT IU QAS PCOMP (6.25 ns, offset 127)
 [17179597.928000] target0:0:14: Ending Domain Validation
 [17179597.932000] Vendor: FUJITSU Model: MAP3367NP Rev: 0108
 [17179597.932000] Type: Direct-Access ANSI SCSI revision: 03
 [17179597.932000] target0:0:15: asynchronous
 [17179597.932000] scsi0:A:15:0: Tagged Queuing enabled. Depth 32
 [17179597.932000] target0:0:15: Beginning Domain Validation
 [17179597.936000] target0:0:15: wide asynchronous
 [17179597.940000] target0:0:15: FAST-160 WIDE SCSI 320.0 MB/s DT IU QAS PCOMP (6.25 ns, offset 127)
 [17179597.956000] target0:0:15: Ending Domain Validation
 [17179597.960000] ACPI: PCI Interrupt 0000:02:0a.1[b] -> GSI 23 (level, low) -> IRQ 177

 boot stops here for a while

 [17179613.188000] scsi1 : Adaptec AIC79XX PCI-X SCSI HBA DRIVER, Rev 3.0
 [17179613.188000] <Adaptec 39320D Ultra320 SCSI adapter>
 [17179613.188000] aic7902: Ultra320 Wide Channel B, SCSI Id=7, PCI 33 or 66Mhz, 512 SCBs
 [17179613.188000]
 [17179617.068000] Driver 'sd' needs updating - please use bus_type methods
 [17179617.072000] SCSI device sda: 71775284 512-byte hdwr sectors (36749 MB)
 [17179617.072000] SCSI device sda: drive cache: write back
 [17179617.076000] SCSI device sda: 71775284 512-byte hdwr sectors (36749 MB)
 [17179617.080000] SCSI device sda: drive cache: write back
 [17179617.080000] sda: sda1 sda2 sda3 < sda5 sda6 > sda4
 [17179617.104000] sd 0:0:14:0: Attached scsi disk sda
 [17179617.104000] SCSI device sdb: 71775284 512-byte hdwr sectors (36749 MB)
 [17179617.104000] SCSI device sdb: drive cache: write back
 [17179617.108000] SCSI device sdb: 71775284 512-byte hdwr sectors (36749 MB)
 [17179617.112000] SCSI device sdb: drive cache: write back
 [17179617.112000] sdb: sdb1 sdb2 sdb3 < sdb5 sdb6 > sdb4
 [17179617.132000] sd 0:0:15:0: Attached scsi disk sdb
 [17179617.348000] ICH5: IDE controller at PCI slot 0000:00:1f.1

karaluh (karaluh) wrote :

Newest Mandriva Live CD is also affected, so i think it's a kernel or driver bug.

Changed in linux:
status: Unknown → Confirmed
karaluh (karaluh) wrote :

> This sounds like a user configuration error. The adaptec has a bus
> settle time in its initialisation path. Originally it was 20s, hence
> for a D card (twin channel) it would take about 50s to come online
> (extra 5s to scan per channel). There was a lot of argument about this,
> and the value was finally made configurable as
>
> CONFIG_AIC79XX_RESET_DELAY_MS
>
> I suspect you have this set to around 15000. You can make the boot
> sequence shorter by reducing this value. I believe Red Hat configures
> it down to the default 5000.

Can Ubuntu do it the Red Hat way?

Changed in linux:
status: Confirmed → Rejected
karaluh (karaluh) on 2007-05-15
Changed in linux-source-2.6.15:
status: Unconfirmed → Confirmed
karaluh (karaluh) wrote :

It's a simple default value change in CONFIG_AIC79XX_RESET_DELAY_MS, and is still not fixed in 2.6.20-16

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this linux-source-2.6.15 kernel bug to the new "linux" package. We appreciate your patience and understanding as we make this transition. Also, if you would be interested in testing the upcoming Intrepid Ibex 8.10 release, it is available at http://www.ubuntu.com/testing . Please let us know your results. Thanks!

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

karaluh (karaluh) wrote :

This bug is still not fixed in Intrepid. Even worse, it's impossible to boot with 2.6.27, because busybox is started before kernel finishes initialisation.

I just wanted to update this report with a comment from the duplicate bug. Karaluh mentioned, "when I increase bootdelay the kernel boots fine."

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Confirmed → Triaged

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

karaluh (karaluh) wrote :

Still not fixed in Jaunty.

Tim Gardner (timg-tpi) wrote :
Changed in linux (Ubuntu Jaunty):
assignee: nobody → Tim Gardner (timg-tpi)
status: Triaged → In Progress
karaluh (karaluh) wrote :

Provided kernel seems to be working fine, the bug is gone and I can remove the rootdelay option. There are no visible regressions. I'll be using this kernel on a daily basis in production, if any problem pops up I'll post it here.

Tim Gardner (timg-tpi) wrote :

SRU Justification

Impact: System is slow to boot
Patch Description: Change aic79xx reset delay config option to Kconfig default
Patch: attached

Test Case: See bug description

Stefan Bader (smb) on 2009-04-29
Changed in linux (Ubuntu Jaunty):
status: In Progress → Fix Committed
Tim Gardner (timg-tpi) wrote :

Already fixed upstream

Changed in linux (Ubuntu):
assignee: Tim Gardner (timg-tpi) → nobody
importance: Medium → Undecided
status: In Progress → Fix Released
Changed in linux:
status: New → Fix Released
Steve Langasek (vorlon) wrote :

Accepted linux into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Steve Beattie (sbeattie) on 2009-05-01
tags: added: hw-specific
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.28-13.44

---------------
linux (2.6.28-13.44) jaunty-proposed; urgency=low

  [ Stefan Bader ]

  * Revert "SAUCE: [jaunty] ALSA: Add retry for Intel8x0 clock measurement"
  * Revert "SAUCE: [jaunty] ALSA: Fix clock and buffer calculations for
    Intel8x0"
  * Revert "SAUCE: [jaunty] ALSA: Fix buffer positions and checks"

linux (2.6.28-12.43) jaunty-proposed; urgency=low

  [ Amit Kucheria ]

  * Enable SYN_COOKIES for iop32x and versatile flavours
    - LP: #361687
  * SAUCE: Quirk for BT USB device on MacbookPro to be reset before use
    - LP: #332443

  [ Brad Figg ]

  * [jaunty] Add missing mvsas (Marvel SAS 6440) module configuration.
    - LP: #352336

  [ Chuck Short ]

  * SAUCE: [USB] Unusual Device support for Gold MP3 Player Energy
    - LP: #125250

  [ Daniel T Chen ]

  * SAUCE: [jaunty] ALSA: Fix buffer positions and checks
    - LP: #345627
  * SAUCE: [jaunty] ALSA: Fix clock and buffer calculations for Intel8x0
    - LP: #345627
  * SAUCE: [jaunty] ALSA: Add retry for Intel8x0 clock measurement
    - LP: #345627

  [ Luke Yelavich ]

  * disable CONFIG_SND_HDA_INPUT_BEEP on amd64 and i386
    - LP: #331589

  [ Makito SHIOKAWA ]

  * [ARM] 5404/1: Fix condition in arm_elf_read_implies_exec() to set
    READ_IMPLIES_EXEC
    - LP: #364358

  [ Manoj Iyer ]

  * SAUCE: Added quirk to fix key release for Samsung NC20
    - LP: #360247

  [ Oleg Nesterov ]

  * posix timers: fix RLIMIT_CPU && fork()
    - LP: #361508

  [ Scott James Remnant ]

  * [Config] Disable libusual and the ub driver
    - LP: #364538

  [ Stefan Bader ]

  * Disable unwanted staging builds
    - LP: #366144
  * Remove prism2_usb driver from ubuntu and use the one from staging
    - LP: #325366
  * SAUCE: Make rtl8187se depend on WIRELESS_EXT
    - LP: #366144
  * Disable CONFIG_RTL8187SE for armel.versatile
    - LP: #366144

  [ Tejun Heo ]

  * libata: handle SEMB signature better
    - LP: #257790

  [ Tim Gardner ]

  * Set USB_SERIAL=m for i386/amd64
    - LP: #345002
  * SAUCE: Jaunty - aic79xx - set reset delay to 5 seconds, down from 15.
    - LP: #79542
  * SAUCE: (drop after 2.6.28) Wifi suspend/resume scan timeout fixes
    - LP: #336055
  * Sony laptop: Sony Vaio laptops do not enable wwan power by default.
    - LP: #364678

  [ Tyler Hicks ]

  * SAUCE: (drop after 2.6.28) eCryptfs: Larger buffer for encrypted
    symlink targets
    - LP: #357345

  [ Upstream Kernel Changes ]

  * V4L/DVB (9999): gspca - zc3xx: Webcam 046d:089d added.
    - LP: #326674
  * V4L/DVB (10044): gspca - pac7311: Webcam 093a:2620 added.
    - LP: #363195
  * hwmon: (it87) Add support for the ITE IT8720F
    - LP: #357766
  * vgacon: Return the upper half of 512 character fonts
    - LP: #355057
  * drm/i915: add support for G41 chipset
    - LP: #365958

 -- Stefan Bader <email address hidden> Mon, 25 May 2009 17:30:40 +0200

Changed in linux (Ubuntu Jaunty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.