Ubuntu

Kernel 2.6.38 doesn't boot showing either a black screen or junk

Reported by Luca Carlon on 2011-05-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-ati

This has happened immediately after I upgraded to Ubuntu 11.04. Kernel 2.6.38 is not booting and shows junk on the screen.
I tried a USB pendrive (USB pendrive works with Ubuntu 10.10) and I get a black screen.

After grub has disappeared the system starts booting, and after some seconds I get a screen screwed up. Cannot switch to virtual terminals and cannot connect via ssh.
With the USB pendrive more or less the same happens. After I click start, nothing else appears on the screen and the boot procedure stops.

The only way I found to get both systems start is to add nomodeset parameter. With this the system starts.
The same system starts with kernel 2.6.35 without the nomodeset parameter. Anyway, since I upgraded to Ubuntu 11.04, I'm experiencing some sudden logouts and frequent complete screen freeze when in dual screen.

The Ubuntu kernel team suggested to try kernel 2.6.39-020639rc7-generic. This is working correctly it seems.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
Uname: Linux 2.6.39-020639rc7-generic i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
DRM.card0.DIN.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI.A.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1280x800 1280x720 1152x768 1024x768 800x600 848x480 720x480 640x480
 edid-base64: AP///////wAyDCABAAAAAAASAQOAIRV4ChRlmFlTiygjUFQAAAABAQEBAQEBAQEBAQEBAQEBEhsAiFAgEDAwGDYAS88QAAAZAAAAAAAAAAAAAAAAAAAAAAAAAAAA/gBMR1BoaWxpcHNMQ0QKAAAA/ABMUDE1NFdYNC1UTEM4AEg=
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: Off
 modes: 1920x1080 1680x1050 1280x1024 1280x1024 1152x864 1024x768 1024x768 800x600 800x600 640x480 640x480 720x400
 edid-base64: AP///////wAebd9XCFUAAAgUAQNsMBt46pU1oVlXnycOUFSlSwCzAIGAgY9xTwEBAQEBAQEBAjqAGHE4LUBYLEUA3QwRAAAeAAAA/QA4Sx5TDwAKICAgICAgAAAA/ABFMjI2MAogICAgICAgAAAA/wAwMDhMTkxDME03NjgKACo=
Date: Tue May 17 18:44:24 2011
DistUpgraded: Log time: 2011-04-30 01:41:39.098164
DistroCodename: natty
DistroVariant: ubuntu
GraphicsCard:
 ATI Technologies Inc Mobility Radeon HD 3400 Series [1002:95c4] (prog-if 00 [VGA controller])
   Subsystem: Toshiba America Info Systems Device [1179:ff1e]
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release i386 (20100816.1)
MachineType: TOSHIBA Satellite Pro A300
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
 LANGUAGE=en_US:en
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.39-020639rc7-generic root=UUID=4635bd6c-8c24-4f5f-b2f6-02c1bd5d5ec8 ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xserver-xorg-video-ati
UpgradeStatus: Upgraded to natty on 2011-04-30 (17 days ago)
dmi.bios.date: 12/07/2009
dmi.bios.vendor: INSYDE
dmi.bios.version: 2.20
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Portable PC
dmi.board.vendor: TOSHIBA
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnINSYDE:bvr2.20:bd12/07/2009:svnTOSHIBA:pnSatelliteProA300:pvrPSAGDE-02C002IT:rvnTOSHIBA:rnPortablePC:rvrBaseBoardVersion:cvnChassisManufacturer:ct10:cvrChassisVersion:
dmi.product.name: Satellite Pro A300
dmi.product.version: PSAGDE-02C002IT
dmi.sys.vendor: TOSHIBA
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Luca Carlon (carlon-luca) wrote :
Timo Aaltonen (tjaalton) wrote :

Hey, as I said on irc we need the /var/log/kern.log that contains the kernel boot messages with the bad kernel. Add 'drm.debug=14' to the kernel boot options, so that the kern.log would contain plenty of debugging information. Attach the logfile here.

Changed in xserver-xorg-video-ati (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
status: New → Incomplete
Luca Carlon (carlon-luca) wrote :

Hi! I tried to attach it, but I need help to get it. VTs are not available and ssh is not working. I don't have any other kern.log other than the one related to the last boot. I suppose it is overwritten. Can I avoid that somehow?

Timo Aaltonen (tjaalton) wrote :

you could also try booting 2.6.38 with adding 'i2c-algo-bit.bit_test=0' to the kernel boot options.. does it help?

Timo Aaltonen (tjaalton) wrote :

just boot it with the good kernel and look for the kern.log.* that has the boot information from the bad kernel.. If there's just one then attach that one.

Timo Aaltonen (tjaalton) wrote :

actually, I'm pretty sure this is fixed in the upcoming natty kernel version. You can try another mainline kernel from here:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.38.6-natty/

Luca Carlon (carlon-luca) wrote :

I tried adding 'i2c-algo-bit.bit_test=0' and update-grub but nothing changed.

I tried again to get a log but it seems like the 2.6.38 prints no log information. The kern.log I'm attaching is the result of more boots, some with 2.6.39 and some with 2.6.38. Only logs from 2.6.39 are there...

It seems, after some hours of usage, that some other issues with graphics drivers I was having with kernel 2.6.35 after upgrading to Ubuntu 11.04 are disappeared with 2.6.39. Like sudden logouts and complete screen freeze when in dual screen.

Luca Carlon (carlon-luca) wrote :

With 2.6.38-02063806-generic the system boots successfully.

Timo Aaltonen (tjaalton) wrote :

Ok, so the machine hung before the logs were flushed to disk. And it's good to know that the mainline 2.6.38.6 kernel fixed it for you, that version should hit the archive at some point.

affects: xserver-xorg-video-ati (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
assignee: Timo Aaltonen (tjaalton) → nobody
importance: Undecided → High
status: Incomplete → Triaged
Julian Wiedmann (jwiedmann) wrote :

Luca:
can you confirm that this is fixed with natty's latest kernel (2.6.38-10.46)?

Luca Carlon (carlon-luca) wrote :

Yes, I confirm that 2.6.38-10.46 solves this issue.

Changed in linux (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers