USB 3.0 devices not working behind USB 3.0 HUBs

Bug #783097 reported by Eduard Hasenleithner on 2011-05-15
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I have both a Western Digital MyPassport Essential 500GB harddisk and a Seagate FreeAgent GoFlex Desk 2TB working ok on my ASUS U3S6 XHCI controller in USB 3.0 mode. Currently I'm using ubuntu 10.04 (Lucid).

When I disconnect the devices, and connect a USB 3.0 hub (DeLock USB 3.0 External HUB 4 Port), the HUB is detected by linux, but no USB 3.0 devices (i.e. the mentioned HDDs) connected to said HUB. USB 2.0 devices connected to the HUB are detected and working properly, though. When connecting the hub, 2109:0810 and 2109:3431 appear in "lsusb".

I've got the HUB working in 3.0 mode by means of compiling a kernel from git: dbe79bbe9dcb22cb3651c46f18943477141ca452 (USB 3.0 Hub Changes). I'm not 100% sure if this is the exact commit enabling USB 3.0 HUB operation, but there is strong evidence for it. If this is "the fix", the next ubuntu release (11.10) will likely support USB 3.0 HUBs "out of the box".

In addition to 10.04, I also tried the HUB on 11.04 (natty), observing the same problem. For now I'll omit the "default" system information, because I believe the problem is not related to my particular hardware setup. If you request, I'm happy to submit this information too.
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: eduard 2509 F.... pulseaudio
CRDA: Error: [Errno 2] Datei oder Verzeichnis nicht gefunden
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xf9ff4000 irq 16'
   Mixer name : 'Analog Devices AD1988B'
   Components : 'HDA:11d4198b,1043829b,00100400'
   Controls : 48
   Simple ctrls : 27
Card1.Amixer.info:
 Card hw:1 'DMX6Fire'/'TerraTec DMX6Fire at 0xe800, irq 21'
   Mixer name : 'ICE1712 - multitrack'
   Components : ''
   Controls : 77
   Simple ctrls : 51
DistroRelease: Ubuntu 10.04
HibernationDevice: RESUME=UUID=2469877a-02d2-4be6-813f-27f2d5ad992a
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100427.1)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.

 virbr0 no wireless extensions.
MachineType: System manufacturer System Product Name
NonfreeKernelModules: nvidia
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-33-generic root=UUID=53ba0584-86de-470e-928e-3a12ac9c278c ro ahci.marvell_enable=1
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=de_AT.UTF-8
ProcVersionSignature: Ubuntu 2.6.32-33.70-generic 2.6.32.41+drm33.18
Regression: No
RelatedPackageVersions: linux-firmware 1.34.7
Reproducible: Yes
RfKill:

Tags: lucid needs-upstream-testing
Uname: Linux 2.6.32-33-generic x86_64
UserGroups: adm admin audio cdrom cyberjack dialout dip fuse libvirtd netdev plugdev sambashare src video
dmi.bios.date: 11/21/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1406
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: M3A32-MVP DELUXE
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1406:bd11/21/2008:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM3A32-MVPDELUXE:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

For experiment, I upgraded now my natty (test) install to oneiric (11.10). Oneiric uses linux-image-2.6.39-2, and is therefore supposed to contain the patch.

The result: as suspected, the USB 3.0 HUB works! I can now mount and read/write the USB 3.0 HDDs connected to the HUB.

This bug is missing log files that will aid in dianosing the problem. From a terminal window please run:

apport-collect 783097

and then change the status of the bug back to 'New'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → New
Brad Figg (brad-figg) on 2011-07-19
Changed in linux (Ubuntu):
status: New → Confirmed

Eduard Hasenleithner, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. As well, please comment on which kernel version specifically you tested.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream', and comment as to why specifically you were unable to test it.

Please let us know your results. Thanks in advance.

Helpful Bug Reporting Links:
https://help.ubuntu.com/community/ReportingBugs#Bug_Reporting_Etiquette
https://help.ubuntu.com/community/ReportingBugs#A3._Make_sure_the_bug_hasn.27t_already_been_reported
https://help.ubuntu.com/community/ReportingBugs#Adding_Apport_Debug_Information_to_an_Existing_Launchpad_Bug
https://help.ubuntu.com/community/ReportingBugs#Adding_Additional_Attachments_to_an_Existing_Launchpad_Bug

tags: added: lucid natty needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete

There is no need to test this with the newest release, since I already reported success with oneiric. But to my knowledge, the problem still exists with the previous LTS release (10.04) which is still in support. It is really a pity that one cannot report bugs on specific ubuntu (LTS) releases.

Nevertheless, since I can use my USB3.0 equipment to the full extend I'm marking this as fixed.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers