"acpi_backlight=vendor" needs to be present in kernel cmdline to have backlight working

Bug #780625 reported by Marcin Juszkiewicz
This bug affects 11 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)

Bug Description

On my laptop I had to add "acpi_backlight=vendor" into kernel cmdline to get working backlight. This state is since beginning (10.04 + maverick kernels during uds-m).

If I remove that argument then /sys/class/backlight/acpi_video0/ is created instead of 'asus_laptop' one and changing backlight by hardware keys works randomly - pressing BacklightUp does nothing or decrease or increase level (same with BacklightDown key).

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: linux-image-2.6.39-1-generic 2.6.39-1.6
ProcVersionSignature: Ubuntu 2.6.39-1.6-generic 2.6.39-rc6
Uname: Linux 2.6.39-1-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
Architecture: amd64
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
 /dev/snd/controlC0: hrw 2993 F.... xfce4-volumed
                      hrw 3012 F.... pulseaudio
 Card hw:0 'Intel'/'HDA Intel at 0xfe9f4000 irq 46'
   Mixer name : 'Intel Cantiga HDMI'
   Components : 'HDA:10ec0269,10431443,00100004 HDA:80862802,80860101,00100000'
   Controls : 15
   Simple ctrls : 8
Date: Tue May 10 18:26:48 2011
HibernationDevice: RESUME=UUID=042b5e75-5bf6-43a9-b93d-957be35f77ec
MachineType: ASUSTeK Computer Inc. UL30A
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-2.6.39-1-generic root=/dev/mapper/hostname-rootfs ro loop.max_loop=256 acpi_backlight=vendor loglevel=0 crashkernel=384M-2G:64M,2G-:128M quiet
 linux-restricted-modules-2.6.39-1-generic N/A
 linux-backports-modules-2.6.39-1-generic N/A
 linux-firmware 1.52
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/28/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 212
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: UL30A
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: ATN12345678901234567
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr212:bd12/28/2009:svnASUSTeKComputerInc.:pnUL30A:pvr1.0:rvnASUSTeKComputerInc.:rnUL30A:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0:
dmi.product.name: UL30A
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.

Revision history for this message
Marcin Juszkiewicz (hrw) wrote :
Brad Figg (brad-figg)
Changed in linux (Ubuntu):
status: New → Confirmed
Revision history for this message
Kamal Mostafa (kamalmostafa) wrote :


You may wish to try my 'linux-kamal-mjgbacklight' PPA:
It provides:
1. A patched kernel which supplies a new /sys/class/backlight/intel_backlight (backported bits from 2.6.39 plus an additional yet-to-land-upstream patch). The patched kernel forces "acpi_backlight=vendor" internally (i.e. it disables acpi_video0). I'm hoping that these patches will all land in Oneiric.
2. A patched gnome-power-manager which connects the brightness keys to the new intel_backlight interface.

See also bug LP: #568611, where other users of this PPA have logged their findings.

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Revision history for this message
Anton Keks (anton-azib) wrote :

On my Toshiba Satellite R830, I can't change brightness after returning from sleep with Fn-keys, but echoing numbers to /sys/class/backlight/intel_backlight/brightness does change the brightness properly.
It seems that Fn keys write to /sys/class/backlight/acpi_video0/brightness, which doesn't do anything.
Perhaps a fix could be made in Unity (or gnome power manager) to prefer intel_brightness if it's available?

Revision history for this message
Marco Lackovic (marco-lackovic) wrote :

I had this problem on my HP Folio 13 both on the old Ubuntu 12.10 and the new Ubuntu 13.04.

I have fixed it by editing /etc/default/grub and changing:




And eventually by running:

sudo update-grub
sudo reboot

During this entire operation the screen was completely dark. In order to see anything I had to put a very bright lamp against the screen.

I don't see how this bug should be a duplicate of bug #568611. This bug is about the screen back-light not working. Bug #568611 is about the screen controls for increasing and reducing brightness not working.

Revision history for this message
madbiologist (me-again) wrote :

The original reporter's issue should be solved upstream in the 3.10-rc3 kernel. It contains the following patch:

author Bastian Triller 2013-05-19 11:52:33 (GMT)
committer Rafael J. Wysocki 2013-05-22 23:41:45 (GMT)
commit c8f6d8351ba8c89d5cd4c562552ec7ec29274e31 (patch)
tree 6bfe155bb1f67c0c798428c93520eca8973738cf
parent ec4602a9588a196fa1a9af46bfdd37cbf5792db4 (diff)

ACPI / video: Add "Asus UL30A" to ACPI video detect blacklist

Like on UL30VT, the ACPI video driver can't control backlight correctly on Asus UL30A. Vendor driver (asus-laptop) can work. This patch is to add "Asus UL30A" to ACPI video detect blacklist in order to use asus-laptop for video control on the "Asus UL30A" rather than ACPI video driver.

Signed-off-by: Bastian Triller
Cc: All stable
Signed-off-by: Rafael J. Wysocki

Revision history for this message
madbiologist (me-again) wrote :

The abovementioned patch is now also available in the upstream 3.9.5 kernel as commit 4c52865e365e443d2e3ffafb8b41a206d7848e8f

madbiologist (me-again)
Changed in linux (Ubuntu):
status: Incomplete → Fix Committed
Revision history for this message
Julian Wiedmann (jwiedmann) wrote :

Marcin Juszkiewicz,

the commit mentioned in comment #5 has now landed in -updates for precise/quantal/raring. Could you please update your kernel to the latest available version and confirm that this bug is fixed? Thanks.

Changed in linux (Ubuntu):
status: Fix Committed → Incomplete
Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.