Ubuntu

[Lenovo L420/L520] System boots to garbled display

Reported by Marc Legris on 2011-05-04
92
This bug affects 15 people
Affects Status Importance Assigned to Milestone
grub-gfxpayload-lists (Ubuntu)
Undecided
Unassigned
Natty
High
Timo Aaltonen
linux (Ubuntu)
High
Unassigned
Natty
Undecided
Timo Aaltonen

Bug Description

When booting to the desktop, vertical lines will be shown instead of the login screen or desktop. This can be solved by removing splash and quiet from the kernel parameters and adding xforcevesa and nomodeset in their place.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-8-generic 2.6.38-8.42
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1421 F.... pulseaudio
 /dev/snd/pcmC0D0p: ubuntu 1421 F...m pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf0900000 irq 44'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:10ec0269,17aa21de,00100100 HDA:80862805,80860101,00100000'
   Controls : 23
   Simple ctrls : 10
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw 8GHT20WW-1.162000'
   Mixer name : 'ThinkPad EC 8GHT20WW-1.162000'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Wed May 4 12:04:08 2011
HibernationDevice: RESUME=UUID=ffc3236e-8f36-4a66-9d5e-178a06359387
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
MachineType: LENOVO 782723U
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=9e7b9e2b-23f6-4b9f-aed1-9ec00cf534bc ro xforcevesa nomodeset initcall_debug vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-8-generic N/A
 linux-backports-modules-2.6.38-8-generic N/A
 linux-firmware 1.52
SourcePackage: linux
StagingDrivers: rts_pstor
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/09/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8GET28WW (1.05 )
dmi.board.name: 782723U
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8GET28WW(1.05):bd02/09/2011:svnLENOVO:pn782723U:pvrThinkPadL412:rvnLENOVO:rn782723U:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 782723U
dmi.product.version: ThinkPad L412
dmi.sys.vendor: LENOVO

Brad Figg (brad-figg) on 2011-05-04
Changed in linux (Ubuntu):
status: New → Confirmed
Plejaden (plejaden) wrote :

amd64 is also affected.

Chris Van Hoof (vanhoof) on 2011-05-18
tags: added: blocks-hwcert
removed: blocking-hwcert
Changed in linux (Ubuntu):
assignee: nobody → Chris Van Hoof (vanhoof)
importance: Undecided → High
madbiologist (me-again) wrote :

It looks like you have one of the new Intel "Sandy Bridge" APU's:

Intel(R) Core(TM) i5-2540M CPU @ 2.60GHz

The graphics part of this chip is poorly supported in Ubuntu 11.04. Some people have been able to get the desktop to work but there are graphical errors/glitches, and the system crashes when running a game. Unfortunately, you cannot even get to a desktop, perhaps due to the particular display interface used in your laptop. Things improved in the upstream 2.6.39-rc6 kernel but then regressed in 2.6.39-rc7 - see http://www.phoronix.com/scan.php?page=article&item=intel_2639_borks&num=1
It has been reported that the latest code which will be in the upcoming 2.6.40 kernel (it may possibly become the 3.0 kernel) is working again. In the meantime, if you wish to use the 2.6.39 final kernel (available in a PPA at http://kernel.ubuntu.com/~kernel-ppa/mainline/ with a date of 19-May-2011) you can boot it with the i915.semaphores=1 parameter on the GRUB command-line to avoid the regression.

Chris Van Hoof (vanhoof) wrote :

Marc does booting with `i915.semaphores=1' as described in Comment #3 offer any assistance here?

Changed in linux (Ubuntu):
assignee: Chris Van Hoof (vanhoof) → Marc Legris (maaarc)
status: Confirmed → Incomplete

@Chris -- Installing the 2.6.39 kernel and adding the "i915.semaphores=1" does not work, I still see vertical lines instead of the login screen/desktop

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Chris Van Hoof (vanhoof) on 2011-06-10
Changed in linux (Ubuntu):
assignee: Marc Legris (maaarc) → Chris Van Hoof (vanhoof)
gleon (gunther-lengl) wrote :

I found a solution for the Natty-AMD64 - Version, what is probably suitable for the 32Bit-Version as well:

When the Page of the bootmanager Grub2 comes up, press 'e' to edit the grub commands. Delete the line "set gfxpayload=$linux_gfx_mode" and press then F10 to continue the Booting-Process. Then the Lenovo L420 starts normal without loss of display-resolution. (I tried it first with "nomodeset" as kernel parameter, but there the display-resolution suffered.)

Then, you can change the corresponing grub-file permanently:
Open the file: "/boot/grub/grub.cfg" as a superuser and delete here again all the entire entries "set gfxpayload=$linux_gfx_mode" near the keywords "menuentry". (This has to be done several times.)
Be aware: the command "update-grub" cancels maybe these changes (I didn't try that).

gleon (gunther-lengl) wrote :

Sorry, in my description above there is an important point missing:
It is necessery to add "i915.modeset=1" as a further kernel parameter after "splash" (in the Grub2-line which starts with linux /boot/vmlinuz...) This starts the graphic driver for intel graphic devices.
Again, one should add this to the /boot/grub/grub.cfg - file...

Here is the corresponding part of my own grub.cfg-file:

menuentry 'Ubuntu, mit Linux 2.6.38-8-generic' --class ubuntu --class gnu-linux --class gnu --class os {
 recordfail
 insmod part_msdos
 insmod ext2
 set root='(/dev/sda,msdos5)'
 search --no-floppy --fs-uuid --set=root 2bb691c9-...
 linux /boot/vmlinuz-2.6.38-8-generic root=UUID=2bb691c9... ro quiet splash i915.modeset=1 vt.handoff=7
 initrd /boot/initrd.img-2.6.38-8-generic
}
menuentry 'Ubuntu, mit Linux 2.6.38-8-generic (Recovery Mode)' --class ubuntu --class gnu-linux --class gnu --class os {
 recordfail
 insmod part_msdos
 insmod ext2
 set root='(/dev/sda,msdos5)'
 search --no-floppy --fs-uuid --set=root 2bb691c9-...
 echo 'Loading Linux 2.6.38-8-generic ...'
 linux /boot/vmlinuz-2.6.38-8-generic root=UUID=2bb691c9... ro single
 echo 'Loading initial ramdisk ...'
 initrd /boot/initrd.img-2.6.38-8-generic
}

@gleon -- Thanks! Following your steps allows the system to boot to the desktop normally.

Chris Van Hoof (vanhoof) wrote :

Assigning Timo to see why forcing KMS seems to sort things out here on the L420

Changed in linux (Ubuntu):
assignee: Chris Van Hoof (vanhoof) → Timo Aaltonen (tjaalton)
Timo Aaltonen (tjaalton) wrote :

what if you add 'GRUB_GFXPAYLOAD_LINUX=text' to /etc/default/grub (run update-grub to update the actual config) and reboot, does it change anything?

Timo Aaltonen (tjaalton) wrote :

Could you also try the latest mainline kernels from http://kernel.ubuntu.com/~kernel-ppa/mainline/ before I'll have a chat with upstream.

@Timo -- Adding that option to grub also allows normal a normal boot to desktop.

@Timo -- Do you have a kernel in mind? I tried a couple of the latest natty rc ones, but they either don't install or fail to boot properly

Damien Elmes (resolve) wrote :

I installed 39-rc4 but it didn't fix the problem. Once I told grub to use text mode as above, the problem went away.

I'm running natty-proposed on an ThinkPad X220T (SandyBridge like the rest) and haven't made any video changes manually. I can boot properly, but have seen the "vertical lines" output once or twice when detaching an external monitor. Not sure if you guys think this is a related or different issue.

Timo Aaltonen (tjaalton) wrote :

Uncle Pedro: no it's unrelated to this one.

Others, could you put this line in a file /usr/share/grub-gfxpayload-lists/blacklist/10_lenovo and test without the earlier line in /etc/default/grub:

v8086d0126sv17aasb21dd.*

from 00_header:
# GRUB gfxpayload blacklist. The format is a sequence of lines of the
# following form:
#
# vVENDORdDEVICEsvSUBVENDORsdSUBDEVICEbcBASECLASSscSUBCLASS

so in case I typoed it, I used the vga device id and lenovo model id to create that line (from lspci output). Not sure if it matches too widely to all Lenovo models having the same processor, though..

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Jukka Matilainen (jackem) wrote :

I am seeing this problem on a ThinkPad L520. Setting GRUB_GFXPAYLOAD_LINUX=text as suggested in Comment #10 helps.

Damien Elmes (resolve) wrote :

Reverting the default/grub change and adding the blacklist didn't work I'm afraid. Attaching lspci -v.

Timo Aaltonen (tjaalton) wrote :

The lspci output is incomplete, it doesn't have the data needed for the quirk line. Try 'lspci -vnn' instead, and update your quirk line to match and try again (likely the DEVICE hex needs to be changed).

Damien Elmes (resolve) wrote :

No luck with v8086d0116sv17aasb21dd.*. Attaching the more detailed output.

gleon (gunther-lengl) wrote :

Confirming, that adding 'GRUB_GFXPAYLOAD_LINUX=text' to /etc/default/grub and typing 'sudo update-grub' solves the problem on the Lenovo L420.

gleon (gunther-lengl) wrote :

@Timo: Concerning your comment #17:

'lspci -vnn' yields in my case:
...
00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
 Subsystem: Lenovo Device [17aa:21dd]
...
So I used the following line: 'v8086d0116sv17aasd21dd.*'
But NO SUCCESS.

@Timo: Using your instructions in comment #17:

Adding only that line in the blacklist and not modifying the kernel parameters does not result in a normal boot.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Timo Aaltonen (tjaalton) wrote :

Ok, one thing I forgot; you need to run 'update-grub-gfxpayload' after adding the line. Does it work then?

@Timo -- That works! I'm getting to the desktop after running that command

Timo Aaltonen (tjaalton) wrote :

*phew*, that helps, thanks :)

Now we need to add the quirk for natty, and confirm oneiric works out-of-the-box..

Ara Pulido (apulido) wrote :

This is happening in Natty

Changed in linux (Ubuntu Natty):
assignee: nobody → Timo Aaltonen (tjaalton)
status: New → Confirmed
Ara Pulido (apulido) wrote :

Marc, It will be helpful if you could confirm that this works out of the box in Oneric.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete

Ara, I'm not seeing this issue in oneiric (using the 07/28 image)

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Ara Pulido (apulido) wrote :

Marking the general task as Fix Released, as it does not happen in Oneiric

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Timo Aaltonen (tjaalton) wrote :

will add a quirk for this to the natty grub2 package.

Changed in grub2 (Ubuntu):
status: New → Invalid
Changed in grub2 (Ubuntu Natty):
importance: Undecided → High
status: New → In Progress
Changed in linux (Ubuntu Natty):
status: Confirmed → Won't Fix
Changed in grub2 (Ubuntu Natty):
assignee: nobody → Timo Aaltonen (tjaalton)
Timo Aaltonen (tjaalton) wrote :

Oops, wrong package.

affects: grub2 (Ubuntu) → grub-gfxpayload-lists (Ubuntu)
Timo Aaltonen (tjaalton) wrote :

Uploaded to natty-proposed, please test the new package.

Changed in grub-gfxpayload-lists (Ubuntu Natty):
status: In Progress → Fix Committed

Hello Marc, or anyone else affected,

Accepted grub-gfxpayload-lists into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed

Guys, please test the package so that this bug could be closed.

Chris Van Hoof (vanhoof) wrote :

Marc -- Can you confirm this with grub-gfxpayload-lists in natty -proposed?

Thanks!

--chris

Changed in grub-gfxpayload-lists (Ubuntu Natty):
assignee: Timo Aaltonen (tjaalton) → Marc Legris (maaarc)

Chris -- Updated to 0.2.1, still seeing the same issue.

Changed in grub-gfxpayload-lists (Ubuntu Natty):
status: Fix Committed → Confirmed
assignee: Marc Legris (maaarc) → Chris Van Hoof (vanhoof)
Timo Aaltonen (tjaalton) wrote :

That's weird.. You do have the blacklist file installed by the update though (/usr/share/grub-gfxpayload-lists/blacklist/10_lenovo_l420)? What if you run update-grub-gfxpayload by hand?

Changed in grub-gfxpayload-lists (Ubuntu Natty):
assignee: Chris Van Hoof (vanhoof) → Timo Aaltonen (tjaalton)
status: Confirmed → Incomplete
Chris Van Hoof (vanhoof) on 2011-08-22
Changed in grub-gfxpayload-lists (Ubuntu Natty):
assignee: Timo Aaltonen (tjaalton) → Marc Legris (maaarc)

Timo -- 10_lenovo_l420 is present on the system, and running update-grub-gfxpayload does not seem to do anything.
10_lenovo_l420:
0
v8086d0116sv17aasd21dd.*

Changed in grub-gfxpayload-lists (Ubuntu Natty):
assignee: Marc Legris (maaarc) → Timo Aaltonen (tjaalton)
status: Incomplete → Confirmed
Timo Aaltonen (tjaalton) wrote :

New version uploaded to natty-proposed.

Changed in grub-gfxpayload-lists (Ubuntu Natty):
status: Confirmed → Fix Committed
Clint Byrum (clint-fewbar) wrote :

Timo, thanks for the upload. I've rejected it from the natty-proposed queue. Please re-build your source package with -v0.2 so that all uploads to natty-proposed show in the changes file, since they will all be copied to updates together. Also be aware that v0.2.2 fixes an unrelated bug, bug #827046 , which must be verified before your upload will be able to move to -updates as well.

Timo Aaltonen (tjaalton) wrote :

Right, reuploaded a proper version.

Hello Marc, or anyone else affected,

Accepted grub-gfxpayload-lists into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Marc, could you check that the package in proposed is fine this time :)

Changed in grub-gfxpayload-lists (Ubuntu Natty):
assignee: Timo Aaltonen (tjaalton) → Marc Legris (maaarc)

Time -- Installed -proposed and now system is unable to boot normally. I'm seeing Bad LUM and several Bad Target Number kernel messages displayed. Still able to access VTs though. I see two entries under the blacklist:
v8086d0116sv17aasd21dd.*
v8086d0126sv17aasd21dd.*

Changed in grub-gfxpayload-lists (Ubuntu Natty):
assignee: Marc Legris (maaarc) → Timo Aaltonen (tjaalton)
Timo Aaltonen (tjaalton) wrote :

Marc, ok so something in -proposed (kernel?) broke the boot, highly unlikely this package :) Could you just update this one and confirm that booting stock natty+the update works?

Changed in grub-gfxpayload-lists (Ubuntu Natty):
assignee: Timo Aaltonen (tjaalton) → Marc Legris (maaarc)
libertarian (david-treumann) wrote :

Timo, I just tried the package from natty-proposed as the only update from proposed and it works nicely with Ubuntu Classic (gnome2), Ubuntu (unity).

libertarian (david-treumann) wrote :

I forgot to add that I'm using a Lenovo Thinkpad L520.

Timo, install stock and updated grub-gfxpayload-lists to v0.2.3. Seeing the same issue. Still have to add xforcevesa and nomodeset to allow normal boot. Otherwise, I'll see the kernel messages.

Joris Van Herzele (jvh) wrote :

"what if you add 'GRUB_GFXPAYLOAD_LINUX=text' to /etc/default/grub (run update-grub to update the actual config) and reboot, does it change anything?"

This fixes the issue as well on the Lenovo ThinkPad L520 model which has the 1600x900 display
Without it you only get the garbled display.

Joris Van Herzele (jvh) wrote :

grub-gfxpayload-lists 0.2.3 from natty-proposed also fixes the issue for the L520

summary: - [Lenovo L420] System boots to garbled display
+ [Lenovo L420/L520] System boots to garbled display
Changed in grub-gfxpayload-lists (Ubuntu Natty):
assignee: Marc Legris (maaarc) → Timo Aaltonen (tjaalton)

Seeing this fixed on the L520 as well, L420 is still borked.

Timo Aaltonen (tjaalton) wrote :

Marc: Please confirm that you _don't_ have /etc/X11/xorg.conf on the machine (as I wrote on the email earlier). Remove the file, install the update and reboot. It should work just fine, at least did when I tested the machine remotely.

Changed in linux (Ubuntu):
assignee: Timo Aaltonen (tjaalton) → Marc Legris (maaarc)
Changed in grub-gfxpayload-lists (Ubuntu Natty):
assignee: Timo Aaltonen (tjaalton) → Marc Legris (maaarc)
Changed in linux (Ubuntu):
assignee: Marc Legris (maaarc) → nobody
Chris Halse Rogers (raof) wrote :

SRU team ping: this is blocking an unrelated fix that would otherwise be moving to -updates.

Marc: Could you please confirm that this is still broken on your L420 without an xorg.conf?

Failing that, perhaps this should proceed through for the L520 fix and the L420 could be split off as a separate bug.

@Chris

Testing with another L420. Confirmed still broken on the L420 with xorg.conf file without the xorg.conf and -proposed grub-gfxpayload-lists installed with stock natty. I'm seeing a black screen after the ubuntu logo is shown, and VTs are still accessible. Though there is no /etc/X11 after installing the grub update, which is puzzling. After installing all updates however, system does boot up to the desktop normally.

Changed in grub-gfxpayload-lists (Ubuntu Natty):
assignee: Marc Legris (maaarc) → Timo Aaltonen (tjaalton)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub-gfxpayload-lists - 0.2.3

---------------
grub-gfxpayload-lists (0.2.3) natty-proposed; urgency=low

  * Add another device to the Lenovo blacklist file. (LP: #777212)

grub-gfxpayload-lists (0.2.2) natty-proposed; urgency=low

  * Ignore broken symlinks in /usr/share/grub-gfxpayload-lists/blacklist
    (LP: #827046).

grub-gfxpayload-lists (0.2.1) natty-proposed; urgency=low

  * Add a blacklist entry for Lenovo L420. (LP: #777212)
 -- Timo Aaltonen <email address hidden> Fri, 02 Sep 2011 11:35:15 +0300

Changed in grub-gfxpayload-lists (Ubuntu Natty):
status: Fix Committed → Fix Released
Chris Halse Rogers (raof) wrote :

It appeared to me that the most-recent status of this bug was ‘Works on L520, and also works on L420’ - and even if it didn't work on L420 it would not *regress* anything on L420, so I've accepted this into updates.

If it turns out that the L420 isn't completely fixed, please open a separate bug for that and we can get another SRU organised.

To post a comment you must log in.