Genesys Logic webcam not working / eee pc 1000h & Ubuntu 11.04 / 11.10 / 12.04 Beta2

Bug #774287 reported by Simon P. on 2011-04-30
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Linux
Confirmed
Medium
linux (Ubuntu)
Medium
Unassigned

Bug Description

Installed natty narwhal yesterday, it does not detect the camera of my Asus eee pc 1000H.

Tested the webcam with the latest upstream kernel 3.4.0-030400rc2.201204072235 now. Worked fine with that kernel. Restarted my netbook and now the webcam is not found by skype/cheese

---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0-0ubuntu4
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: simon 1437 F.... pulseaudio
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=8f11bccc-7781-4e49-ade5-2151f3278694
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120328)
MachineType: ASUSTeK Computer INC. 1000H
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-20-generic-pae root=UUID=782f43a1-f8a1-4770-b1a8-4dd04747d823 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-20.33-generic-pae 3.2.12
SourcePackage: linux
Tags: precise precise
Uname: Linux 3.2.0-20-generic-pae i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 10/21/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 2204
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 1000H
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTek Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr2204:bd10/21/2009:svnASUSTeKComputerINC.:pn1000H:pvrx.x:rvnASUSTeKComputerINC.:rn1000H:rvrx.xx:cvnASUSTekComputerINC.:ct10:cvrx.x:
dmi.product.name: 1000H
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.

Simon P. (simpre) wrote :

Hope that helps:
When I want to open the webcam with vlc via terminal I usually get this message:

simon@eeerika:~$ vlc v4l2:///dev/video0
VLC media player 1.1.9 The Luggage (revision exported)
Blocked: call to unsetenv("DBUS_ACTIVATION_ADDRESS")
Blocked: call to unsetenv("DBUS_ACTIVATION_BUS_TYPE")
[0x929d92c] main libvlc: VLC wird mit dem Standard-Interface ausgeführt. Benutzen Sie 'cvlc', um VLC ohne Interface zu verwenden.
Blocked: call to setlocale(6, "")
Warning: call to srand(1303797074)
Warning: call to rand()
Blocked: call to setlocale(6, "")

(process:3188): Gtk-WARNING **: Locale not supported by C library.
 Using the fallback 'C' locale.
[0x963bcf4] v4l2 demux error: cannot open video device '/dev/video0' (Device or resource busy)
[0x963bcf4] v4l2 demux error: cannot open video device '/dev/video0' (Permission denied)
[0x963c414] v4l2 access error: cannot open video device '/dev/video0' (No such file or directory)
[0x963c414] v4l2 access error: cannot open video device '/dev/video0' (No such file or directory)
[0x9370cec] main input error: open of `v4l2:///dev/video0' failed: (null)

If the camera is in a good mood, it will sometimes start showing the webcam video output in vlc, I get the following output in the terminal:
simon@eeerika:~$ vlc v4l2:///dev/video0
VLC media player 1.1.9 The Luggage (revision exported)
Blocked: call to unsetenv("DBUS_ACTIVATION_ADDRESS")
Blocked: call to unsetenv("DBUS_ACTIVATION_BUS_TYPE")
[0x9db492c] main libvlc: VLC wird mit dem Standard-Interface ausgeführt. Benutzen Sie 'cvlc', um VLC ohne Interface zu verwenden.
Blocked: call to setlocale(6, "")
Warning: call to srand(1304304020)
Warning: call to rand()
Blocked: call to setlocale(6, "")

(process:2740): Gtk-WARNING **: Locale not supported by C library.
 Using the fallback 'C' locale.
[0x9e70e44] signals interface error: signal 17 overriden (0x54904c0)
[0x9e70e44] signals interface error: /usr/lib/libQtCore.so.4(?)[(nil)]
[0x9e70e44] signals interface error: signal 17 overriden (0x54904c0)
[0x9e70e44] signals interface error: /usr/lib/libQtCore.so.4(?)[(nil)]

IKT (ikt) on 2011-05-10
affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Confirmed

Today I installed the latest Ubuntu 11.10 and to my disappointment I had to find out that this bug is still not fixed. I seriously hope this bug can be fixed soon as a working webcam is essential for me and I actually would like to stick with the latest Ubuntu release.

summary: - webcam not working / eee pc 1000h & natty
+ webcam not working / eee pc 1000h & Ubuntu 11.04 / 11.10
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the release candidate kernel versus the daily build. Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

tags: added: needs-upstream-testing oneiric
Simon P. (simpre) wrote :

I tried to start the webcam with VLC again, exactly the same error messages as above. When I try to find my webcam with the "lsusb" command, no such device is found.

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-12.20

I have installed the latest version of the mainline kernel I could find at /~kernel-ppa/mainline - the v3.1-rc9. Unluckily the bug was not fixed in this kernel version yet.
As the daily built of the kernel seems to be from the same date than the release candidate 9 I didn't try it.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Simon P. (simpre) wrote :

Some additional info for my problem: This problem seems to originate in the Linux kernel as I was trying Fedora on my eeepc and I was confronted with the same problem.

Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

Simon P. (simpre) wrote :

Ok, sure. Will report this issue as an upstream bug. Is there any additional information on my system that I can give the developers so they will be able to find a fix for the problem?

Joseph Salisbury (jsalisbury) wrote :

The details you provided in comment #1 would be good to add to the upstream bug.

Simon P. (simpre) wrote :

bugzilla.kernel.org is down...

Simon P. (simpre) wrote :

Just discovered that actually my webcam is recognized as a usb device. The webcam of my eeePc is a Genesys Logic 05e3:0505 device. My research showed that this webcam supports uvc and was well working with older kernels. However, several people with the same webcam complained in forums about malfunction. The MSI Wind uses the same webcam, here is another bug listed on launchpad concerning the same device: https://bugs.launchpad.net/ubuntu/+bug/763977

Simon P. (simpre) on 2011-10-17
summary: - webcam not working / eee pc 1000h & Ubuntu 11.04 / 11.10
+ Genesys Logic webcam not working / eee pc 1000h & Ubuntu 11.04 / 11.10

Today I ran some tests with gstreamer-properties. Initially the webcam is not working there, the terminal output is:

"gstreamer-properties-Message: Error running pipeline 'Video for Linux 2 (v4l2)': Could not open device '/dev/video0' for reading and writing. [v4l2_calls.c(507): gst_v4l2_open (): /GstPipeline:pipeline0/GstV4l2Src:v4l2src1:
system error: Device or resource busy]"

But when I test another plugin for the video input and then switch back to the v4l2 plugin, the webcam is suddenly working in gstreamer. However, this effect is only temporary.

The integrated webcam is not recognized,
but if I insert a Smartphone into a USB port,
the integrated webcam, miraculously, it works,
take off theSmartphone and the integrated webcam dies.

Excuse my bad English!!!

Simon P. (simpre) wrote :

I also can report strange webcam behavior:

Today I connected an external USB webcam with my EEEpc and surprisingly with Skype my internal webcam worked (but not the external one).

Simon P. (simpre) wrote :

Just tested the webcam under 12.04 Alpha 2. Webcam works fine there!

Simon P., this bug report is being closed due to your last comment regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

tags: added: natty
Changed in linux (Ubuntu):
status: Confirmed → Invalid

Alright! Just thought I'd wait to close the bug until the final version of 12.04 is released.

Sent from my Garmin-Asus phone.

"Christopher M. Penalver" <email address hidden> wrote:

>Simon P., this bug report is being closed due to your last comment
>regarding this being fixed with an update. For future reference you can
>manage the status of your own bugs by clicking on the current status in
>the yellow line and then choosing a new status in the revealed drop down
>box. You can learn more about bug statuses at
>https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time
>to report this bug and helping to make Ubuntu better. Please submit any
>future bugs you may find.
>
>** Tags added: natty
>
>** Changed in: linux (Ubuntu)
> Status: Confirmed => Invalid
>
>--
>You received this bug notification because you are subscribed to the bug
>report.
>https://bugs.launchpad.net/bugs/774287
>
>Title:
> Genesys Logic webcam not working / eee pc 1000h & Ubuntu 11.04 / 11.10
>
>Status in “linux” package in Ubuntu:
> Invalid
>
>Bug description:
> Installed natty narwhal yesterday, it does not detect the camera of my Asus eee pc 1000H.
> Please help, the camera is quite essential for me to stay in contact with my close ones :)
>
>To manage notifications about this bug go to:
>https://bugs.launchpad.net/ubuntu/+source/linux/+bug/774287/+subscriptions
>

Tested the webcam with Precise Beta 2. Not working with Cheese and Skype at the moment. Worked while the installation (take profile picture) and one time during testing the webcam in the Skype options menu, though.

Changed in linux (Ubuntu):
status: Invalid → Confirmed

Simon P., if the issue remains, in Precise please run the following command in the development release from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: bot-stop-nagging precise
removed: kernel-request-3.0.0-12.20

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

Simon P. (simpre) wrote : CRDA.txt

apport information

apport information

apport information

apport information

apport information

apport information

Simon P. (simpre) wrote : Lspci.txt

apport information

That command gives me following output instead of collecting information:

simon@precise-1000H-beta:~$ apport-collect -p linux 774287
No packages found matching linux.
ERROR: hook /usr/share/apport/general-hooks/ubuntu.py crashed:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/apport/report.py", line 718, in add_hooks_info
    symb['add_info'](self, ui)
  File "/usr/share/apport/general-hooks/ubuntu.py", line 37, in add_info
    match_error_messages(report)
  File "/usr/share/apport/general-hooks/ubuntu.py", line 121, in match_error_messages
    if report['ProblemType'] == 'Package':
  File "/usr/lib/python2.7/UserDict.py", line 23, in __getitem__
    raise KeyError(key)
KeyError: 'ProblemType'
Traceback (most recent call last):
  File "/usr/share/apport/apport-gtk", line 493, in <lambda>
    GLib.idle_add(lambda: self.collect_info(on_finished=self.ui_update_view))
  File "/usr/lib/python2.7/dist-packages/apport/ui.py", line 861, in collect_info
    icthread.exc_raise()
  File "/usr/lib/python2.7/dist-packages/apport/REThread.py", line 34, in run
    self._retval = self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.7/dist-packages/apport/ui.py", line 111, in thread_collect_info
    if report['ProblemType'] == 'Crash' and \
  File "/usr/lib/python2.7/UserDict.py", line 23, in __getitem__
    raise KeyError(key)
KeyError: 'ProblemType'

What to do? Will also test the upstream kernel in the next days when I have more time.

Simon P. (simpre) wrote :

Oh, it seemed to work. Was confused by the errors shown in the terminal. Sorry for the unnecessary post above, it is my first time to use that command.

Simon P. (simpre) on 2012-04-08
summary: - Genesys Logic webcam not working / eee pc 1000h & Ubuntu 11.04 / 11.10
+ Genesys Logic webcam not working / eee pc 1000h & Ubuntu 11.04 / 11.10 /
+ 12.04 Beta2
Simon P. (simpre) on 2012-04-09
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: removed: needs-upstream-testing
Simon P. (simpre) wrote :

Tested the webcam with the latest upstream kernel 3.4.0-030400rc2.201204072235 now. Worked fine with that kernel.

Marking Triaged Medium as this is a problem with a non-essential hardware component (webcam).

description: updated
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged

Not an issue in mainline.

Changed in linux:
status: New → Invalid
Simon P. (simpre) wrote :

Hm, still seems to be an issue in mainline. Restarted my netbook and now the webcam is not found by skype/cheese

description: updated
Changed in linux:
status: Invalid → New
Simon P. (simpre) wrote :

I can confirm now that the webcam is working when a smartphone is connected to the netbook like it was reported earlier by Mapelli Fabrizio. However, for me this is only working when my android phone is in internet sharing mode. That was also the reason why I initially thought the webcam was working with the upstream kernel.

Edgardo (edgardo-ieee) wrote :

I'm having the same problem.
(I reported it as bug #990825, and then I found this one, and I marked mine as a duplicate.)

The built-in camera of the netbook asus eee pc 1000h is not recognized in Ubuntu 12.04

It stopped working after upgrading to 11.04. 11.10, and it is still not working when upgrading to 12.04
I tried updating drivers following the instructions here http://git.linuxtv.org/media_build.git
but it still doesn't work.

Changed in linux:
status: New → Incomplete
Edgardo (edgardo-ieee) wrote :

I submitted this bug to the developers as bug 44301.
This is the link: https://bugzilla.kernel.org/show_bug.cgi?id=44301

It's the first time I submit there. Review, corrections, comments, and additions from others are welcome !

Changed in linux:
importance: Undecided → Unknown
status: Incomplete → Unknown
Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
tags: added: latest-bios-2204 needs-upstream-testing

Simon P., could you please confirm this issue exists with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ . If the issue remains, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue.Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc1

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

Changed in linux (Ubuntu):
status: Triaged → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.